Welcome to the Sitecore Data Exchange Framework

Sitecore Data Exchange Framework API
Welcome to the Sitecore Data Exchange Framework

Sitecore Data Exchange Framework provides a standard means for exchanging data between systems.

The framework consists of two major components: the framework and providers.

The framework describes the components that make up a provider. For example, the framework describes components for reading data from a source system and writing write data to a target system.

A collection of components that, together, serve to provide access to a specific system is called a provider. A provider is also called a connector.

See Also

Other Resources

Version History

© 2016 Sitecore Corporation


Version History

Version History

The topics in this section describe the various changes made to the Sitecore Data Exchange Framework over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 1.0.0

  • Version 1.1.0

See Also

Other Resources

Welcome to the Sitecore Data Exchange Framework


Version 1.0.0

Version 1.0.0

Version 1.0.0 was released on 30 June 2016.

Changes in This Release

  • Initial release

See Also

Other Resources

Version History


Version 1.1.0

Version 1.1.0

Version 1.1.0 was released on 30 August 2016.

Changes in This Release

  • Plugin for configuring date offsets

  • Setting to disable logging in telemetry types

  • Event for activity started in telemetry types

  • Property to determine if telemetry is currently running

  • Setting to limit the number of messages that can be written to the pipeline batch summary plugin

  • Value reader for enum values

  • Support for invoking extension methods from the method value reader

See Also

Other Resources

Version History


Namespaces

Namespaces
Namespaces
Namespace | Description
Sitecore.DataExchange | This namespace contains types that define the components available in the framework.
Sitecore.DataExchange.Attributes | This namespace contains attributes that are used by the framework.
Sitecore.DataExchange.Contexts | This namespace contains contexts that are used by the framework.
Sitecore.DataExchange.Converters | This namespace contains converters for the framework.
Sitecore.DataExchange.Converters.ApplyMappingRules | This namespace contains converters for IApplyMappingRule types.
Sitecore.DataExchange.Converters.DataAccess.Readers | This namespace contains converters for IValueReader types.
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors | This namespace contains converters for IValueAccessor and IValueAccessorSet types.
Sitecore.DataExchange.Converters.DataAccess.Writers | This namespace contains converters for IValueWriter types.
Sitecore.DataExchange.Converters.Endpoints | This namespace contains converters for Endpoint types.
Sitecore.DataExchange.Converters.Mappings | This namespace contains converters for types related to mapping.
Sitecore.DataExchange.Converters.PipelineBatches | This namespace contains converters for PipelineBatch types.
Sitecore.DataExchange.Converters.Pipelines | This namespace contains converters for PipelineStep types.
Sitecore.DataExchange.Converters.PipelineSteps | This namespace contains converters for PipelineStep types.
Sitecore.DataExchange.Converters.Tenants | This namespace contains converters for Tenant types.
Sitecore.DataExchange.DataAccess | This namespace contains types that define the components that are used to read and write values on objects.
Sitecore.DataExchange.DataAccess.Appenders | This namespace contains implementations of IValueAppender.
Sitecore.DataExchange.DataAccess.ApplyMappingRules | This namespace contains implementations of IApplyMappingRule.
Sitecore.DataExchange.DataAccess.Extensions | This namespace contains extension methods that are used by data access components.
Sitecore.DataExchange.DataAccess.Mappings | This namespace contains implementations of the interfaces used to specify and control the process of mapping data between objects.
Sitecore.DataExchange.DataAccess.Plugins | This namespace contains implementations of IDataAccessPlugin.
Sitecore.DataExchange.DataAccess.Readers | This namespace contains implementations of IValueReader.
Sitecore.DataExchange.DataAccess.Reflection | This namespace contains implementations of IReflectionUtil.
Sitecore.DataExchange.DataAccess.Utilities | This namespace contains utility classes.
Sitecore.DataExchange.DataAccess.Writers | This namespace contains implementations of IValueWriter.
Sitecore.DataExchange.Diagnostics | This namespace contains diagnostic components for the framework.
Sitecore.DataExchange.Extensions | This namespace contains extension methods that are used by the framework.
Sitecore.DataExchange.ItemModels.Endpoints |
Sitecore.DataExchange.Loggers | This namespace contains loggers that are used by the framework.
Sitecore.DataExchange.Models | This namespace contains models that represent framework components.
Sitecore.DataExchange.Models.ItemModels.Common | This namespace contains item models that represent common framework components.
Sitecore.DataExchange.Models.ItemModels.DataAccess | This namespace contains item models that represent framework components related to data access.
Sitecore.DataExchange.Models.ItemModels.Endpoints | This namespace contains item models that represent framework components related to endpoints.
Sitecore.DataExchange.Models.ItemModels.Mapping | This namespace contains item models that represent framework components related to mapping.
Sitecore.DataExchange.Models.ItemModels.Pipelines | This namespace contains item models that represent framework components related to pipelines.
Sitecore.DataExchange.Models.ItemModels.PipelineSteps | This namespace contains item models that represent framework components related to pipeline processor definitions.
Sitecore.DataExchange.Plugins | This namespace contains implementations of IPlugin.
Sitecore.DataExchange.Processors | This namespace contains processors used by framework components. Processors are used to implement business logic.
Sitecore.DataExchange.Processors.PipelineBatches | This namespace contains implementations of IPipelineBatchProcessor.
Sitecore.DataExchange.Processors.Pipelines | This namespace contains implementations of IPipelineProcessor.
Sitecore.DataExchange.Processors.PipelineSteps | This namespace contains implementations of IPipelineStepProcessor.
Sitecore.DataExchange.Queues |
Sitecore.DataExchange.Remote.Http | This namespace contains types that define the components used to make HTTP calls to a Sitecore server in order to use the Sitecore Client Services API.
Sitecore.DataExchange.Remote.Repositories | This namespace contains repositories used by framework components to read and write data.
Sitecore.DataExchange.Remote.Runners | This namespace contains repositories used by framework components to run other framework components.
Sitecore.DataExchange.Repositories | This namespace contains repositories used by framework components to read and write data.
Sitecore.DataExchange.Repositories.PipelineBatches | This namespace contains implementations of IPipelineBatchRepository.
Sitecore.DataExchange.Runners | This namespace contains components that are used to run pipeline batches.
Sitecore.DataExchange.Telemetry | This namespace contains framework components related to telemetry.
Sitecore.DataExchange.Telemetry.Pipelines | This namespace contains framework components related to telemetry related to pipelines.


Sitecore.DataExchange Namespace

Sitecore.DataExchange Namespace

This namespace contains types that define the components available in the framework.

Classes
 | Class | Description
Public class | Context | This object acts as a container for resources. It is the responsibility of the application using the framework to initialize the properties on this object. If the framework is running within the Sitecore process, these properties are initialized by a processor that runs in the pipeline initialize. If the framework is running outside the Sitecore process, these properties must be initialized in a manner appropriate for the environment the framework is running in.
Interfaces
 | Interface | Description
Public interface | IConverterTFrom, TTo | Represents the ability to create a new object based on a source object. The primary use for converters is to create framework components using settings configured in Sitecore ItemModel objects.
Public interface | IHasPlugins | Represents support for IPlugin objects.
Public interface | IPlugin | Represents an extension to a component. Plugins are used when inheritence is not the best solution to adding functionality to a component. For example, a plugin can provide functionality that is shared across multiple data access components, such as logging.


Context Class

Context Class

This object acts as a container for resources. It is the responsibility of the application using the framework to initialize the properties on this object.

If the framework is running within the Sitecore process, these properties are initialized by a processor that runs in the pipeline initialize.

If the framework is running outside the Sitecore process, these properties must be initialized in a manner appropriate for the environment the framework is running in.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchangeContext

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class Context

The Context type exposes the following members.

Constructors
 | Name | Description
Public method | Context | Initializes a new instance of the Context class
Top
Properties
Name | Description
ItemModelRepository | Gets or sets the component used to access the Sitecore items.
Logger | Gets or sets the component used for logging.
PipelineBatchRepository | Gets or sets the component used to access pipeline batches.
Plugins | Gets the collection of plugins assigned to the global context.
Top
Methods
Name | Description
GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
See Also

Reference

Sitecore.DataExchange Namespace


Context Constructor

Context Constructor
Initializes a new instance of the Context class

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Context()
See Also

Reference

Context Class
Sitecore.DataExchange Namespace


Context Properties

Context Properties

The Context type exposes the following members.

Properties
Name | Description
ItemModelRepository | Gets or sets the component used to access the Sitecore items.
Logger | Gets or sets the component used for logging.
PipelineBatchRepository | Gets or sets the component used to access pipeline batches.
Plugins | Gets the collection of plugins assigned to the global context.
Top
See Also

Reference

Context Class
Sitecore.DataExchange Namespace


Context.ItemModelRepository Property

ContextItemModelRepository Property
Gets or sets the component used to access the Sitecore items.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static IItemModelRepository ItemModelRepository { get; set; }

Property Value

Type: IItemModelRepository
See Also

Reference

Context Class
Sitecore.DataExchange Namespace


Context.Logger Property

ContextLogger Property
Gets or sets the component used for logging.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static ILogger Logger { get; set; }

Property Value

Type: ILogger
See Also

Reference

Context Class
Sitecore.DataExchange Namespace


Context.PipelineBatchRepository Property

ContextPipelineBatchRepository Property
Gets or sets the component used to access pipeline batches.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static IPipelineBatchRepository PipelineBatchRepository { get; set; }

Property Value

Type: IPipelineBatchRepository
See Also

Reference

Context Class
Sitecore.DataExchange Namespace


Context.Plugins Property

ContextPlugins Property
Gets the collection of plugins assigned to the global context.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin
See Also

Reference

Context Class
Sitecore.DataExchange Namespace


Context Methods

Context Methods

The Context type exposes the following members.

Methods
Name | Description
GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
See Also

Reference

Context Class
Sitecore.DataExchange Namespace


Context.GetPlugin(T) Method

ContextGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.
See Also

Reference

Context Class
Sitecore.DataExchange Namespace


IConverter(TFrom, TTo) Interface

IConverterTFrom, TTo Interface
Represents the ability to create a new object based on a source object. The primary use for converters is to create framework components using settings configured in Sitecore ItemModel objects.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IConverter<TFrom, TTo>

Type Parameters

TFrom
The type of object the converter can convert from.
TTo
The type of object the converter can convert to.

The IConverterTFrom, TTo type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified object can be converted.
Public method | Convert | Creates a new object based on the specified object.
Top
See Also

Reference

Sitecore.DataExchange Namespace
Sitecore.DataExchange.ConvertersBaseItemModelConverterTFrom, TTo


IConverter(TFrom, TTo) Methods

IConverterTFrom, TTo Methods

The IConverterTFrom, TTo generic type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified object can be converted.
Public method | Convert | Creates a new object based on the specified object.
Top
See Also

Reference

IConverterTFrom, TTo Interface
Sitecore.DataExchange Namespace


IConverter(TFrom, TTo).CanConvert Method

IConverterTFrom, TToCanConvert Method
Indicates whether or not the specified object can be converted.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool CanConvert(
    TFrom source
)

Parameters

source
Type: TFrom
The object to convert from.

Return Value

Type: Boolean
if the source object contains enough information to allow the converter to create a new object of the type specified by TTo.
See Also

Reference

IConverterTFrom, TTo Interface
Sitecore.DataExchange Namespace


IConverter(TFrom, TTo).Convert Method

IConverterTFrom, TToConvert Method
Creates a new object based on the specified object.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
TTo Convert(
    TFrom source
)

Parameters

source
Type: TFrom
The object whose settings are used to create a new object.

Return Value

Type: TTo
The new object; the default value of the type specified by TTo ( for reference types) if the object cannot be created, such as when insufficient information is available from the source object.
See Also

Reference

IConverterTFrom, TTo Interface
Sitecore.DataExchange Namespace


IHasPlugins Interface

IHasPlugins Interface

Represents support for IPlugin objects.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IHasPlugins

The IHasPlugins type exposes the following members.

Properties
 | Name | Description
Public property | Plugins | Gets the collection of plugins that are assigned to the component.
Top
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

Sitecore.DataExchange Namespace


IHasPlugins Properties

IHasPlugins Properties

The IHasPlugins type exposes the following members.

Properties
 | Name | Description
Public property | Plugins | Gets the collection of plugins that are assigned to the component.
Top
See Also

Reference

IHasPlugins Interface
Sitecore.DataExchange Namespace


IHasPlugins.Plugins Property

IHasPluginsPlugins Property
Gets the collection of plugins that are assigned to the component.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin
See Also

Reference

IHasPlugins Interface
Sitecore.DataExchange Namespace


IHasPlugins Methods

IHasPlugins Methods
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

IHasPlugins Interface
Sitecore.DataExchange Namespace


IHasPlugins.GetPlugin Method

IHasPluginsGetPlugin Method
Overload List
 | Name | Description
Public method | GetPluginT | Gets a specific plugin that has been assigned to the component.
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

IHasPlugins Interface
Sitecore.DataExchange Namespace


IHasPlugins.GetPlugin(T) Method

IHasPluginsGetPluginT Method
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of plugin to get.

Return Value

Type: T
If a plugin of the specified type is set, the plugin; otherwise .
See Also

Reference

IHasPlugins Interface
GetPlugin Overload
Sitecore.DataExchange Namespace


IHasPlugins.GetPlugin Method (Type)

IHasPluginsGetPlugin Method (Type)
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
Object GetPlugin(
    Type type
)

Parameters

type
Type: SystemType
The type of the plugin to get.

Return Value

Type: Object
If a plugin of the specified type is set, the plugin; otherwise .
See Also

Reference

IHasPlugins Interface
GetPlugin Overload
Sitecore.DataExchange Namespace


IPlugin Interface

IPlugin Interface

Represents an extension to a component.

Plugins are used when inheritence is not the best solution to adding functionality to a component. For example, a plugin can provide functionality that is shared across multiple data access components, such as logging.

Namespace: Sitecore.DataExchange
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IPlugin
See Also

Reference

Sitecore.DataExchange Namespace


Sitecore.DataExchange.Attributes Namespace

Sitecore.DataExchange.Attributes Namespace

This namespace contains attributes that are used by the framework.

Classes
 | Class | Description
Public class | BaseRequiredPluginsAttribute | Identifies the plugins that are required on a component.
Public class | RequiredEndpointPluginsAttribute | Identifies the plugins on a Endpoint that are required. Required plugins are those plugins that, if missing, will prevent the component from working properly.
Public class | RequiredPipelineContextPluginsAttribute | Identifies the plugins on a PipelineContext that are required. Required plugins are those plugins that, if missing, will prevent the component from working properly.
Public class | RequiredPipelineStepPluginsAttribute | Identifies the plugins on a PipelineStep that are required. Required plugins are those plugins that, if missing, will prevent the component from working properly.
Public class | UsesRunAsUserNameAttribute | Indicates this PipelineStep uses the ElevatedSecurityUserName setting.


BaseRequiredPluginsAttribute Class

BaseRequiredPluginsAttribute Class
Identifies the plugins that are required on a component.
Inheritance Hierarchy
SystemObject
SystemAttribute
Sitecore.DataExchange.AttributesBaseRequiredPluginsAttribute
Sitecore.DataExchange.AttributesRequiredEndpointPluginsAttribute
Sitecore.DataExchange.AttributesRequiredPipelineContextPluginsAttribute
Sitecore.DataExchange.AttributesRequiredPipelineStepPluginsAttribute

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BaseRequiredPluginsAttribute : Attribute

The BaseRequiredPluginsAttribute type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseRequiredPluginsAttribute | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | RequiredPlugins | Gets a collection of the required plugin types.
Top
See Also

Reference

Sitecore.DataExchange.Attributes Namespace


BaseRequiredPluginsAttribute Constructor

BaseRequiredPluginsAttribute Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BaseRequiredPluginsAttribute(
    params Type[] types
)

Parameters

types
Type: SystemType
The types of the required plugins.
See Also

Reference

BaseRequiredPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


BaseRequiredPluginsAttribute Properties

BaseRequiredPluginsAttribute Properties

The BaseRequiredPluginsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | RequiredPlugins | Gets a collection of the required plugin types.
Top
See Also

Reference

BaseRequiredPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


BaseRequiredPluginsAttribute.RequiredPlugins Property

BaseRequiredPluginsAttributeRequiredPlugins Property
Gets a collection of the required plugin types.

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<Type> RequiredPlugins { get; }

Property Value

Type: IEnumerable Type
See Also

Reference

BaseRequiredPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


RequiredEndpointPluginsAttribute Class

RequiredEndpointPluginsAttribute Class
Identifies the plugins on a Endpoint that are required. Required plugins are those plugins that, if missing, will prevent the component from working properly.
Inheritance Hierarchy
SystemObject
SystemAttribute
Sitecore.DataExchange.AttributesBaseRequiredPluginsAttribute
Sitecore.DataExchange.AttributesRequiredEndpointPluginsAttribute

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class RequiredEndpointPluginsAttribute : BaseRequiredPluginsAttribute

The RequiredEndpointPluginsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RequiredEndpointPluginsAttribute | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | RequiredPlugins | Gets a collection of the required plugin types. (Inherited from BaseRequiredPluginsAttribute.)
Top
See Also

Reference

Sitecore.DataExchange.Attributes Namespace


RequiredEndpointPluginsAttribute Constructor

RequiredEndpointPluginsAttribute Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public RequiredEndpointPluginsAttribute(
    params Type[] types
)

Parameters

types
Type: SystemType
The types of the required plugins.
See Also

Reference

RequiredEndpointPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


RequiredEndpointPluginsAttribute Properties

RequiredEndpointPluginsAttribute Properties

The RequiredEndpointPluginsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | RequiredPlugins | Gets a collection of the required plugin types. (Inherited from BaseRequiredPluginsAttribute.)
Top
See Also

Reference

RequiredEndpointPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


RequiredPipelineContextPluginsAttribute Class

RequiredPipelineContextPluginsAttribute Class
Identifies the plugins on a PipelineContext that are required. Required plugins are those plugins that, if missing, will prevent the component from working properly.
Inheritance Hierarchy
SystemObject
SystemAttribute
Sitecore.DataExchange.AttributesBaseRequiredPluginsAttribute
Sitecore.DataExchange.AttributesRequiredPipelineContextPluginsAttribute

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class RequiredPipelineContextPluginsAttribute : BaseRequiredPluginsAttribute

The RequiredPipelineContextPluginsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RequiredPipelineContextPluginsAttribute | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | RequiredPlugins | Gets a collection of the required plugin types. (Inherited from BaseRequiredPluginsAttribute.)
Top
See Also

Reference

Sitecore.DataExchange.Attributes Namespace


RequiredPipelineContextPluginsAttribute Constructor

RequiredPipelineContextPluginsAttribute Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public RequiredPipelineContextPluginsAttribute(
    params Type[] types
)

Parameters

types
Type: SystemType
The types of the required plugins.
See Also

Reference

RequiredPipelineContextPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


RequiredPipelineContextPluginsAttribute Properties

RequiredPipelineContextPluginsAttribute Properties

The RequiredPipelineContextPluginsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | RequiredPlugins | Gets a collection of the required plugin types. (Inherited from BaseRequiredPluginsAttribute.)
Top
See Also

Reference

RequiredPipelineContextPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


RequiredPipelineStepPluginsAttribute Class

RequiredPipelineStepPluginsAttribute Class
Identifies the plugins on a PipelineStep that are required. Required plugins are those plugins that, if missing, will prevent the component from working properly.
Inheritance Hierarchy
SystemObject
SystemAttribute
Sitecore.DataExchange.AttributesBaseRequiredPluginsAttribute
Sitecore.DataExchange.AttributesRequiredPipelineStepPluginsAttribute

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class RequiredPipelineStepPluginsAttribute : BaseRequiredPluginsAttribute

The RequiredPipelineStepPluginsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RequiredPipelineStepPluginsAttribute | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | RequiredPlugins | Gets a collection of the required plugin types. (Inherited from BaseRequiredPluginsAttribute.)
Top
See Also

Reference

Sitecore.DataExchange.Attributes Namespace


RequiredPipelineStepPluginsAttribute Constructor

RequiredPipelineStepPluginsAttribute Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public RequiredPipelineStepPluginsAttribute(
    params Type[] types
)

Parameters

types
Type: SystemType
The types of the required plugins.
See Also

Reference

RequiredPipelineStepPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


RequiredPipelineStepPluginsAttribute Properties

RequiredPipelineStepPluginsAttribute Properties

The RequiredPipelineStepPluginsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | RequiredPlugins | Gets a collection of the required plugin types. (Inherited from BaseRequiredPluginsAttribute.)
Top
See Also

Reference

RequiredPipelineStepPluginsAttribute Class
Sitecore.DataExchange.Attributes Namespace


UsesRunAsUserNameAttribute Class

UsesRunAsUserNameAttribute Class
Indicates this PipelineStep uses the ElevatedSecurityUserName setting.
Inheritance Hierarchy
SystemObject
SystemAttribute
Sitecore.DataExchange.AttributesUsesRunAsUserNameAttribute

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class UsesRunAsUserNameAttribute : Attribute

The UsesRunAsUserNameAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | UsesRunAsUserNameAttribute | Initializes a new instance of the class.
Top
See Also

Reference

Sitecore.DataExchange.Attributes Namespace


UsesRunAsUserNameAttribute Constructor

UsesRunAsUserNameAttribute Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Attributes
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public UsesRunAsUserNameAttribute()
See Also

Reference

UsesRunAsUserNameAttribute Class
Sitecore.DataExchange.Attributes Namespace


Sitecore.DataExchange.Contexts Namespace

Sitecore.DataExchange.Contexts Namespace

This namespace contains contexts that are used by the framework.

Classes
 | Class | Description
Public class | PipelineBatchContext | The context available when a PipelineBatch is run.
Public class | PipelineContext | The context available when a PipelineStep is run.
Public class | WorkQueueProcessorContext | The context available when a IWorkQueueProcessor is run.
Interfaces
 | Interface | Description
Public interface | IDataExchangeContext | Base type for contexts used in the framework.


IDataExchangeContext Interface

IDataExchangeContext Interface
Base type for contexts used in the framework.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IDataExchangeContext

The IDataExchangeContext type exposes the following members.

Properties
 | Name | Description
Public property | Logger | Gets or sets the component used for logging.
Top
See Also

Reference

Sitecore.DataExchange.Contexts Namespace


IDataExchangeContext Properties

IDataExchangeContext Properties

The IDataExchangeContext type exposes the following members.

Properties
 | Name | Description
Public property | Logger | Gets or sets the component used for logging.
Top
See Also

Reference

IDataExchangeContext Interface
Sitecore.DataExchange.Contexts Namespace


IDataExchangeContext.Logger Property

IDataExchangeContextLogger Property
Gets or sets the component used for logging.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ILogger Logger { get; set; }

Property Value

Type: ILogger
See Also

Reference

IDataExchangeContext Interface
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext Class

PipelineBatchContext Class
The context available when a PipelineBatch is run.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ContextsPipelineBatchContext

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineBatchContext : IDataExchangeContext,
    IHasPlugins

The PipelineBatchContext type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineBatchContext | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | CriticalError | Gets or sets a value that indicates whether a pipeline failed. This value is used to prevent subsequent pipelines from being executed.
Public property | CurrentPipelineBatch | Gets or sets the current PipelineBatch.
Public property | Logger | Gets or sets the component used for logging.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.
Top
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
See Also

Reference

Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext Constructor

PipelineBatchContext Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatchContext()
See Also

Reference

PipelineBatchContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext Properties

PipelineBatchContext Properties

The PipelineBatchContext type exposes the following members.

Properties
 | Name | Description
Public property | CriticalError | Gets or sets a value that indicates whether a pipeline failed. This value is used to prevent subsequent pipelines from being executed.
Public property | CurrentPipelineBatch | Gets or sets the current PipelineBatch.
Public property | Logger | Gets or sets the component used for logging.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.
Top
See Also

Reference

PipelineBatchContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext.CriticalError Property

PipelineBatchContextCriticalError Property
Gets or sets a value that indicates whether a pipeline failed. This value is used to prevent subsequent pipelines from being executed.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool CriticalError { get; set; }

Property Value

Type: Boolean
See Also

Reference

PipelineBatchContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext.CurrentPipelineBatch Property

PipelineBatchContextCurrentPipelineBatch Property
Gets or sets the current PipelineBatch.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatch CurrentPipelineBatch { get; set; }

Property Value

Type: PipelineBatch
See Also

Reference

PipelineBatchContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext.Logger Property

PipelineBatchContextLogger Property
Gets or sets the component used for logging.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ILogger Logger { get; set; }

Property Value

Type: ILogger

Implements

IDataExchangeContextLogger
See Also

Reference

PipelineBatchContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext.Plugins Property

PipelineBatchContextPlugins Property
Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin

Implements

IHasPluginsPlugins
See Also

Reference

PipelineBatchContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext Methods

PipelineBatchContext Methods
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
See Also

Reference

PipelineBatchContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext.GetPlugin Method

PipelineBatchContextGetPlugin Method
Overload List
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

PipelineBatchContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext.GetPlugin(T) Method

PipelineBatchContextGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.

Implements

IHasPluginsGetPluginT
See Also

Reference

PipelineBatchContext Class
GetPlugin Overload
Sitecore.DataExchange.Contexts Namespace


PipelineBatchContext.GetPlugin Method (Type)

PipelineBatchContextGetPlugin Method (Type)
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object GetPlugin(
    Type type
)

Parameters

type
Type: SystemType
The type of the plugin to get.

Return Value

Type: Object
If a plugin of the specified type is set, the plugin; otherwise .

Implements

IHasPluginsGetPlugin(Type)
See Also

Reference

PipelineBatchContext Class
GetPlugin Overload
Sitecore.DataExchange.Contexts Namespace


PipelineContext Class

PipelineContext Class
The context available when a PipelineStep is run.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ContextsPipelineContext

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineContext : IDataExchangeContext,
    IHasPlugins

The PipelineContext type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineContext | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | CriticalError | Gets or sets a value that indicates whether a pipeline failed. This value is used to prevent subsequent pipeline steps or pipelines from being executed.
Public property | CurrentPipeline | Gets or sets the current Pipeline.
Public property | CurrentPipelineStep | Gets or sets the current PipelineStep.
Public property | Finished | Gets or sets a value that indicates whether a pipeline is finished. This value is used to prevent subsequent pipeline steps or pipelines from being executed, but is not considered an error.
Public property | Logger | Gets or sets the component used for logging.
Public property | PipelineBatchContext | Gets or sets the current PipelineBatchContext.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.
Top
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetElevatedSecurityUserName | Gets the "elevated security user name" value from the pipeline batch set on the pipeline context. This value is set on a plugin on the pipeline batch. If this plugin is not found on the pipeline batch, the parent context for the pipeline context is checked. (Defined by PipelineContextExtensions.)
Public Extension Method | GetIterableDataSettings | Gets the settings from the component. (Defined by PipelineContextExtensions.)
Public Extension Method | GetParentPipelineContextSettings | Gets the settings from the component. (Defined by PipelineContextExtensions.)
Public Extension Method | GetSynchronizationSettings | Gets the settings from the component. (Defined by PipelineContextExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by PipelineContextExtensions.)
Public Extension Method | HasIterableDataSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineContextExtensions.)
Public Extension Method | HasParentPipelineContextSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineContextExtensions.)
Public Extension Method | HasSynchronizationSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineContextExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by PipelineContextExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Contexts Namespace


PipelineContext Constructor

PipelineContext Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineContext(
    PipelineBatchContext taskContext
)

Parameters

taskContext
Type: Sitecore.DataExchange.ContextsPipelineBatchContext
The context for the pipeline batch in which the pipeline context will be used.
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext Properties

PipelineContext Properties

The PipelineContext type exposes the following members.

Properties
 | Name | Description
Public property | CriticalError | Gets or sets a value that indicates whether a pipeline failed. This value is used to prevent subsequent pipeline steps or pipelines from being executed.
Public property | CurrentPipeline | Gets or sets the current Pipeline.
Public property | CurrentPipelineStep | Gets or sets the current PipelineStep.
Public property | Finished | Gets or sets a value that indicates whether a pipeline is finished. This value is used to prevent subsequent pipeline steps or pipelines from being executed, but is not considered an error.
Public property | Logger | Gets or sets the component used for logging.
Public property | PipelineBatchContext | Gets or sets the current PipelineBatchContext.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.
Top
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.CriticalError Property

PipelineContextCriticalError Property
Gets or sets a value that indicates whether a pipeline failed. This value is used to prevent subsequent pipeline steps or pipelines from being executed.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool CriticalError { get; set; }

Property Value

Type: Boolean
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.CurrentPipeline Property

PipelineContextCurrentPipeline Property
Gets or sets the current Pipeline.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Pipeline CurrentPipeline { get; set; }

Property Value

Type: Pipeline
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.CurrentPipelineStep Property

PipelineContextCurrentPipelineStep Property
Gets or sets the current PipelineStep.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineStep CurrentPipelineStep { get; set; }

Property Value

Type: PipelineStep
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.Finished Property

PipelineContextFinished Property
Gets or sets a value that indicates whether a pipeline is finished. This value is used to prevent subsequent pipeline steps or pipelines from being executed, but is not considered an error.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Finished { get; set; }

Property Value

Type: Boolean
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.Logger Property

PipelineContextLogger Property
Gets or sets the component used for logging.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ILogger Logger { get; set; }

Property Value

Type: ILogger

Implements

IDataExchangeContextLogger
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.PipelineBatchContext Property

PipelineContextPipelineBatchContext Property
Gets or sets the current PipelineBatchContext.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatchContext PipelineBatchContext { get; }

Property Value

Type: PipelineBatchContext
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.Plugins Property

PipelineContextPlugins Property
Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin

Implements

IHasPluginsPlugins
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext Methods

PipelineContext Methods

The PipelineContext type exposes the following members.

Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetElevatedSecurityUserName | Gets the "elevated security user name" value from the pipeline batch set on the pipeline context. This value is set on a plugin on the pipeline batch. If this plugin is not found on the pipeline batch, the parent context for the pipeline context is checked. (Defined by PipelineContextExtensions.)
Public Extension Method | GetIterableDataSettings | Gets the settings from the component. (Defined by PipelineContextExtensions.)
Public Extension Method | GetParentPipelineContextSettings | Gets the settings from the component. (Defined by PipelineContextExtensions.)
Public Extension Method | GetSynchronizationSettings | Gets the settings from the component. (Defined by PipelineContextExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by PipelineContextExtensions.)
Public Extension Method | HasIterableDataSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineContextExtensions.)
Public Extension Method | HasParentPipelineContextSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineContextExtensions.)
Public Extension Method | HasSynchronizationSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineContextExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by PipelineContextExtensions.)
Top
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.GetPlugin Method

PipelineContextGetPlugin Method
Overload List
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

PipelineContext Class
Sitecore.DataExchange.Contexts Namespace


PipelineContext.GetPlugin(T) Method

PipelineContextGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.

Implements

IHasPluginsGetPluginT
See Also

Reference

PipelineContext Class
GetPlugin Overload
Sitecore.DataExchange.Contexts Namespace


PipelineContext.GetPlugin Method (Type)

PipelineContextGetPlugin Method (Type)
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object GetPlugin(
    Type type
)

Parameters

type
Type: SystemType
The type of the plugin to get.

Return Value

Type: Object
If a plugin of the specified type is set, the plugin; otherwise .

Implements

IHasPluginsGetPlugin(Type)
See Also

Reference

PipelineContext Class
GetPlugin Overload
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext Class

WorkQueueProcessorContext Class
The context available when a IWorkQueueProcessor is run.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ContextsWorkQueueProcessorContext

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class WorkQueueProcessorContext : IDataExchangeContext,
    IHasPlugins

The WorkQueueProcessorContext type exposes the following members.

Constructors
 | Name | Description
Public method | WorkQueueProcessorContext | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | CountNotSubmitted | Gets or sets the number of work queue items that were not submitted.
Public property | CountSubmitted | Gets or sets the number of work queue items that were submitted.
Public property | Logger | Gets or sets the component used for logging.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. It is the responsibility of IWorkQueueProcessor to know how to use any plugins that are assigned.
Top
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetParentPipelineContextSettings | Gets the settings from the component. (Defined by WorkQueueContextExtensions.)
Public Extension Method | HasParentPipelineContextSettings | Determines whether the settings have been assigned to the component. (Defined by WorkQueueContextExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext Constructor

WorkQueueProcessorContext Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public WorkQueueProcessorContext()
See Also

Reference

WorkQueueProcessorContext Class
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext Properties

WorkQueueProcessorContext Properties

The WorkQueueProcessorContext type exposes the following members.

Properties
 | Name | Description
Public property | CountNotSubmitted | Gets or sets the number of work queue items that were not submitted.
Public property | CountSubmitted | Gets or sets the number of work queue items that were submitted.
Public property | Logger | Gets or sets the component used for logging.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. It is the responsibility of IWorkQueueProcessor to know how to use any plugins that are assigned.
Top
See Also

Reference

WorkQueueProcessorContext Class
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext.CountNotSubmitted Property

WorkQueueProcessorContextCountNotSubmitted Property
Gets or sets the number of work queue items that were not submitted.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int CountNotSubmitted { get; set; }

Property Value

Type: Int32
See Also

Reference

WorkQueueProcessorContext Class
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext.CountSubmitted Property

WorkQueueProcessorContextCountSubmitted Property
Gets or sets the number of work queue items that were submitted.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int CountSubmitted { get; set; }

Property Value

Type: Int32
See Also

Reference

WorkQueueProcessorContext Class
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext.Logger Property

WorkQueueProcessorContextLogger Property
Gets or sets the component used for logging.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ILogger Logger { get; set; }

Property Value

Type: ILogger

Implements

IDataExchangeContextLogger
See Also

Reference

WorkQueueProcessorContext Class
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext.Plugins Property

WorkQueueProcessorContextPlugins Property

Gets the collection of plugins assigned to this component.

These plugins are used to extend the component without requiring inheritence. It is the responsibility of IWorkQueueProcessor to know how to use any plugins that are assigned.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin

Implements

IHasPluginsPlugins
See Also

Reference

WorkQueueProcessorContext Class
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext Methods

WorkQueueProcessorContext Methods

The WorkQueueProcessorContext type exposes the following members.

Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetParentPipelineContextSettings | Gets the settings from the component. (Defined by WorkQueueContextExtensions.)
Public Extension Method | HasParentPipelineContextSettings | Determines whether the settings have been assigned to the component. (Defined by WorkQueueContextExtensions.)
Top
See Also

Reference

WorkQueueProcessorContext Class
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext.GetPlugin Method

WorkQueueProcessorContextGetPlugin Method
Overload List
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

WorkQueueProcessorContext Class
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext.GetPlugin(T) Method

WorkQueueProcessorContextGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.

Implements

IHasPluginsGetPluginT
See Also

Reference

WorkQueueProcessorContext Class
GetPlugin Overload
Sitecore.DataExchange.Contexts Namespace


WorkQueueProcessorContext.GetPlugin Method (Type)

WorkQueueProcessorContextGetPlugin Method (Type)
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange.Contexts
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object GetPlugin(
    Type type
)

Parameters

type
Type: SystemType
The type of the plugin to get.

Return Value

Type: Object
If a plugin of the specified type is set, the plugin; otherwise .

Implements

IHasPluginsGetPlugin(Type)
See Also

Reference

WorkQueueProcessorContext Class
GetPlugin Overload
Sitecore.DataExchange.Contexts Namespace


Sitecore.DataExchange.Converters Namespace

Sitecore.DataExchange.Converters Namespace

This namespace contains converters for the framework.

Classes
 | Class | Description
 | BaseItemModelConverterTFrom, TTo | Base class for converters that accept ItemModel as a source object. This class provides a number of methods that facilitate reading field values from the ItemModel.
Public class | IsoDateTimeConverter | Provides the ability to convert to and from ISO date/time format, which Sitecore uses to store date/time values.


BaseItemModelConverter(TFrom, TTo) Class

BaseItemModelConverterTFrom, TTo Class
Base class for converters that accept ItemModel as a source object. This class provides a number of methods that facilitate reading field values from the ItemModel.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverterTFrom, TTo
More...

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BaseItemModelConverter<TFrom, TTo> : IConverter<TFrom, TTo>
where TFrom : ItemModel

Type Parameters

TFrom
The type of ItemModel the converter can convert from.
TTo
The type of object the converter can convert to.

The BaseItemModelConverterTFrom, TTo type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseItemModelConverterTFrom, TTo | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object.
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method.
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds.
Public method | Convert | Creates a new object based on the specified ItemModel.
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T.
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel.
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel).
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel.
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T.
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String).
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String).
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel.
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel.
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String).
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String).
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel.
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel.
Top
Examples

The following example demonstrates how to implement a converter that converts an ItemModel into an instance of a custom class.

Custom object that can be converted from an item model
Copy
public class Person
{
    public string Name { get; set; }
    public string Email { get; set; }
    public DateTime DateOfBirth { get; set; }
}
Item model converter implementation
Copy
public class PersonConverter : BaseItemModelConverter<ItemModel, Person>
{
    public PersonConverter(IItemModelRepository repository) : base(repository)
    {
        //
        //CanConvert() uses the templateID to determine whether
        //or not the converter can convert the source item model
        this.SupportedTemplateIds.Add(PersonTemplateId);
    }
    private static Guid PersonTemplateId = Guid.Parse("01ABE3FD-405A-4813-9565-E24B7DAB99CC");
    public override Person Convert(ItemModel source)
    {
        if (source != null)
        {
            //
            //create a new object and set properties using field values
            return new Person
            {
                Name = base.GetStringValue(source, "Name"),
                Email = base.GetStringValue(source, "Email"),
                DateOfBirth = base.GetDateTimeValue(source, "DOB")
            };
        }
        return null;
    }
}
See Also

Reference

Sitecore.DataExchange.Converters Namespace
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverterTFrom, TTo
Sitecore.DataExchange.Converters.ApplyMappingRulesCollectionCountMappingRuleConverter
Sitecore.DataExchange.Converters.ApplyMappingRulesDefaultValueMappingRuleConverter
Sitecore.DataExchange.Converters.ApplyMappingRulesNullValueMappingRuleConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersArrayValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersConstantValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersDateTimeValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersEnumValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersFallbackValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersGuidValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersIsoDateValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersMethodValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersMethodValueReaderParameterConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersNowValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersNullValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersPropertyValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersRawValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersSequentialValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ReadersValueAccessorValueReaderConverter
Sitecore.DataExchange.Converters.DataAccess.ValueAccessorsChildBasedValueAccessorSetConverter
Sitecore.DataExchange.Converters.DataAccess.ValueAccessorsValueAccessorConverter
Sitecore.DataExchange.Converters.DataAccess.WritersPropertyValueWriterConverter
Sitecore.DataExchange.Converters.DataAccess.WritersTargetReaderValueWriterConverter
Sitecore.DataExchange.Converters.EndpointsBaseEndpointConverterTFrom
Sitecore.DataExchange.Converters.MappingsChildBasedMappingSetConverter
Sitecore.DataExchange.Converters.MappingsMappingConverter
Sitecore.DataExchange.Converters.PipelineBatchesPipelineBatchConverter
Sitecore.DataExchange.Converters.PipelinesPipelineConverter
Sitecore.DataExchange.Converters.PipelineStepsBasePipelineStepConverterTFrom
Sitecore.DataExchange.Converters.TenantsTenantConverter


BaseItemModelConverter(TFrom, TTo) Constructor

BaseItemModelConverterTFrom, TTo Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BaseItemModelConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo) Properties

BaseItemModelConverterTFrom, TTo Properties

The BaseItemModelConverterTFrom, TTo generic type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object.
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method.
Top
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).ItemModelRepository Property

BaseItemModelConverterTFrom, TToItemModelRepository Property
Gets the component used to read ItemModel objects that are referenced by the source object.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IItemModelRepository ItemModelRepository { get; }

Property Value

Type: IItemModelRepository
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).SupportedTemplateIds Property

BaseItemModelConverterTFrom, TToSupportedTemplateIds Property
Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<Guid> SupportedTemplateIds { get; }

Property Value

Type: ICollection Guid
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo) Methods

BaseItemModelConverterTFrom, TTo Methods

The BaseItemModelConverterTFrom, TTo generic type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds.
Public method | Convert | Creates a new object based on the specified ItemModel.
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T.
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel.
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel).
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel.
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T.
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String).
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String).
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel.
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel.
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String).
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String).
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel.
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel.
Top
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).CanConvert Method

BaseItemModelConverterTFrom, TToCanConvert Method

Indicates whether or not the specified ItemModel can be converted.

This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool CanConvert(
    TFrom source
)

Parameters

source
Type: TFrom
The item model object to convert from.

Return Value

Type: Boolean
if the source item model object can be converted to the type specified by TTo.

Implements

IConverterTFrom, TToCanConvert(TFrom)
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).Convert Method

BaseItemModelConverterTFrom, TToConvert Method
Creates a new object based on the specified ItemModel.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract TTo Convert(
    TFrom source
)

Parameters

source
Type: TFrom
The item model object whose settings are used to create a new object.

Return Value

Type: TTo
The new object; the default value of the type specified by TTo ( for reference types) if the object cannot be created, such as when insufficient information is available from the source object.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).ConvertChildrenToModels(T) Method

BaseItemModelConverterTFrom, TToConvertChildrenToModelsT Method

Gets a collection of T objects by converting the child objects of the specified ItemModel.

In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IEnumerable<T> ConvertChildrenToModels<T>(
    ItemModel itemModel
)

Parameters

itemModel
Type: ItemModel
The object whose children are converted.

Type Parameters

T
The type of model that the child objects are converted to.

Return Value

Type: IEnumerable T
The collection of models; An empty IEnumerableT if no child objects are found or if none of the child objects can be converted.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).ConvertReferencesToModels(T) Method

BaseItemModelConverterTFrom, TToConvertReferencesToModelsT Method

Gets a collection of T objects by converting the child objects of the specified ItemModel.

In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IEnumerable<T> ConvertReferencesToModels<T>(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose children are converted.
fieldName
Type: SystemString
The name of the field who value is read.

Type Parameters

T
The type of model that the child objects are converted to.

Return Value

Type: IEnumerable T
The collection of converted objects; An empty IEnumerableT if the specified field does not exist, or if the field value does not reference any objects, or if none of the referenced objects can be converted.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).ConvertReferenceToModel(T) Method

BaseItemModelConverterTFrom, TToConvertReferenceToModelT Method

Converts the ItemModel referenced by the specified field from the specified ItemModel.

In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository).

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected T ConvertReferenceToModel<T>(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Type Parameters

T
The type of model that the child objects are converted to.

Return Value

Type: T
The converted object; the default value for T if the field does not exist or if the field value cannot be converted.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).ConvertToModel(T) Method

BaseItemModelConverterTFrom, TToConvertToModelT Method
Converts the specified ItemModel into an object of the type specified by T.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected T ConvertToModel<T>(
    ItemModel itemModel
)

Parameters

itemModel
Type: ItemModel
The object that is converted.

Type Parameters

T
The type of object that the item model is converted to.

Return Value

Type: T
The converted object; if the item model could not be converted.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetBoolValue Method

BaseItemModelConverterTFrom, TToGetBoolValue Method
Gets the specified bool field value from the specified ItemModel.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected bool GetBoolValue(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: Boolean
The specified field value; if the field does not exist or if the field value is not a valid Sitecore checkbox field value.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetChildItemModels Method

BaseItemModelConverterTFrom, TToGetChildItemModels Method

Gets a collection of ItemModel objects that are children of the specified ItemModel.

If the child objects represent references to other framework components it is usually more convenient to use

ConvertChildrenToModelsT(ItemModel).

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IEnumerable<ItemModel> GetChildItemModels(
    ItemModel itemModel
)

Parameters

itemModel
Type: ItemModel
The object whose children are read.

Return Value

Type: IEnumerable ItemModel
The collection of child objects; An empty IEnumerableT if no child objects are found.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetDateTimeValue Method

BaseItemModelConverterTFrom, TToGetDateTimeValue Method
Gets the specified DateTime field value from the specified ItemModel.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected DateTime GetDateTimeValue(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: DateTime
The specified field value; MinValue if the field does not exist or if the field value is not a valid Sitecore date or datetime field value.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetEnumValue(T) Method

BaseItemModelConverterTFrom, TToGetEnumValueT Method
Gets the specified field value from the specified ItemModel as an enum of type T.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected T GetEnumValue<T>(
    TFrom itemModel,
    string fieldName
)
where T : struct, new()

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Type Parameters

T

Return Value

Type: T
The specified field value; default enum value if the field does not exist or if the field value is not a valid enum value.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetGuidValue Method

BaseItemModelConverterTFrom, TToGetGuidValue Method

Gets the specified Guid field value from the specified ItemModel.

If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String).

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected Guid GetGuidValue(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: Guid
The specified field value; Empty if the field does not exist or if the field value is not a valid Guid.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetGuidValues Method

BaseItemModelConverterTFrom, TToGetGuidValues Method

Gets a collection of Guid objects from the field value from the specified ItemModel.

If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String).

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IEnumerable<Guid> GetGuidValues(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: IEnumerable Guid
The collection of field values; An empty IEnumerableT if the field does not exist or if the field value is not a valid set of Guid value.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetInstance Method

BaseItemModelConverterTFrom, TToGetInstance Method

Creates an instance of the Type identified in the specified field from the specified ItemModel.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected Object GetInstance(
    TFrom itemModel,
    string fieldName,
    Object[] args = null
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.
args (Optional)
Type: SystemObject
The args that are passed to the constructor.

Return Value

Type: Object
The object; if the field does not exist or if the field value is not a valid Type or if the type does not have a public default constructor.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetIntValue Method

BaseItemModelConverterTFrom, TToGetIntValue Method
Gets the specified int field value from the specified ItemModel.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected int GetIntValue(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: Int32
The specified field value; 0 if the field does not exist or if the field value is not a valid int.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetReferenceAsModel Method

BaseItemModelConverterTFrom, TToGetReferenceAsModel Method

Gets the ItemModel referenced by the specified field from the specified ItemModel.

If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String).

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ItemModel GetReferenceAsModel(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: ItemModel
The specified field value; Empty if the field does not exist or if the field value is not a valid Guid.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetReferencesAsModels Method

BaseItemModelConverterTFrom, TToGetReferencesAsModels Method

Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel.

If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String).

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IEnumerable<ItemModel> GetReferencesAsModels(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: IEnumerable ItemModel
The specified field value; Empty if the field does not exist or if the field value is not a valid Guid.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetStringValue Method

BaseItemModelConverterTFrom, TToGetStringValue Method
Gets the specified string field value from the specified ItemModel.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected string GetStringValue(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: String
The specified field value; if the field does not exist.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


BaseItemModelConverter(TFrom, TTo).GetTypeFromTypeName Method

BaseItemModelConverterTFrom, TToGetTypeFromTypeName Method
Gets the Type identified in the specified field from the specified ItemModel.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected Type GetTypeFromTypeName(
    TFrom itemModel,
    string fieldName
)

Parameters

itemModel
Type: TFrom
The object whose field is read.
fieldName
Type: SystemString
The name of the field who value is read.

Return Value

Type: Type
The type; if the field does not exist or if the field value is not a valid Type.
See Also

Reference

BaseItemModelConverterTFrom, TTo Class
Sitecore.DataExchange.Converters Namespace


IsoDateTimeConverter Class

IsoDateTimeConverter Class

Provides the ability to convert to and from ISO date/time format, which Sitecore uses to store date/time values.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersIsoDateTimeConverter

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IsoDateTimeConverter : IConverter<string, DateTime>,
    IConverter<DateTime, string>

The IsoDateTimeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | IsoDateTimeConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ConvertToUtc | Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.
Public property | IncludeTicks | Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.
Top
Remarks
This logic replicates logic from Sitecore.DateUtil. This logic is replicated in order to avoid having to referencing Sitecore.Kernel.dll.
See Also

Reference

Sitecore.DataExchange.Converters Namespace


IsoDateTimeConverter Constructor

IsoDateTimeConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IsoDateTimeConverter()
See Also

Reference

IsoDateTimeConverter Class
Sitecore.DataExchange.Converters Namespace


IsoDateTimeConverter Properties

IsoDateTimeConverter Properties

The IsoDateTimeConverter type exposes the following members.

Properties
 | Name | Description
Public property | ConvertToUtc | Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.
Public property | IncludeTicks | Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.
Top
See Also

Reference

IsoDateTimeConverter Class
Sitecore.DataExchange.Converters Namespace


IsoDateTimeConverter.ConvertToUtc Property

IsoDateTimeConverterConvertToUtc Property
Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool ConvertToUtc { get; set; }

Property Value

Type: Boolean
See Also

Reference

IsoDateTimeConverter Class
Sitecore.DataExchange.Converters Namespace


IsoDateTimeConverter.IncludeTicks Property

IsoDateTimeConverterIncludeTicks Property
Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.

Namespace: Sitecore.DataExchange.Converters
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IncludeTicks { get; set; }

Property Value

Type: Boolean
See Also

Reference

IsoDateTimeConverter Class
Sitecore.DataExchange.Converters Namespace


Sitecore.DataExchange.Converters.ApplyMappingRules Namespace

Sitecore.DataExchange.Converters.ApplyMappingRules Namespace

This namespace contains converters for IApplyMappingRule types.

Classes
 | Class | Description
Public class | CollectionCountMappingRuleConverter | Converts an item model that represents a CollectionCountMappingRule object.
Public class | DefaultValueMappingRuleConverter | Converts an item model that represents a DefaultValueMappingRule object.
Public class | NullValueMappingRuleConverter | Converts an item model that represents a NullValueMappingRule object.


CollectionCountMappingRuleConverter Class

CollectionCountMappingRuleConverter Class

Converts an item model that represents a CollectionCountMappingRule object.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IApplyMappingRule
Sitecore.DataExchange.Converters.ApplyMappingRulesCollectionCountMappingRuleConverter

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class CollectionCountMappingRuleConverter : BaseItemModelConverter<ItemModel, IApplyMappingRule>

The CollectionCountMappingRuleConverter type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionCountMappingRuleConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new CollectionCountMappingRule object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


CollectionCountMappingRuleConverter Constructor

CollectionCountMappingRuleConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CollectionCountMappingRuleConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

CollectionCountMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


CollectionCountMappingRuleConverter Properties

CollectionCountMappingRuleConverter Properties

The CollectionCountMappingRuleConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

CollectionCountMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


CollectionCountMappingRuleConverter Methods

CollectionCountMappingRuleConverter Methods

The CollectionCountMappingRuleConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new CollectionCountMappingRule object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

CollectionCountMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


CollectionCountMappingRuleConverter.Convert Method

CollectionCountMappingRuleConverterConvert Method
Creates a new CollectionCountMappingRule object.

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IApplyMappingRule Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IApplyMappingRule
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

CollectionCountMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


DefaultValueMappingRuleConverter Class

DefaultValueMappingRuleConverter Class

Converts an item model that represents a DefaultValueMappingRule object.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IApplyMappingRule
Sitecore.DataExchange.Converters.ApplyMappingRulesDefaultValueMappingRuleConverter

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DefaultValueMappingRuleConverter : BaseItemModelConverter<ItemModel, IApplyMappingRule>

The DefaultValueMappingRuleConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultValueMappingRuleConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new DefaultValueMappingRule object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


DefaultValueMappingRuleConverter Constructor

DefaultValueMappingRuleConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DefaultValueMappingRuleConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

DefaultValueMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


DefaultValueMappingRuleConverter Properties

DefaultValueMappingRuleConverter Properties

The DefaultValueMappingRuleConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

DefaultValueMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


DefaultValueMappingRuleConverter Methods

DefaultValueMappingRuleConverter Methods

The DefaultValueMappingRuleConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new DefaultValueMappingRule object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

DefaultValueMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


DefaultValueMappingRuleConverter.Convert Method

DefaultValueMappingRuleConverterConvert Method
Creates a new DefaultValueMappingRule object.

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IApplyMappingRule Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IApplyMappingRule
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

DefaultValueMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


NullValueMappingRuleConverter Class

NullValueMappingRuleConverter Class

Converts an item model that represents a NullValueMappingRule object.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IApplyMappingRule
Sitecore.DataExchange.Converters.ApplyMappingRulesNullValueMappingRuleConverter

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class NullValueMappingRuleConverter : BaseItemModelConverter<ItemModel, IApplyMappingRule>

The NullValueMappingRuleConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NullValueMappingRuleConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new NullValueMappingRule object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


NullValueMappingRuleConverter Constructor

NullValueMappingRuleConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public NullValueMappingRuleConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

NullValueMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


NullValueMappingRuleConverter Properties

NullValueMappingRuleConverter Properties

The NullValueMappingRuleConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

NullValueMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


NullValueMappingRuleConverter Methods

NullValueMappingRuleConverter Methods

The NullValueMappingRuleConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new NullValueMappingRule object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

NullValueMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


NullValueMappingRuleConverter.Convert Method

NullValueMappingRuleConverterConvert Method
Creates a new NullValueMappingRule object.

Namespace: Sitecore.DataExchange.Converters.ApplyMappingRules
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IApplyMappingRule Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IApplyMappingRule
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

NullValueMappingRuleConverter Class
Sitecore.DataExchange.Converters.ApplyMappingRules Namespace


Sitecore.DataExchange.Converters.DataAccess.Readers Namespace

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace

This namespace contains converters for IValueReader types.

Classes
 | Class | Description
Public class | ArrayValueReaderConverter | Converts an item model that represents a ArrayValueReader object.
Public class | ConstantValueReaderConverter | Converts an item model that represents a ConstantValueReader object.
Public class | DateTimeValueReaderConverter | The DateTimeValueReaderConverter class
Public class | EnumValueReaderConverter | Converts an item model that represents a EnumValueReader object.
Public class | FallbackValueReaderConverter | Converts an item model that represents a FallbackValueReader object.
Public class | GuidValueReaderConverter | Converts an item model that represents a GuidValueReader object.
Public class | IsoDateValueReaderConverter | Converts an item model that represents a IsoDateValueReader object.
Public class | MethodValueReaderConverter | Converts an item model that represents a MethodValueReader object.
Public class | MethodValueReaderParameterConverter | Converts an item model that represents an object that is used as a parameter for a MethodValueReader.
Public class | NowValueReaderConverter | Converts an item model that represents a NowValueReader object.
Public class | NullValueReaderConverter | Converts an item model that represents a NullValueReader object.
Public class | PropertyValueReaderConverter | Converts an item model that represents a PropertyValueReader object.
Public class | RawValueReaderConverter | Converts an item model that represents a RawValueReader object.
Public class | SequentialValueReaderConverter | Converts an item model that represents a SequentialValueReader object.
Public class | ValueAccessorValueReaderConverter | Converts an item model that represents the IValueReader assigned to a IValueAccessor object.


ArrayValueReaderConverter Class

ArrayValueReaderConverter Class
Converts an item model that represents a ArrayValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersArrayValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ArrayValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The ArrayValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new ArrayValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ArrayValueReaderConverter Constructor

ArrayValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ArrayValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

ArrayValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ArrayValueReaderConverter Properties

ArrayValueReaderConverter Properties

The ArrayValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ArrayValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ArrayValueReaderConverter Methods

ArrayValueReaderConverter Methods

The ArrayValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new ArrayValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ArrayValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ArrayValueReaderConverter.Convert Method

ArrayValueReaderConverterConvert Method
Creates a new ArrayValueReader object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

ArrayValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ConstantValueReaderConverter Class

ConstantValueReaderConverter Class
Converts an item model that represents a ConstantValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersConstantValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ConstantValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The ConstantValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ConstantValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new ConstantValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToValueType | Converts the specified value into the specified value type.
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ConstantValueReaderConverter Constructor

ConstantValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ConstantValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

ConstantValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ConstantValueReaderConverter Properties

ConstantValueReaderConverter Properties

The ConstantValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ConstantValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ConstantValueReaderConverter Methods

ConstantValueReaderConverter Methods

The ConstantValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new ConstantValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToValueType | Converts the specified value into the specified value type.
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ConstantValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ConstantValueReaderConverter.Convert Method

ConstantValueReaderConverterConvert Method
Creates a new ConstantValueReader object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

ConstantValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ConstantValueReaderConverter.ConvertToValueType Method

ConstantValueReaderConverterConvertToValueType Method
Converts the specified value into the specified value type.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual Object ConvertToValueType(
    Object value,
    Type valueType
)

Parameters

value
Type: SystemObject
The value to convert.
valueType
Type: SystemType
The type to convert the value to.

Return Value

Type: Object
The value converted into the specified value type; if the specified value type is not supported, or if the value cannot be converted into the specified value type.
See Also

Reference

ConstantValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


DateTimeValueReaderConverter Class

DateTimeValueReaderConverter Class
The DateTimeValueReaderConverter class
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersDateTimeValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DateTimeValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The DateTimeValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeValueReaderConverter | Initializes a new instance of the DateTimeValueReaderConverter class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Converts the specified source. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace
[!:Sitecore.DataExchange.Converters.BaseItemModelConverter<Sitecore.Services.Core.Model.ItemModel, Sitecore.DataExchange.DataAccess.IValueReader>]


DateTimeValueReaderConverter Constructor

DateTimeValueReaderConverter Constructor
Initializes a new instance of the DateTimeValueReaderConverter class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateTimeValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The repository.
See Also

Reference

DateTimeValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


DateTimeValueReaderConverter Properties

DateTimeValueReaderConverter Properties

The DateTimeValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

DateTimeValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


DateTimeValueReaderConverter Methods

DateTimeValueReaderConverter Methods

The DateTimeValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Converts the specified source. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

DateTimeValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


DateTimeValueReaderConverter.Convert Method

DateTimeValueReaderConverterConvert Method
Converts the specified source.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The source.

Return Value

Type: IValueReader

[Missing <returns> documentation for "M:Sitecore.DataExchange.Converters.DataAccess.Readers.DateTimeValueReaderConverter.Convert(Sitecore.Services.Core.Model.ItemModel)"]

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

DateTimeValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


EnumValueReaderConverter Class

EnumValueReaderConverter Class
Converts an item model that represents a EnumValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersEnumValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class EnumValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The EnumValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | EnumValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new ConstantValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


EnumValueReaderConverter Constructor

EnumValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public EnumValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

EnumValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


EnumValueReaderConverter Properties

EnumValueReaderConverter Properties

The EnumValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

EnumValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


EnumValueReaderConverter Methods

EnumValueReaderConverter Methods

The EnumValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new ConstantValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

EnumValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


EnumValueReaderConverter.Convert Method

EnumValueReaderConverterConvert Method
Creates a new ConstantValueReader object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

EnumValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


FallbackValueReaderConverter Class

FallbackValueReaderConverter Class
Converts an item model that represents a FallbackValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersFallbackValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class FallbackValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The FallbackValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | FallbackValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new FallbackValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


FallbackValueReaderConverter Constructor

FallbackValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public FallbackValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

FallbackValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


FallbackValueReaderConverter Properties

FallbackValueReaderConverter Properties

The FallbackValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

FallbackValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


FallbackValueReaderConverter Methods

FallbackValueReaderConverter Methods

The FallbackValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new FallbackValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

FallbackValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


FallbackValueReaderConverter.Convert Method

FallbackValueReaderConverterConvert Method
Creates a new FallbackValueReader object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

FallbackValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


GuidValueReaderConverter Class

GuidValueReaderConverter Class
Converts an item model that represents a GuidValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersGuidValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class GuidValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The GuidValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | GuidValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. (Overrides BaseItemModelConverterTFrom, TToCanConvert(TFrom).)
Public method | Convert | Creates a new GuidValueReader object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


GuidValueReaderConverter Constructor

GuidValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public GuidValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

GuidValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


GuidValueReaderConverter Properties

GuidValueReaderConverter Properties

The GuidValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

GuidValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


GuidValueReaderConverter Methods

GuidValueReaderConverter Methods

The GuidValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. (Overrides BaseItemModelConverterTFrom, TToCanConvert(TFrom).)
Public method | Convert | Creates a new GuidValueReader object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

GuidValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


GuidValueReaderConverter.CanConvert Method

GuidValueReaderConverterCanConvert Method

Indicates whether or not the specified ItemModel can be converted.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override bool CanConvert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object to convert from.

Return Value

Type: Boolean
Since this converter does not use any settings on the source item model, this converter can convert any source item model. As a result this method always returns .

Implements

IConverterTFrom, TToCanConvert(TFrom)
See Also

Reference

GuidValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


GuidValueReaderConverter.Convert Method

GuidValueReaderConverterConvert Method
Creates a new GuidValueReader object.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

GuidValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


IsoDateValueReaderConverter Class

IsoDateValueReaderConverter Class
Converts an item model that represents a IsoDateValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersIsoDateValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IsoDateValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The IsoDateValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | IsoDateValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IsoDateValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


IsoDateValueReaderConverter Constructor

IsoDateValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IsoDateValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

IsoDateValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


IsoDateValueReaderConverter Properties

IsoDateValueReaderConverter Properties

The IsoDateValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

IsoDateValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


IsoDateValueReaderConverter Methods

IsoDateValueReaderConverter Methods

The IsoDateValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IsoDateValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

IsoDateValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


IsoDateValueReaderConverter.Convert Method

IsoDateValueReaderConverterConvert Method
Creates a new IsoDateValueReader object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

IsoDateValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderConverter Class

MethodValueReaderConverter Class
Converts an item model that represents a MethodValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersMethodValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MethodValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The MethodValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MethodValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new MethodValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDefaultArguments | Gets a collection of objects that represent the default arguments for the method. Override this method if more sophisticated logic is needed to determine the default arguments.
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderConverter Constructor

MethodValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MethodValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

MethodValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderConverter Properties

MethodValueReaderConverter Properties

The MethodValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

MethodValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderConverter Methods

MethodValueReaderConverter Methods

The MethodValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new MethodValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDefaultArguments | Gets a collection of objects that represent the default arguments for the method. Override this method if more sophisticated logic is needed to determine the default arguments.
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

MethodValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderConverter.Convert Method

MethodValueReaderConverterConvert Method
Creates a new MethodValueReader object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

MethodValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderConverter.GetDefaultArguments Method

MethodValueReaderConverterGetDefaultArguments Method

Gets a collection of objects that represent the default arguments for the method.

Override this method if more sophisticated logic is needed to determine the default arguments.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual ICollection<Object> GetDefaultArguments(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: ICollection Object
A collection of objects that represent the default arguments for the method.
See Also

Reference

MethodValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderParameterConverter Class

MethodValueReaderParameterConverter Class
Converts an item model that represents an object that is used as a parameter for a MethodValueReader.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, Object
Sitecore.DataExchange.Converters.DataAccess.ReadersMethodValueReaderParameterConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MethodValueReaderParameterConverter : BaseItemModelConverter<ItemModel, Object>

The MethodValueReaderParameterConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MethodValueReaderParameterConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertValue | Converts the specified value into the specified type.
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderParameterConverter Constructor

MethodValueReaderParameterConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MethodValueReaderParameterConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

MethodValueReaderParameterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderParameterConverter Properties

MethodValueReaderParameterConverter Properties

The MethodValueReaderParameterConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

MethodValueReaderParameterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderParameterConverter Methods

MethodValueReaderParameterConverter Methods

The MethodValueReaderParameterConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertValue | Converts the specified value into the specified type.
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

MethodValueReaderParameterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderParameterConverter.Convert Method

MethodValueReaderParameterConverterConvert Method
Creates a new object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override Object Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: Object
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

MethodValueReaderParameterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


MethodValueReaderParameterConverter.ConvertValue Method

MethodValueReaderParameterConverterConvertValue Method
Converts the specified value into the specified type.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual Object ConvertValue(
    string value,
    Type type
)

Parameters

value
Type: SystemString
The value to convert.
type
Type: SystemType
The type the value is converted to.

Return Value

Type: Object

[Missing <returns> documentation for "M:Sitecore.DataExchange.Converters.DataAccess.Readers.MethodValueReaderParameterConverter.ConvertValue(System.String,System.Type)"]

See Also

Reference

MethodValueReaderParameterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NowValueReaderConverter Class

NowValueReaderConverter Class
Converts an item model that represents a NowValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersNowValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class NowValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The NowValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NowValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new NowValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NowValueReaderConverter Constructor

NowValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public NowValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

NowValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NowValueReaderConverter Properties

NowValueReaderConverter Properties

The NowValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

NowValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NowValueReaderConverter Methods

NowValueReaderConverter Methods

The NowValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new NowValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

NowValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NowValueReaderConverter.Convert Method

NowValueReaderConverterConvert Method
Creates a new NowValueReader object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

NowValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NullValueReaderConverter Class

NullValueReaderConverter Class
Converts an item model that represents a NullValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersNullValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class NullValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The NullValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NullValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. (Overrides BaseItemModelConverterTFrom, TToCanConvert(TFrom).)
Public method | Convert | Creates a new NullValueReader object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NullValueReaderConverter Constructor

NullValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public NullValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

NullValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NullValueReaderConverter Properties

NullValueReaderConverter Properties

The NullValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

NullValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NullValueReaderConverter Methods

NullValueReaderConverter Methods

The NullValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. (Overrides BaseItemModelConverterTFrom, TToCanConvert(TFrom).)
Public method | Convert | Creates a new NullValueReader object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

NullValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NullValueReaderConverter.CanConvert Method

NullValueReaderConverterCanConvert Method

Indicates whether or not the specified ItemModel can be converted.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override bool CanConvert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object to convert from.

Return Value

Type: Boolean
Since this converter does not use any settings on the source item model, this converter can convert any source item model. As a result this method always returns .

Implements

IConverterTFrom, TToCanConvert(TFrom)
See Also

Reference

NullValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


NullValueReaderConverter.Convert Method

NullValueReaderConverterConvert Method
Creates a new NullValueReader object.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

NullValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


PropertyValueReaderConverter Class

PropertyValueReaderConverter Class
Converts an item model that represents a PropertyValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersPropertyValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PropertyValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The PropertyValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PropertyValueReader object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


PropertyValueReaderConverter Constructor

PropertyValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

PropertyValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


PropertyValueReaderConverter Properties

PropertyValueReaderConverter Properties

The PropertyValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PropertyValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


PropertyValueReaderConverter Methods

PropertyValueReaderConverter Methods

The PropertyValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PropertyValueReader object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PropertyValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


PropertyValueReaderConverter.Convert Method

PropertyValueReaderConverterConvert Method
Creates a new PropertyValueReader object.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

PropertyValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


RawValueReaderConverter Class

RawValueReaderConverter Class
Converts an item model that represents a RawValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersRawValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class RawValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The RawValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | RawValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. (Overrides BaseItemModelConverterTFrom, TToCanConvert(TFrom).)
Public method | Convert | Creates a new RawValueReader object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


RawValueReaderConverter Constructor

RawValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public RawValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

RawValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


RawValueReaderConverter Properties

RawValueReaderConverter Properties

The RawValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

RawValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


RawValueReaderConverter Methods

RawValueReaderConverter Methods

The RawValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. (Overrides BaseItemModelConverterTFrom, TToCanConvert(TFrom).)
Public method | Convert | Creates a new RawValueReader object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

RawValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


RawValueReaderConverter.CanConvert Method

RawValueReaderConverterCanConvert Method

Indicates whether or not the specified ItemModel can be converted.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override bool CanConvert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object to convert from.

Return Value

Type: Boolean
Since this converter does not use any settings on the source item model, this converter can convert any source item model. As a result this method always returns .

Implements

IConverterTFrom, TToCanConvert(TFrom)
See Also

Reference

RawValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


RawValueReaderConverter.Convert Method

RawValueReaderConverterConvert Method
Creates a new RawValueReader object.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

RawValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


SequentialValueReaderConverter Class

SequentialValueReaderConverter Class
Converts an item model that represents a SequentialValueReader object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersSequentialValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class SequentialValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The SequentialValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SequentialValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new SequentialValueReader object and populates the Readers collection using the child items. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


SequentialValueReaderConverter Constructor

SequentialValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public SequentialValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

SequentialValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


SequentialValueReaderConverter Properties

SequentialValueReaderConverter Properties

The SequentialValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

SequentialValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


SequentialValueReaderConverter Methods

SequentialValueReaderConverter Methods

The SequentialValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new SequentialValueReader object and populates the Readers collection using the child items. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

SequentialValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


SequentialValueReaderConverter.Convert Method

SequentialValueReaderConverterConvert Method
Creates a new SequentialValueReader object and populates the Readers collection using the child items.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

SequentialValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ValueAccessorValueReaderConverter Class

ValueAccessorValueReaderConverter Class
Converts an item model that represents the IValueReader assigned to a IValueAccessor object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueReader
Sitecore.DataExchange.Converters.DataAccess.ReadersValueAccessorValueReaderConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ValueAccessorValueReaderConverter : BaseItemModelConverter<ItemModel, IValueReader>

The ValueAccessorValueReaderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAccessorValueReaderConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ValueAccessorValueReaderConverter Constructor

ValueAccessorValueReaderConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ValueAccessorValueReaderConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

ValueAccessorValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ValueAccessorValueReaderConverter Properties

ValueAccessorValueReaderConverter Properties

The ValueAccessorValueReaderConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ValueAccessorValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ValueAccessorValueReaderConverter Methods

ValueAccessorValueReaderConverter Methods

The ValueAccessorValueReaderConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IValueReader object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ValueAccessorValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


ValueAccessorValueReaderConverter.Convert Method

ValueAccessorValueReaderConverterConvert Method
Creates a new IValueReader object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Readers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueReader Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueReader
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

ValueAccessorValueReaderConverter Class
Sitecore.DataExchange.Converters.DataAccess.Readers Namespace


Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace

Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace

This namespace contains converters for IValueAccessor and IValueAccessorSet types.

Classes
 | Class | Description
Public class | ChildBasedValueAccessorSetConverter | Creates a IValueAccessorSet object based on settings from a ItemModel. The IValueAccessorSet object is populated using the children of the specified source item model.
Public class | PropertyValueAccessorConverter | Creates a IValueAccessor object based on settings from a ItemModel. The IValueAccessor object provides the ability to read and write a property value from any object.
Public class | ValueAccessorConverter | Creates a IValueAccessor object based on settings from a ItemModel. This type is extended when additional fields are available on the item model that are used to determine the objects set on ValueReader and ValueWriter. An example is PropertyValueAccessorConverter.


ChildBasedValueAccessorSetConverter Class

ChildBasedValueAccessorSetConverter Class
Creates a IValueAccessorSet object based on settings from a ItemModel. The IValueAccessorSet object is populated using the children of the specified source item model.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueAccessorSet
Sitecore.DataExchange.Converters.DataAccess.ValueAccessorsChildBasedValueAccessorSetConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ChildBasedValueAccessorSetConverter : BaseItemModelConverter<ItemModel, IValueAccessorSet>

The ChildBasedValueAccessorSetConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ChildBasedValueAccessorSetConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Converts the specified object to a IValueAccessorSet object, converts each child item model into a IValueAccessor object and adds the value accessor object to the value accessor set object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ChildBasedValueAccessorSetConverter Constructor

ChildBasedValueAccessorSetConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ChildBasedValueAccessorSetConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

ChildBasedValueAccessorSetConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ChildBasedValueAccessorSetConverter Properties

ChildBasedValueAccessorSetConverter Properties

The ChildBasedValueAccessorSetConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ChildBasedValueAccessorSetConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ChildBasedValueAccessorSetConverter Methods

ChildBasedValueAccessorSetConverter Methods

The ChildBasedValueAccessorSetConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Converts the specified object to a IValueAccessorSet object, converts each child item model into a IValueAccessor object and adds the value accessor object to the value accessor set object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ChildBasedValueAccessorSetConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ChildBasedValueAccessorSetConverter.Convert Method

ChildBasedValueAccessorSetConverterConvert Method
Converts the specified object to a IValueAccessorSet object, converts each child item model into a IValueAccessor object and adds the value accessor object to the value accessor set object.

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueAccessorSet Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueAccessorSet
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

ChildBasedValueAccessorSetConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


PropertyValueAccessorConverter Class

PropertyValueAccessorConverter Class
Creates a IValueAccessor object based on settings from a ItemModel. The IValueAccessor object provides the ability to read and write a property value from any object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueAccessor
Sitecore.DataExchange.Converters.DataAccess.ValueAccessorsValueAccessorConverter
Sitecore.DataExchange.Converters.DataAccess.ValueAccessorsPropertyValueAccessorConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PropertyValueAccessorConverter : ValueAccessorConverter

The PropertyValueAccessorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyValueAccessorConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IValueAccessor object based on the specified item model. The IValueAccessor is configured to be able to read and write the property specified on the item model. The property is specified on the item model by the field PropertyName. (Overrides ValueAccessorConverterConvert(ItemModel).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


PropertyValueAccessorConverter Constructor

PropertyValueAccessorConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyValueAccessorConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

PropertyValueAccessorConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


PropertyValueAccessorConverter Properties

PropertyValueAccessorConverter Properties

The PropertyValueAccessorConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PropertyValueAccessorConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


PropertyValueAccessorConverter Methods

PropertyValueAccessorConverter Methods

The PropertyValueAccessorConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IValueAccessor object based on the specified item model. The IValueAccessor is configured to be able to read and write the property specified on the item model. The property is specified on the item model by the field PropertyName. (Overrides ValueAccessorConverterConvert(ItemModel).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PropertyValueAccessorConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


PropertyValueAccessorConverter.Convert Method

PropertyValueAccessorConverterConvert Method

Creates a new IValueAccessor object based on the specified item model.

The IValueAccessor is configured to be able to read and write the property specified on the item model. The property is specified on the item model by the field PropertyName.

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueAccessor Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object whose settings are used to create a new IValueAccessor object.

Return Value

Type: IValueAccessor
The new object; if the object cannot be created, such as when insufficient information is available from the source object.

Implements

IConverterTFrom, TToConvert(TFrom)
Remarks

The converter creates the appropriate objects for the ValueReader property and the ValueWriter property, unless the base class has already set them. This allows specific source item models to "override" the default behavior of this converter.

For example, you might want to let the converter determine the value reader that is used, but there is special logic that is needed for the value writer. In this case, the Sitecore item would have a specific value writer specified on the field ValueWriter, but not on the field ValueReader. By setting the value writer field, the converter will use the specified value writer. But not setting the value reader field, the converter will determine the appropriate value reader.

See Also

Reference

PropertyValueAccessorConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ValueAccessorConverter Class

ValueAccessorConverter Class

Creates a IValueAccessor object based on settings from a ItemModel.

This type is extended when additional fields are available on the item model that are used to determine the objects set on ValueReader and ValueWriter. An example is PropertyValueAccessorConverter.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueAccessor
Sitecore.DataExchange.Converters.DataAccess.ValueAccessorsValueAccessorConverter
Sitecore.DataExchange.Converters.DataAccess.ValueAccessorsPropertyValueAccessorConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ValueAccessorConverter : BaseItemModelConverter<ItemModel, IValueAccessor>

The ValueAccessorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAccessorConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IValueAccessor object based on the specified item model. The new object provides access to the value reader specified on the field ValueReader and the value writer specified on the field ValueWriter. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ValueAccessorConverter Constructor

ValueAccessorConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ValueAccessorConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

ValueAccessorConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ValueAccessorConverter Properties

ValueAccessorConverter Properties

The ValueAccessorConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ValueAccessorConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ValueAccessorConverter Methods

ValueAccessorConverter Methods

The ValueAccessorConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IValueAccessor object based on the specified item model. The new object provides access to the value reader specified on the field ValueReader and the value writer specified on the field ValueWriter. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ValueAccessorConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


ValueAccessorConverter.Convert Method

ValueAccessorConverterConvert Method

Creates a new IValueAccessor object based on the specified item model. The new object provides access to the value reader specified on the field ValueReader and the value writer specified on the field ValueWriter.

Namespace: Sitecore.DataExchange.Converters.DataAccess.ValueAccessors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueAccessor Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object whose settings are used to create a new IValueAccessor object.

Return Value

Type: IValueAccessor
The new object; if the object cannot be created, such as when insufficient information is available from the source object.

Implements

IConverterTFrom, TToConvert(TFrom)
Remarks

Classes that extend this type should consider deferring to the ValueReader and ValueWriter populated by this converter.

Types that extend this type typically do so in order to implement logic to determine the most appropriate value reader and value writer. But it can be useful to allow this logic to be overridden when needed. By deferring to the value reader and value writer determined by this converter, you can take advantage of a built-in means for overriding these properties.

See Also

Reference

ValueAccessorConverter Class
Sitecore.DataExchange.Converters.DataAccess.ValueAccessors Namespace


Sitecore.DataExchange.Converters.DataAccess.Writers Namespace

Sitecore.DataExchange.Converters.DataAccess.Writers Namespace

This namespace contains converters for IValueWriter types.

Classes
 | Class | Description
Public class | PropertyValueWriterConverter | Converts an item model that represents a PropertyValueWriter object.
Public class | TargetReaderValueWriterConverter | Converts an item model that represents the IValueWriter assigned to a IValueAccessor object.


PropertyValueWriterConverter Class

PropertyValueWriterConverter Class
Converts an item model that represents a PropertyValueWriter object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueWriter
Sitecore.DataExchange.Converters.DataAccess.WritersPropertyValueWriterConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Writers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PropertyValueWriterConverter : BaseItemModelConverter<ItemModel, IValueWriter>

The PropertyValueWriterConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyValueWriterConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PropertyValueWriter object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


PropertyValueWriterConverter Constructor

PropertyValueWriterConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Writers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyValueWriterConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

PropertyValueWriterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


PropertyValueWriterConverter Properties

PropertyValueWriterConverter Properties

The PropertyValueWriterConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PropertyValueWriterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


PropertyValueWriterConverter Methods

PropertyValueWriterConverter Methods

The PropertyValueWriterConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PropertyValueWriter object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PropertyValueWriterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


PropertyValueWriterConverter.Convert Method

PropertyValueWriterConverterConvert Method
Creates a new PropertyValueWriter object.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Writers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueWriter Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueWriter
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

PropertyValueWriterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


TargetReaderValueWriterConverter Class

TargetReaderValueWriterConverter Class
Converts an item model that represents the IValueWriter assigned to a IValueAccessor object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IValueWriter
Sitecore.DataExchange.Converters.DataAccess.WritersTargetReaderValueWriterConverter

Namespace: Sitecore.DataExchange.Converters.DataAccess.Writers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class TargetReaderValueWriterConverter : BaseItemModelConverter<ItemModel, IValueWriter>

The TargetReaderValueWriterConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TargetReaderValueWriterConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IValueWriter object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


TargetReaderValueWriterConverter Constructor

TargetReaderValueWriterConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Writers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public TargetReaderValueWriterConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

TargetReaderValueWriterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


TargetReaderValueWriterConverter Properties

TargetReaderValueWriterConverter Properties

The TargetReaderValueWriterConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

TargetReaderValueWriterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


TargetReaderValueWriterConverter Methods

TargetReaderValueWriterConverter Methods

The TargetReaderValueWriterConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IValueWriter object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

TargetReaderValueWriterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


TargetReaderValueWriterConverter.Convert Method

TargetReaderValueWriterConverterConvert Method
Creates a new IValueWriter object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.DataAccess.Writers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IValueWriter Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IValueWriter
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

TargetReaderValueWriterConverter Class
Sitecore.DataExchange.Converters.DataAccess.Writers Namespace


Sitecore.DataExchange.Converters.Endpoints Namespace

Sitecore.DataExchange.Converters.Endpoints Namespace

This namespace contains converters for Endpoint types.

Classes
 | Class | Description
Public class | BaseEndpointConverterTFrom | Base class for converters that are used to create Endpoint objects. This type is extended when additional fields are available on the item model that are used to create IPlugin objects that are assigned to the Endpoint.
Public class | QueueEndpointConverter | Creates a Endpoint object based on settings from a ItemModel.


BaseEndpointConverter(TFrom) Class

BaseEndpointConverterTFrom Class

Base class for converters that are used to create Endpoint objects.

This type is extended when additional fields are available on the item model that are used to create IPlugin objects that are assigned to the Endpoint.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter TFrom, Endpoint
Sitecore.DataExchange.Converters.EndpointsBaseEndpointConverterTFrom
Sitecore.DataExchange.Converters.EndpointsQueueEndpointConverter

Namespace: Sitecore.DataExchange.Converters.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BaseEndpointConverter<TFrom> : BaseItemModelConverter<TFrom, Endpoint>
where TFrom : ItemModel

Type Parameters

TFrom

[Missing <typeparam name="TFrom"/> documentation for "T:Sitecore.DataExchange.Converters.Endpoints.BaseEndpointConverter`1"]

The BaseEndpointConverterTFrom type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseEndpointConverterTFrom | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the Endpoint object's collection of plugins.
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new Endpoint object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.Endpoints Namespace


BaseEndpointConverter(TFrom) Constructor

BaseEndpointConverterTFrom Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BaseEndpointConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

BaseEndpointConverterTFrom Class
Sitecore.DataExchange.Converters.Endpoints Namespace


BaseEndpointConverter(TFrom) Properties

BaseEndpointConverterTFrom Properties

The BaseEndpointConverterTFrom generic type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

BaseEndpointConverterTFrom Class
Sitecore.DataExchange.Converters.Endpoints Namespace


BaseEndpointConverter(TFrom) Methods

BaseEndpointConverterTFrom Methods

The BaseEndpointConverterTFrom generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the Endpoint object's collection of plugins.
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new Endpoint object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

BaseEndpointConverterTFrom Class
Sitecore.DataExchange.Converters.Endpoints Namespace


BaseEndpointConverter(TFrom).AddPlugins Method

BaseEndpointConverterTFromAddPlugins Method
Creates new IPlugin objects based on the specified item model and adds them to the Endpoint object's collection of plugins.

Namespace: Sitecore.DataExchange.Converters.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected abstract void AddPlugins(
    TFrom source,
    Endpoint endpoint
)

Parameters

source
Type: TFrom
The object to read plugin settings from.
endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
The object to which the plugin objects are added.
See Also

Reference

BaseEndpointConverterTFrom Class
Sitecore.DataExchange.Converters.Endpoints Namespace


BaseEndpointConverter(TFrom).Convert Method

BaseEndpointConverterTFromConvert Method
Creates a new Endpoint object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override Endpoint Convert(
    TFrom source
)

Parameters

source
Type: TFrom
The object to convert from.

Return Value

Type: Endpoint
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

BaseEndpointConverterTFrom Class
Sitecore.DataExchange.Converters.Endpoints Namespace


QueueEndpointConverter Class

QueueEndpointConverter Class
Creates a Endpoint object based on settings from a ItemModel.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, Endpoint
Sitecore.DataExchange.Converters.EndpointsBaseEndpointConverter ItemModel
Sitecore.DataExchange.Converters.EndpointsQueueEndpointConverter

Namespace: Sitecore.DataExchange.Converters.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class QueueEndpointConverter : BaseEndpointConverter<ItemModel>

The QueueEndpointConverter type exposes the following members.

Constructors
 | Name | Description
Public method | QueueEndpointConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the Endpoint object's collection of plugins. By default this method adds the plugin WorkQueueSettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the Endpoint object. (Overrides BaseEndpointConverterTFromAddPlugins(TFrom, Endpoint).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new Endpoint object based on the specified item model. (Inherited from BaseEndpointConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.Endpoints Namespace


QueueEndpointConverter Constructor

QueueEndpointConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public QueueEndpointConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

QueueEndpointConverter Class
Sitecore.DataExchange.Converters.Endpoints Namespace


QueueEndpointConverter Properties

QueueEndpointConverter Properties

The QueueEndpointConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

QueueEndpointConverter Class
Sitecore.DataExchange.Converters.Endpoints Namespace


QueueEndpointConverter Methods

QueueEndpointConverter Methods

The QueueEndpointConverter type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the Endpoint object's collection of plugins. By default this method adds the plugin WorkQueueSettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the Endpoint object. (Overrides BaseEndpointConverterTFromAddPlugins(TFrom, Endpoint).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new Endpoint object based on the specified item model. (Inherited from BaseEndpointConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

QueueEndpointConverter Class
Sitecore.DataExchange.Converters.Endpoints Namespace


QueueEndpointConverter.AddPlugins Method

QueueEndpointConverterAddPlugins Method

Creates new IPlugin objects based on the specified item model and adds them to the Endpoint object's collection of plugins.

By default this method adds the plugin WorkQueueSettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the Endpoint object.

Namespace: Sitecore.DataExchange.Converters.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void AddPlugins(
    ItemModel source,
    Endpoint endpoint
)

Parameters

source
Type: ItemModel
The object to read plugin settings from.
endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
The object to which the plugin objects are added.
See Also

Reference

QueueEndpointConverter Class
Sitecore.DataExchange.Converters.Endpoints Namespace


Sitecore.DataExchange.Converters.Mappings Namespace

Sitecore.DataExchange.Converters.Mappings Namespace

This namespace contains converters for types related to mapping.

Classes
 | Class | Description
Public class | ChildBasedMappingSetConverter | Creates a IMappingSet object based on settings from a ItemModel. The IMappingSet object is populated using the children of the specified source item model.
Public class | MappingConverter | Creates a IMapping object based on settings from a ItemModel.


ChildBasedMappingSetConverter Class

ChildBasedMappingSetConverter Class
Creates a IMappingSet object based on settings from a ItemModel. The IMappingSet object is populated using the children of the specified source item model.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IMappingSet
Sitecore.DataExchange.Converters.MappingsChildBasedMappingSetConverter

Namespace: Sitecore.DataExchange.Converters.Mappings
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ChildBasedMappingSetConverter : BaseItemModelConverter<ItemModel, IMappingSet>

The ChildBasedMappingSetConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ChildBasedMappingSetConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Converts the specified object to a IMappingSet object, converts each child item model into a IMapping object and adds the mapping object to the mapping set object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.Mappings Namespace


ChildBasedMappingSetConverter Constructor

ChildBasedMappingSetConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.Mappings
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ChildBasedMappingSetConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

ChildBasedMappingSetConverter Class
Sitecore.DataExchange.Converters.Mappings Namespace


ChildBasedMappingSetConverter Properties

ChildBasedMappingSetConverter Properties

The ChildBasedMappingSetConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ChildBasedMappingSetConverter Class
Sitecore.DataExchange.Converters.Mappings Namespace


ChildBasedMappingSetConverter Methods

ChildBasedMappingSetConverter Methods

The ChildBasedMappingSetConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Converts the specified object to a IMappingSet object, converts each child item model into a IMapping object and adds the mapping object to the mapping set object. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ChildBasedMappingSetConverter Class
Sitecore.DataExchange.Converters.Mappings Namespace


ChildBasedMappingSetConverter.Convert Method

ChildBasedMappingSetConverterConvert Method
Converts the specified object to a IMappingSet object, converts each child item model into a IMapping object and adds the mapping object to the mapping set object.

Namespace: Sitecore.DataExchange.Converters.Mappings
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IMappingSet Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: IMappingSet
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

ChildBasedMappingSetConverter Class
Sitecore.DataExchange.Converters.Mappings Namespace


MappingConverter Class

MappingConverter Class

Creates a IMapping object based on settings from a ItemModel.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, IMapping
Sitecore.DataExchange.Converters.MappingsMappingConverter

Namespace: Sitecore.DataExchange.Converters.Mappings
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MappingConverter : BaseItemModelConverter<ItemModel, IMapping>

The MappingConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MappingConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IMapping object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.Mappings Namespace


MappingConverter Constructor

MappingConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.Mappings
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MappingConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

MappingConverter Class
Sitecore.DataExchange.Converters.Mappings Namespace


MappingConverter Properties

MappingConverter Properties

The MappingConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

MappingConverter Class
Sitecore.DataExchange.Converters.Mappings Namespace


MappingConverter Methods

MappingConverter Methods

The MappingConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new IMapping object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

MappingConverter Class
Sitecore.DataExchange.Converters.Mappings Namespace


MappingConverter.Convert Method

MappingConverterConvert Method

Creates a new IMapping object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.Mappings
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override IMapping Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object whose settings are used to create a new IMapping object.

Return Value

Type: IMapping
The new object; if the object cannot be created, such as when insufficient information is available from the source object.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

MappingConverter Class
Sitecore.DataExchange.Converters.Mappings Namespace


Sitecore.DataExchange.Converters.PipelineBatches Namespace

Sitecore.DataExchange.Converters.PipelineBatches Namespace

This namespace contains converters for PipelineBatch types.

Classes
 | Class | Description
Public class | PipelineBatchConverter | Creates a PipelineBatch object based on settings from a ItemModel.


PipelineBatchConverter Class

PipelineBatchConverter Class

Creates a PipelineBatch object based on settings from a ItemModel.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, PipelineBatch
Sitecore.DataExchange.Converters.PipelineBatchesPipelineBatchConverter

Namespace: Sitecore.DataExchange.Converters.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineBatchConverter : BaseItemModelConverter<ItemModel, PipelineBatch>

The PipelineBatchConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineBatchConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the PipelineBatch object's collection of plugins. By default this method adds the plugin TelemetryActivitySettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the PipelineBatch object.
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineBatch object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.PipelineBatches Namespace


PipelineBatchConverter Constructor

PipelineBatchConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatchConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

PipelineBatchConverter Class
Sitecore.DataExchange.Converters.PipelineBatches Namespace


PipelineBatchConverter Properties

PipelineBatchConverter Properties

The PipelineBatchConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PipelineBatchConverter Class
Sitecore.DataExchange.Converters.PipelineBatches Namespace


PipelineBatchConverter Methods

PipelineBatchConverter Methods

The PipelineBatchConverter type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the PipelineBatch object's collection of plugins. By default this method adds the plugin TelemetryActivitySettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the PipelineBatch object.
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineBatch object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PipelineBatchConverter Class
Sitecore.DataExchange.Converters.PipelineBatches Namespace


PipelineBatchConverter.AddPlugins Method

PipelineBatchConverterAddPlugins Method

Creates new IPlugin objects based on the specified item model and adds them to the PipelineBatch object's collection of plugins.

By default this method adds the plugin TelemetryActivitySettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the PipelineBatch object.

Namespace: Sitecore.DataExchange.Converters.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void AddPlugins(
    ItemModel source,
    PipelineBatch pipelineBatch
)

Parameters

source
Type: ItemModel
The object to read plugin settings from.
pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The object to which the plugin objects are added.
See Also

Reference

PipelineBatchConverter Class
Sitecore.DataExchange.Converters.PipelineBatches Namespace


PipelineBatchConverter.Convert Method

PipelineBatchConverterConvert Method

Creates a new PipelineBatch object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override PipelineBatch Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object whose settings are used to create a new PipelineBatch object.

Return Value

Type: PipelineBatch
The new object; if the object cannot be created, such as when insufficient information is available from the source object.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

PipelineBatchConverter Class
Sitecore.DataExchange.Converters.PipelineBatches Namespace


Sitecore.DataExchange.Converters.Pipelines Namespace

Sitecore.DataExchange.Converters.Pipelines Namespace

This namespace contains converters for PipelineStep types.

Classes
 | Class | Description
Public class | PipelineConverter | Creates a Pipeline object based on settings from a ItemModel. This converter attempts to convert child items on the source item model into PipelineStep objects that are set on PipelineSteps.


PipelineConverter Class

PipelineConverter Class

Creates a Pipeline object based on settings from a ItemModel.

This converter attempts to convert child items on the source item model into PipelineStep objects that are set on PipelineSteps.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, Pipeline
Sitecore.DataExchange.Converters.PipelinesPipelineConverter

Namespace: Sitecore.DataExchange.Converters.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineConverter : BaseItemModelConverter<ItemModel, Pipeline>

The PipelineConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the Pipeline object's collection of plugins. By default this method adds the plugin TelemetryActivitySettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the Pipeline object.
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new Pipeline object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.Pipelines Namespace


PipelineConverter Constructor

PipelineConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

PipelineConverter Class
Sitecore.DataExchange.Converters.Pipelines Namespace


PipelineConverter Properties

PipelineConverter Properties

The PipelineConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PipelineConverter Class
Sitecore.DataExchange.Converters.Pipelines Namespace


PipelineConverter Methods

PipelineConverter Methods

The PipelineConverter type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the Pipeline object's collection of plugins. By default this method adds the plugin TelemetryActivitySettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the Pipeline object.
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new Pipeline object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

PipelineConverter Class
Sitecore.DataExchange.Converters.Pipelines Namespace


PipelineConverter.AddPlugins Method

PipelineConverterAddPlugins Method

Creates new IPlugin objects based on the specified item model and adds them to the Pipeline object's collection of plugins.

By default this method adds the plugin TelemetryActivitySettings. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the Pipeline object.

Namespace: Sitecore.DataExchange.Converters.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void AddPlugins(
    ItemModel source,
    Pipeline pipeline
)

Parameters

source
Type: ItemModel
The object to read plugin settings from.
pipeline
Type: Sitecore.DataExchange.ModelsPipeline
The object to which the plugin objects are added.
See Also

Reference

PipelineConverter Class
Sitecore.DataExchange.Converters.Pipelines Namespace


PipelineConverter.Convert Method

PipelineConverterConvert Method

Creates a new Pipeline object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override Pipeline Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object whose settings are used to create a new Pipeline object.

Return Value

Type: Pipeline
The new object; if the object cannot be created, such as when insufficient information is available from the source object.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

PipelineConverter Class
Sitecore.DataExchange.Converters.Pipelines Namespace


Sitecore.DataExchange.Converters.PipelineSteps Namespace

Sitecore.DataExchange.Converters.PipelineSteps Namespace

This namespace contains converters for PipelineStep types.

Classes
 | Class | Description
Public class | ApplyMappingStepConverter | Creates a PipelineStep object with a MappingSettings plugin based on settings from a ItemModel.
Public class | BasePipelineStepConverterTFrom | Base class for converters that are used to create PipelineStep objects. This type is extended when additional fields are available on the item model that are used to create IPlugin objects that are assigned to the PipelineStep.
Public class | BaseResolveObjectFromEndpointStepConverter | Creates a PipelineStep object with a ResolveObjectSettings plugin and a EndpointSettings plugin based on settings from a ItemModel.
Public class | DefaultPipelineStepConverter | Creates a PipelineStep object based on settings from a ItemModel.
Public class | IterateDataAndRunPipelinesStepConverter | Creates a PipelineStep object with a PipelinesSettings plugin based on settings from a ItemModel.
Public class | ProcessQueueStepConverter | Creates a PipelineStep object with a WorkQueueProcessorStepSettings plugin based on settings from a ItemModel.


ApplyMappingStepConverter Class

ApplyMappingStepConverter Class
Creates a PipelineStep object with a MappingSettings plugin based on settings from a ItemModel.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, PipelineStep
Sitecore.DataExchange.Converters.PipelineStepsBasePipelineStepConverter ItemModel
Sitecore.DataExchange.Converters.PipelineStepsApplyMappingStepConverter

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ApplyMappingStepConverter : BasePipelineStepConverter<ItemModel>

The ApplyMappingStepConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ApplyMappingStepConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates a new MappingSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Inherited from BasePipelineStepConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.PipelineSteps Namespace


ApplyMappingStepConverter Constructor

ApplyMappingStepConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ApplyMappingStepConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

ApplyMappingStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


ApplyMappingStepConverter Properties

ApplyMappingStepConverter Properties

The ApplyMappingStepConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ApplyMappingStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


ApplyMappingStepConverter Methods

ApplyMappingStepConverter Methods

The ApplyMappingStepConverter type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates a new MappingSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Inherited from BasePipelineStepConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ApplyMappingStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


ApplyMappingStepConverter.AddPlugins Method

ApplyMappingStepConverterAddPlugins Method
Creates a new MappingSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void AddPlugins(
    ItemModel source,
    PipelineStep pipelineStep
)

Parameters

source
Type: ItemModel
The object to read plugin settings from.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object to which the plugin objects are added.
See Also

Reference

ApplyMappingStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BasePipelineStepConverter(TFrom) Class

BasePipelineStepConverterTFrom Class

Base class for converters that are used to create PipelineStep objects.

This type is extended when additional fields are available on the item model that are used to create IPlugin objects that are assigned to the PipelineStep.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter TFrom, PipelineStep
Sitecore.DataExchange.Converters.PipelineStepsBasePipelineStepConverterTFrom
Sitecore.DataExchange.Converters.PipelineStepsApplyMappingStepConverter
Sitecore.DataExchange.Converters.PipelineStepsBaseResolveObjectFromEndpointStepConverter
Sitecore.DataExchange.Converters.PipelineStepsDefaultPipelineStepConverter
Sitecore.DataExchange.Converters.PipelineStepsIterateDataAndRunPipelinesStepConverter
Sitecore.DataExchange.Converters.PipelineStepsProcessQueueStepConverter

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BasePipelineStepConverter<TFrom> : BaseItemModelConverter<TFrom, PipelineStep>
where TFrom : ItemModel

Type Parameters

TFrom

[Missing <typeparam name="TFrom"/> documentation for "T:Sitecore.DataExchange.Converters.PipelineSteps.BasePipelineStepConverter`1"]

The BasePipelineStepConverterTFrom type exposes the following members.

Constructors
 | Name | Description
Protected method | BasePipelineStepConverterTFrom | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the PipelineStep object's collection of plugins.
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.PipelineSteps Namespace


BasePipelineStepConverter(TFrom) Constructor

BasePipelineStepConverterTFrom Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BasePipelineStepConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

BasePipelineStepConverterTFrom Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BasePipelineStepConverter(TFrom) Properties

BasePipelineStepConverterTFrom Properties

The BasePipelineStepConverterTFrom generic type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

BasePipelineStepConverterTFrom Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BasePipelineStepConverter(TFrom) Methods

BasePipelineStepConverterTFrom Methods

The BasePipelineStepConverterTFrom generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the PipelineStep object's collection of plugins.
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

BasePipelineStepConverterTFrom Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BasePipelineStepConverter(TFrom).AddPlugins Method

BasePipelineStepConverterTFromAddPlugins Method
Creates new IPlugin objects based on the specified item model and adds them to the PipelineStep object's collection of plugins.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected abstract void AddPlugins(
    TFrom source,
    PipelineStep pipelineStep
)

Parameters

source
Type: TFrom
The object to read plugin settings from.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object to which the plugin objects are added.
See Also

Reference

BasePipelineStepConverterTFrom Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BasePipelineStepConverter(TFrom).Convert Method

BasePipelineStepConverterTFromConvert Method
Creates a new PipelineStep object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override PipelineStep Convert(
    TFrom source
)

Parameters

source
Type: TFrom
The object to convert from.

Return Value

Type: PipelineStep
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

BasePipelineStepConverterTFrom Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepConverter Class

BaseResolveObjectFromEndpointStepConverter Class

Creates a PipelineStep object with a ResolveObjectSettings plugin and a EndpointSettings plugin based on settings from a ItemModel.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, PipelineStep
Sitecore.DataExchange.Converters.PipelineStepsBasePipelineStepConverter ItemModel
Sitecore.DataExchange.Converters.PipelineStepsBaseResolveObjectFromEndpointStepConverter

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BaseResolveObjectFromEndpointStepConverter : BasePipelineStepConverter<ItemModel>

The BaseResolveObjectFromEndpointStepConverter type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseResolveObjectFromEndpointStepConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates a new ResolveObjectSettings plugin and a new EndpointSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Inherited from BasePipelineStepConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepConverter Constructor

BaseResolveObjectFromEndpointStepConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BaseResolveObjectFromEndpointStepConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

BaseResolveObjectFromEndpointStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepConverter Properties

BaseResolveObjectFromEndpointStepConverter Properties

The BaseResolveObjectFromEndpointStepConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

BaseResolveObjectFromEndpointStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepConverter Methods

BaseResolveObjectFromEndpointStepConverter Methods

The BaseResolveObjectFromEndpointStepConverter type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates a new ResolveObjectSettings plugin and a new EndpointSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Inherited from BasePipelineStepConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

BaseResolveObjectFromEndpointStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepConverter.AddPlugins Method

BaseResolveObjectFromEndpointStepConverterAddPlugins Method
Creates a new ResolveObjectSettings plugin and a new EndpointSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void AddPlugins(
    ItemModel source,
    PipelineStep pipelineStep
)

Parameters

source
Type: ItemModel
The object to read plugin settings from.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object to which the plugin objects are added.
See Also

Reference

BaseResolveObjectFromEndpointStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


DefaultPipelineStepConverter Class

DefaultPipelineStepConverter Class
Creates a PipelineStep object based on settings from a ItemModel.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, PipelineStep
Sitecore.DataExchange.Converters.PipelineStepsBasePipelineStepConverter ItemModel
Sitecore.DataExchange.Converters.PipelineStepsDefaultPipelineStepConverter

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DefaultPipelineStepConverter : BasePipelineStepConverter<ItemModel>

The DefaultPipelineStepConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultPipelineStepConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the PipelineStep object's collection of plugins. By default this method does nothing. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the PipelineStep object. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method returns if source is convertible and processible. (Overrides BaseItemModelConverterTFrom, TToCanConvert(TFrom).)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Inherited from BasePipelineStepConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.PipelineSteps Namespace


DefaultPipelineStepConverter Constructor

DefaultPipelineStepConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DefaultPipelineStepConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

DefaultPipelineStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


DefaultPipelineStepConverter Properties

DefaultPipelineStepConverter Properties

The DefaultPipelineStepConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

DefaultPipelineStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


DefaultPipelineStepConverter Methods

DefaultPipelineStepConverter Methods

The DefaultPipelineStepConverter type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates new IPlugin objects based on the specified item model and adds them to the PipelineStep object's collection of plugins. By default this method does nothing. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the PipelineStep object. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method returns if source is convertible and processible. (Overrides BaseItemModelConverterTFrom, TToCanConvert(TFrom).)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Inherited from BasePipelineStepConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

DefaultPipelineStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


DefaultPipelineStepConverter.AddPlugins Method

DefaultPipelineStepConverterAddPlugins Method

Creates new IPlugin objects based on the specified item model and adds them to the PipelineStep object's collection of plugins.

By default this method does nothing. Override this method when extending this type in order to read values from the source item model, to use those values to create the appropriate plugin objects and then to add the plugins to the PipelineStep object.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void AddPlugins(
    ItemModel source,
    PipelineStep pipelineStep
)

Parameters

source
Type: ItemModel
The object to read plugin settings from.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object to which the plugin objects are added.
See Also

Reference

DefaultPipelineStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


DefaultPipelineStepConverter.CanConvert Method

DefaultPipelineStepConverterCanConvert Method

Indicates whether or not the specified ItemModel can be converted. This method returns if source is convertible and processible.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override bool CanConvert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object to convert from.

Return Value

Type: Boolean
if the source item model object can be converted to the type specified by TTo.

Implements

IConverterTFrom, TToCanConvert(TFrom)
See Also

Reference

DefaultPipelineStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


IterateDataAndRunPipelinesStepConverter Class

IterateDataAndRunPipelinesStepConverter Class
Creates a PipelineStep object with a PipelinesSettings plugin based on settings from a ItemModel.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, PipelineStep
Sitecore.DataExchange.Converters.PipelineStepsBasePipelineStepConverter ItemModel
Sitecore.DataExchange.Converters.PipelineStepsIterateDataAndRunPipelinesStepConverter

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IterateDataAndRunPipelinesStepConverter : BasePipelineStepConverter<ItemModel>

The IterateDataAndRunPipelinesStepConverter type exposes the following members.

Constructors
 | Name | Description
Public method | IterateDataAndRunPipelinesStepConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates a new PipelinesSettings plugin based on the specified item model and adds it to the PipelineBatch object's collection of plugins. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Overrides BasePipelineStepConverterTFromConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.PipelineSteps Namespace


IterateDataAndRunPipelinesStepConverter Constructor

IterateDataAndRunPipelinesStepConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IterateDataAndRunPipelinesStepConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

IterateDataAndRunPipelinesStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


IterateDataAndRunPipelinesStepConverter Properties

IterateDataAndRunPipelinesStepConverter Properties

The IterateDataAndRunPipelinesStepConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

IterateDataAndRunPipelinesStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


IterateDataAndRunPipelinesStepConverter Methods

IterateDataAndRunPipelinesStepConverter Methods

The IterateDataAndRunPipelinesStepConverter type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates a new PipelinesSettings plugin based on the specified item model and adds it to the PipelineBatch object's collection of plugins. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Overrides BasePipelineStepConverterTFromConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

IterateDataAndRunPipelinesStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


IterateDataAndRunPipelinesStepConverter.AddPlugins Method

IterateDataAndRunPipelinesStepConverterAddPlugins Method
Creates a new PipelinesSettings plugin based on the specified item model and adds it to the PipelineBatch object's collection of plugins.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void AddPlugins(
    ItemModel source,
    PipelineStep pipelineStep
)

Parameters

source
Type: ItemModel
The object to read plugin settings from.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object to which the plugin objects are added.
See Also

Reference

IterateDataAndRunPipelinesStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


IterateDataAndRunPipelinesStepConverter.Convert Method

IterateDataAndRunPipelinesStepConverterConvert Method
Creates a new PipelineStep object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override PipelineStep Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The object to convert from.

Return Value

Type: PipelineStep
The converted object; if the object cannot be converted.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

IterateDataAndRunPipelinesStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


ProcessQueueStepConverter Class

ProcessQueueStepConverter Class
Creates a PipelineStep object with a WorkQueueProcessorStepSettings plugin based on settings from a ItemModel.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, PipelineStep
Sitecore.DataExchange.Converters.PipelineStepsBasePipelineStepConverter ItemModel
Sitecore.DataExchange.Converters.PipelineStepsProcessQueueStepConverter

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ProcessQueueStepConverter : BasePipelineStepConverter<ItemModel>

The ProcessQueueStepConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessQueueStepConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Protected method | AddPlugins | Creates a new WorkQueueProcessorStepSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Inherited from BasePipelineStepConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.PipelineSteps Namespace


ProcessQueueStepConverter Constructor

ProcessQueueStepConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ProcessQueueStepConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

ProcessQueueStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


ProcessQueueStepConverter Properties

ProcessQueueStepConverter Properties

The ProcessQueueStepConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ProcessQueueStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


ProcessQueueStepConverter Methods

ProcessQueueStepConverter Methods

The ProcessQueueStepConverter type exposes the following members.

Methods
 | Name | Description
Protected method | AddPlugins | Creates a new WorkQueueProcessorStepSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins. (Overrides BasePipelineStepConverterTFromAddPlugins(TFrom, PipelineStep).)
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new PipelineStep object based on the specified item model. (Inherited from BasePipelineStepConverterTFrom.)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

ProcessQueueStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


ProcessQueueStepConverter.AddPlugins Method

ProcessQueueStepConverterAddPlugins Method
Creates a new WorkQueueProcessorStepSettings plugin based on the specified item model and adds it to the PipelineStep object's collection of plugins.

Namespace: Sitecore.DataExchange.Converters.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void AddPlugins(
    ItemModel source,
    PipelineStep pipelineStep
)

Parameters

source
Type: ItemModel
The object to read plugin settings from.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object to which the plugin objects are added.
See Also

Reference

ProcessQueueStepConverter Class
Sitecore.DataExchange.Converters.PipelineSteps Namespace


Sitecore.DataExchange.Converters.Tenants Namespace

Sitecore.DataExchange.Converters.Tenants Namespace

This namespace contains converters for Tenant types.

Classes
 | Class | Description
Public class | TenantConverter | Creates a Tenant object based on settings from a ItemModel.


TenantConverter Class

TenantConverter Class

Creates a Tenant object based on settings from a ItemModel.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ConvertersBaseItemModelConverter ItemModel, Tenant
Sitecore.DataExchange.Converters.TenantsTenantConverter

Namespace: Sitecore.DataExchange.Converters.Tenants
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class TenantConverter : BaseItemModelConverter<ItemModel, Tenant>

The TenantConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TenantConverter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new Tenant object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

Sitecore.DataExchange.Converters.Tenants Namespace


TenantConverter Constructor

TenantConverter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Converters.Tenants
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public TenantConverter(
    IItemModelRepository repository
)

Parameters

repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component used to read objects that are referenced by the source object.
Exceptions
Exception | Condition
ArgumentNullException | repository is null.
See Also

Reference

TenantConverter Class
Sitecore.DataExchange.Converters.Tenants Namespace


TenantConverter Properties

TenantConverter Properties

The TenantConverter type exposes the following members.

Properties
 | Name | Description
Protected property | ItemModelRepository | Gets the component used to read ItemModel objects that are referenced by the source object. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public property | SupportedTemplateIds | Gets a collection of the Guid objects for the templates this converter supports. The base implementation of CanConvert(TFrom) uses this method. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

TenantConverter Class
Sitecore.DataExchange.Converters.Tenants Namespace


TenantConverter Methods

TenantConverter Methods

The TenantConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | Indicates whether or not the specified ItemModel can be converted. This method compares the template ID for the source item model to the template IDs returned by SupportedTemplateIds. (Inherited from BaseItemModelConverterTFrom, TTo.)
Public method | Convert | Creates a new Tenant object based on the specified item model. (Overrides BaseItemModelConverterTFrom, TToConvert(TFrom).)
Protected method | ConvertChildrenToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferencesToModelsT | Gets a collection of T objects by converting the child objects of the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertReferenceToModelT | Converts the ItemModel referenced by the specified field from the specified ItemModel. In order for a child object to be converted, the child object must have IConverterTFrom, TTo associated with it. The logic to resolve a converter is implemented in the extension method GetConverterTTo(ItemModel, IItemModelRepository). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | ConvertToModelT | Converts the specified ItemModel into an object of the type specified by T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetBoolValue | Gets the specified bool field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetChildItemModels | Gets a collection of ItemModel objects that are children of the specified ItemModel. If the child objects represent references to other framework components it is usually more convenient to use ConvertChildrenToModelsT(ItemModel). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetDateTimeValue | Gets the specified DateTime field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetEnumValueT | Gets the specified field value from the specified ItemModel as an enum of type T. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValue | Gets the specified Guid field value from the specified ItemModel. If the Guid represents a reference to another framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetGuidValues | Gets a collection of Guid objects from the field value from the specified ItemModel. If the Guid objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetInstance | Creates an instance of the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetIntValue | Gets the specified int field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferenceAsModel | Gets the ItemModel referenced by the specified field from the specified ItemModel. If the ItemModel represents a reference to a framework component, it is usually more convenient to use ConvertReferenceToModelT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetReferencesAsModels | Gets a collection of ItemModel objects referenced by the specified field from the specified ItemModel. If the ItemModel objects represent references to other framework components, it is usually more convenient to use ConvertReferencesToModelsT(TFrom, String). (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetStringValue | Gets the specified string field value from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Protected method | GetTypeFromTypeName | Gets the Type identified in the specified field from the specified ItemModel. (Inherited from BaseItemModelConverterTFrom, TTo.)
Top
See Also

Reference

TenantConverter Class
Sitecore.DataExchange.Converters.Tenants Namespace


TenantConverter.Convert Method

TenantConverterConvert Method

Creates a new Tenant object based on the specified item model.

Namespace: Sitecore.DataExchange.Converters.Tenants
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override Tenant Convert(
    ItemModel source
)

Parameters

source
Type: ItemModel
The item model object whose settings are used to create a new Tenant object.

Return Value

Type: Tenant
The new object; if the object cannot be created, such as when insufficient information is available from the source object.

Implements

IConverterTFrom, TToConvert(TFrom)
See Also

Reference

TenantConverter Class
Sitecore.DataExchange.Converters.Tenants Namespace


Sitecore.DataExchange.DataAccess Namespace

Sitecore.DataExchange.DataAccess Namespace

This namespace contains types that define the components that are used to read and write values on objects.

Classes
 | Class | Description
Public class | AppendResult | Represents the result of the call used to append a value to a specific source object.
Public class | CanAppendResult | Represents the result of the call used to determine whether or not a value appender can appender a value to a specific source object.
Public class | CanReadResult | Represents the result of the call used to determine whether or not a value reader can read a value from a specific source object.
Public class | CanWriteResult | Represents the result of the call used to determine whether or not a value writer can write a value to a specific target object.
Public class | DataAccessContext | Represents the parameters passed to a data access component.
Public class | MappingContext | Represents the parameters passed to a IMappingSet when it is run in order to track status as the mapping set is run.
Public class | ReadResult | Represents the result of the call used to read a value from a specific source object.
Public class | ValueAccessor | Provides access to components that are used to read and write values.
Public class | ValueAccessorSet | Represents a collection of IValueAccessor objects that can be used to read and write values.
Interfaces
 | Interface | Description
Public interface | IApplyMappingRule | Represents a rule that must pass in order for a mapping to be applied. The IMappingSet uses these rules before attempting to write a value to a target object. This type allows rules such as "only update the target object if the source value is a more recent value than the value on the target object".
Public interface | IDataAccessPlugin | Represents an extension to a component. Plugins are used when inheritence is not the best solution to adding functionality to a component. For example, a plugin can provide functionality that is shared across multiple data access components, such as logging.
Public interface | IHasDataAccessPlugins | Represents support for IDataAccessPlugin objects.
Public interface | IMapping | Represents a single object in a IMappingSet. It defines the components the mapping set uses in order to read a value from a source object and to write a value to a target object.
 | IMappingSet | Represents a collection of IMapping objects that can be run.
Public interface | IReflectionUtil | Provides methods for working with reflection.
Public interface | IValueAccessor | Provides access to components that are used to read and write values. If a IValueReader is like a property getter and a IValueWriter is like a property setter, a IValueAccessor is like a property.
Public interface | IValueAccessorSet | Represents a collection of IValueAccessor objects that can be used to read and write values. If a IValueReader is like a property getter and a IValueWriter is like a property setter and a IValueAccessor is like a property, a IValueAccessorSet is like a type that can have properties set on it.
 | IValueAppender | Component that appends a value to another value. The value that is updated is called the target value. Whether the target value is actually changed or whether a new value is created is determined by the implementation and the target value type.
 | IValueReader | Represents the ability to read a value from a source object.
 | IValueWriter | Represents the ability to write a value to a target object.


AppendResult Class

AppendResult Class
Represents the result of the call used to append a value to a specific source object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessAppendResult

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class AppendResult

The AppendResult type exposes the following members.

Constructors
 | Name | Description
Public method | AppendResult | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | AppendedValue | Gets or sets the appended value. If the target object can be appended with the value, the object with the appended value is set. If the target object cannot be appended with the value, null is set. The implementation of Append(Object, Object, DataAccessContext) determines whether the target object itself is updated or a new object is created and the new object is updated.
Public property | WasValueAppended | Gets or sets whether the value appender appended a value.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


AppendResult Constructor

AppendResult Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public AppendResult()
See Also

Reference

AppendResult Class
Sitecore.DataExchange.DataAccess Namespace


AppendResult Properties

AppendResult Properties

The AppendResult type exposes the following members.

Properties
 | Name | Description
Public property | AppendedValue | Gets or sets the appended value. If the target object can be appended with the value, the object with the appended value is set. If the target object cannot be appended with the value, null is set. The implementation of Append(Object, Object, DataAccessContext) determines whether the target object itself is updated or a new object is created and the new object is updated.
Public property | WasValueAppended | Gets or sets whether the value appender appended a value.
Top
See Also

Reference

AppendResult Class
Sitecore.DataExchange.DataAccess Namespace


AppendResult.AppendedValue Property

AppendResultAppendedValue Property

Gets or sets the appended value.

If the target object can be appended with the value, the object with the appended value is set. If the target object cannot be appended with the value, null is set.

The implementation of Append(Object, Object, DataAccessContext) determines whether the target object itself is updated or a new object is created and the new object is updated.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object AppendedValue { get; set; }

Property Value

Type: Object
See Also

Reference

AppendResult Class
Sitecore.DataExchange.DataAccess Namespace


AppendResult.WasValueAppended Property

AppendResultWasValueAppended Property

Gets or sets whether the value appender appended a value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool WasValueAppended { get; set; }

Property Value

Type: Boolean
See Also

Reference

AppendResult Class
Sitecore.DataExchange.DataAccess Namespace


CanAppendResult Class

CanAppendResult Class
Represents the result of the call used to determine whether or not a value appender can appender a value to a specific source object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessCanAppendResult

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class CanAppendResult

The CanAppendResult type exposes the following members.

Constructors
 | Name | Description
Public method | CanAppendResult | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | CanAppendValue | Gets or sets whether the value appender can append a value. This value does not guarantee that Append(Object, Object, DataAccessContext) will be able to actually append the value. This value only indicates whether it is worthwhile to try to append the value.
Public property | IsGuess | Gets or sets a value that indicates the certainty of the result. It is not always possible for a value appender to determine whether or not it can append a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanAppend(Object, Object, DataAccessContext)) that indicates whether it is even worth trying to append the value to a specific object. means the value reported by CanAppendValue may or may not be accurate. means the value reported by CanAppendValue is accurate.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


CanAppendResult Constructor

CanAppendResult Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanAppendResult()
See Also

Reference

CanAppendResult Class
Sitecore.DataExchange.DataAccess Namespace


CanAppendResult Properties

CanAppendResult Properties

The CanAppendResult type exposes the following members.

Properties
 | Name | Description
Public property | CanAppendValue | Gets or sets whether the value appender can append a value. This value does not guarantee that Append(Object, Object, DataAccessContext) will be able to actually append the value. This value only indicates whether it is worthwhile to try to append the value.
Public property | IsGuess | Gets or sets a value that indicates the certainty of the result. It is not always possible for a value appender to determine whether or not it can append a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanAppend(Object, Object, DataAccessContext)) that indicates whether it is even worth trying to append the value to a specific object. means the value reported by CanAppendValue may or may not be accurate. means the value reported by CanAppendValue is accurate.
Top
See Also

Reference

CanAppendResult Class
Sitecore.DataExchange.DataAccess Namespace


CanAppendResult.CanAppendValue Property

CanAppendResultCanAppendValue Property

Gets or sets whether the value appender can append a value.

This value does not guarantee that Append(Object, Object, DataAccessContext) will be able to actually append the value. This value only indicates whether it is worthwhile to try to append the value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool CanAppendValue { get; set; }

Property Value

Type: Boolean
See Also

Reference

CanAppendResult Class
Sitecore.DataExchange.DataAccess Namespace


CanAppendResult.IsGuess Property

CanAppendResultIsGuess Property

Gets or sets a value that indicates the certainty of the result.

It is not always possible for a value appender to determine whether or not it can append a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanAppend(Object, Object, DataAccessContext)) that indicates whether it is even worth trying to append the value to a specific object.

means the value reported by CanAppendValue may or may not be accurate. means the value reported by CanAppendValue is accurate.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IsGuess { get; set; }

Property Value

Type: Boolean
See Also

Reference

CanAppendResult Class
Sitecore.DataExchange.DataAccess Namespace


CanReadResult Class

CanReadResult Class
Represents the result of the call used to determine whether or not a value reader can read a value from a specific source object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessCanReadResult

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class CanReadResult

The CanReadResult type exposes the following members.

Constructors
 | Name | Description
Public method | CanReadResult | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | CanReadValue | Gets or sets whether the value reader can read a value. This value does not guarantee that Read(Object, DataAccessContext) will be able to actually read the value. This value only indicates whether it is worthwhile to try to read the value.
Public property | IsGuess | Gets or sets a value that indicates the certainty of the result. It is not always possible for a value reader to determine whether or not it can read a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanRead(Object, DataAccessContext)) that indicates whether it is even worth trying to read the value from a specific object. means the value reported by CanReadValue may or may not be accurate. means the value reported by CanReadValue is accurate.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


CanReadResult Constructor

CanReadResult Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult()
See Also

Reference

CanReadResult Class
Sitecore.DataExchange.DataAccess Namespace


CanReadResult Properties

CanReadResult Properties

The CanReadResult type exposes the following members.

Properties
 | Name | Description
Public property | CanReadValue | Gets or sets whether the value reader can read a value. This value does not guarantee that Read(Object, DataAccessContext) will be able to actually read the value. This value only indicates whether it is worthwhile to try to read the value.
Public property | IsGuess | Gets or sets a value that indicates the certainty of the result. It is not always possible for a value reader to determine whether or not it can read a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanRead(Object, DataAccessContext)) that indicates whether it is even worth trying to read the value from a specific object. means the value reported by CanReadValue may or may not be accurate. means the value reported by CanReadValue is accurate.
Top
See Also

Reference

CanReadResult Class
Sitecore.DataExchange.DataAccess Namespace


CanReadResult.CanReadValue Property

CanReadResultCanReadValue Property

Gets or sets whether the value reader can read a value.

This value does not guarantee that Read(Object, DataAccessContext) will be able to actually read the value. This value only indicates whether it is worthwhile to try to read the value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool CanReadValue { get; set; }

Property Value

Type: Boolean
See Also

Reference

CanReadResult Class
Sitecore.DataExchange.DataAccess Namespace


CanReadResult.IsGuess Property

CanReadResultIsGuess Property

Gets or sets a value that indicates the certainty of the result.

It is not always possible for a value reader to determine whether or not it can read a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanRead(Object, DataAccessContext)) that indicates whether it is even worth trying to read the value from a specific object.

means the value reported by CanReadValue may or may not be accurate. means the value reported by CanReadValue is accurate.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IsGuess { get; set; }

Property Value

Type: Boolean
See Also

Reference

CanReadResult Class
Sitecore.DataExchange.DataAccess Namespace


CanWriteResult Class

CanWriteResult Class
Represents the result of the call used to determine whether or not a value writer can write a value to a specific target object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessCanWriteResult

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class CanWriteResult

The CanWriteResult type exposes the following members.

Constructors
 | Name | Description
Public method | CanWriteResult | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | CanWriteValue | Gets or sets whether the value writer can write a value. This value does not guarantee that Write(Object, Object, DataAccessContext) will be able to actually write the value. This value only indicates whether it is worthwhile to try to read the value.
Public property | IsGuess | Gets or sets a value that indicates the certainty of the result. It is not always possible for a value writer to determine whether or not it can write a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanWrite(Object, Object, DataAccessContext)) that indicates whether it is even worth trying to write the value to a specific object. means the value reported by CanWriteValue may or may not be accurate. means the value reported by CanWriteValue is accurate.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


CanWriteResult Constructor

CanWriteResult Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanWriteResult()
See Also

Reference

CanWriteResult Class
Sitecore.DataExchange.DataAccess Namespace


CanWriteResult Properties

CanWriteResult Properties

The CanWriteResult type exposes the following members.

Properties
 | Name | Description
Public property | CanWriteValue | Gets or sets whether the value writer can write a value. This value does not guarantee that Write(Object, Object, DataAccessContext) will be able to actually write the value. This value only indicates whether it is worthwhile to try to read the value.
Public property | IsGuess | Gets or sets a value that indicates the certainty of the result. It is not always possible for a value writer to determine whether or not it can write a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanWrite(Object, Object, DataAccessContext)) that indicates whether it is even worth trying to write the value to a specific object. means the value reported by CanWriteValue may or may not be accurate. means the value reported by CanWriteValue is accurate.
Top
See Also

Reference

CanWriteResult Class
Sitecore.DataExchange.DataAccess Namespace


CanWriteResult.CanWriteValue Property

CanWriteResultCanWriteValue Property

Gets or sets whether the value writer can write a value.

This value does not guarantee that Write(Object, Object, DataAccessContext) will be able to actually write the value. This value only indicates whether it is worthwhile to try to read the value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool CanWriteValue { get; set; }

Property Value

Type: Boolean
See Also

Reference

CanWriteResult Class
Sitecore.DataExchange.DataAccess Namespace


CanWriteResult.IsGuess Property

CanWriteResultIsGuess Property

Gets or sets a value that indicates the certainty of the result.

It is not always possible for a value writer to determine whether or not it can write a value without actually trying to do so. But trying to do so defeats the purpose of a having a separate method (CanWrite(Object, Object, DataAccessContext)) that indicates whether it is even worth trying to write the value to a specific object.

means the value reported by CanWriteValue may or may not be accurate. means the value reported by CanWriteValue is accurate.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IsGuess { get; set; }

Property Value

Type: Boolean
See Also

Reference

CanWriteResult Class
Sitecore.DataExchange.DataAccess Namespace


DataAccessContext Class

DataAccessContext Class
Represents the parameters passed to a data access component.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessDataAccessContext
Sitecore.DataExchange.DataAccessMappingContext

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DataAccessContext : IHasDataAccessPlugins

The DataAccessContext type exposes the following members.

Constructors
 | Name | Description
Public method | DataAccessContext | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.
Top
Methods
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetMethodSettings | Gets the MethodSettings plugin from the context. (Defined by DataAccessContextExtensions.)
Public Extension Method | HasMethodSettings | Indicates whether or not the MethodSettings plugin is set on the context. (Defined by DataAccessContextExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


DataAccessContext Constructor

DataAccessContext Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DataAccessContext()
See Also

Reference

DataAccessContext Class
Sitecore.DataExchange.DataAccess Namespace


DataAccessContext Properties

DataAccessContext Properties

The DataAccessContext type exposes the following members.

Properties
 | Name | Description
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.
Top
See Also

Reference

DataAccessContext Class
Sitecore.DataExchange.DataAccess Namespace


DataAccessContext.Plugins Property

DataAccessContextPlugins Property
Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IDataAccessPlugin> Plugins { get; }

Property Value

Type: ICollection IDataAccessPlugin

Implements

IHasDataAccessPluginsPlugins
See Also

Reference

DataAccessContext Class
Sitecore.DataExchange.DataAccess Namespace


DataAccessContext Methods

DataAccessContext Methods

The DataAccessContext type exposes the following members.

Methods
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetMethodSettings | Gets the MethodSettings plugin from the context. (Defined by DataAccessContextExtensions.)
Public Extension Method | HasMethodSettings | Indicates whether or not the MethodSettings plugin is set on the context. (Defined by DataAccessContextExtensions.)
Top
See Also

Reference

DataAccessContext Class
Sitecore.DataExchange.DataAccess Namespace


DataAccessContext.GetPlugin(T) Method

DataAccessContextGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T GetPlugin<T>()
where T : IDataAccessPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.

Implements

IHasDataAccessPluginsGetPluginT
See Also

Reference

DataAccessContext Class
Sitecore.DataExchange.DataAccess Namespace


IApplyMappingRule Interface

IApplyMappingRule Interface

Represents a rule that must pass in order for a mapping to be applied. The IMappingSet uses these rules before attempting to write a value to a target object.

This type allows rules such as "only update the target object if the source value is a more recent value than the value on the target object".

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IApplyMappingRule

The IApplyMappingRule type exposes the following members.

Methods
 | Name | Description
Public method | ShouldMappingBeApplied | Indicates whether or not the mapping should be applied. The IMappingSet uses the return value to determine whether or not it should attempt to apply the mapping.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IApplyMappingRule Methods

IApplyMappingRule Methods

The IApplyMappingRule type exposes the following members.

Methods
 | Name | Description
Public method | ShouldMappingBeApplied | Indicates whether or not the mapping should be applied. The IMappingSet uses the return value to determine whether or not it should attempt to apply the mapping.
Top
See Also

Reference

IApplyMappingRule Interface
Sitecore.DataExchange.DataAccess Namespace


IApplyMappingRule.ShouldMappingBeApplied Method

IApplyMappingRuleShouldMappingBeApplied Method

Indicates whether or not the mapping should be applied.

The IMappingSet uses the return value to determine whether or not it should attempt to apply the mapping.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool ShouldMappingBeApplied(
    Object value,
    Object source,
    Object target
)

Parameters

value
Type: SystemObject
The value to check.
source
Type: SystemObject
The source object from which the value was read.
target
Type: SystemObject
The target object to which the value may be written.

Return Value

Type: Boolean
if the mapping should be applied; otherwise.
See Also

Reference

IApplyMappingRule Interface
Sitecore.DataExchange.DataAccess Namespace


IDataAccessPlugin Interface

IDataAccessPlugin Interface

Represents an extension to a component.

Plugins are used when inheritence is not the best solution to adding functionality to a component. For example, a plugin can provide functionality that is shared across multiple data access components, such as logging.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IDataAccessPlugin
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IHasDataAccessPlugins Interface

IHasDataAccessPlugins Interface

Represents support for IDataAccessPlugin objects.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IHasDataAccessPlugins

The IHasDataAccessPlugins type exposes the following members.

Properties
 | Name | Description
Public property | Plugins | Gets the collection of plugins that are assigned to the component.
Top
Methods
 | Name | Description
Public method | GetPluginT | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IHasDataAccessPlugins Properties

IHasDataAccessPlugins Properties

The IHasDataAccessPlugins type exposes the following members.

Properties
 | Name | Description
Public property | Plugins | Gets the collection of plugins that are assigned to the component.
Top
See Also

Reference

IHasDataAccessPlugins Interface
Sitecore.DataExchange.DataAccess Namespace


IHasDataAccessPlugins.Plugins Property

IHasDataAccessPluginsPlugins Property
Gets the collection of plugins that are assigned to the component.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ICollection<IDataAccessPlugin> Plugins { get; }

Property Value

Type: ICollection IDataAccessPlugin
See Also

Reference

IHasDataAccessPlugins Interface
Sitecore.DataExchange.DataAccess Namespace


IHasDataAccessPlugins Methods

IHasDataAccessPlugins Methods

The IHasDataAccessPlugins type exposes the following members.

Methods
 | Name | Description
Public method | GetPluginT | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

IHasDataAccessPlugins Interface
Sitecore.DataExchange.DataAccess Namespace


IHasDataAccessPlugins.GetPlugin(T) Method

IHasDataAccessPluginsGetPluginT Method
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
T GetPlugin<T>()
where T : IDataAccessPlugin

Type Parameters

T
The type of plugin to get.

Return Value

Type: T
The plugin if a plugin of the specified type is set; otherwise .
See Also

Reference

IHasDataAccessPlugins Interface
Sitecore.DataExchange.DataAccess Namespace


IMapping Interface

IMapping Interface
Represents a single object in a IMappingSet. It defines the components the mapping set uses in order to read a value from a source object and to write a value to a target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IMapping

The IMapping type exposes the following members.

Properties
 | Name | Description
Public property | ApplyMappingRules | Gets the component that determines whether or not the source value should be written to the target object. The IMappingSet must use this collection before attempting to apply the mapping. If the collection is empty, the mapping set should apply the mapping. If any of the mapping validators returns false, the mapping set should not apply the mapping.
Public property | Enabled | Gets a value that indicates whether or not the mapping is enabled. If , IMappingSet will skip this pipeline step.
Public property | Identifier | Get a value that identifies the mapping.
Public property | IgnoreNullValues | Gets a value that indicates whether or not the mapping is applied when the SourceAccessor reads a null value.
Public property | SourceAccessor | Gets the component used by a IMappingSet to access the IValueReader used to read a value from a source object.
Public property | SourceValueTransformer | Gets or sets the component that transforms the source value before it is written to the target object.
Public property | TargetAccessor | Gets the component used by a IMappingSet to access the IValueWriter used to write a value to a target object.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IMapping Properties

IMapping Properties

The IMapping type exposes the following members.

Properties
 | Name | Description
Public property | ApplyMappingRules | Gets the component that determines whether or not the source value should be written to the target object. The IMappingSet must use this collection before attempting to apply the mapping. If the collection is empty, the mapping set should apply the mapping. If any of the mapping validators returns false, the mapping set should not apply the mapping.
Public property | Enabled | Gets a value that indicates whether or not the mapping is enabled. If , IMappingSet will skip this pipeline step.
Public property | Identifier | Get a value that identifies the mapping.
Public property | IgnoreNullValues | Gets a value that indicates whether or not the mapping is applied when the SourceAccessor reads a null value.
Public property | SourceAccessor | Gets the component used by a IMappingSet to access the IValueReader used to read a value from a source object.
Public property | SourceValueTransformer | Gets or sets the component that transforms the source value before it is written to the target object.
Public property | TargetAccessor | Gets the component used by a IMappingSet to access the IValueWriter used to write a value to a target object.
Top
See Also

Reference

IMapping Interface
Sitecore.DataExchange.DataAccess Namespace


IMapping.ApplyMappingRules Property

IMappingApplyMappingRules Property

Gets the component that determines whether or not the source value should be written to the target object.

The IMappingSet must use this collection before attempting to apply the mapping. If the collection is empty, the mapping set should apply the mapping. If any of the mapping validators returns false, the mapping set should not apply the mapping.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ICollection<IApplyMappingRule> ApplyMappingRules { get; }

Property Value

Type: ICollection IApplyMappingRule
See Also

Reference

IMapping Interface
Sitecore.DataExchange.DataAccess Namespace


IMapping.Enabled Property

IMappingEnabled Property

Gets a value that indicates whether or not the mapping is enabled.

If , IMappingSet will skip this pipeline step.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool Enabled { get; }

Property Value

Type: Boolean
See Also

Reference

IMapping Interface
Sitecore.DataExchange.DataAccess Namespace


IMapping.Identifier Property

IMappingIdentifier Property
Get a value that identifies the mapping.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
string Identifier { get; }

Property Value

Type: String
See Also

Reference

IMapping Interface
Sitecore.DataExchange.DataAccess Namespace


IMapping.IgnoreNullValues Property

IMappingIgnoreNullValues Property
Gets a value that indicates whether or not the mapping is applied when the SourceAccessor reads a null value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool IgnoreNullValues { get; }

Property Value

Type: Boolean
See Also

Reference

IMapping Interface
Sitecore.DataExchange.DataAccess Namespace


IMapping.SourceAccessor Property

IMappingSourceAccessor Property
Gets the component used by a IMappingSet to access the IValueReader used to read a value from a source object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IValueAccessor SourceAccessor { get; }

Property Value

Type: IValueAccessor
See Also

Reference

IMapping Interface
Sitecore.DataExchange.DataAccess Namespace


IMapping.SourceValueTransformer Property

IMappingSourceValueTransformer Property

Gets or sets the component that transforms the source value before it is written to the target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IValueReader SourceValueTransformer { get; set; }

Property Value

Type: IValueReader
See Also

Reference

IMapping Interface
Sitecore.DataExchange.DataAccess Namespace


IMapping.TargetAccessor Property

IMappingTargetAccessor Property
Gets the component used by a IMappingSet to access the IValueWriter used to write a value to a target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IValueAccessor TargetAccessor { get; }

Property Value

Type: IValueAccessor
See Also

Reference

IMapping Interface
Sitecore.DataExchange.DataAccess Namespace


IMappingSet Interface

IMappingSet Interface
Represents a collection of IMapping objects that can be run.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IMappingSet

The IMappingSet type exposes the following members.

Properties
 | Name | Description
Public property | Mappings | Gets the IMapping objects that are applied when the method Run(MappingContext) is run.
Top
Methods
 | Name | Description
Public method | Run | Iterates the IMapping from Mappings. For each mapping a value is read from Source on the context using SourceAccessor. Then that value is written to Target on the context using TargetAccessor. The implementation shall implement the logic above, but it is up to the implementation to determine the specifics of how this is accomplished. For example, implementations may differ in how they handle errors or the order in which the mappings are applied. In addition, the implementation shall populate RunSuccess and RunFail as it applies each mapping.
Top
Examples

The following code demonstrates how to use the component to run a collection of mappings.

Custom object with a name and an email address
Copy
public class Person
{
  public string Name { get; set; }
  public string Email { get; set; }
}
Mapping set that maps fields from one person to another.
Copy
var namePropertyValueAccess = ... //get implementation of IValueAccessor
namePropertyValueAccess.ValueReader = new PropertyValueReader("Name");
namePropertyValueAccess.ValueWriter = new PropertyValueWriter("Name");
var emailPropertyValueAccess = ... //get implementation of IValueAccessor
emailPropertyValueAccess.ValueReader = new PropertyValueReader("Email");
emailPropertyValueAccess.ValueWriter = new PropertyValueWriter("Email");
var mappingSet = ... //get implementation of IMappingSet
var nameMapping = ... //get implementation of IMapping
nameMapping.Source = namePropertyValueAccess;
nameMapping.Target = namePropertyValueAccess;
mappingSet.Mappings.Add(nameMapping);
var emailMapping = ... //get implementation of IMapping
emailMapping.Source = emailPropertyValueAccess;
emailMapping.Target = emailPropertyValueAccess;
mappingSet.Mappings.Add(emailMapping);
//
//
var name = "Test Person";
var email = "test@test.com";
//
//create the source object
var sourcePerson = new Person
{
    Name = name,
    Email = email
};
//
//create the target object
var targetPerson = new Person();
//
//create the mapping context
var mappingContext = new MappingContext
{
    Source = sourcePerson,
    Target = targetPerson
};
//
//run the mapping
var result = mappingSet.Run(mappingContext);
Assert.True(result);
//
//confirm the source object has not changed
Assert.Equal(name, sourcePerson.Name);
Assert.Equal(email, sourcePerson.Email);
//
//confirm the target object has changed
Assert.Equal(sourcePerson.Name, targetPerson.Name);
Assert.Equal(sourcePerson.Email, targetPerson.Email);
//
//confirm the mapping context reports the correct number of mappings that were run
Assert.Equal(2, mappingContext.RunSuccess.Count);
Assert.Equal(0, mappingContext.RunFail.Count);
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IMappingSet Properties

IMappingSet Properties

The IMappingSet type exposes the following members.

Properties
 | Name | Description
Public property | Mappings | Gets the IMapping objects that are applied when the method Run(MappingContext) is run.
Top
See Also

Reference

IMappingSet Interface
Sitecore.DataExchange.DataAccess Namespace


IMappingSet.Mappings Property

IMappingSetMappings Property
Gets the IMapping objects that are applied when the method Run(MappingContext) is run.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ICollection<IMapping> Mappings { get; }

Property Value

Type: ICollection IMapping
See Also

Reference

IMappingSet Interface
Sitecore.DataExchange.DataAccess Namespace


IMappingSet Methods

IMappingSet Methods

The IMappingSet type exposes the following members.

Methods
 | Name | Description
Public method | Run | Iterates the IMapping from Mappings. For each mapping a value is read from Source on the context using SourceAccessor. Then that value is written to Target on the context using TargetAccessor. The implementation shall implement the logic above, but it is up to the implementation to determine the specifics of how this is accomplished. For example, implementations may differ in how they handle errors or the order in which the mappings are applied. In addition, the implementation shall populate RunSuccess and RunFail as it applies each mapping.
Top
See Also

Reference

IMappingSet Interface
Sitecore.DataExchange.DataAccess Namespace


IMappingSet.Run Method

IMappingSetRun Method

Iterates the IMapping from Mappings. For each mapping a value is read from Source on the context using SourceAccessor. Then that value is written to Target on the context using TargetAccessor.

The implementation shall implement the logic above, but it is up to the implementation to determine the specifics of how this is accomplished. For example, implementations may differ in how they handle errors or the order in which the mappings are applied.

In addition, the implementation shall populate RunSuccess and RunFail as it applies each mapping.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool Run(
    MappingContext context
)

Parameters

context
Type: Sitecore.DataExchange.DataAccessMappingContext
The mapping context.

Return Value

Type: Boolean
if the mappings were applied successfully; otherwise .
See Also

Reference

IMappingSet Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil Interface

IReflectionUtil Interface
Provides methods for working with reflection.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IReflectionUtil

The IReflectionUtil type exposes the following members.

Methods
 | Name | Description
Public method | CastT | Casts the object to the specified type.
 | GetDerivedTypes | Gets a collection of types that an object implements or inherits that match the specified generic type definition.
 | GetIndexerProperty | Gets the indexed property whose index type is compatible with the specified index.
Public method | GetMethod(String, Object, ICollectionObject) | Gets the specified method from the source object.
Public method | GetMethod(String, Type, ICollectionObject) | Gets the specified method from the specified type. This method is used for extension methods.
Public method | GetProperty(String, Object) | Gets the specified property from the source object.
 | GetProperty(String, Object, Object) | Gets the specified property from the source object if it can be set to the specified value.
 | IsProperDictionary | Indicates whether the source object is a dictionary whose index is compatible with the specified index and whose value can be set to the specified value.
 | IsTypeDerivedFrom | Indicates whether or not the object is derived from the specified generic type definition. Technically this method determines whether or not the object is type that implements or inherits from the specified generic type, and whether the generic type is compatible with the specified argument types. For example, this method can be used to determine whether an object is a list that can accept string values, even if the list is defined as a list of objects.
 | SetIndexerProperty | Sets the value on the source object using the index.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil Methods

IReflectionUtil Methods

The IReflectionUtil type exposes the following members.

Methods
 | Name | Description
Public method | CastT | Casts the object to the specified type.
 | GetDerivedTypes | Gets a collection of types that an object implements or inherits that match the specified generic type definition.
 | GetIndexerProperty | Gets the indexed property whose index type is compatible with the specified index.
Public method | GetMethod(String, Object, ICollectionObject) | Gets the specified method from the source object.
Public method | GetMethod(String, Type, ICollectionObject) | Gets the specified method from the specified type. This method is used for extension methods.
Public method | GetProperty(String, Object) | Gets the specified property from the source object.
 | GetProperty(String, Object, Object) | Gets the specified property from the source object if it can be set to the specified value.
 | IsProperDictionary | Indicates whether the source object is a dictionary whose index is compatible with the specified index and whose value can be set to the specified value.
 | IsTypeDerivedFrom | Indicates whether or not the object is derived from the specified generic type definition. Technically this method determines whether or not the object is type that implements or inherits from the specified generic type, and whether the generic type is compatible with the specified argument types. For example, this method can be used to determine whether an object is a list that can accept string values, even if the list is defined as a list of objects.
 | SetIndexerProperty | Sets the value on the source object using the index.
Top
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.Cast(T) Method

IReflectionUtilCastT Method
Casts the object to the specified type.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
T Cast<T>(
    Object source
)

Parameters

source
Type: SystemObject
Object that will be cast.

Type Parameters

T
Type to which the source object is cast.

Return Value

Type: T
The object if it could be cast; if the cast fails.
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.GetDerivedTypes Method

IReflectionUtilGetDerivedTypes Method
Gets a collection of types that an object implements or inherits that match the specified generic type definition.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IEnumerable<Type> GetDerivedTypes(
    Object obj,
    Type genericTypeDefinition
)

Parameters

obj
Type: SystemObject
The object to check.
genericTypeDefinition
Type: SystemType
The generic type definition to check.

Return Value

Type: IEnumerable Type
A collection of types that obj implements or inherits that are compatible with the type specified by genericTypeDefinition.
Examples

The following code demonstrates how the method works.

C#
Copy
IReflectionUtil util = ... //get implementation
//
//the generic type can be an interface
var types = util.GetDerivedTypes(new List<string>(), typeof(IList<>));
Assert.Count(1, types.Count());
Assert.Equal(typeof(IList<string>), types.FirstOrDefault());
//
//the generic type can be a class
types = util.GetDerivedTypes(new List<string>(), typeof(List<>));
Assert.Count(1, types.Count());
Assert.Equal(typeof(IList<string>), types.FirstOrDefault());
//
//the object itself does not need to be a generic type: a string is an enumeration of characters
types = util.GetDerivedTypes(typeof(string), typeof(IEnumerable<>));
Assert.Count(1, types.Count());
Assert.Equal(typeof(IEnumerable<Char>), types.FirstOrDefault());
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.GetIndexerProperty Method

IReflectionUtilGetIndexerProperty Method
Gets the indexed property whose index type is compatible with the specified index.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
PropertyInfo GetIndexerProperty(
    Object source,
    ICollection<Object> indexes
)

Parameters

source
Type: SystemObject
Object with the indexed property to get.
indexes
Type: System.Collections.GenericICollection Object
The source object has an indexed property whose type matches this object's type.

Return Value

Type: PropertyInfo
The property; if the property cannot be read for any reason or if no indexed property is compatible with the object specified by indexes.
Examples

The following code demonstrates how the method works.

C#
Copy
var dictionary = new Dictionary<string, object>();
IReflectionUtil util = ... //get implementation
//
//compatible index
Assert.NotNull(util.GetIndexerProperty("name", dictionary));
//
//incompatible index
Assert.Null(util.GetIndexerProperty(1, dictionary));
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.GetMethod Method

IReflectionUtilGetMethod Method
Overload List
 | Name | Description
Public method | GetMethod(String, Object, ICollectionObject) | Gets the specified method from the source object.
Public method | GetMethod(String, Type, ICollectionObject) | Gets the specified method from the specified type. This method is used for extension methods.
Top
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.GetMethod Method (String, Object, ICollection(Object))

IReflectionUtilGetMethod Method (String, Object, ICollectionObject)
Gets the specified method from the source object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
MethodInfo GetMethod(
    string methodName,
    Object source,
    ICollection<Object> args
)

Parameters

methodName
Type: SystemString
Name of the method to get.
source
Type: SystemObject
Object with the method to get.
args
Type: System.Collections.GenericICollection Object
Arguments that would be passed to the method. This object is used to determine the appropriate method signature.

Return Value

Type: MethodInfo
The method; if the method cannot be read for any reason.
See Also

Reference

IReflectionUtil Interface
GetMethod Overload
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.GetMethod Method (String, Type, ICollection(Object))

IReflectionUtilGetMethod Method (String, Type, ICollectionObject)
Gets the specified method from the specified type. This method is used for extension methods.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
MethodInfo GetMethod(
    string methodName,
    Type type,
    ICollection<Object> args
)

Parameters

methodName
Type: SystemString
Name of the method to get.
type
Type: SystemType
Type with the method to get.
args
Type: System.Collections.GenericICollection Object
Arguments that would be passed to the method. This object is used to determine the appropriate method signature.

Return Value

Type: MethodInfo
The method; if the method cannot be read for any reason.
See Also

Reference

IReflectionUtil Interface
GetMethod Overload
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.GetProperty Method

IReflectionUtilGetProperty Method
Overload List
 | Name | Description
Public method | GetProperty(String, Object) | Gets the specified property from the source object.
 | GetProperty(String, Object, Object) | Gets the specified property from the source object if it can be set to the specified value.
Top
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.GetProperty Method (String, Object)

IReflectionUtilGetProperty Method (String, Object)
Gets the specified property from the source object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
PropertyInfo GetProperty(
    string propertyName,
    Object source
)

Parameters

propertyName
Type: SystemString
Name of the property to get.
source
Type: SystemObject
Object with the property to get.

Return Value

Type: PropertyInfo
The property; if the property cannot be read for any reason.
See Also

Reference

IReflectionUtil Interface
GetProperty Overload
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.GetProperty Method (String, Object, Object)

IReflectionUtilGetProperty Method (String, Object, Object)
Gets the specified property from the source object if it can be set to the specified value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
PropertyInfo GetProperty(
    string propertyName,
    Object source,
    Object value
)

Parameters

propertyName
Type: SystemString
Name of the property to get.
source
Type: SystemObject
Object with the property to get.
value
Type: SystemObject
Object that must be compatible with the property type.

Return Value

Type: PropertyInfo
The property; if the property cannot be read for any reason or if the property type is not compatible with the object specified by value.
Examples

The following code demonstrates how the method works.

Sample type
Copy
public class Person
{
   public string Name { get; set; }
   public Guid Id { get; }
}
Method being used
Copy
var source = new Person();
IReflectionUtil util = ... //get implementation
Assert.NotNull(util.GetProperty("Name", source, string.Empty));
Assert.Null(util.GetProperty("Name", source, 0));          //incompatible property type
Assert.Null(util.GetProperty("Guid", source, Guid.Empty)); //read-only property
Assert.Null(util.GetProperty("Guid", source, 0));          //incompatible property type
See Also

Reference

IReflectionUtil Interface
GetProperty Overload
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.IsProperDictionary Method

IReflectionUtilIsProperDictionary Method
Indicates whether the source object is a dictionary whose index is compatible with the specified index and whose value can be set to the specified value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool IsProperDictionary(
    Object index,
    Object source,
    Object value
)

Parameters

index
Type: SystemObject
The source object is a dictionary that can have an index whose type matches this object's type.
source
Type: SystemObject
IDictionaryTKey, TValue object.
value
Type: SystemObject
This value can be added to the source object using the specified index.

Return Value

Type: Boolean
if the source object is a proper dictionary; otherwise .
Examples

The following code demonstrates how the method works.

C#
Copy
var dictionary = new Dictionary<string, int>();
IReflectionUtil util = ... //get implementation
Assert.True(util.IsProperDictionary("---key---", dictionary, 0));
Assert.True(util.IsProperDictionary("---key---", dictionary, 1));
Assert.False(util.IsProperDictionary("---key---", dictionary, null); //incompatible value
Assert.False(util.IsProperDictionary(0, dictionary, 0);              //incompatible index
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.IsTypeDerivedFrom Method

IReflectionUtilIsTypeDerivedFrom Method

Indicates whether or not the object is derived from the specified generic type definition.

Technically this method determines whether or not the object is type that implements or inherits from the specified generic type, and whether the generic type is compatible with the specified argument types.

For example, this method can be used to determine whether an object is a list that can accept string values, even if the list is defined as a list of objects.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool IsTypeDerivedFrom(
    Object obj,
    Type genericTypeDefinition,
    params Type[] args
)

Parameters

obj
Type: SystemObject
The object to check.
genericTypeDefinition
Type: SystemType
The generic type definition that the object may be derived from.
args
Type: SystemType
The generic type parameters for the generic type definition. If no values are provided the method determines whether or not the object is derived from the generic type definition without considering the generic parameter types.

Return Value

Type: Boolean
if the object is derived from a generic type that is compatible with the specified arguments (if provided); otherwise.
Examples

The following code demonstrates how the method works.

C#
Copy
IReflectionUtil util = ... //get implementation
//
//a string is derived from IEnumerable<char>
Assert.True(util.IsTypeDerivedFrom("", typeof(IEnumerable<>), typeof(char)));
//
//a string is derived from IEnumerable<>
Assert.True(util.IsTypeDerivedFrom("", typeof(IEnumerable<>)));
//
//List<string> is derived from IEnumerable<string>
Assert.True(util.IsTypeDerivedFrom(new List<string>(), typeof(IEnumerable<>), typeof(string)));
//
//List<string> is derived from IList<string>
Assert.True(util.IsTypeDerivedFrom(new List<string>(), typeof(IList<>), typeof(string)));
//
//List<string> is derived from List<string>
Assert.True(util.IsTypeDerivedFrom(new List<string>(), typeof(List<>), typeof(string)));
//
//List<object> is derived from IList<string>
Assert.True(util.IsTypeDerivedFrom(new List<object>(), typeof(List<>), typeof(string)));
//
//string is not derived from IList<char>
Assert.False(util.IsTypeDerivedFrom("", typeof(IList<>), typeof(char)));
//
//List<string> is not derived from IList<int>
Assert.False(util.IsTypeDerivedFrom(new List<string>(), typeof(IList<>), typeof(int)));
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IReflectionUtil.SetIndexerProperty Method

IReflectionUtilSetIndexerProperty Method
Sets the value on the source object using the index.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool SetIndexerProperty(
    Object source,
    Object value,
    params Object[] index
)

Parameters

source
Type: SystemObject
Object with the indexed property to get.
value
Type: SystemObject
Value that is set on the source object using the specified index.
index
Type: SystemObject
The index used to add the specified value to the source object.

Return Value

Type: Boolean
if the property was set; otherwise .
Examples

The following code demonstrates how the method works.

C#
Copy
var dictionary = new Dictionary<int, string>();
IReflectionUtil util = ... //get implementation
//
//int is a compatible index
Assert.True(util.SetIndexerProperty(dictionary, "---value1---", 1));
Assert.True(util.SetIndexerProperty(dictionary, "---value2---", 2));
//
//int is an incompatible value
Assert.False(util.SetIndexerProperty(0, dictionary, new object()));
//
//null is an incompatible index
Assert.False(util.SetIndexerProperty(null, dictionary, "---value3---");
//
//a string is an incompatible index
Assert.False(util.SetIndexerProperty("---index---", dictionary, "---value3---");
See Also

Reference

IReflectionUtil Interface
Sitecore.DataExchange.DataAccess Namespace


IValueAccessor Interface

IValueAccessor Interface

Provides access to components that are used to read and write values.

If a IValueReader is like a property getter and a IValueWriter is like a property setter, a IValueAccessor is like a property.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IValueAccessor

The IValueAccessor type exposes the following members.

Properties
 | Name | Description
Public property | ValueReader | Gets or sets the component used to read a value from a source object.
Public property | ValueWriter | Gets or sets the component used to write a value to a target object.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IValueAccessor Properties

IValueAccessor Properties

The IValueAccessor type exposes the following members.

Properties
 | Name | Description
Public property | ValueReader | Gets or sets the component used to read a value from a source object.
Public property | ValueWriter | Gets or sets the component used to write a value to a target object.
Top
See Also

Reference

IValueAccessor Interface
Sitecore.DataExchange.DataAccess Namespace


IValueAccessor.ValueReader Property

IValueAccessorValueReader Property
Gets or sets the component used to read a value from a source object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IValueReader ValueReader { get; set; }

Property Value

Type: IValueReader
See Also

Reference

IValueAccessor Interface
Sitecore.DataExchange.DataAccess Namespace


IValueAccessor.ValueWriter Property

IValueAccessorValueWriter Property
Gets or sets the component used to write a value to a target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IValueWriter ValueWriter { get; set; }

Property Value

Type: IValueWriter
See Also

Reference

IValueAccessor Interface
Sitecore.DataExchange.DataAccess Namespace


IValueAccessorSet Interface

IValueAccessorSet Interface

Represents a collection of IValueAccessor objects that can be used to read and write values.

If a IValueReader is like a property getter and a IValueWriter is like a property setter and a IValueAccessor is like a property, a IValueAccessorSet is like a type that can have properties set on it.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IValueAccessorSet

The IValueAccessorSet type exposes the following members.

Properties
 | Name | Description
Public property | Entries | Gets the IValueAccessor objects.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IValueAccessorSet Properties

IValueAccessorSet Properties

The IValueAccessorSet type exposes the following members.

Properties
 | Name | Description
Public property | Entries | Gets the IValueAccessor objects.
Top
See Also

Reference

IValueAccessorSet Interface
Sitecore.DataExchange.DataAccess Namespace


IValueAccessorSet.Entries Property

IValueAccessorSetEntries Property
Gets the IValueAccessor objects.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ICollection<IValueAccessor> Entries { get; }

Property Value

Type: ICollection IValueAccessor
See Also

Reference

IValueAccessorSet Interface
Sitecore.DataExchange.DataAccess Namespace


IValueAppender Interface

IValueAppender Interface

Component that appends a value to another value. The value that is updated is called the target value. Whether the target value is actually changed or whether a new value is created is determined by the implementation and the target value type.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IValueAppender

The IValueAppender type exposes the following members.

Methods
 | Name | Description
Public method | Append | Appends the specified value to the target value.
Public method | CanAppend | Indicates whether or not a value can be appended to the specified target object.
Top
Examples

A value appended may either change the target value or it may create a new target value.

The first option is to for the implementation to change the target value.

This is possible when then target value is mutable.

Value appender that changes the target value
Copy
public class StringListAppender : IValueAppender
{
    public CanAppendResult CanAppend(object target, object value, DataAccessContext context)
    {
        var isStringList = (target != null && target is IList<string>);
        var isValueString = (value is string);
        var canAppend = isStringList && isValueString;
        return new CanAppendResult { CanAppendValue = canAppend, IsGuess = false };
    }
    public AppendResult Append(object target, object value, DataAccessContext context)
    {
        var isStringList = (target != null && target is IList<string>);
        var isValueString = (value is string);
        if (!isStringList || !isValueString)
        {
            return new AppendResult { WasValueAppended = false, AppendedValue = null };
        }
        var list = target as IList<string>;
        var stringValue = value as string;
        list.Add(stringValue);
        return new AppendResult { WasValueAppended = true, AppendedValue = list };
    }
}
Using the string list value appender
Copy
var places = new List<string>();
places.Add("nyc");
var context = new DataAccessContext();
var appender = new StringListAppender();
var caResult = appender.CanAppend(places, "la", context);
Assert.True(caResult.CanAppendValue);
Assert.False(caResult.IsGuess);
//
//add "la" to the list of places
var aResult = appender.Append(places, "la", context);
//
//confirm the list of places was appended
Assert.True(aResult.WasValueAppended);
Assert.Same(places, aResult.AppendedValue);
Assert.Equal(2, places.Count);

The second option is to for the implementation to create a new object that contains the combination of the original target value with the value being appended.

This is the only option when then target value is immutable, but this option also is available when the target target is mutable.

Value appender for an immutable target value (string array)
Copy
public class StringArrayAppender : IValueAppender
{
    public CanAppendResult CanAppend(object target, object value, DataAccessContext context)
    {
        var canAppend = (target != null && target is string[] && value is string);
        return new CanAppendResult { CanAppendValue = canAppend, IsGuess = false };
    }
    public AppendResult Append(object target, object value, DataAccessContext context)
    {
        var wasAppended = false;
        string[] newArray = null;
        var array = target as string[];
        if (array != null)
        {
            var list = new List<string>(array);
            list.Add(value as string);
            newArray = list.ToArray();
            wasAppended = true;
        }
       return new AppendResult { WasValueAppended = wasAppended, AppendedValue = newArray };
    }
}
Using the string array value appender
Copy
var places = new string[] { "nyc" };
var context = new DataAccessContext();
//
//append "la" to the array
var appender = new StringArrayAppender();
var caResult = appender.CanAppend(places, "la", context);
Assert.True(caResult.CanAppendValue);
Assert.False(caResult.IsGuess);
var aResult = appender.Append(places, "la", context);
Assert.True(aResult.WasValueAppended);
var places2 = aResult.AppendedValue as string[];
Assert.NotNull(places2);
Assert.Equal(2, places2.Length);
Assert.Equal("nyc", places2[0]);
Assert.Equal("la", places2[1]);
//
//confirm the original array is unchanged
Assert.Equal(1, places.Length);
Assert.Equal("nyc", places[0]);
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IValueAppender Methods

IValueAppender Methods

The IValueAppender type exposes the following members.

Methods
 | Name | Description
Public method | Append | Appends the specified value to the target value.
Public method | CanAppend | Indicates whether or not a value can be appended to the specified target object.
Top
See Also

Reference

IValueAppender Interface
Sitecore.DataExchange.DataAccess Namespace


IValueAppender.Append Method

IValueAppenderAppend Method

Appends the specified value to the target value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
AppendResult Append(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object whose value is appended.
value
Type: SystemObject
The value that is appended to the target object.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: AppendResult
Object that represents whether or not the value was appended, and if it was appended, the new value.
See Also

Reference

IValueAppender Interface
Sitecore.DataExchange.DataAccess Namespace


IValueAppender.CanAppend Method

IValueAppenderCanAppend Method
Indicates whether or not a value can be appended to the specified target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
CanAppendResult CanAppend(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object whose value would be appended.
value
Type: SystemObject
The value that would be appended to the target object.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanAppendResult
A value that indicates whether a value can be appended or not.
See Also

Reference

IValueAppender Interface
Sitecore.DataExchange.DataAccess Namespace


IValueReader Interface

IValueReader Interface

Represents the ability to read a value from a source object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IValueReader

The IValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether a value can be read from the specified source object.
Public method | Read | Reads the value from the specified source object.
Top
Examples

Most value readers are fairly simple. They read a property from an object or invoke a method on an object. But there are cases where must more complex logic is required.

Consider an example where a fallback value is needed. If the object has an identifier, that value is read. But if no identifier is set, then the email address is read.

Custom object with an identifier and an email address
Copy
public class Person
{
  public Guid Id { get; set; }
  public string Email { get; set; }
}

You need a value reader that can read the identifier from the data object. The logic is that the Email value should be used unless it is not set, in which case the Id value should be used.

Value reader implementation
Copy
public class IdentifierValueReader : IValueReader
{
  public CanReadResult CanRead(object source, DataAccessContext context)
  {
    var canRead = false;
    if (source is Person)
    {
      canRead = true;
    }
    return new CanReadResult { CanReadValue = canRead, IsGuess = true };
  }
  public ReadResult Read(object source, DataAccessContext context)
  {
    var wasRead = false;
    string identifier = null;
    var person = source as Person;
    if (person != null)
    {
      identifier = person.Email;
      if (string.IsNullOrWhiteSpace(identifier))
      {
        identifier = person.Id.ToString();
      }
    }
    return new ReadResult { ReadValue = wasReader, WasValueRead = identifier };
  }
}
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IValueReader Methods

IValueReader Methods

The IValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether a value can be read from the specified source object.
Public method | Read | Reads the value from the specified source object.
Top
See Also

Reference

IValueReader Interface
Sitecore.DataExchange.DataAccess Namespace


IValueReader.CanRead Method

IValueReaderCanRead Method
Indicates whether a value can be read from the specified source object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value would be read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
A value that indicates whether a value can be read or not.
See Also

Reference

IValueReader Interface
Sitecore.DataExchange.DataAccess Namespace


IValueReader.Read Method

IValueReaderRead Method
Reads the value from the specified source object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents whether or not the value was read, and if it was read, the value itself.
See Also

Reference

IValueReader Interface
Sitecore.DataExchange.DataAccess Namespace


IValueWriter Interface

IValueWriter Interface

Represents the ability to write a value to a target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IValueWriter

The IValueWriter type exposes the following members.

Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified value can be written to the target object.
Public method | Write | Writes the specified value to the target object.
Top
Examples

Most value writers are fairly simple. They set a property on the target object. Configuration involves specifying which property needs to be set and which component is used to set the property.

Consider an example where an identifier must be set on an object. The identifier is a Guid. The value writer is able to set the identifier on a target object if the target object is an instance of the following class.

Custom object with an identifier
Copy
public class Person
{
  public Guid Id { get; set; }
  public string Email { get; set; }
}

You need a value writer that can set the value of the Id property. A PropertyValueWriter can do this, but the PropertyValueWriter requires the object passed to it be an object that is compatible with the specified property, which in this case is Guid.

If you want the value writer to be able to accept a string, the value that is passed to the value writer must be converted to a Guid first.

Value writer implementation
Copy
public class IdentifierValueWriter : IValueWriter
{
  public CanWriteResult CanWrite(object target, object value, DataAccessContext context)
  {
    var canWrite = false;
    if (value != null)
    {
      var id = Guid.Empty;
      if (Guid.TryParse(value.ToString(), out id))
      {
        if (source is Person)
        {
          canRead = true;
        }
      }
    }
    return new CanReadResult { CanReadValue = canRead };
  }
  public bool Write(object target, object value, DataAccessContext context)
  {
    var id = Guid.Empty;
    if (Guid.TryParse(value.ToString(), out id))
    {
      var person = source as Person;
      if (person != null)
      {
        person.Id = id;
        return true;
      }
    }
    return false;
  }
}
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


IValueWriter Methods

IValueWriter Methods

The IValueWriter type exposes the following members.

Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified value can be written to the target object.
Public method | Write | Writes the specified value to the target object.
Top
See Also

Reference

IValueWriter Interface
Sitecore.DataExchange.DataAccess Namespace


IValueWriter.CanWrite Method

IValueWriterCanWrite Method
Indicates whether the specified value can be written to the target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
CanWriteResult CanWrite(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object that value would be written to.
value
Type: SystemObject
The object that would be written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanWriteResult

Return Value

Type: CanWriteResult
A value that indicates whether a value can be written or not.
See Also

Reference

IValueWriter Interface
Sitecore.DataExchange.DataAccess Namespace


IValueWriter.Write Method

IValueWriterWrite Method
Writes the specified value to the target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool Write(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object that value is written to.
value
Type: SystemObject
The object that is written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: Boolean
if the value was written to the target object; otherwise .
See Also

Reference

IValueWriter Interface
Sitecore.DataExchange.DataAccess Namespace


MappingContext Class

MappingContext Class
Represents the parameters passed to a IMappingSet when it is run in order to track status as the mapping set is run.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessDataAccessContext
Sitecore.DataExchange.DataAccessMappingContext

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MappingContext : DataAccessContext

The MappingContext type exposes the following members.

Constructors
 | Name | Description
Public method | MappingContext | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. (Inherited from DataAccessContext.)
Public property | RunFail | Gets a list of the mapping objects that were were not successfully applied.
Public property | RunSuccess | Gets a list of the mapping objects that were successfully applied.
Public property | Source | Gets or sets the object the mapping set will read values from.
Public property | Target | Gets or sets the object the mapping set will write values to.
Top
Methods
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter. (Inherited from DataAccessContext.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetMethodSettings | Gets the MethodSettings plugin from the context. (Defined by DataAccessContextExtensions.)
Public Extension Method | HasMethodSettings | Indicates whether or not the MethodSettings plugin is set on the context. (Defined by DataAccessContextExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


MappingContext Constructor

MappingContext Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MappingContext()
See Also

Reference

MappingContext Class
Sitecore.DataExchange.DataAccess Namespace


MappingContext Properties

MappingContext Properties

The MappingContext type exposes the following members.

Properties
 | Name | Description
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. (Inherited from DataAccessContext.)
Public property | RunFail | Gets a list of the mapping objects that were were not successfully applied.
Public property | RunSuccess | Gets a list of the mapping objects that were successfully applied.
Public property | Source | Gets or sets the object the mapping set will read values from.
Public property | Target | Gets or sets the object the mapping set will write values to.
Top
See Also

Reference

MappingContext Class
Sitecore.DataExchange.DataAccess Namespace


MappingContext.RunFail Property

MappingContextRunFail Property
Gets a list of the mapping objects that were were not successfully applied.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IMapping> RunFail { get; }

Property Value

Type: ICollection IMapping
See Also

Reference

MappingContext Class
Sitecore.DataExchange.DataAccess Namespace


MappingContext.RunSuccess Property

MappingContextRunSuccess Property
Gets a list of the mapping objects that were successfully applied.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IMapping> RunSuccess { get; }

Property Value

Type: ICollection IMapping
See Also

Reference

MappingContext Class
Sitecore.DataExchange.DataAccess Namespace


MappingContext.Source Property

MappingContextSource Property
Gets or sets the object the mapping set will read values from.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object Source { get; set; }

Property Value

Type: Object
See Also

Reference

MappingContext Class
Sitecore.DataExchange.DataAccess Namespace


MappingContext.Target Property

MappingContextTarget Property
Gets or sets the object the mapping set will write values to.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object Target { get; set; }

Property Value

Type: Object
See Also

Reference

MappingContext Class
Sitecore.DataExchange.DataAccess Namespace


MappingContext Methods

MappingContext Methods

The MappingContext type exposes the following members.

Methods
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter. (Inherited from DataAccessContext.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetMethodSettings | Gets the MethodSettings plugin from the context. (Defined by DataAccessContextExtensions.)
Public Extension Method | HasMethodSettings | Indicates whether or not the MethodSettings plugin is set on the context. (Defined by DataAccessContextExtensions.)
Top
See Also

Reference

MappingContext Class
Sitecore.DataExchange.DataAccess Namespace


ReadResult Class

ReadResult Class
Represents the result of the call used to read a value from a specific source object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessReadResult

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ReadResult

The ReadResult type exposes the following members.

Constructors
 | Name | Description
Public method | ReadResult | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ReadDateTime | Gets when the value was read.
Public property | ReadValue | Gets or sets the value that was read. If the value was read, the object that was read is set. If the value cannot be read, null is set.
Public property | WasValueRead | Gets or sets whether the value reader read a value.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


ReadResult Constructor

ReadResult Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult(
    DateTime readDateTime
)

Parameters

readDateTime
Type: SystemDateTime
When the value was read.
See Also

Reference

ReadResult Class
Sitecore.DataExchange.DataAccess Namespace


ReadResult Properties

ReadResult Properties

The ReadResult type exposes the following members.

Properties
 | Name | Description
Public property | ReadDateTime | Gets when the value was read.
Public property | ReadValue | Gets or sets the value that was read. If the value was read, the object that was read is set. If the value cannot be read, null is set.
Public property | WasValueRead | Gets or sets whether the value reader read a value.
Top
See Also

Reference

ReadResult Class
Sitecore.DataExchange.DataAccess Namespace


ReadResult.ReadDateTime Property

ReadResultReadDateTime Property
Gets when the value was read.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateTime ReadDateTime { get; }

Property Value

Type: DateTime
See Also

Reference

ReadResult Class
Sitecore.DataExchange.DataAccess Namespace


ReadResult.ReadValue Property

ReadResultReadValue Property

Gets or sets the value that was read.

If the value was read, the object that was read is set. If the value cannot be read, null is set.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object ReadValue { get; set; }

Property Value

Type: Object
See Also

Reference

ReadResult Class
Sitecore.DataExchange.DataAccess Namespace


ReadResult.WasValueRead Property

ReadResultWasValueRead Property

Gets or sets whether the value reader read a value.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool WasValueRead { get; set; }

Property Value

Type: Boolean
See Also

Reference

ReadResult Class
Sitecore.DataExchange.DataAccess Namespace


ValueAccessor Class

ValueAccessor Class
Provides access to components that are used to read and write values.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessValueAccessor

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ValueAccessor : IValueAccessor

The ValueAccessor type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAccessor | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ValueReader | Gets or sets the component used to read a value from a source object.
Public property | ValueWriter | Gets or sets the component used to write a value to a target object.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


ValueAccessor Constructor

ValueAccessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ValueAccessor()
See Also

Reference

ValueAccessor Class
Sitecore.DataExchange.DataAccess Namespace


ValueAccessor Properties

ValueAccessor Properties

The ValueAccessor type exposes the following members.

Properties
 | Name | Description
Public property | ValueReader | Gets or sets the component used to read a value from a source object.
Public property | ValueWriter | Gets or sets the component used to write a value to a target object.
Top
See Also

Reference

ValueAccessor Class
Sitecore.DataExchange.DataAccess Namespace


ValueAccessor.ValueReader Property

ValueAccessorValueReader Property
Gets or sets the component used to read a value from a source object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueReader ValueReader { get; set; }

Property Value

Type: IValueReader

Implements

IValueAccessorValueReader
See Also

Reference

ValueAccessor Class
Sitecore.DataExchange.DataAccess Namespace


ValueAccessor.ValueWriter Property

ValueAccessorValueWriter Property
Gets or sets the component used to write a value to a target object.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueWriter ValueWriter { get; set; }

Property Value

Type: IValueWriter

Implements

IValueAccessorValueWriter
See Also

Reference

ValueAccessor Class
Sitecore.DataExchange.DataAccess Namespace


ValueAccessorSet Class

ValueAccessorSet Class
Represents a collection of IValueAccessor objects that can be used to read and write values.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccessValueAccessorSet

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ValueAccessorSet : IValueAccessorSet

The ValueAccessorSet type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAccessorSet | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Entries | Gets the IValueAccessor objects.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess Namespace


ValueAccessorSet Constructor

ValueAccessorSet Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ValueAccessorSet()
See Also

Reference

ValueAccessorSet Class
Sitecore.DataExchange.DataAccess Namespace


ValueAccessorSet Properties

ValueAccessorSet Properties

The ValueAccessorSet type exposes the following members.

Properties
 | Name | Description
Public property | Entries | Gets the IValueAccessor objects.
Top
See Also

Reference

ValueAccessorSet Class
Sitecore.DataExchange.DataAccess Namespace


ValueAccessorSet.Entries Property

ValueAccessorSetEntries Property
Gets the IValueAccessor objects.

Namespace: Sitecore.DataExchange.DataAccess
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IValueAccessor> Entries { get; }

Property Value

Type: ICollection IValueAccessor

Implements

IValueAccessorSetEntries
See Also

Reference

ValueAccessorSet Class
Sitecore.DataExchange.DataAccess Namespace


Sitecore.DataExchange.DataAccess.Appenders Namespace

Sitecore.DataExchange.DataAccess.Appenders Namespace

This namespace contains implementations of IValueAppender.

Classes
Class | Description
CollectionValueAppender | Component that appends a value to an object that inherits from ICollectionT.


CollectionValueAppender Class

CollectionValueAppender Class
Component that appends a value to an object that inherits from ICollectionT.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.AppendersCollectionValueAppender

Namespace: Sitecore.DataExchange.DataAccess.Appenders
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class CollectionValueAppender : IValueAppender

The CollectionValueAppender type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionValueAppender | Initializes a new instance of the class.
Top
Properties
 | Name | Description
 | AllowDuplicateValues | If , any value can be appended. If the value will be appended only if the list does not already contain the value. If the list already contains the value the append method returns an object that indicates the value was appended in order to avoid confusion on the part of components using this appender.
Public property | ReflectionUtil | Gets or sets the component that provides access to reflection capabilities that the reader required.
Top
Methods
 | Name | Description
Public method | Append | Adds the specified value to the target list.
Public method | CanAppend | Indicates whether the specified value can be appended to the target list.
Protected method | DoesTargetContainValue | Gets a value that indicates whether or not the target object already contains the specified value. This method uses the Contains method to determine the value it returns. You should override this method when you need to use a different approach to determine whether or not the target object already contains the specified value.
Top
Examples

The following code demonstrates how to use the component to add another name to a list of names.

C#
Copy
var names = new List<string>(new[] { "name1", "name2" });
Assert.Equal(2, names.Count);
var appender = new CollectionValueAppender();
var context = new DataAccessContext();
var caResult = appender.CanAppend(names, "name3", context);
Assert.True(caResult.CanAppendValue);
Assert.False(caResult.IsGuess);
var aResult = appender.Append(names, "name3", context);
Assert.True(aResult.WasValueAppended);
Assert.Equal(names, aResult.AppendedValue);
Assert.Equal(3, names.Count);

The following code demonstrates how the component behaves when an unsupported target object is used. In this case, ArrayList is used, which does not inherit from ICollectionT.

C#
Copy
var names = new List<string>(new[] { "name1", "name2" });
Assert.Equal(2, names.Count);
var appender = new CollectionValueAppender();
var context = new DataAccessContext();
var caResult = appender.CanAppend(names, "name3", context);
Assert.False(caResult.CanAppendValue);
Assert.False(caResult.IsGuess);
var aResult = appender.Append(names, "name3", context);
Assert.False(aResult.WasValueAppended);
Assert.Null(aResult.AppendedValue);
Assert.Equal(2, names.Count);
See Also

Reference

Sitecore.DataExchange.DataAccess.Appenders Namespace


CollectionValueAppender Constructor

CollectionValueAppender Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Appenders
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CollectionValueAppender()
See Also

Reference

CollectionValueAppender Class
Sitecore.DataExchange.DataAccess.Appenders Namespace


CollectionValueAppender Properties

CollectionValueAppender Properties

The CollectionValueAppender type exposes the following members.

Properties
 | Name | Description
 | AllowDuplicateValues | If , any value can be appended. If the value will be appended only if the list does not already contain the value. If the list already contains the value the append method returns an object that indicates the value was appended in order to avoid confusion on the part of components using this appender.
Public property | ReflectionUtil | Gets or sets the component that provides access to reflection capabilities that the reader required.
Top
See Also

Reference

CollectionValueAppender Class
Sitecore.DataExchange.DataAccess.Appenders Namespace


CollectionValueAppender.AllowDuplicateValues Property

CollectionValueAppenderAllowDuplicateValues Property
If , any value can be appended. If the value will be appended only if the list does not already contain the value. If the list already contains the value the append method returns an object that indicates the value was appended in order to avoid confusion on the part of components using this appender.

Namespace: Sitecore.DataExchange.DataAccess.Appenders
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool AllowDuplicateValues { get; set; }

Property Value

Type: Boolean
Examples

The following example demonstrates how the component works when AllowDuplicateValues is (the default value).

C#
Copy
var names = new List<string>();
//
//add the name to the collection
var name = "my name";
names.Add(name);
Assert.Equal(1, names.Count);
//
//explicitly set the appender not to allow duplicate values
var appender = new CollectionValueAppender();
appender.AllowDuplicateValues = false;
var context = new DataAccessContext();
//
//use the appender to add the name again
var caResult = appender.CanAppend(names, name, context);
Assert.False(caResult.CanAppendValue);
Assert.False(caResult.IsGuess);
var aResult = appender.Append(names, name, context);
Assert.False(aResult.WasValueAppended);
Assert.Null(aResult.AppendedValue);
Assert.Equal(1, names.Count);

The following example demonstrates how the component works when AllowDuplicateValues is .

C#
Copy
var names = new List<string>();
//
//add the name to the collection
var name = "my name";
names.Add(name);
Assert.Equal(1, names.Count);
//
//set the appender to allow duplicate values
var appender = new CollectionValueAppender();
appender.AllowDuplicateValues = true;
var context = new DataAccessContext();
//
//use the appender to add the name again
var caResult = appender.CanAppend(names, name, context);
Assert.True(caResult.CanAppendValue);
Assert.False(caResult.IsGuess);
var aResult = appender.Append(names, name, context);
Assert.True(aResult.WasValueAppended);
Assert.Equal(names, aResult.AppendedValue);
Assert.Equal(2, names.Count);
See Also

Reference

CollectionValueAppender Class
Sitecore.DataExchange.DataAccess.Appenders Namespace


CollectionValueAppender.ReflectionUtil Property

CollectionValueAppenderReflectionUtil Property

Gets or sets the component that provides access to reflection capabilities that the reader required.

Namespace: Sitecore.DataExchange.DataAccess.Appenders
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IReflectionUtil ReflectionUtil { get; set; }

Property Value

Type: IReflectionUtil
Remarks

This property is set in the constructor. The property setter can be used to specify an alternative object to use.

See Also

Reference

CollectionValueAppender Class
Sitecore.DataExchange.DataAccess.Appenders Namespace


CollectionValueAppender Methods

CollectionValueAppender Methods

The CollectionValueAppender type exposes the following members.

Methods
 | Name | Description
Public method | Append | Adds the specified value to the target list.
Public method | CanAppend | Indicates whether the specified value can be appended to the target list.
Protected method | DoesTargetContainValue | Gets a value that indicates whether or not the target object already contains the specified value. This method uses the Contains method to determine the value it returns. You should override this method when you need to use a different approach to determine whether or not the target object already contains the specified value.
Top
See Also

Reference

CollectionValueAppender Class
Sitecore.DataExchange.DataAccess.Appenders Namespace


CollectionValueAppender.Append Method

CollectionValueAppenderAppend Method

Adds the specified value to the target list.

Namespace: Sitecore.DataExchange.DataAccess.Appenders
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual AppendResult Append(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The list to append.
value
Type: SystemObject
The value to appended to the target list.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: AppendResult
Object that represents whether or not the target list was appended, and if it was appended, the new value.

Implements

IValueAppenderAppend(Object, Object, DataAccessContext)
See Also

Reference

CollectionValueAppender Class
Sitecore.DataExchange.DataAccess.Appenders Namespace


CollectionValueAppender.CanAppend Method

CollectionValueAppenderCanAppend Method

Indicates whether the specified value can be appended to the target list.

Namespace: Sitecore.DataExchange.DataAccess.Appenders
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual CanAppendResult CanAppend(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The list that would be appended.
value
Type: SystemObject
The value that would be appended to the target list.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanAppendResult
if the target is a list and to which the value can be added; otherwise .

Implements

IValueAppenderCanAppend(Object, Object, DataAccessContext)
See Also

Reference

CollectionValueAppender Class
Sitecore.DataExchange.DataAccess.Appenders Namespace


CollectionValueAppender.DoesTargetContainValue Method

CollectionValueAppenderDoesTargetContainValue Method

Gets a value that indicates whether or not the target object already contains the specified value.

This method uses the Contains method to determine the value it returns. You should override this method when you need to use a different approach to determine whether or not the target object already contains the specified value.

Namespace: Sitecore.DataExchange.DataAccess.Appenders
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual bool DoesTargetContainValue(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The list that might contain the value.
value
Type: SystemObject
The value that might exist in a list.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: Boolean
if the target object contains the specified value; otherwise.
See Also

Reference

CollectionValueAppender Class
Sitecore.DataExchange.DataAccess.Appenders Namespace


Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace

Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace

This namespace contains implementations of IApplyMappingRule.

Classes
 | Class | Description
Public class | CollectionCountMappingRule | Represents a mapping rule that is used to prevent a collection of a certain size from being written to target objects.
Public class | DefaultValueMappingRule | Represents a mapping rule that is used to prevent default values from being written to target objects.
Public class | NullValueMappingRule | Represents a mapping rule that is used to prevent values from being written to target objects.


CollectionCountMappingRule Class

CollectionCountMappingRule Class
Represents a mapping rule that is used to prevent a collection of a certain size from being written to target objects.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ApplyMappingRulesCollectionCountMappingRule

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class CollectionCountMappingRule : IApplyMappingRule

The CollectionCountMappingRule type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionCountMappingRule | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | MaxCount | Gets or sets the maximum number of members in the collection that are allowed in order for ShouldMappingBeApplied(Object, Object, Object) to return . Use a negative number to indicate no maximum count is specified. The default value is -1.
Public property | MinCount | Gets or sets the minimum number of members in the collection that are required in order for ShouldMappingBeApplied(Object, Object, Object) to return . Use zero to indicate no minimum value is specified. The default value is 0.
Top
Methods
 | Name | Description
Public method | ShouldMappingBeApplied | Indicates whether or not the mapping should be applied, based on the value specified.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


CollectionCountMappingRule Constructor

CollectionCountMappingRule Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CollectionCountMappingRule()
See Also

Reference

CollectionCountMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


CollectionCountMappingRule Properties

CollectionCountMappingRule Properties

The CollectionCountMappingRule type exposes the following members.

Properties
 | Name | Description
Public property | MaxCount | Gets or sets the maximum number of members in the collection that are allowed in order for ShouldMappingBeApplied(Object, Object, Object) to return . Use a negative number to indicate no maximum count is specified. The default value is -1.
Public property | MinCount | Gets or sets the minimum number of members in the collection that are required in order for ShouldMappingBeApplied(Object, Object, Object) to return . Use zero to indicate no minimum value is specified. The default value is 0.
Top
See Also

Reference

CollectionCountMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


CollectionCountMappingRule.MaxCount Property

CollectionCountMappingRuleMaxCount Property
Gets or sets the maximum number of members in the collection that are allowed in order for ShouldMappingBeApplied(Object, Object, Object) to return . Use a negative number to indicate no maximum count is specified. The default value is -1.

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int MaxCount { get; set; }

Property Value

Type: Int32
See Also

Reference

CollectionCountMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


CollectionCountMappingRule.MinCount Property

CollectionCountMappingRuleMinCount Property
Gets or sets the minimum number of members in the collection that are required in order for ShouldMappingBeApplied(Object, Object, Object) to return . Use zero to indicate no minimum value is specified. The default value is 0.

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int MinCount { get; set; }

Property Value

Type: Int32
See Also

Reference

CollectionCountMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


CollectionCountMappingRule Methods

CollectionCountMappingRule Methods

The CollectionCountMappingRule type exposes the following members.

Methods
 | Name | Description
Public method | ShouldMappingBeApplied | Indicates whether or not the mapping should be applied, based on the value specified.
Top
See Also

Reference

CollectionCountMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


CollectionCountMappingRule.ShouldMappingBeApplied Method

CollectionCountMappingRuleShouldMappingBeApplied Method
Indicates whether or not the mapping should be applied, based on the value specified.

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool ShouldMappingBeApplied(
    Object value,
    Object source,
    Object target
)

Parameters

value
Type: SystemObject
The value to check.
source
Type: SystemObject
The source object from which the value was read.
target
Type: SystemObject
The target object to which the value may be written.

Return Value

Type: Boolean
if the value is a collection whose size is within the specified range; otherwise.

Implements

IApplyMappingRuleShouldMappingBeApplied(Object, Object, Object)
See Also

Reference

CollectionCountMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


DefaultValueMappingRule Class

DefaultValueMappingRule Class
Represents a mapping rule that is used to prevent default values from being written to target objects.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ApplyMappingRulesDefaultValueMappingRule

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DefaultValueMappingRule : IApplyMappingRule

The DefaultValueMappingRule type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultValueMappingRule | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Public method | ShouldMappingBeApplied | Indicates whether or not the mapping should be applied, based on the value specified.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


DefaultValueMappingRule Constructor

DefaultValueMappingRule Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DefaultValueMappingRule()
See Also

Reference

DefaultValueMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


DefaultValueMappingRule Methods

DefaultValueMappingRule Methods

The DefaultValueMappingRule type exposes the following members.

Methods
 | Name | Description
Public method | ShouldMappingBeApplied | Indicates whether or not the mapping should be applied, based on the value specified.
Top
See Also

Reference

DefaultValueMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


DefaultValueMappingRule.ShouldMappingBeApplied Method

DefaultValueMappingRuleShouldMappingBeApplied Method
Indicates whether or not the mapping should be applied, based on the value specified.

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool ShouldMappingBeApplied(
    Object value,
    Object source,
    Object target
)

Parameters

value
Type: SystemObject
The value to check.
source
Type: SystemObject
The source object from which the value was read.
target
Type: SystemObject
The target object to which the value may be written.

Return Value

Type: Boolean
if the value is not the default value for the type; otherwise.

Implements

IApplyMappingRuleShouldMappingBeApplied(Object, Object, Object)
See Also

Reference

DefaultValueMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


NullValueMappingRule Class

NullValueMappingRule Class
Represents a mapping rule that is used to prevent values from being written to target objects.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ApplyMappingRulesNullValueMappingRule

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class NullValueMappingRule : IApplyMappingRule

The NullValueMappingRule type exposes the following members.

Constructors
 | Name | Description
Public method | NullValueMappingRule | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Public method | ShouldMappingBeApplied | Indicates whether or not the mapping should be applied, based on the value specified.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


NullValueMappingRule Constructor

NullValueMappingRule Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public NullValueMappingRule()
See Also

Reference

NullValueMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


NullValueMappingRule Methods

NullValueMappingRule Methods

The NullValueMappingRule type exposes the following members.

Methods
 | Name | Description
Public method | ShouldMappingBeApplied | Indicates whether or not the mapping should be applied, based on the value specified.
Top
See Also

Reference

NullValueMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


NullValueMappingRule.ShouldMappingBeApplied Method

NullValueMappingRuleShouldMappingBeApplied Method
Indicates whether or not the mapping should be applied, based on the value specified.

Namespace: Sitecore.DataExchange.DataAccess.ApplyMappingRules
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool ShouldMappingBeApplied(
    Object value,
    Object source,
    Object target
)

Parameters

value
Type: SystemObject
The value to check.
source
Type: SystemObject
The source object from which the value was read.
target
Type: SystemObject
The target object to which the value may be written.

Return Value

Type: Boolean
if the value is not ; if the value is .

Implements

IApplyMappingRuleShouldMappingBeApplied(Object, Object, Object)
See Also

Reference

NullValueMappingRule Class
Sitecore.DataExchange.DataAccess.ApplyMappingRules Namespace


Sitecore.DataExchange.DataAccess.Extensions Namespace

Sitecore.DataExchange.DataAccess.Extensions Namespace

This namespace contains extension methods that are used by data access components.

Classes
 | Class | Description
Public class | DataAccessContextExtensions | This class contains extension methods for accessing plugins on DataAccessContext objects.


DataAccessContextExtensions Class

DataAccessContextExtensions Class
This class contains extension methods for accessing plugins on DataAccessContext objects.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ExtensionsDataAccessContextExtensions

Namespace: Sitecore.DataExchange.DataAccess.Extensions
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class DataAccessContextExtensions

The DataAccessContextExtensions type exposes the following members.

Methods
Name | Description
GetMethodSettings | Gets the MethodSettings plugin from the context.
HasMethodSettings | Indicates whether or not the MethodSettings plugin is set on the context.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Extensions Namespace


DataAccessContextExtensions Methods

DataAccessContextExtensions Methods

The DataAccessContextExtensions type exposes the following members.

Methods
Name | Description
GetMethodSettings | Gets the MethodSettings plugin from the context.
HasMethodSettings | Indicates whether or not the MethodSettings plugin is set on the context.
Top
See Also

Reference

DataAccessContextExtensions Class
Sitecore.DataExchange.DataAccess.Extensions Namespace


DataAccessContextExtensions.GetMethodSettings Method

DataAccessContextExtensionsGetMethodSettings Method
Gets the MethodSettings plugin from the context.

Namespace: Sitecore.DataExchange.DataAccess.Extensions
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static MethodSettings GetMethodSettings(
    this DataAccessContext context
)

Parameters

context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context

Return Value

Type: MethodSettings
The plugin if it is set on the context; otherwise .

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataAccessContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataAccessContextExtensions Class
Sitecore.DataExchange.DataAccess.Extensions Namespace


DataAccessContextExtensions.HasMethodSettings Method

DataAccessContextExtensionsHasMethodSettings Method
Indicates whether or not the MethodSettings plugin is set on the context.

Namespace: Sitecore.DataExchange.DataAccess.Extensions
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasMethodSettings(
    this DataAccessContext context
)

Parameters

context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context

Return Value

Type: Boolean
if the plugin is set on the context; otherwise .

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataAccessContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataAccessContextExtensions Class
Sitecore.DataExchange.DataAccess.Extensions Namespace


Sitecore.DataExchange.DataAccess.Mappings Namespace

Sitecore.DataExchange.DataAccess.Mappings Namespace

This namespace contains implementations of the interfaces used to specify and control the process of mapping data between objects.

Classes
 | Class | Description
Public class | Mapping | Represents a single object in a IMappingSet. It defines the components the mapping set uses in order to read a value from a source object and to write a value to a target object.
Public class | SequentialMappingSet | Runs a collection of mappings in a specific order.


Mapping Class

Mapping Class
Represents a single object in a IMappingSet. It defines the components the mapping set uses in order to read a value from a source object and to write a value to a target object.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.MappingsMapping

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class Mapping : IMapping

The Mapping type exposes the following members.

Constructors
 | Name | Description
Public method | Mapping | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ApplyMappingRules | Gets the component that determines whether or not the source value should be written to the target object. The IMappingSet must use this collection before attempting to apply the mapping. If the collection is empty, the mapping set should apply the mapping. If any of the mapping validators returns false, the mapping set should not apply the mapping.
Public property | Enabled | Gets or sets a value that indicates whether or not the mapping is enabled. If , IMappingSet will skip this pipeline step.
Public property | Identifier | Gets or sets the identifier for the mapping.
Public property | IgnoreNullValues | Gets or sets a value that indicates whether or not the mapping is applied when the SourceAccessor reads a null value.
Public property | SourceAccessor | Gets or sets the component used by a IMappingSet to access the IValueReader used to read a value from a source object.
Public property | SourceValueTransformer | Gets or sets the component that transforms the source value before it is written to the target object.
Public property | TargetAccessor | Gets or sets the component used by a IMappingSet to access the IValueWriter used to write a value to a target object.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping Constructor

Mapping Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Mapping()
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping Properties

Mapping Properties

The Mapping type exposes the following members.

Properties
 | Name | Description
Public property | ApplyMappingRules | Gets the component that determines whether or not the source value should be written to the target object. The IMappingSet must use this collection before attempting to apply the mapping. If the collection is empty, the mapping set should apply the mapping. If any of the mapping validators returns false, the mapping set should not apply the mapping.
Public property | Enabled | Gets or sets a value that indicates whether or not the mapping is enabled. If , IMappingSet will skip this pipeline step.
Public property | Identifier | Gets or sets the identifier for the mapping.
Public property | IgnoreNullValues | Gets or sets a value that indicates whether or not the mapping is applied when the SourceAccessor reads a null value.
Public property | SourceAccessor | Gets or sets the component used by a IMappingSet to access the IValueReader used to read a value from a source object.
Public property | SourceValueTransformer | Gets or sets the component that transforms the source value before it is written to the target object.
Public property | TargetAccessor | Gets or sets the component used by a IMappingSet to access the IValueWriter used to write a value to a target object.
Top
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping.ApplyMappingRules Property

MappingApplyMappingRules Property

Gets the component that determines whether or not the source value should be written to the target object.

The IMappingSet must use this collection before attempting to apply the mapping. If the collection is empty, the mapping set should apply the mapping. If any of the mapping validators returns false, the mapping set should not apply the mapping.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IApplyMappingRule> ApplyMappingRules { get; }

Property Value

Type: ICollection IApplyMappingRule

Implements

IMappingApplyMappingRules
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping.Enabled Property

MappingEnabled Property

Gets or sets a value that indicates whether or not the mapping is enabled.

If , IMappingSet will skip this pipeline step.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Enabled { get; set; }

Property Value

Type: Boolean

Implements

IMappingEnabled
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping.Identifier Property

MappingIdentifier Property
Gets or sets the identifier for the mapping.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Identifier { get; set; }

Property Value

Type: String

Implements

IMappingIdentifier
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping.IgnoreNullValues Property

MappingIgnoreNullValues Property
Gets or sets a value that indicates whether or not the mapping is applied when the SourceAccessor reads a null value.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IgnoreNullValues { get; set; }

Property Value

Type: Boolean

Implements

IMappingIgnoreNullValues
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping.SourceAccessor Property

MappingSourceAccessor Property
Gets or sets the component used by a IMappingSet to access the IValueReader used to read a value from a source object.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueAccessor SourceAccessor { get; set; }

Property Value

Type: IValueAccessor

Implements

IMappingSourceAccessor
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping.SourceValueTransformer Property

MappingSourceValueTransformer Property

Gets or sets the component that transforms the source value before it is written to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueReader SourceValueTransformer { get; set; }

Property Value

Type: IValueReader

Implements

IMappingSourceValueTransformer
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Mapping.TargetAccessor Property

MappingTargetAccessor Property
Gets or sets the component used by a IMappingSet to access the IValueWriter used to write a value to a target object.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueAccessor TargetAccessor { get; set; }

Property Value

Type: IValueAccessor

Implements

IMappingTargetAccessor
See Also

Reference

Mapping Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


SequentialMappingSet Class

SequentialMappingSet Class
Runs a collection of mappings in a specific order.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.MappingsSequentialMappingSet

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class SequentialMappingSet : IMappingSet

The SequentialMappingSet type exposes the following members.

Constructors
 | Name | Description
Public method | SequentialMappingSet | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Mappings | Gets the mappings that will be applied.
Top
Methods
 | Name | Description
Public method | Run | Applies the mappings in the order they are read from Mappings. Mappings are applied one at a time. If one mapping fails this method returns , but the remaining mappings are applied.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Mappings Namespace


SequentialMappingSet Constructor

SequentialMappingSet Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public SequentialMappingSet()
See Also

Reference

SequentialMappingSet Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


SequentialMappingSet Properties

SequentialMappingSet Properties

The SequentialMappingSet type exposes the following members.

Properties
 | Name | Description
Public property | Mappings | Gets the mappings that will be applied.
Top
See Also

Reference

SequentialMappingSet Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


SequentialMappingSet.Mappings Property

SequentialMappingSetMappings Property
Gets the mappings that will be applied.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IMapping> Mappings { get; }

Property Value

Type: ICollection IMapping

Implements

IMappingSetMappings
See Also

Reference

SequentialMappingSet Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


SequentialMappingSet Methods

SequentialMappingSet Methods

The SequentialMappingSet type exposes the following members.

Methods
 | Name | Description
Public method | Run | Applies the mappings in the order they are read from Mappings. Mappings are applied one at a time. If one mapping fails this method returns , but the remaining mappings are applied.
Top
See Also

Reference

SequentialMappingSet Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


SequentialMappingSet.Run Method

SequentialMappingSetRun Method

Applies the mappings in the order they are read from Mappings.

Mappings are applied one at a time. If one mapping fails this method returns , but the remaining mappings are applied.

Namespace: Sitecore.DataExchange.DataAccess.Mappings
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool Run(
    MappingContext context
)

Parameters

context
Type: Sitecore.DataExchange.DataAccessMappingContext
The mapping context.

Return Value

Type: Boolean
if all of the mappings are applied successfully; otherwise .

Implements

IMappingSetRun(MappingContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

SequentialMappingSet Class
Sitecore.DataExchange.DataAccess.Mappings Namespace


Sitecore.DataExchange.DataAccess.Plugins Namespace

Sitecore.DataExchange.DataAccess.Plugins Namespace

This namespace contains implementations of IDataAccessPlugin.

Classes
 | Class | Description
Public class | MethodSettings | Settings used to invoke a method or to handle the results of a method being invoked.


MethodSettings Class

MethodSettings Class
Settings used to invoke a method or to handle the results of a method being invoked.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.PluginsMethodSettings

Namespace: Sitecore.DataExchange.DataAccess.Plugins
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MethodSettings : IDataAccessPlugin

The MethodSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MethodSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments that are used when the method is invoked.
Public property | MethodResult | Gets or sets the result of the method being invoked.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Plugins Namespace


MethodSettings Constructor

MethodSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Plugins
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MethodSettings()
See Also

Reference

MethodSettings Class
Sitecore.DataExchange.DataAccess.Plugins Namespace


MethodSettings Properties

MethodSettings Properties

The MethodSettings type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments that are used when the method is invoked.
Public property | MethodResult | Gets or sets the result of the method being invoked.
Top
See Also

Reference

MethodSettings Class
Sitecore.DataExchange.DataAccess.Plugins Namespace


MethodSettings.Arguments Property

MethodSettingsArguments Property
Gets the arguments that are used when the method is invoked.

Namespace: Sitecore.DataExchange.DataAccess.Plugins
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<Object> Arguments { get; }

Property Value

Type: ICollection Object
See Also

Reference

MethodSettings Class
Sitecore.DataExchange.DataAccess.Plugins Namespace


MethodSettings.MethodResult Property

MethodSettingsMethodResult Property
Gets or sets the result of the method being invoked.

Namespace: Sitecore.DataExchange.DataAccess.Plugins
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object MethodResult { get; set; }

Property Value

Type: Object
See Also

Reference

MethodSettings Class
Sitecore.DataExchange.DataAccess.Plugins Namespace


Sitecore.DataExchange.DataAccess.Readers Namespace

Sitecore.DataExchange.DataAccess.Readers Namespace

This namespace contains implementations of IValueReader.

Classes
 | Class | Description
Public class | ArrayValueReader | Reads the value at the specified position from an array.
 | ConstantValueReader | Provides the ability to read a specific value in all cases.
Public class | DateTimeValueReader | The DateTimeValueReader class
Public class | EnumValueReader | Provides the ability to read the value of a specific enum member in all cases. This reader can handle a source object that is a string (which is treated as the name of the member or the value of the member as a string), an int (which is treated as the value of the member), or a member of the enum (which results in the source object itself being read).
 | FallbackValueReader | Iterates a collection of value readers. The first one to return a non-null object (or non-default value) is the one whose value is used.
Public class | GuidValueReader | Reads a guid that is determined by converting a source object to a string and then converting the string to a guid.
 | IndexerPropertyValueReader | Provides the ability to read the value of a indexer property using an index.
Public class | IsoDateValueReader | Provides the ability to read a date/time in the ISO date format.
 | MethodValueReader | Reads the value from the source object using the specified method.
Public class | NowValueReader | Provides the ability to read the current date/time.
 | NullValueReader | Provides the ability to read in all cases.
 | PropertyValueReader | Reads the value from the source object using the specified property.
 | RawValueReader | Returns the source object in all cases. This type is used when the source object should be used directly. An example is when the data object read by the data reader is a string. If it is the string itself that is needed (as opposed to a substring or the string after it is transformed in some way), this value reader can be used.
 | SequentialValueReader | Reads a value by using a set of value readers. The source object is passed to the first reader. The result from the first reader is used as the source object for the second reader, and so on until a value reader returns null or all of the value readers are used.
Enumerations
 | Enumeration | Description
Public enumeration | IndexerPropertyKeyStatus | Describes whether or not an indexer property is set for a specific index. It is possible for a indexer property to be set to for a specific index. This value helps to differentiate between an index being set to null and the index not being used at all.


ArrayValueReader Class

ArrayValueReader Class
Reads the value at the specified position from an array.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersArrayValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ArrayValueReader : IValueReader

The ArrayValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayValueReader | Initializes a new value reader that reads a value at a specific position on the source object.
Top
Properties
 | Name | Description
Public property | Position | Gets the position of the value that will be read from the source object.
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether the specified source object is an array whose size is large enough to read.
Public method | Read | Reads a value from the array.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


ArrayValueReader Constructor

ArrayValueReader Constructor
Initializes a new value reader that reads a value at a specific position on the source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ArrayValueReader(
    int position
)

Parameters

position
Type: SystemInt32
The name of the method that is invoked when the reader is used.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | position is less than zero.
See Also

Reference

ArrayValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ArrayValueReader Properties

ArrayValueReader Properties

The ArrayValueReader type exposes the following members.

Properties
 | Name | Description
Public property | Position | Gets the position of the value that will be read from the source object.
Top
See Also

Reference

ArrayValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ArrayValueReader.Position Property

ArrayValueReaderPosition Property
Gets the position of the value that will be read from the source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int Position { get; }

Property Value

Type: Int32
See Also

Reference

ArrayValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ArrayValueReader Methods

ArrayValueReader Methods

The ArrayValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether the specified source object is an array whose size is large enough to read.
Public method | Read | Reads a value from the array.
Top
See Also

Reference

ArrayValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ArrayValueReader.CanRead Method

ArrayValueReaderCanRead Method
Indicates whether the specified source object is an array whose size is large enough to read.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value would be read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

ArrayValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ArrayValueReader.Read Method

ArrayValueReaderRead Method
Reads a value from the array.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents whether or not the value was read, and if it was read, the value itself.

Implements

IValueReaderRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

ArrayValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ConstantValueReader Class

ConstantValueReader Class
Provides the ability to read a specific value in all cases.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersConstantValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ConstantValueReader : IValueReader

The ConstantValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | ConstantValueReader | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Value | Gets the value that was passed in the constructor.
Top
Methods
 | Name | Description
Public method | CanRead | Since this value reader returns a specific value in all cases this method always returns .
Public method | Read | Returns the value specified by Value.
Top
Remarks

An example where this value reader is useful is if you are reading data from a specific CRM. You are reading a variety of values from the CRM: contact name, location and email address.

The CRM data will eventually be written to a contact in xDB, but contacts are read from other sources as well. Contact data also comes from a file that is uploaded nightly, as well as from an external database.

When you update a contact with CRM data you want to record that the contact was updated from the CRM. This value does not vary based on the data that is read. It is always the same: "CRM".

In this case you could use the ConstantValueReader to ensure the value "CRM" is always used.

Examples

The following code demonstrates how to use the component:

C#
Copy
var reader = new ConstantValueReader("---value---");
Assert.True(reader.CanRead(null, null).CanReadValue);
var rResult = reader.Read(null, null);
Assert.True(rResult.WasValueRead);
Assert.Equal("---value---", rResult.ReadValue);
Assert.Equal(reader.Value, rResult.ReadValue);
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


ConstantValueReader Constructor

ConstantValueReader Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ConstantValueReader(
    Object value
)

Parameters

value
Type: SystemObject
The value that will be returned when the reader is used.
See Also

Reference

ConstantValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ConstantValueReader Properties

ConstantValueReader Properties

The ConstantValueReader type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value that was passed in the constructor.
Top
See Also

Reference

ConstantValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ConstantValueReader.Value Property

ConstantValueReaderValue Property
Gets the value that was passed in the constructor.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object Value { get; }

Property Value

Type: Object
See Also

Reference

ConstantValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ConstantValueReader Methods

ConstantValueReader Methods

The ConstantValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Since this value reader returns a specific value in all cases this method always returns .
Public method | Read | Returns the value specified by Value.
Top
See Also

Reference

ConstantValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ConstantValueReader.CanRead Method

ConstantValueReaderCanRead Method
Since this value reader returns a specific value in all cases this method always returns .

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
This parameter is not used.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
See Also

Reference

ConstantValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


ConstantValueReader.Read Method

ConstantValueReaderRead Method
Returns the value specified by Value.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
This parameter is not used.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents that the value was read.

Implements

IValueReaderRead(Object, DataAccessContext)
See Also

Reference

ConstantValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


DateTimeValueReader Class

DateTimeValueReader Class
The DateTimeValueReader class
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersDateTimeValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DateTimeValueReader : IValueReader

The DateTimeValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeValueReader | Initializes a new instance of the DateTimeValueReader class
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether a value can be read from the specified source object.
Public method | Read | Reads the value from the specified source object.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


DateTimeValueReader Constructor

DateTimeValueReader Constructor
Initializes a new instance of the DateTimeValueReader class

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateTimeValueReader()
See Also

Reference

DateTimeValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


DateTimeValueReader Methods

DateTimeValueReader Methods

The DateTimeValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether a value can be read from the specified source object.
Public method | Read | Reads the value from the specified source object.
Top
See Also

Reference

DateTimeValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


DateTimeValueReader.CanRead Method

DateTimeValueReaderCanRead Method
Indicates whether a value can be read from the specified source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value would be read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
A value that indicates whether a value can be read or not.

Implements

IValueReaderCanRead(Object, DataAccessContext)
See Also

Reference

DateTimeValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


DateTimeValueReader.Read Method

DateTimeValueReaderRead Method
Reads the value from the specified source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents whether or not the value was read, and if it was read, the value itself.

Implements

IValueReaderRead(Object, DataAccessContext)
See Also

Reference

DateTimeValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


EnumValueReader Class

EnumValueReader Class

Provides the ability to read the value of a specific enum member in all cases.

This reader can handle a source object that is a string (which is treated as the name of the member or the value of the member as a string), an int (which is treated as the value of the member), or a member of the enum (which results in the source object itself being read).

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersEnumValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class EnumValueReader : IValueReader

The EnumValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | EnumValueReader | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | EnumType | Gets the enum type whose member is read.
Top
Methods
 | Name | Description
Public method | CanRead | Return if the specified value is a member of the enum.
Public method | Read | Returns the member of the enum specified by EnumType for the source.
Top
Remarks

An example where this value reader is useful is if you are synchronizing a CRM contact. The xDB contact must have the contact identification level set to "Known". This value reader can read the appropriate member from the enum used to represent the identification level.

See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


EnumValueReader Constructor

EnumValueReader Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public EnumValueReader(
    Type enumType
)

Parameters

enumType
Type: SystemType
The type of enum whose value is read.
See Also

Reference

EnumValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


EnumValueReader Properties

EnumValueReader Properties

The EnumValueReader type exposes the following members.

Properties
 | Name | Description
Public property | EnumType | Gets the enum type whose member is read.
Top
See Also

Reference

EnumValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


EnumValueReader.EnumType Property

EnumValueReaderEnumType Property
Gets the enum type whose member is read.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Type EnumType { get; }

Property Value

Type: Type
See Also

Reference

EnumValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


EnumValueReader Methods

EnumValueReader Methods

The EnumValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Return if the specified value is a member of the enum.
Public method | Read | Returns the member of the enum specified by EnumType for the source.
Top
See Also

Reference

EnumValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


EnumValueReader.CanRead Method

EnumValueReaderCanRead Method
Return if the specified value is a member of the enum.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
This parameter is not used.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether or not the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
See Also

Reference

EnumValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


EnumValueReader.Read Method

EnumValueReaderRead Method
Returns the member of the enum specified by EnumType for the source.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
This parameter is not used.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents that the source object converted to a member of the enum. If source cannot be converted into a member of the enum, the value is not read and is returned.

Implements

IValueReaderRead(Object, DataAccessContext)
See Also

Reference

EnumValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


FallbackValueReader Class

FallbackValueReader Class
Iterates a collection of value readers. The first one to return a non-null object (or non-default value) is the one whose value is used.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersFallbackValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class FallbackValueReader : IValueReader

The FallbackValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | FallbackValueReader | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Readers | Gets the collection of value readers that are used.
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether the value readers specified by Readers can read the value from the source object. This method only estimates whether the value can be read.
Public method | Read | Iterates the value readers in Readers, passing the source object to each until a non-null object (or non-default value) is read.
Top
Examples

The following code demonstrates how the component works:

C#
Copy
//
//read the work email, but if no work email address is set, read the home email address
var reader = new FallbackValueReader();
var context = new DataAccessContext();
var workEmail = new PropertyValueReader { PropertyName = "WorkEmail" };
var homeEmail = new PropertyValueReader { PropertyName = "HomeEmail" };
reader.Readers.Add(workEmail);
reader.Readers.Add(homeEmail);
var source = new { WorkEmail = (string)null, HomeEmail = "home@test.com" };
var expectedResult = "home@test.com";
Assert.Equals(expectedResult, reader.Read(source, context);
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


FallbackValueReader Constructor

FallbackValueReader Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public FallbackValueReader()
See Also

Reference

FallbackValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


FallbackValueReader Properties

FallbackValueReader Properties

The FallbackValueReader type exposes the following members.

Properties
 | Name | Description
Public property | Readers | Gets the collection of value readers that are used.
Top
See Also

Reference

FallbackValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


FallbackValueReader.Readers Property

FallbackValueReaderReaders Property
Gets the collection of value readers that are used.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IValueReader> Readers { get; }

Property Value

Type: ICollection IValueReader
See Also

Reference

FallbackValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


FallbackValueReader Methods

FallbackValueReader Methods

The FallbackValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether the value readers specified by Readers can read the value from the source object. This method only estimates whether the value can be read.
Public method | Read | Iterates the value readers in Readers, passing the source object to each until a non-null object (or non-default value) is read.
Top
See Also

Reference

FallbackValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


FallbackValueReader.CanRead Method

FallbackValueReaderCanRead Method

Indicates whether the value readers specified by Readers can read the value from the source object.

This method only estimates whether the value can be read.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is to be read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

FallbackValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


FallbackValueReader.Read Method

FallbackValueReaderRead Method

Iterates the value readers in Readers, passing the source object to each until a non-null object (or non-default value) is read.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents whether or not the value was read, and if it was read, the value itself.

Implements

IValueReaderRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

FallbackValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


GuidValueReader Class

GuidValueReader Class

Reads a guid that is determined by converting a source object to a string and then converting the string to a guid.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersGuidValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class GuidValueReader : IValueReader

The GuidValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | GuidValueReader | Initializes a new instance of the GuidValueReader class
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether the value reader can be used to read the specified source. Since this reader returns a value type that supports the TryParse method, this method always returns .
Public method | Read | Returns the source value converted to a string and the string converted to a guid.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


GuidValueReader Constructor

GuidValueReader Constructor
Initializes a new instance of the GuidValueReader class

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public GuidValueReader()
See Also

Reference

GuidValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


GuidValueReader Methods

GuidValueReader Methods

The GuidValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether the value reader can be used to read the specified source. Since this reader returns a value type that supports the TryParse method, this method always returns .
Public method | Read | Returns the source value converted to a string and the string converted to a guid.
Top
See Also

Reference

GuidValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


GuidValueReader.CanRead Method

GuidValueReaderCanRead Method
Indicates whether the value reader can be used to read the specified source. Since this reader returns a value type that supports the TryParse method, this method always returns .

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object the value reader will read from.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
See Also

Reference

GuidValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


GuidValueReader.Read Method

GuidValueReaderRead Method
Returns the source value converted to a string and the string converted to a guid.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object the value reader will read from.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The value reader context.

Return Value

Type: ReadResult
Object that represents the value was read.

Implements

IValueReaderRead(Object, DataAccessContext)
See Also

Reference

GuidValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyKeyStatus Enumeration

IndexerPropertyKeyStatus Enumeration
Describes whether or not an indexer property is set for a specific index. It is possible for a indexer property to be set to for a specific index. This value helps to differentiate between an index being set to null and the index not being used at all.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public enum IndexerPropertyKeyStatus
Members
Member name | Value | Description
Undetermined | 0 | It could not be determined whether or not the index is used.
IndexNotUsed | 1 | The index is not used.
IndexUsedNotNull | 2 | The index is used and the value associated with it is not null.
IndexUsedNull | 3 | The index is used and the value associated with it is null.
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader Class

IndexerPropertyValueReader Class

Provides the ability to read the value of a indexer property using an index.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersIndexerPropertyValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IndexerPropertyValueReader : IValueReader

The IndexerPropertyValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | IndexerPropertyValueReader | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ContainsIndexMethodNames | Gets the names of the methods that are used in order to attempt to determine whether or not an index is used.
Public property | Indexes | Gets the indexes that are used to access values from the source object.
Public property | ReflectionUtil | Gets or sets the component that provides access to reflection capabilities that the reader required.
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether or not the index that is specified on the value reader can be read from source. It determines whether source has an indexer property that is compatible with the index that is specified on the value reader. This method does not indicate whether or not a value is actually set on source. That logic is implemented in IsValueSet(Object, DataAccessContext).
Protected method | IsValueSet | Indicates whether the source object has a value set using the index specified by Indexes.
Public method | Read | Reads the value from an indexed property on the specified source object using the indexes specified by Indexes.
Top
Remarks

This base class does not provide a way to specify the index. This is because indexer properties may use any kind of object, as well as multiple objects, as a index.

It is the responsibility of the class that inherits from this type to provide a way to set the index. This is usually done via a constructor.

Examples

The following code demonstrates how the method works.

Example 1. Using the value reader with IDictionary<TKey, TValue>
Copy
var source = new Dictionary<string, int>();
source["nyc"] = 10000000;
//
//Gets the value for the index "nyc"
var reader = new IndexerPropertyValueReader("nyc");
reader.ContainsKeyMethodNames.Add("ContainsKey");
var context = new DataAccessContext();
var crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.True(crResult.IsGuess);
var rResult = reader.Read(source, context);
Assert.True(rResult.WasValueRead);
Assert.Equal(10000000, rResult.ReadValue);
Assert.True(source.ContainsKey("nyc"));
Assert.Equal(source["nyc"], rResult.ReadValue);
//
//Tries to get the value for the index "la", which has not been set
reader = new IndexerPropertyValueReader("la");
reader.ContainsKeyMethodNames.Add("ContainsKey");
crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.True(crResult.IsGuess);
rResult = reader.Read(source, context);
Assert.False(rResult.WasValueRead);
Assert.Null(rResult.ReadValue);
Assert.False(source.ContainsKey("la"));
Example 2. Custom class with a 2-parameter indexer property
Copy
public class PopulationInfo
{
    public int this[string city, string country]
    {
        get
        {
            var pair = new KeyValuePair<string, string>(city, country);
            return _data[pair];
        }
        set
        {
            var pair = new KeyValuePair<string, string>(city, country);
            _data[pair] = value;
        }
    }
    private Dictionary<KeyValuePair<string, string>, int> _data = new Dictionary<KeyValuePair<string, string>, int>();
    public bool ContainsKey(string city, string country)
    {
        var index = new KeyValuePair<string, string>(city, country);
        return (_data.ContainsKey(index));
    }
}
Example 2. Using the value reader with the custom class
Copy
var source = new PopulationInfo();
source["nyc", "usa"] = 10000000;
//
//Gets the value for the multi-value index "nyc" & "usa"
var reader = new IndexerPropertyValueReader("nyc", "usa");
reader.ContainsKeyMethodNames.Add("ContainsKey");
var context = new DataAccessContext();
var crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.True(crResult.IsGuess);
var rResult = reader.Read(source, context);
Assert.True(rResult.WasValueRead);
Assert.Equal(10000000, rResult.ReadValue);
Assert.Equal(source["nyc", "usa"], rResult.ReadValue);
//
//Tries to get the value for the multi-value index "la" & "usa", which has not been set
reader = new IndexerPropertyValueReader("la", "usa");
reader.ContainsKeyMethodNames.Add("ContainsKey");
crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.True(crResult.IsGuess);
rResult = reader.Read(source, context);
Assert.False(rResult.WasValueRead);
Assert.Null(rResult.ReadValue);
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader Constructor

IndexerPropertyValueReader Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IndexerPropertyValueReader(
    params Object[] indexes
)

Parameters

indexes
Type: SystemObject
The indexes that are used to access the indexer.
See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader Properties

IndexerPropertyValueReader Properties

The IndexerPropertyValueReader type exposes the following members.

Properties
 | Name | Description
Public property | ContainsIndexMethodNames | Gets the names of the methods that are used in order to attempt to determine whether or not an index is used.
Public property | Indexes | Gets the indexes that are used to access values from the source object.
Public property | ReflectionUtil | Gets or sets the component that provides access to reflection capabilities that the reader required.
Top
See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader.ContainsIndexMethodNames Property

IndexerPropertyValueReaderContainsIndexMethodNames Property
Gets the names of the methods that are used in order to attempt to determine whether or not an index is used.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<string> ContainsIndexMethodNames { get; }

Property Value

Type: ICollection String
See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader.Indexes Property

IndexerPropertyValueReaderIndexes Property
Gets the indexes that are used to access values from the source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object[] Indexes { get; }

Property Value

Type: Object
Remarks

In most cases an indexer uses a single property, but it is possible to have multi-value indexers. In order to support multi-value indexers this property is a collection.

See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader.ReflectionUtil Property

IndexerPropertyValueReaderReflectionUtil Property

Gets or sets the component that provides access to reflection capabilities that the reader required.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IReflectionUtil ReflectionUtil { get; set; }

Property Value

Type: IReflectionUtil
Remarks

This property is set in the constructor. The property setter can be used to specify an alternative object to use.

See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader Methods

IndexerPropertyValueReader Methods

The IndexerPropertyValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether or not the index that is specified on the value reader can be read from source. It determines whether source has an indexer property that is compatible with the index that is specified on the value reader. This method does not indicate whether or not a value is actually set on source. That logic is implemented in IsValueSet(Object, DataAccessContext).
Protected method | IsValueSet | Indicates whether the source object has a value set using the index specified by Indexes.
Public method | Read | Reads the value from an indexed property on the specified source object using the indexes specified by Indexes.
Top
See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader.CanRead Method

IndexerPropertyValueReaderCanRead Method

Indicates whether or not the index that is specified on the value reader can be read from source. It determines whether source has an indexer property that is compatible with the index that is specified on the value reader.

This method does not indicate whether or not a value is actually set on source. That logic is implemented in IsValueSet(Object, DataAccessContext).

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose indexer property would be read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader.IsValueSet Method

IndexerPropertyValueReaderIsValueSet Method

Indicates whether the source object has a value set using the index specified by Indexes.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual IndexerPropertyKeyStatus IsValueSet(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject

[Missing <param name="source"/> documentation for "M:Sitecore.DataExchange.DataAccess.Readers.IndexerPropertyValueReader.IsValueSet(System.Object,Sitecore.DataExchange.DataAccess.DataAccessContext)"]

context
Type: Sitecore.DataExchange.DataAccessDataAccessContext

[Missing <param name="context"/> documentation for "M:Sitecore.DataExchange.DataAccess.Readers.IndexerPropertyValueReader.IsValueSet(System.Object,Sitecore.DataExchange.DataAccess.DataAccessContext)"]

Return Value

Type: IndexerPropertyKeyStatus
IndexerPropertyKeyStatus that indicates whether a value is set on the source object.
Remarks

This method attempts to use the methods specified by ContainsIndexMethodNames to determine whether the value is set. The first method that is found is used.

If no methods are specified by ContainsIndexMethodNames or if none of the specified methods is found, the indexer property is read directly.

When the indexer property is read directly this method may not return a completely accurate value. For example, consider the SortedList type. While this class has a method ContainsKey(Object) that could be set on ContainsIndexMethodNames, it is not required. The indexer property can be used even if the index is not being used. The indexer property simply returns :

Indexer property being used directly
Copy
var list = new SortedList();
Assert.Null(list["key"]); //no exception is thrown
Assert.Equal(0, list.Count);

In this case the value is not set and attempting to read the value returns . But consider the following example:

Indexer property being used directly
Copy
var list = new SortedList();
list["key"] = null;
Assert.Null(list["key"]); //no exception is thrown
Assert.Equal(1, list.Count);

The index has been set on the list, but it is a null. This method does not make a distinction in this case. If is returned this method assumes that the index is not set on the source object.

See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IndexerPropertyValueReader.Read Method

IndexerPropertyValueReaderRead Method
Reads the value from an indexed property on the specified source object using the indexes specified by Indexes.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents whether or not the value was read, and if it was read, the value itself.

Implements

IValueReaderRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

IndexerPropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IsoDateValueReader Class

IsoDateValueReader Class
Provides the ability to read a date/time in the ISO date format.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersIsoDateValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IsoDateValueReader : IValueReader

The IsoDateValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | IsoDateValueReader | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ConvertToUtc | Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.
Public property | IncludeTicks | Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.
Top
Methods
 | Name | Description
Public method | CanRead | Since this value reader converts a date/time into ISO date format, this method indicates the source can be read if the source is a DateTime.
Public method | Read | Returns the source object as an ISO date.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


IsoDateValueReader Constructor

IsoDateValueReader Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IsoDateValueReader()
See Also

Reference

IsoDateValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IsoDateValueReader Properties

IsoDateValueReader Properties

The IsoDateValueReader type exposes the following members.

Properties
 | Name | Description
Public property | ConvertToUtc | Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.
Public property | IncludeTicks | Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.
Top
See Also

Reference

IsoDateValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IsoDateValueReader.ConvertToUtc Property

IsoDateValueReaderConvertToUtc Property
Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool ConvertToUtc { get; set; }

Property Value

Type: Boolean
See Also

Reference

IsoDateValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IsoDateValueReader.IncludeTicks Property

IsoDateValueReaderIncludeTicks Property
Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IncludeTicks { get; set; }

Property Value

Type: Boolean
See Also

Reference

IsoDateValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IsoDateValueReader Methods

IsoDateValueReader Methods

The IsoDateValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Since this value reader converts a date/time into ISO date format, this method indicates the source can be read if the source is a DateTime.
Public method | Read | Returns the source object as an ISO date.
Top
See Also

Reference

IsoDateValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IsoDateValueReader.CanRead Method

IsoDateValueReaderCanRead Method
Since this value reader converts a date/time into ISO date format, this method indicates the source can be read if the source is a DateTime.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object to be converted into ISO date format.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
See Also

Reference

IsoDateValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


IsoDateValueReader.Read Method

IsoDateValueReaderRead Method
Returns the source object as an ISO date.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object to convert into ISO date format.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents that the value was read.

Implements

IValueReaderRead(Object, DataAccessContext)
See Also

Reference

IsoDateValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader Class

MethodValueReader Class
Reads the value from the source object using the specified method.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersMethodValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MethodValueReader : IValueReader

The MethodValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | MethodValueReader | Initializes a new value reader that reads a value by invoking a method on the source object.
Top
Properties
 | Name | Description
Public property | DefaultArguments | Gets a collection of arguments that are passed to the method if no arguments are provided in the context. The primary use for this collection is to handle static arguments. For example, this can be used to provide a format parameter to a ToString method.
Public property | ExtensionMethodType | Gets or sets the type where the extension method is defined.
Public property | IsExtensionMethod | Indicates whether or not the method is an extension method.
Public property | MethodName | Gets the name of the method used to read a value from the source object.
Public property | ReflectionUtil | Gets or sets the component used to read the value from the source object. The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether the specified source object has a method with a signature that is compatible with the values specified by MethodName and Arguments.
Public method | Read | Returns the result of invoking the method specified by MethodName with the parameters specified by Arguments on the plugin.
Top
Examples

The following code demonstrates how the method works.

Using the value reader with a method with no parameters
Copy
//
//call the ToUpper() method
var source = "---value---";
var reader = new MethodValueReader("ToUpper");
var context = new DataAccessContext();
var settings = new MethodSettings();
context.Plugins.Add(settings);
var crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
var rResult = reader.Read(source, context);
Assert.True(rResult.WasValueRead);
Assert.NotEqual("---value---", rResult.ReadValue);
Assert.NotEqual(source, rResult.ReadValue);
Assert.Equal("---value---".ToUpper(), rResult.ReadValue);
Assert.Equal(source1.ToUpper(), rResult.ReadValue);
Using the value reader with a method with parameters
Copy
//
//call the ToString(string) method
var source = new DateTime(2016, 03, 13);
var reader = new MethodValueReader("ToString");
var context = new DataAccessContext();
var settings = new MethodSettings();
settings.Arguments.Add("yyyy/MM/dd");
context.Plugins.Add(settings);
var crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
var rResult = reader.Read(source, context);
Assert.True(rResult.WasValueRead);
Assert.Equal(source.ToString("yyyy/MM/dd"), rResult.ReadValue);
Using the value reader with a method with no return value (void)
Copy
//
//call the Clear() method
var source = new List<string>();
source.Add("---value---");
var reader = new MethodValueReader("Clear");
var context = new DataAccessContext();
var settings = new MethodSettings();
context.Plugins.Add(settings);
Assert.Equal(1, source.Count);
var crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
Assert.Equal(1, source.Count);
var rResult = reader.Read(source, context);
Assert.True(rResult.WasValueRead);
Assert.Null(rResult.ReadValue);
Assert.Equal(0, source.Count);
Using the value reader with a method that does not exist
Copy
//
//call the NoMethod() method, which does not exist
var source = "---value---";
var reader = new MethodValueReader("NoMethod");
var context = new DataAccessContext();
var settings = new MethodSettings();
context.Plugins.Add(settings);
var crResult = reader.CanRead(source, context);
Assert.False(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
var rResult = reader.Read(source, context);
Assert.False(rResult.WasValueRead);
Assert.Null(rResult.ReadValue);
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader Constructor

MethodValueReader Constructor
Initializes a new value reader that reads a value by invoking a method on the source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MethodValueReader(
    string methodName
)

Parameters

methodName
Type: SystemString
The name of the method that is invoked when the reader is used.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | methodName is null, empty or whitespace.
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader Properties

MethodValueReader Properties

The MethodValueReader type exposes the following members.

Properties
 | Name | Description
Public property | DefaultArguments | Gets a collection of arguments that are passed to the method if no arguments are provided in the context. The primary use for this collection is to handle static arguments. For example, this can be used to provide a format parameter to a ToString method.
Public property | ExtensionMethodType | Gets or sets the type where the extension method is defined.
Public property | IsExtensionMethod | Indicates whether or not the method is an extension method.
Public property | MethodName | Gets the name of the method used to read a value from the source object.
Public property | ReflectionUtil | Gets or sets the component used to read the value from the source object. The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.
Top
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader.DefaultArguments Property

MethodValueReaderDefaultArguments Property

Gets a collection of arguments that are passed to the method if no arguments are provided in the context.

The primary use for this collection is to handle static arguments. For example, this can be used to provide a format parameter to a ToString method.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<Object> DefaultArguments { get; }

Property Value

Type: ICollection Object
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader.ExtensionMethodType Property

MethodValueReaderExtensionMethodType Property
Gets or sets the type where the extension method is defined.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Type ExtensionMethodType { get; set; }

Property Value

Type: Type
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader.IsExtensionMethod Property

MethodValueReaderIsExtensionMethod Property
Indicates whether or not the method is an extension method.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IsExtensionMethod { get; set; }

Property Value

Type: Boolean
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader.MethodName Property

MethodValueReaderMethodName Property
Gets the name of the method used to read a value from the source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string MethodName { get; }

Property Value

Type: String
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader.ReflectionUtil Property

MethodValueReaderReflectionUtil Property

Gets or sets the component used to read the value from the source object.

The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IReflectionUtil ReflectionUtil { get; set; }

Property Value

Type: IReflectionUtil
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader Methods

MethodValueReader Methods

The MethodValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether the specified source object has a method with a signature that is compatible with the values specified by MethodName and Arguments.
Public method | Read | Returns the result of invoking the method specified by MethodName with the parameters specified by Arguments on the plugin.
Top
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader.CanRead Method

MethodValueReaderCanRead Method
Indicates whether the specified source object has a method with a signature that is compatible with the values specified by MethodName and Arguments.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value would be read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


MethodValueReader.Read Method

MethodValueReaderRead Method
Returns the result of invoking the method specified by MethodName with the parameters specified by Arguments on the plugin.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents whether or not the value was read, and if it was read, the value itself.

Implements

IValueReaderRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

MethodValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NowValueReader Class

NowValueReader Class
Provides the ability to read the current date/time.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersNowValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class NowValueReader : IValueReader

The NowValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | NowValueReader | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | UtcDate | Gets or sets the value that determines whether or not the date is returned as a UTC date/time.
Top
Methods
 | Name | Description
Public method | CanRead | Since this value reader returns the current date/time in all cases, this method always returns .
Public method | Read | Returns the current date/time.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


NowValueReader Constructor

NowValueReader Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public NowValueReader()
See Also

Reference

NowValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NowValueReader Properties

NowValueReader Properties

The NowValueReader type exposes the following members.

Properties
 | Name | Description
Public property | UtcDate | Gets or sets the value that determines whether or not the date is returned as a UTC date/time.
Top
See Also

Reference

NowValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NowValueReader.UtcDate Property

NowValueReaderUtcDate Property
Gets or sets the value that determines whether or not the date is returned as a UTC date/time.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool UtcDate { get; set; }

Property Value

Type: Boolean
See Also

Reference

NowValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NowValueReader Methods

NowValueReader Methods

The NowValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Since this value reader returns the current date/time in all cases, this method always returns .
Public method | Read | Returns the current date/time.
Top
See Also

Reference

NowValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NowValueReader.CanRead Method

NowValueReaderCanRead Method
Since this value reader returns the current date/time in all cases, this method always returns .

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
This parameter is not used.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
See Also

Reference

NowValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NowValueReader.Read Method

NowValueReaderRead Method
Returns the current date/time.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
This parameter is not used.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents that the value was read.

Implements

IValueReaderRead(Object, DataAccessContext)
See Also

Reference

NowValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NullValueReader Class

NullValueReader Class
Provides the ability to read in all cases.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersNullValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class NullValueReader : IValueReader

The NullValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | NullValueReader | Initializes a new instance of the NullValueReader class
Top
Methods
 | Name | Description
Public method | CanRead | Since this value reader returns a specific value in all cases this method always returns .
Public method | Read | Returns .
Top
Remarks

Consider a case where you are reading data from a CRM. You are reading those values in order to update a contact in xDB.

A consistent pattern is used to do this: you use a value reader to read the value from the CRM contact and you use a value writer to set the value on the xDB contact.

But imagine that during this process you want to clear a value that is set on the xDB contact. This means setting the value on the xDB to null. In order to set the value to null you have to have read a null value. This is how the pattern works.

In this case you could use the NullValueReader to ensure the value null is always used.

Examples

The following code demonstrates how the component works:

C#
Copy
//
//using the reader with a null source object
var reader = new NullValueReader();
var crResult = reader.CanRead(null, null);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
var rResult = reader.Read(null, null);
Assert.True(rResult.WasValueRead);
Assert.Null(rResult.ReadValue);
//
//using the reader with a null source object
reader = new NullValueReader();
crResult = reader.CanRead("---value---", null);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
rResult = reader.Read(null, null);
Assert.True(rResult.WasValueRead);
Assert.Null(rResult.ReadValue);
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


NullValueReader Constructor

NullValueReader Constructor
Initializes a new instance of the NullValueReader class

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public NullValueReader()
See Also

Reference

NullValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NullValueReader Methods

NullValueReader Methods

The NullValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Since this value reader returns a specific value in all cases this method always returns .
Public method | Read | Returns .
Top
See Also

Reference

NullValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NullValueReader.CanRead Method

NullValueReaderCanRead Method
Since this value reader returns a specific value in all cases this method always returns .

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
This parameter is not used.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
See Also

Reference

NullValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


NullValueReader.Read Method

NullValueReaderRead Method
Returns .

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
This parameter is not used.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents that null was read.

Implements

IValueReaderRead(Object, DataAccessContext)
See Also

Reference

NullValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


PropertyValueReader Class

PropertyValueReader Class
Reads the value from the source object using the specified property.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersPropertyValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PropertyValueReader : IValueReader

The PropertyValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyValueReader | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | PropertyName | Gets the name of the property used to read a value from the source object.
Public property | ReflectionUtil | Gets or sets the component used to read the value from the source object. The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether the specified source object has a readable property with the name specified by PropertyName.
Public method | Read | Returns the result of reading the property PropertyName from the source object.
Top
Examples

The following code demonstrates how the component works:

C#
Copy
var source = new KeyValuePair<string, int>("---value---", 100);
//
//read the value of the Index property
var reader = new PropertyValueReader("Index");
var context = new DataAccessContext();
var crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
var rResult = reader.Read(source, context);
Assert.True(rResult.WasValueRead);
Assert.Equal(source.Key, rResult.ReadValue);
Assert.Equal("---value---", rResult.ReadValue);
//
//read the value of the Value property
reader = new PropertyValueReader("Value");
crResult = reader.CanRead(source, context);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
rResult = reader.Read(source, context);
Assert.True(rResult.WasValueRead);
Assert.Equal(100, rResult.ReadValue);
Assert.Equal(source.Value, rResult.ReadValue);
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


PropertyValueReader Constructor

PropertyValueReader Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyValueReader(
    string propertyName
)

Parameters

propertyName
Type: SystemString
The name of the property that is read when the reader is used.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | propertyName is null, empty or whitespace.
See Also

Reference

PropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


PropertyValueReader Properties

PropertyValueReader Properties

The PropertyValueReader type exposes the following members.

Properties
 | Name | Description
Public property | PropertyName | Gets the name of the property used to read a value from the source object.
Public property | ReflectionUtil | Gets or sets the component used to read the value from the source object. The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.
Top
See Also

Reference

PropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


PropertyValueReader.PropertyName Property

PropertyValueReaderPropertyName Property
Gets the name of the property used to read a value from the source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string PropertyName { get; }

Property Value

Type: String
See Also

Reference

PropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


PropertyValueReader.ReflectionUtil Property

PropertyValueReaderReflectionUtil Property

Gets or sets the component used to read the value from the source object.

The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IReflectionUtil ReflectionUtil { get; set; }

Property Value

Type: IReflectionUtil
See Also

Reference

PropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


PropertyValueReader Methods

PropertyValueReader Methods

The PropertyValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether the specified source object has a readable property with the name specified by PropertyName.
Public method | Read | Returns the result of reading the property PropertyName from the source object.
Top
See Also

Reference

PropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


PropertyValueReader.CanRead Method

PropertyValueReaderCanRead Method
Indicates whether the specified source object has a readable property with the name specified by PropertyName.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value would be read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

PropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


PropertyValueReader.Read Method

PropertyValueReaderRead Method
Returns the result of reading the property PropertyName from the source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents whether or not the value was read, and if it was read, the value itself.

Implements

IValueReaderRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

PropertyValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


RawValueReader Class

RawValueReader Class

Returns the source object in all cases.

This type is used when the source object should be used directly. An example is when the data object read by the data reader is a string. If it is the string itself that is needed (as opposed to a substring or the string after it is transformed in some way), this value reader can be used.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersRawValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class RawValueReader : IValueReader

The RawValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | RawValueReader | Initializes a new instance of the RawValueReader class
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether the value reader can be used to read the specified source. Since this reader always returns the source, this method always returns .
Public method | Read | Returns the value read by the value reader. This method returns the source object.
Top
Examples

The following code demonstrates how the component works:

C#
Copy
//
//using the reader to read an object
var obj = new object();
var reader = new RawValueReader();
var crResult = reader.CanRead(obj, null);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
var rResult = reader.Read(obj, null);
Assert.True(rResult.WasValueRead);
Assert.Same(obj, rResult.ReadValue);
//
//using the reader to read an int value
crResult = reader.CanRead(100, null);
Assert.True(crResult.CanReadValue);
Assert.False(crResult.IsGuess);
rResult = reader.Read(100, null);
Assert.True(rResult.WasValueRead);
Assert.Equal(100, rResult.ReadValue);
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


RawValueReader Constructor

RawValueReader Constructor
Initializes a new instance of the RawValueReader class

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public RawValueReader()
See Also

Reference

RawValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


RawValueReader Methods

RawValueReader Methods

The RawValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether the value reader can be used to read the specified source. Since this reader always returns the source, this method always returns .
Public method | Read | Returns the value read by the value reader. This method returns the source object.
Top
See Also

Reference

RawValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


RawValueReader.CanRead Method

RawValueReaderCanRead Method
Indicates whether the value reader can be used to read the specified source. Since this reader always returns the source, this method always returns .

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object the value reader will read from.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
See Also

Reference

RawValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


RawValueReader.Read Method

RawValueReaderRead Method
Returns the value read by the value reader. This method returns the source object.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object the value reader will read from.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The value reader context.

Return Value

Type: ReadResult
Object that represents the value was read.

Implements

IValueReaderRead(Object, DataAccessContext)
See Also

Reference

RawValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


SequentialValueReader Class

SequentialValueReader Class
Reads a value by using a set of value readers. The source object is passed to the first reader. The result from the first reader is used as the source object for the second reader, and so on until a value reader returns null or all of the value readers are used.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReadersSequentialValueReader

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class SequentialValueReader : IValueReader

The SequentialValueReader type exposes the following members.

Constructors
 | Name | Description
Public method | SequentialValueReader | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Readers | Gets the collection of value readers that are used.
Top
Methods
 | Name | Description
Public method | CanRead | Indicates whether the value readers specified by Readers can read the value from the source object. The value readers specified by Readers are run in order. This method only estimates whether the value can be read.
Public method | Read | Passes the source object to the first value reader in Readers. The result of that read is passed as the source object to the next value reader. This repeats until one of the value readers returns or the last value reader is used.
Top
Examples

The following code demonstrates how the component works:

C#
Copy
//
//use 2 method value readers to call Trim() and pass the results to ToUpper()
var reader = new SequentialValueReader();
var context = new DataAccessContext();
var trim = new MethodValueReader { MethodName = "Trim" };
var toUpper = new MethodValueReader { MethodName = "ToUpper" };
reader.Readers.Add(trim);
reader.Readers.Add(toUpper);
var source = "   Sitecore is here   ";
var expectedResult = source.Trim().ToUpper();
Assert.Equals(expectedResult, reader.Read(source, context);
See Also

Reference

Sitecore.DataExchange.DataAccess.Readers Namespace


SequentialValueReader Constructor

SequentialValueReader Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public SequentialValueReader()
See Also

Reference

SequentialValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


SequentialValueReader Properties

SequentialValueReader Properties

The SequentialValueReader type exposes the following members.

Properties
 | Name | Description
Public property | Readers | Gets the collection of value readers that are used.
Top
See Also

Reference

SequentialValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


SequentialValueReader.Readers Property

SequentialValueReaderReaders Property
Gets the collection of value readers that are used.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IValueReader> Readers { get; }

Property Value

Type: ICollection IValueReader
See Also

Reference

SequentialValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


SequentialValueReader Methods

SequentialValueReader Methods

The SequentialValueReader type exposes the following members.

Methods
 | Name | Description
Public method | CanRead | Indicates whether the value readers specified by Readers can read the value from the source object. The value readers specified by Readers are run in order. This method only estimates whether the value can be read.
Public method | Read | Passes the source object to the first value reader in Readers. The result of that read is passed as the source object to the next value reader. This repeats until one of the value readers returns or the last value reader is used.
Top
See Also

Reference

SequentialValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


SequentialValueReader.CanRead Method

SequentialValueReaderCanRead Method

Indicates whether the value readers specified by Readers can read the value from the source object.

The value readers specified by Readers are run in order.

This method only estimates whether the value can be read.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual CanReadResult CanRead(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value would be passed to the first value reader.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanReadResult
Object that indicates whether the value can be read from the source.

Implements

IValueReaderCanRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

SequentialValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


SequentialValueReader.Read Method

SequentialValueReaderRead Method

Passes the source object to the first value reader in Readers. The result of that read is passed as the source object to the next value reader. This repeats until one of the value readers returns or the last value reader is used.

Namespace: Sitecore.DataExchange.DataAccess.Readers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual ReadResult Read(
    Object source,
    DataAccessContext context
)

Parameters

source
Type: SystemObject
The object whose value is read.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: ReadResult
Object that represents whether or not the value was read, and if it was read, the value itself.

Implements

IValueReaderRead(Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

SequentialValueReader Class
Sitecore.DataExchange.DataAccess.Readers Namespace


Sitecore.DataExchange.DataAccess.Reflection Namespace

Sitecore.DataExchange.DataAccess.Reflection Namespace

This namespace contains implementations of IReflectionUtil.

Classes
 | Class | Description
Public class | ReflectionUtil | Provides methods for working with reflection.


ReflectionUtil Class

ReflectionUtil Class
Provides methods for working with reflection.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.ReflectionReflectionUtil

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ReflectionUtil : IReflectionUtil

The ReflectionUtil type exposes the following members.

Constructors
 | Name | Description
Public method | ReflectionUtil | Initializes a new instance of the ReflectionUtil class
Top
Methods
 | Name | Description
Public method | CastT | Casts the object to the specified type.
Public method | GetDerivedTypes | Gets a collection of types that an object implements or inherits that match the specified generic type definition.
Public method | GetIndexerProperty | Gets the indexed property whose index type is compatible with the specified index.
Public method | GetMethod(String, Object, ICollectionObject) | Gets the specified method from the source object.
Public method | GetMethod(String, Type, ICollectionObject) | Gets the specified method from the specified type. This method is used for extension methods.
Public method | GetProperty(String, Object) | Gets the specified property from the source object.
Public method | GetProperty(String, Object, Object) | Gets the specified property from the source object if it can be set to the specified value.
Public method | IsProperDictionary | Indicates whether the source object is a dictionary whose key is compatible with the specified key and whose value can be set to the specified value.
Public method | IsTypeDerivedFrom | Indicates whether or not the object is derived from the specified generic type definition. Technically this method determines whether or not the object is type that implements or inherits from the specified generic type, and whether the generic type is compatible with the specified argument types. For example, this method can be used to determine whether an object is a list that can accept string values, even if the list is defined as a list of objects.
Public method | SetIndexerProperty | Sets the value on the source object using the index.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil Constructor

ReflectionUtil Constructor
Initializes a new instance of the ReflectionUtil class

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ReflectionUtil()
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil Methods

ReflectionUtil Methods

The ReflectionUtil type exposes the following members.

Methods
 | Name | Description
Public method | CastT | Casts the object to the specified type.
Public method | GetDerivedTypes | Gets a collection of types that an object implements or inherits that match the specified generic type definition.
Public method | GetIndexerProperty | Gets the indexed property whose index type is compatible with the specified index.
Public method | GetMethod(String, Object, ICollectionObject) | Gets the specified method from the source object.
Public method | GetMethod(String, Type, ICollectionObject) | Gets the specified method from the specified type. This method is used for extension methods.
Public method | GetProperty(String, Object) | Gets the specified property from the source object.
Public method | GetProperty(String, Object, Object) | Gets the specified property from the source object if it can be set to the specified value.
Public method | IsProperDictionary | Indicates whether the source object is a dictionary whose key is compatible with the specified key and whose value can be set to the specified value.
Public method | IsTypeDerivedFrom | Indicates whether or not the object is derived from the specified generic type definition. Technically this method determines whether or not the object is type that implements or inherits from the specified generic type, and whether the generic type is compatible with the specified argument types. For example, this method can be used to determine whether an object is a list that can accept string values, even if the list is defined as a list of objects.
Public method | SetIndexerProperty | Sets the value on the source object using the index.
Top
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.Cast(T) Method

ReflectionUtilCastT Method
Casts the object to the specified type.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T Cast<T>(
    Object source
)

Parameters

source
Type: SystemObject
Object that will be cast.

Type Parameters

T
Type to which the source object is cast.

Return Value

Type: T
The object if it could be cast; if the cast fails.

Implements

IReflectionUtilCastT(Object)
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.GetDerivedTypes Method

ReflectionUtilGetDerivedTypes Method
Gets a collection of types that an object implements or inherits that match the specified generic type definition.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<Type> GetDerivedTypes(
    Object obj,
    Type genericTypeDefinition
)

Parameters

obj
Type: SystemObject
The object to check.
genericTypeDefinition
Type: SystemType
The generic type definition to check.

Return Value

Type: IEnumerable Type
A collection of types that obj implements or inherits that are compatible with the type specified by genericTypeDefinition.

Implements

IReflectionUtilGetDerivedTypes(Object, Type)
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.GetIndexerProperty Method

ReflectionUtilGetIndexerProperty Method
Gets the indexed property whose index type is compatible with the specified index.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyInfo GetIndexerProperty(
    Object source,
    ICollection<Object> indexes
)

Parameters

source
Type: SystemObject
Object with the indexed property to get.
indexes
Type: System.Collections.GenericICollection Object
The source object has an indexed property whose type matches this object's type.

Return Value

Type: PropertyInfo
The property; if the property cannot be read for any reason or if no indexed property is compatible with the object specified by indexes.

Implements

IReflectionUtilGetIndexerProperty(Object, ICollectionObject)
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.GetMethod Method

ReflectionUtilGetMethod Method
Overload List
 | Name | Description
Public method | GetMethod(String, Object, ICollectionObject) | Gets the specified method from the source object.
Public method | GetMethod(String, Type, ICollectionObject) | Gets the specified method from the specified type. This method is used for extension methods.
Top
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.GetMethod Method (String, Object, ICollection(Object))

ReflectionUtilGetMethod Method (String, Object, ICollectionObject)
Gets the specified method from the source object.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MethodInfo GetMethod(
    string methodName,
    Object source,
    ICollection<Object> args
)

Parameters

methodName
Type: SystemString
Name of the method to get.
source
Type: SystemObject
Object with the method to get.
args
Type: System.Collections.GenericICollection Object
Arguments that would be passed to the method. This object is used to determine the appropriate method signature.

Return Value

Type: MethodInfo
The method; if the method cannot be read for any reason.

Implements

IReflectionUtilGetMethod(String, Object, ICollectionObject)
See Also

Reference

ReflectionUtil Class
GetMethod Overload
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.GetMethod Method (String, Type, ICollection(Object))

ReflectionUtilGetMethod Method (String, Type, ICollectionObject)
Gets the specified method from the specified type. This method is used for extension methods.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MethodInfo GetMethod(
    string methodName,
    Type type,
    ICollection<Object> args
)

Parameters

methodName
Type: SystemString
Name of the method to get.
type
Type: SystemType
Type with the method to get.
args
Type: System.Collections.GenericICollection Object
Arguments that would be passed to the method. This object is used to determine the appropriate method signature.

Return Value

Type: MethodInfo
The method; if the method cannot be read for any reason.

Implements

IReflectionUtilGetMethod(String, Type, ICollectionObject)
See Also

Reference

ReflectionUtil Class
GetMethod Overload
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.GetProperty Method

ReflectionUtilGetProperty Method
Overload List
 | Name | Description
Public method | GetProperty(String, Object) | Gets the specified property from the source object.
Public method | GetProperty(String, Object, Object) | Gets the specified property from the source object if it can be set to the specified value.
Top
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.GetProperty Method (String, Object)

ReflectionUtilGetProperty Method (String, Object)
Gets the specified property from the source object.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyInfo GetProperty(
    string propertyName,
    Object source
)

Parameters

propertyName
Type: SystemString
Name of the property to get.
source
Type: SystemObject
Object with the property to get.

Return Value

Type: PropertyInfo
The property; if the property cannot be read for any reason.

Implements

IReflectionUtilGetProperty(String, Object)
See Also

Reference

ReflectionUtil Class
GetProperty Overload
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.GetProperty Method (String, Object, Object)

ReflectionUtilGetProperty Method (String, Object, Object)
Gets the specified property from the source object if it can be set to the specified value.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyInfo GetProperty(
    string propertyName,
    Object source,
    Object value
)

Parameters

propertyName
Type: SystemString
Name of the property to get.
source
Type: SystemObject
Object with the property to get.
value
Type: SystemObject
Object that must be compatible with the property type.

Return Value

Type: PropertyInfo
The property; if the property cannot be read for any reason or if the property type is not compatible with the object specified by value.

Implements

IReflectionUtilGetProperty(String, Object, Object)
See Also

Reference

ReflectionUtil Class
GetProperty Overload
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.IsProperDictionary Method

ReflectionUtilIsProperDictionary Method
Indicates whether the source object is a dictionary whose key is compatible with the specified key and whose value can be set to the specified value.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IsProperDictionary(
    Object key,
    Object source,
    Object value
)

Parameters

key
Type: SystemObject
The source object is a dictionary that can have a key whose type matches this object's type.
source
Type: SystemObject
IDictionaryTKey, TValue object.
value
Type: SystemObject
This value can be added to the source object using the specified key.

Return Value

Type: Boolean
if the source object is a proper dictionary; otherwise .

Implements

IReflectionUtilIsProperDictionary(Object, Object, Object)
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.IsTypeDerivedFrom Method

ReflectionUtilIsTypeDerivedFrom Method

Indicates whether or not the object is derived from the specified generic type definition.

Technically this method determines whether or not the object is type that implements or inherits from the specified generic type, and whether the generic type is compatible with the specified argument types.

For example, this method can be used to determine whether an object is a list that can accept string values, even if the list is defined as a list of objects.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IsTypeDerivedFrom(
    Object obj,
    Type genericTypeDefinition,
    params Type[] args
)

Parameters

obj
Type: SystemObject
The object to check.
genericTypeDefinition
Type: SystemType
The generic type definition that the object may be derived from.
args
Type: SystemType
The generic type parameters for the generic type definition. If no values are provided the method determines whether or not the object is derived from the generic type definition without considering the generic parameter types.

Return Value

Type: Boolean
if the object is derived from a generic type that is compatible with the specified arguments (if provided); otherwise.

Implements

IReflectionUtilIsTypeDerivedFrom(Object, Type, Type)
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


ReflectionUtil.SetIndexerProperty Method

ReflectionUtilSetIndexerProperty Method
Sets the value on the source object using the index.

Namespace: Sitecore.DataExchange.DataAccess.Reflection
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool SetIndexerProperty(
    Object source,
    Object value,
    params Object[] indexes
)

Parameters

source
Type: SystemObject
Object with the indexed property to get.
value
Type: SystemObject
Value that is set on the source object using the specified index.
indexes
Type: SystemObject
The index used to add the specified value to the source object.

Return Value

Type: Boolean
if the property was set; otherwise .

Implements

IReflectionUtilSetIndexerProperty(Object, Object, Object)
See Also

Reference

ReflectionUtil Class
Sitecore.DataExchange.DataAccess.Reflection Namespace


Sitecore.DataExchange.DataAccess.Utilities Namespace

Sitecore.DataExchange.DataAccess.Utilities Namespace

This namespace contains utility classes.

Classes
 | Class | Description
Public class | IsoDateUtil | Provides the ability to convert to and from ISO date/time format, which Sitecore uses to store date/time values.


IsoDateUtil Class

IsoDateUtil Class

Provides the ability to convert to and from ISO date/time format, which Sitecore uses to store date/time values.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.UtilitiesIsoDateUtil

Namespace: Sitecore.DataExchange.DataAccess.Utilities
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IsoDateUtil

The IsoDateUtil type exposes the following members.

Constructors
 | Name | Description
Public method | IsoDateUtil | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ConvertToUtc | Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.
Public property | IncludeTicks | Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.
Top
Methods
 | Name | Description
Public method | Convert(DateTime) | Creates a new ISO date based on the specified DateTime. The properties IncludeTicks and ConvertToUtc control how the ISO date is generated.
Public method | Convert(String) | Creates a new DateTime object based on the specified ISO date.
Top
Remarks
This logic replicates logic from Sitecore.DateUtil. This logic is replicated in order to avoid having to referencing Sitecore.Kernel.dll.
See Also

Reference

Sitecore.DataExchange.DataAccess.Utilities Namespace


IsoDateUtil Constructor

IsoDateUtil Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Utilities
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IsoDateUtil()
See Also

Reference

IsoDateUtil Class
Sitecore.DataExchange.DataAccess.Utilities Namespace


IsoDateUtil Properties

IsoDateUtil Properties

The IsoDateUtil type exposes the following members.

Properties
 | Name | Description
Public property | ConvertToUtc | Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.
Public property | IncludeTicks | Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.
Top
See Also

Reference

IsoDateUtil Class
Sitecore.DataExchange.DataAccess.Utilities Namespace


IsoDateUtil.ConvertToUtc Property

IsoDateUtilConvertToUtc Property
Gets or sets the value that indicates whether or not the DateTime is converted to a UTC date before being converted to an ISO date.

Namespace: Sitecore.DataExchange.DataAccess.Utilities
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool ConvertToUtc { get; set; }

Property Value

Type: Boolean
See Also

Reference

IsoDateUtil Class
Sitecore.DataExchange.DataAccess.Utilities Namespace


IsoDateUtil.IncludeTicks Property

IsoDateUtilIncludeTicks Property
Gets or sets the value that indicates whether or not ticks are included when a DateTime is converted to an ISO date.

Namespace: Sitecore.DataExchange.DataAccess.Utilities
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IncludeTicks { get; set; }

Property Value

Type: Boolean
See Also

Reference

IsoDateUtil Class
Sitecore.DataExchange.DataAccess.Utilities Namespace


IsoDateUtil Methods

IsoDateUtil Methods
Methods
 | Name | Description
Public method | Convert(DateTime) | Creates a new ISO date based on the specified DateTime. The properties IncludeTicks and ConvertToUtc control how the ISO date is generated.
Public method | Convert(String) | Creates a new DateTime object based on the specified ISO date.
Top
See Also

Reference

IsoDateUtil Class
Sitecore.DataExchange.DataAccess.Utilities Namespace


IsoDateUtil.Convert Method

IsoDateUtilConvert Method
Overload List
 | Name | Description
Public method | Convert(DateTime) | Creates a new ISO date based on the specified DateTime. The properties IncludeTicks and ConvertToUtc control how the ISO date is generated.
Public method | Convert(String) | Creates a new DateTime object based on the specified ISO date.
Top
See Also

Reference

IsoDateUtil Class
Sitecore.DataExchange.DataAccess.Utilities Namespace


IsoDateUtil.Convert Method (DateTime)

IsoDateUtilConvert Method (DateTime)

Creates a new ISO date based on the specified DateTime.

The properties IncludeTicks and ConvertToUtc control how the ISO date is generated.

Namespace: Sitecore.DataExchange.DataAccess.Utilities
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Convert(
    DateTime source
)

Parameters

source
Type: SystemDateTime
The DateTime object to convert into an ISO date.

Return Value

Type: String
The new object
See Also

Reference

IsoDateUtil Class
Convert Overload
Sitecore.DataExchange.DataAccess.Utilities Namespace


IsoDateUtil.Convert Method (String)

IsoDateUtilConvert Method (String)
Creates a new DateTime object based on the specified ISO date.

Namespace: Sitecore.DataExchange.DataAccess.Utilities
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateTime Convert(
    string source
)

Parameters

source
Type: SystemString
An ISO date to convert into a DateTime.

Return Value

Type: DateTime
The new object
See Also

Reference

IsoDateUtil Class
Convert Overload
Sitecore.DataExchange.DataAccess.Utilities Namespace


Sitecore.DataExchange.DataAccess.Writers Namespace

Sitecore.DataExchange.DataAccess.Writers Namespace

This namespace contains implementations of IValueWriter.

Classes
Class Description
AppendValueWriter

Provides the ability to read a value from the target object using a IValueReader (called the source value) and then use an IValueAppender to add a value (called the target value) to the source value. If a IValueWriter is set, the target value is written using that component.

This type is used when you want to append the value on a target object. An example is a target object that represents a contact. The contact is a member of multiple marketing lists. The marketing lists the contact is a member of is exposed as a property on the contact. The property is a collection.

IValueAccessor is configured with a IValueReader that can read the collection of marketing lists from the target object. ValueAppender is set to a value appender that can add a value to the collection.

When this writer is used, two objects are passed to the writer: the target object and the target value. The value reader reads the source value. The writer then passes the source value and the target value to the value appender. The value appender appends the target value to the source value.

Public class ArrayValueWriter
Writes the value to the specified position in an array.
IndexerPropertyValueWriter
Base class that provides the ability to write the value of an indexed property.
MethodValueWriter
Writes the value to the target object using the specified method.
PropertyValueWriter
Writes the value to the target object using the specified property.
TargetReaderValueWriter
Reads a value from the target object using a IValueReader and uses that value as the target object for a IValueWriter.


AppendValueWriter Class

AppendValueWriter Class

Provides the ability to read a value from the target object using a IValueReader (called the source value) and then use an IValueAppender to add a value (called the target value) to the source value. If a IValueWriter is set, the target value is written using that component.

This type is used when you want to append the value on a target object. An example is a target object that represents a contact. The contact is a member of multiple marketing lists. The marketing lists the contact is a member of is exposed as a property on the contact. The property is a collection.

IValueAccessor is configured with a IValueReader that can read the collection of marketing lists from the target object. ValueAppender is set to a value appender that can add a value to the collection.

When this writer is used, two objects are passed to the writer: the target object and the target value. The value reader reads the source value. The writer then passes the source value and the target value to the value appender. The value appender appends the target value to the source value.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.WritersAppendValueWriter

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class AppendValueWriter : IValueWriter

The AppendValueWriter type exposes the following members.

Constructors
 | Name | Description
Public method | AppendValueWriter | Initializes a new instance of the AppendValueWriter class
Top
Properties
 | Name | Description
Public property | ValueAccessor | Gets or sets the component reads the source value from the target object and that writes the target value to the target object. Settings a value writer is not needed if the appender modifies a reference. For example, if the appender is used to update a list that was read from the object that needs to be updated, there is no reason to use a writer because the appender has done everything that is needed.
Public property | ValueAppender | Gets or sets the component that appends the specified value to the source value in order to determine the target value.
Top
Methods
 | Name | Description
Public method | CanWrite | Indicates whether the target value can be determines and if so whether the target value can be written to the target object. This method checks to ensure a IValueReader and a IValueWriter are set on ValueAccessor and that ValueAppender is set.
Public method | Write | Reads the source value from the target object, appends the value to the source value to create the target value and, if a writer is available, writes the target value to the target object.
Top
Examples

The following code demonstrates how the component works:

Custom class with a property to append
Copy
public class Person
{
    public Person()
    {
        this.Names = new List<string>();
    }
    public ICollection<string> Names { get; private set; }
}
Using the value writer to update the property
Copy
var accessor = new ValueAccessor
{
    ValueReader = new PropertyValueReader("Names"),
    ValueWriter = new PropertyValueWriter("Names")
};
var writer = new AppendValueWriter
{
    ValueAccessor = accessor,
    ValueAppender = new ListValueAppender()
};
var context = new DataAccessContext();
var person = new Person();
//
//add a name to the person's Names property
Assert.Equal(0, person.Names.Count);
var cwResult = writer.CanWrite(person, "---value1---", context);
Assert.True(cwResult.CanWriteValue);
var wResult = writer.Write(person, "---value1---", context);
Assert.True(wResult);
Assert.Equal(1, person.Names.Count);
Assert.True(person.Names.Contains("---value1---"));
//
//add another name to the person's Names property
wResult = writer.Write(person, "---value2---", context);
Assert.True(wResult);
Assert.Equal(2, person.Names.Count);
Assert.True(person.Names.Contains("---value1---"));
Assert.True(person.Names.Contains("---value2---"));
See Also

Reference

Sitecore.DataExchange.DataAccess.Writers Namespace


AppendValueWriter Constructor

AppendValueWriter Constructor
Initializes a new instance of the AppendValueWriter class

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public AppendValueWriter()
See Also

Reference

AppendValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


AppendValueWriter Properties

AppendValueWriter Properties

The AppendValueWriter type exposes the following members.

Properties
 | Name | Description
Public property | ValueAccessor | Gets or sets the component reads the source value from the target object and that writes the target value to the target object. Settings a value writer is not needed if the appender modifies a reference. For example, if the appender is used to update a list that was read from the object that needs to be updated, there is no reason to use a writer because the appender has done everything that is needed.
Public property | ValueAppender | Gets or sets the component that appends the specified value to the source value in order to determine the target value.
Top
See Also

Reference

AppendValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


AppendValueWriter.ValueAccessor Property

AppendValueWriterValueAccessor Property

Gets or sets the component reads the source value from the target object and that writes the target value to the target object.

Settings a value writer is not needed if the appender modifies a reference. For example, if the appender is used to update a list that was read from the object that needs to be updated, there is no reason to use a writer because the appender has done everything that is needed.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueAccessor ValueAccessor { get; set; }

Property Value

Type: IValueAccessor
See Also

Reference

AppendValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


AppendValueWriter.ValueAppender Property

AppendValueWriterValueAppender Property
Gets or sets the component that appends the specified value to the source value in order to determine the target value.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueAppender ValueAppender { get; set; }

Property Value

Type: IValueAppender
See Also

Reference

AppendValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


AppendValueWriter Methods

AppendValueWriter Methods

The AppendValueWriter type exposes the following members.

Methods
 | Name | Description
Public method | CanWrite | Indicates whether the target value can be determines and if so whether the target value can be written to the target object. This method checks to ensure a IValueReader and a IValueWriter are set on ValueAccessor and that ValueAppender is set.
Public method | Write | Reads the source value from the target object, appends the value to the source value to create the target value and, if a writer is available, writes the target value to the target object.
Top
See Also

Reference

AppendValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


AppendValueWriter.CanWrite Method

AppendValueWriterCanWrite Method

Indicates whether the target value can be determines and if so whether the target value can be written to the target object.

This method checks to ensure a IValueReader and a IValueWriter are set on ValueAccessor and that ValueAppender is set.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual CanWriteResult CanWrite(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The target object (the object with a value that would be read and appended).
value
Type: SystemObject
The object that would be appended to source value (which is the object read from the target object).
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanWriteResult
A value that indicates whether a value can be written or not.

Implements

IValueWriterCanWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

AppendValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


AppendValueWriter.Write Method

AppendValueWriterWrite Method

Reads the source value from the target object, appends the value to the source value to create the target value and, if a writer is available, writes the target value to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool Write(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The target object (the object with a value that is read and appended).
value
Type: SystemObject
The object that is appended to source value (which is the object read from the target object).
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: Boolean
if the value was written to the target object; otherwise .

Implements

IValueWriterWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

AppendValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


ArrayValueWriter Class

ArrayValueWriter Class
Writes the value to the specified position in an array.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.WritersArrayValueWriter

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ArrayValueWriter : IValueWriter

The ArrayValueWriter type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayValueWriter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Position | Gets the position in the array that the value that will be written to on the source object.
Top
Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified source object is an array whose size is large enough to write, and that the value type is compatible with the array.
Public method | Write | Returns the result of writing the value to the target object.
Top
See Also

Reference

Sitecore.DataExchange.DataAccess.Writers Namespace


ArrayValueWriter Constructor

ArrayValueWriter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ArrayValueWriter(
    int position
)

Parameters

position
Type: SystemInt32
The name of the property that is written when the writer is used.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | position is less than zero.
See Also

Reference

ArrayValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


ArrayValueWriter Properties

ArrayValueWriter Properties

The ArrayValueWriter type exposes the following members.

Properties
 | Name | Description
Public property | Position | Gets the position in the array that the value that will be written to on the source object.
Top
See Also

Reference

ArrayValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


ArrayValueWriter.Position Property

ArrayValueWriterPosition Property
Gets the position in the array that the value that will be written to on the source object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int Position { get; }

Property Value

Type: Int32
See Also

Reference

ArrayValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


ArrayValueWriter Methods

ArrayValueWriter Methods

The ArrayValueWriter type exposes the following members.

Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified source object is an array whose size is large enough to write, and that the value type is compatible with the array.
Public method | Write | Returns the result of writing the value to the target object.
Top
See Also

Reference

ArrayValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


ArrayValueWriter.CanWrite Method

ArrayValueWriterCanWrite Method
Indicates whether the specified source object is an array whose size is large enough to write, and that the value type is compatible with the array.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanWriteResult CanWrite(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object to which value would be written.
value
Type: SystemObject
The value that would be written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanWriteResult

Return Value

Type: CanWriteResult
A value that indicates whether a value can be written or not.

Implements

IValueWriterCanWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

ArrayValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


ArrayValueWriter.Write Method

ArrayValueWriterWrite Method
Returns the result of writing the value to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Write(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object to which value was written.
value
Type: SystemObject
The value that was written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: Boolean
if the value was written to the target; otherwise .

Implements

IValueWriterWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

ArrayValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


IndexerPropertyValueWriter Class

IndexerPropertyValueWriter Class
Base class that provides the ability to write the value of an indexed property.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.WritersIndexerPropertyValueWriter

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IndexerPropertyValueWriter : IValueWriter

The IndexerPropertyValueWriter type exposes the following members.

Constructors
 | Name | Description
Public method | IndexerPropertyValueWriter | Initializes a new value writer and sets the Indexes value to the specified index.
Top
Properties
 | Name | Description
Public property | Indexes | Gets the indexes that are used to write values to the target object.
Public property | ReflectionUtil | Gets or sets the component that provides access to reflection capabilities that the reader required.
Top
Methods
 | Name | Description
Public method | CanWrite | Indicates whether or not the index that is specified on the value writer can be write to target. It determines whether target has an indexer property that is compatible with the index that is specified on the value writer.
Public method | Write | Writes the value to an indexed property on the specified target object using the indexes specified by Indexes.
Top
Examples

The following code demonstrates how the component works:

Example 1. Using the value reader with IDictionary<TKey, TValue>
Copy
//
//Sets the value of the "nyc" index on a dictionary to 10000000.
var target = new Dictionary<string, int>();
var writer = new IndexerPropertyValueWriter("nyc");
var context = new DataAccessContext();
var cwResult = writer.CanWrite(target, 10000000, context);
Assert.True(cwResult.CanWriteValue);
Assert.True(cwResult.IsGuess);
Assert.False(target.ContainsKey("nyc"));
Assert.True(writer.Write(target, 10000000, context));
Assert.True(target.ContainsKey("nyc"));
Assert.Equal(10000000, target["nyc"]);
//
//Tries to set the value of the "la" index on a dictionary to a string when it expects an int.
writer = new IndexerPropertyValueWriter("la");
cwResult = writer.CanWrite(target, "---value---", context);
Assert.False(cwResult.CanWriteValue);
Assert.False(cwResult.IsGuess);
Assert.False(target.ContainsKey("la"));
Assert.False(writer.Write(target, "---value---", context));
Assert.False(target.ContainsKey("la"));
Example 2. Custom class with a 2-parameter indexer property
Copy
public class PopulationInfo
{
    public int this[string city, string country]
    {
        get
        {
            var pair = new KeyValuePair<string, string>(city, country);
            return _data[pair];
        }
        set
        {
            var pair = new KeyValuePair<string, string>(city, country);
            _data[pair] = value;
        }
    }
    private Dictionary<KeyValuePair<string, string>, int> _data = new Dictionary<KeyValuePair<string, string>, int>();
    public bool ContainsKey(string city, string country)
    {
        var index = new KeyValuePair<string, string>(city, country);
        return (_data.ContainsKey(index));
    }
}
Example 2. Using the value reader with the custom class
Copy
//
//Sets the value of the 2-value index "nyc" & "usa" on an object to 10000000.
var target = new PopulationInfo();
var writer = new IndexerPropertyValueWriter("nyc", "usa");
var context = new DataAccessContext();
var cwResult = writer.CanWrite(target, 10000000, context);
Assert.True(cwResult.CanWriteValue);
Assert.True(cwResult.IsGuess);
var wResult = writer.Write(target, 10000000, context);
Assert.True(target.ContainsKey("nyc", "usa"));
Assert.Equal(10000000, target["nyc", "usa"]);
//
//Tries to set the value of the 2-value index "la" & "use" to a string when it expects an int.
writer = new IndexerPropertyValueWriter("la", "usa");
cwResult = writer.CanWrite(target, "---value---", context);
Assert.False(cwResult.CanWriteValue);
Assert.False(cwResult.IsGuess);
wResult = writer.Write(target, "---value---", context);
Assert.False(target.ContainsKey("la", "usa"));
See Also

Reference

Sitecore.DataExchange.DataAccess.Writers Namespace


IndexerPropertyValueWriter Constructor

IndexerPropertyValueWriter Constructor
Initializes a new value writer and sets the Indexes value to the specified index.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IndexerPropertyValueWriter(
    params Object[] indexes
)

Parameters

indexes
Type: SystemObject
The indexes that are used to access the indexer.
See Also

Reference

IndexerPropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


IndexerPropertyValueWriter Properties

IndexerPropertyValueWriter Properties

The IndexerPropertyValueWriter type exposes the following members.

Properties
 | Name | Description
Public property | Indexes | Gets the indexes that are used to write values to the target object.
Public property | ReflectionUtil | Gets or sets the component that provides access to reflection capabilities that the reader required.
Top
See Also

Reference

IndexerPropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


IndexerPropertyValueWriter.Indexes Property

IndexerPropertyValueWriterIndexes Property
Gets the indexes that are used to write values to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object[] Indexes { get; }

Property Value

Type: Object
Remarks

In most cases an indexer uses a single property, but it is possible to have multi-value indexers. In order to support multi-value indexers this property is a collection.

See Also

Reference

IndexerPropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


IndexerPropertyValueWriter.ReflectionUtil Property

IndexerPropertyValueWriterReflectionUtil Property

Gets or sets the component that provides access to reflection capabilities that the reader required.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IReflectionUtil ReflectionUtil { get; set; }

Property Value

Type: IReflectionUtil
Remarks

This property is set in the constructor. The property setter can be used to specify an alternative object to use.

See Also

Reference

IndexerPropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


IndexerPropertyValueWriter Methods

IndexerPropertyValueWriter Methods

The IndexerPropertyValueWriter type exposes the following members.

Methods
 | Name | Description
Public method | CanWrite | Indicates whether or not the index that is specified on the value writer can be write to target. It determines whether target has an indexer property that is compatible with the index that is specified on the value writer.
Public method | Write | Writes the value to an indexed property on the specified target object using the indexes specified by Indexes.
Top
See Also

Reference

IndexerPropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


IndexerPropertyValueWriter.CanWrite Method

IndexerPropertyValueWriterCanWrite Method

Indicates whether or not the index that is specified on the value writer can be write to target. It determines whether target has an indexer property that is compatible with the index that is specified on the value writer.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual CanWriteResult CanWrite(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object whose indexer property would be written.
value
Type: SystemObject
The object that would be written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanWriteResult
Object that indicates whether the value can be written to the target.

Implements

IValueWriterCanWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

IndexerPropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


IndexerPropertyValueWriter.Write Method

IndexerPropertyValueWriterWrite Method
Writes the value to an indexed property on the specified target object using the indexes specified by Indexes.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool Write(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object whose value is written.
value
Type: SystemObject
The object that is written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: Boolean
if the value was written to the target object; otherwise .

Implements

IValueWriterWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

IndexerPropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


MethodValueWriter Class

MethodValueWriter Class
Writes the value to the target object using the specified method.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.WritersMethodValueWriter

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MethodValueWriter : IValueWriter

The MethodValueWriter type exposes the following members.

Constructors
 | Name | Description
Public method | MethodValueWriter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | MethodName | Gets the name of the method used to write a value to the target object.
Public property | ReflectionUtil | Gets or sets the component used to write the value to the target object. The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.
Top
Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified target object has a method with the name specified by MethodName. Arguments to the method are specified using a IDataAccessPlugin set on context.
Public method | Write | Calls the method with the name specified by MethodName and passes Arguments specified on a MethodSettings on context. The result of the method is set on MethodResult on context.
Top
Examples

The following code demonstrates how the component works:

Using the value writer with a method with no parameters
Copy
//
//Calls the ToUpper() method on the target object.
var target = "---value---";
var writer = new MethodValueWriter("ToUpper");
var context = new DataAccessContext();
var settings = new MethodSettings();
context.Plugins.Add(settings);
var cwResult = writer.CanWrite(target, null, context);
Assert.True(cwResult.CanWriteValue);
Assert.False(cwResult.IsGuess);
Assert.True(writer.Write(target, null, context));
Assert.Equal(target.ToUpper(), settings.MethodResult);
Using the value reader with a method with parameters
Copy
//
//Calls the ToString() method on the target object.
var target = new DateTime(2016, 03, 13);
var writer = new MethodValueWriter("ToString");
var context = new DataAccessContext();
var settings = new MethodSettings();
settings.Arguments.Add("yyyy/MM/dd");
context.Plugins.Add(settings);
var cwResult = writer.CanWrite(target, null, context);
Assert.True(cwResult.CanWriteValue);
Assert.False(cwResult.IsGuess);
Assert.True(writer.Write(target, null, context));
Assert.Equal(target.ToString("yyyy/MM/dd"), settings.MethodResult);
Using the value reader with a method with no return value (void)
Copy
//
//Calls the Clear() method on the target object.
var target = new List<string>();
target.Add("---value---");
var writer = new MethodValueWriter("Clear");
var context = new DataAccessContext();
var settings = new MethodSettings();
context.Plugins.Add(settings);
var cwResult = writer.CanWrite(target, null, context);
Assert.True(cwResult.CanWriteValue);
Assert.False(cwResult.IsGuess);
Assert.Equal(1, target.Count);
Assert.True(writer.Write(target, null, context));
Assert.Equal(0, target.Count);
Using the value reader with a method that does not exist
Copy
//
//Calls the NoMethod() method on the target object.
var target = "---value---";
var writer = new MethodValueWriter("NoMethod");
var context = new DataAccessContext();
var settings = new MethodSettings();
context.Plugins.Add(settings);
var cwResult = writer.CanWrite(target, null, context);
Assert.False(cwResult.CanWriteValue);
Assert.False(cwResult.IsGuess);
Assert.False(writer.Write(target, null, context));
See Also

Reference

Sitecore.DataExchange.DataAccess.Writers Namespace


MethodValueWriter Constructor

MethodValueWriter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MethodValueWriter(
    string methodName
)

Parameters

methodName
Type: SystemString
The name of the method that is called when the writer is used.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | methodName is null, empty or whitespace.
See Also

Reference

MethodValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


MethodValueWriter Properties

MethodValueWriter Properties

The MethodValueWriter type exposes the following members.

Properties
 | Name | Description
Public property | MethodName | Gets the name of the method used to write a value to the target object.
Public property | ReflectionUtil | Gets or sets the component used to write the value to the target object. The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.
Top
See Also

Reference

MethodValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


MethodValueWriter.MethodName Property

MethodValueWriterMethodName Property
Gets the name of the method used to write a value to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string MethodName { get; }

Property Value

Type: String
See Also

Reference

MethodValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


MethodValueWriter.ReflectionUtil Property

MethodValueWriterReflectionUtil Property

Gets or sets the component used to write the value to the target object.

The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IReflectionUtil ReflectionUtil { get; set; }

Property Value

Type: IReflectionUtil
See Also

Reference

MethodValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


MethodValueWriter Methods

MethodValueWriter Methods

The MethodValueWriter type exposes the following members.

Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified target object has a method with the name specified by MethodName. Arguments to the method are specified using a IDataAccessPlugin set on context.
Public method | Write | Calls the method with the name specified by MethodName and passes Arguments specified on a MethodSettings on context. The result of the method is set on MethodResult on context.
Top
See Also

Reference

MethodValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


MethodValueWriter.CanWrite Method

MethodValueWriterCanWrite Method
Indicates whether the specified target object has a method with the name specified by MethodName. Arguments to the method are specified using a IDataAccessPlugin set on context.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanWriteResult CanWrite(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object with the method that would be called.
value
Type: SystemObject
This parameter is not used by this implementation.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanWriteResult

Return Value

Type: CanWriteResult
A value that indicates whether a value can be read or not.

Implements

IValueWriterCanWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

MethodValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


MethodValueWriter.Write Method

MethodValueWriterWrite Method
Calls the method with the name specified by MethodName and passes Arguments specified on a MethodSettings on context. The result of the method is set on MethodResult on context.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Write(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object with the method that is called.
value
Type: SystemObject
This parameter is not used by this implementation.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: Boolean
if the method was invoked on the target; otherwise .

Implements

IValueWriterWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

MethodValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


PropertyValueWriter Class

PropertyValueWriter Class
Writes the value to the target object using the specified property.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.WritersPropertyValueWriter

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PropertyValueWriter : IValueWriter

The PropertyValueWriter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyValueWriter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | PropertyName | Gets the name of the property used to write a value to the target object.
Public property | ReflectionUtil | Gets or sets the component used to write the value to the target object. The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.
Top
Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified target object has a writable property with the name specified by PropertyName.
Public method | Write | Returns the result of writing the property PropertyName to the target object.
Top
Examples

The following code demonstrates how the component works:

C#
Copy
//
//Sets the value of the InnerXml property on a XmlDocument object.
var target = new XmlDocument();
var writer = new PropertyValueWriter("InnerXml");
var context = new DataAccessContext();
var cwResult = writer.CanWrite(target, "<test />", context);
Assert.True(cwResult.CanWriteValue);
Assert.False(cwResult.IsGuess);
Assert.Equal(string.Empty, target.InnerXml);
Assert.True(writer.Write(target, "<test />", context));
Assert.Equal("<test />", target.InnerXml);
See Also

Reference

Sitecore.DataExchange.DataAccess.Writers Namespace


PropertyValueWriter Constructor

PropertyValueWriter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyValueWriter(
    string propertyName
)

Parameters

propertyName
Type: SystemString
The name of the property that is written when the writer is used.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | propertyName is null, empty or whitespace.
See Also

Reference

PropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


PropertyValueWriter Properties

PropertyValueWriter Properties

The PropertyValueWriter type exposes the following members.

Properties
 | Name | Description
Public property | PropertyName | Gets the name of the property used to write a value to the target object.
Public property | ReflectionUtil | Gets or sets the component used to write the value to the target object. The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.
Top
See Also

Reference

PropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


PropertyValueWriter.PropertyName Property

PropertyValueWriterPropertyName Property
Gets the name of the property used to write a value to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string PropertyName { get; }

Property Value

Type: String
See Also

Reference

PropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


PropertyValueWriter.ReflectionUtil Property

PropertyValueWriterReflectionUtil Property

Gets or sets the component used to write the value to the target object.

The default constructor creates an instance and sets this property. This property only needs to be set if an alternate implementation is needed.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IReflectionUtil ReflectionUtil { get; set; }

Property Value

Type: IReflectionUtil
See Also

Reference

PropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


PropertyValueWriter Methods

PropertyValueWriter Methods

The PropertyValueWriter type exposes the following members.

Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified target object has a writable property with the name specified by PropertyName.
Public method | Write | Returns the result of writing the property PropertyName to the target object.
Top
See Also

Reference

PropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


PropertyValueWriter.CanWrite Method

PropertyValueWriterCanWrite Method
Indicates whether the specified target object has a writable property with the name specified by PropertyName.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CanWriteResult CanWrite(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object to which value would be written.
value
Type: SystemObject
The value that would be written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanWriteResult

Return Value

Type: CanWriteResult
A value that indicates whether a value can be read or not.

Implements

IValueWriterCanWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

PropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


PropertyValueWriter.Write Method

PropertyValueWriterWrite Method
Returns the result of writing the property PropertyName to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Write(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object to which value was written.
value
Type: SystemObject
The value that was written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: Boolean
if the value was written to the target; otherwise .

Implements

IValueWriterWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

PropertyValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


TargetReaderValueWriter Class

TargetReaderValueWriter Class
Reads a value from the target object using a IValueReader and uses that value as the target object for a IValueWriter.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DataAccess.WritersTargetReaderValueWriter

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class TargetReaderValueWriter : IValueWriter

The TargetReaderValueWriter type exposes the following members.

Constructors
 | Name | Description
Public method | TargetReaderValueWriter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ValueAccessor | Gets or sets the component that provides access to the IValueReader that is used to read a value from the target object (called the target value) and the IValueWriter that is used to write the target value to the target object.
Top
Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified value can be written to the target object.
Public method | Write | Writes the specified value to the target object.
Top
Examples

The following code demonstrates how the component works:

Custom class with properties that can be read from and written to
Copy
public class Person
{
    public Person Supervisor { get; set; }
    public bool HasBeenNotified { get; set; }
}
Using the value reader with the custom class
Copy
//
//Reads the employee's supervisor and sets the HasBeenNotified property on the supervisor to true.
var boss = new Person();
var employee = new Person
{
    Supervisor = boss
};
var accessor = new ValueAccessor
{
    ValueReader = new PropertyValueReader("Supervisor"),
    ValueWriter = new PropertyValueWriter("HasBeenNotified")
};
var writer = new TargetReaderValueWriter
{
    ValueAccess = accessor
};
var context = new DataAccessContext();
Assert.False(boss.HasBeenNotified);
var cwResult = writer.CanWrite(employee, true, context);
Assert.True(cwResult.CanWriteValue);
Assert.False(cwResult.IsGuess);
Assert.True(writer.Write(employee, true, context));
Assert.True(boss.HasBeenNotified);
See Also

Reference

Sitecore.DataExchange.DataAccess.Writers Namespace


TargetReaderValueWriter Constructor

TargetReaderValueWriter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public TargetReaderValueWriter()
See Also

Reference

TargetReaderValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


TargetReaderValueWriter Properties

TargetReaderValueWriter Properties

The TargetReaderValueWriter type exposes the following members.

Properties
 | Name | Description
Public property | ValueAccessor | Gets or sets the component that provides access to the IValueReader that is used to read a value from the target object (called the target value) and the IValueWriter that is used to write the target value to the target object.
Top
See Also

Reference

TargetReaderValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


TargetReaderValueWriter.ValueAccessor Property

TargetReaderValueWriterValueAccessor Property
Gets or sets the component that provides access to the IValueReader that is used to read a value from the target object (called the target value) and the IValueWriter that is used to write the target value to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueAccessor ValueAccessor { get; set; }

Property Value

Type: IValueAccessor
See Also

Reference

TargetReaderValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


TargetReaderValueWriter Methods

TargetReaderValueWriter Methods

The TargetReaderValueWriter type exposes the following members.

Methods
 | Name | Description
Public method | CanWrite | Indicates whether the specified value can be written to the target object.
Public method | Write | Writes the specified value to the target object.
Top
See Also

Reference

TargetReaderValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


TargetReaderValueWriter.CanWrite Method

TargetReaderValueWriterCanWrite Method
Indicates whether the specified value can be written to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual CanWriteResult CanWrite(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object that value would be written to.
value
Type: SystemObject
The object that would be written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: CanWriteResult
A value that indicates whether a value can be written or not.

Implements

IValueWriterCanWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

TargetReaderValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


TargetReaderValueWriter.Write Method

TargetReaderValueWriterWrite Method
Writes the specified value to the target object.

Namespace: Sitecore.DataExchange.DataAccess.Writers
Assembly: Sitecore.DataExchange.DataAccess (in Sitecore.DataExchange.DataAccess.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool Write(
    Object target,
    Object value,
    DataAccessContext context
)

Parameters

target
Type: SystemObject
The object that value is written to.
value
Type: SystemObject
The object that is written to target.
context
Type: Sitecore.DataExchange.DataAccessDataAccessContext
The context.

Return Value

Type: Boolean
if the value was written to the target object; otherwise .

Implements

IValueWriterWrite(Object, Object, DataAccessContext)
Exceptions
Exception | Condition
ArgumentNullException | context is null.
See Also

Reference

TargetReaderValueWriter Class
Sitecore.DataExchange.DataAccess.Writers Namespace


Sitecore.DataExchange.Diagnostics Namespace

Sitecore.DataExchange.Diagnostics Namespace

This namespace contains diagnostic components for the framework.

Classes
 | Class | Description
Public class | MessageCollection | Represents a collection of messages. This type is used as a light-weight logging mechanism for capturing information when a pipeline batch runs.
Interfaces
 | Interface | Description
Public interface | IRuntimeSummary | Provides access to information that describes what happened at runtime for a component.


IRuntimeSummary Interface

IRuntimeSummary Interface
Provides access to information that describes what happened at runtime for a component.

Namespace: Sitecore.DataExchange.Diagnostics
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IRuntimeSummary

The IRuntimeSummary type exposes the following members.

Properties
 | Name | Description
Public property | Messages | Gets an object used to store messages that describe what happened at runtime.
Top
See Also

Reference

Sitecore.DataExchange.Diagnostics Namespace


IRuntimeSummary Properties

IRuntimeSummary Properties

The IRuntimeSummary type exposes the following members.

Properties
 | Name | Description
Public property | Messages | Gets an object used to store messages that describe what happened at runtime.
Top
See Also

Reference

IRuntimeSummary Interface
Sitecore.DataExchange.Diagnostics Namespace


IRuntimeSummary.Messages Property

IRuntimeSummaryMessages Property
Gets an object used to store messages that describe what happened at runtime.

Namespace: Sitecore.DataExchange.Diagnostics
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
MessageCollection Messages { get; }

Property Value

Type: MessageCollection
See Also

Reference

IRuntimeSummary Interface
Sitecore.DataExchange.Diagnostics Namespace


MessageCollection Class

MessageCollection Class
Represents a collection of messages. This type is used as a light-weight logging mechanism for capturing information when a pipeline batch runs.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.DiagnosticsMessageCollection

Namespace: Sitecore.DataExchange.Diagnostics
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MessageCollection

The MessageCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MessageCollection | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Size | Gets the number of messages in the collection.
Top
Methods
 | Name | Description
Public method | Add(LogLevel, String) | Adds a message to the collection.
Public method | Add(LogLevel, String, Object) | Adds a message to the collection.
Public method | GetMessages | Gets the messages that have been written to the collection.
Top
See Also

Reference

Sitecore.DataExchange.Diagnostics Namespace


MessageCollection Constructor

MessageCollection Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Diagnostics
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MessageCollection()
See Also

Reference

MessageCollection Class
Sitecore.DataExchange.Diagnostics Namespace


MessageCollection Properties

MessageCollection Properties

The MessageCollection type exposes the following members.

Properties
 | Name | Description
Public property | Size | Gets the number of messages in the collection.
Top
See Also

Reference

MessageCollection Class
Sitecore.DataExchange.Diagnostics Namespace


MessageCollection.Size Property

MessageCollectionSize Property
Gets the number of messages in the collection.

Namespace: Sitecore.DataExchange.Diagnostics
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int Size { get; }

Property Value

Type: Int32
See Also

Reference

MessageCollection Class
Sitecore.DataExchange.Diagnostics Namespace


MessageCollection Methods

MessageCollection Methods

The MessageCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(LogLevel, String) | Adds a message to the collection.
Public method | Add(LogLevel, String, Object) | Adds a message to the collection.
Public method | GetMessages | Gets the messages that have been written to the collection.
Top
See Also

Reference

MessageCollection Class
Sitecore.DataExchange.Diagnostics Namespace


MessageCollection.Add Method

MessageCollectionAdd Method
Overload List
 | Name | Description
Public method | Add(LogLevel, String) | Adds a message to the collection.
Public method | Add(LogLevel, String, Object) | Adds a message to the collection.
Top
See Also

Reference

MessageCollection Class
Sitecore.DataExchange.Diagnostics Namespace


MessageCollection.Add Method (LogLevel, String)

MessageCollectionAdd Method (LogLevel, String)
Adds a message to the collection.

Namespace: Sitecore.DataExchange.Diagnostics
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Add(
    LogLevel logLevel,
    string message
)

Parameters

logLevel
Type: Sitecore.DataExchange.LoggersLogLevel
The log level for the message.
message
Type: SystemString
The message to add to the collection.
See Also

Reference

MessageCollection Class
Add Overload
Sitecore.DataExchange.Diagnostics Namespace


MessageCollection.Add Method (LogLevel, String, Object[])

MessageCollectionAdd Method (LogLevel, String, Object)
Adds a message to the collection.

Namespace: Sitecore.DataExchange.Diagnostics
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Add(
    LogLevel logLevel,
    string format,
    params Object[] args
)

Parameters

logLevel
Type: Sitecore.DataExchange.LoggersLogLevel
The log level for the message.
format
Type: SystemString
A composite format string.
args
Type: SystemObject
An object arracy that contains zero or more objects to format.
See Also

Reference

MessageCollection Class
Add Overload
Sitecore.DataExchange.Diagnostics Namespace


MessageCollection.GetMessages Method

MessageCollectionGetMessages Method
Gets the messages that have been written to the collection.

Namespace: Sitecore.DataExchange.Diagnostics
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<string> GetMessages()

Return Value

Type: IEnumerable String
The messages that have been written to the collection.
See Also

Reference

MessageCollection Class
Sitecore.DataExchange.Diagnostics Namespace


Sitecore.DataExchange.Extensions Namespace

Sitecore.DataExchange.Extensions Namespace

This namespace contains extension methods that are used by the framework.

Classes
 | Class | Description
Public class | DateTimeExtensions | Extension methods for the DateTime type.
Public class | EndpointExtensions | Extension methods for the Endpoint type.
Public class | ItemModelExtensions | Extension methods for the ItemModel type.
Public class | PipelineBatchExtensions | Extension methods for the PipelineBatch type.
Public class | PipelineContextExtensions | Extension methods for the PipelineContext type.
Public class | PipelineExtensions | Extension methods for the PipelineStep type.
Public class | PipelineStepExtensions | Extension methods for the PipelineStep type.
Public class | WorkQueueContextExtensions | Extension methods for the WorkQueueProcessorContext type.


DateTimeExtensions Class

DateTimeExtensions Class
Extension methods for the DateTime type.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ExtensionsDateTimeExtensions

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class DateTimeExtensions

The DateTimeExtensions type exposes the following members.

Methods
Name | Description
IsInRange | Determines whether a date is greater-than or equal startDate and less-than endDate.
Top
See Also

Reference

Sitecore.DataExchange.Extensions Namespace


DateTimeExtensions Methods

DateTimeExtensions Methods

The DateTimeExtensions type exposes the following members.

Methods
Name | Description
IsInRange | Determines whether a date is greater-than or equal startDate and less-than endDate.
Top
See Also

Reference

DateTimeExtensions Class
Sitecore.DataExchange.Extensions Namespace


DateTimeExtensions.IsInRange Method

DateTimeExtensionsIsInRange Method
Determines whether a date is greater-than or equal startDate and less-than endDate.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool IsInRange(
    this DateTime dateToCheck,
    DateTime startDate,
    DateTime endDate
)

Parameters

dateToCheck
Type: SystemDateTime
The date to check.
startDate
Type: SystemDateTime
The start date.
endDate
Type: SystemDateTime
The end date.

Return Value

Type: Boolean
if the date is within the date range; otherwise .

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
Sitecore.DataExchange.Extensions Namespace


EndpointExtensions Class

EndpointExtensions Class
Extension methods for the Endpoint type.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ExtensionsEndpointExtensions

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class EndpointExtensions

The EndpointExtensions type exposes the following members.

Methods
Name | Description
GetSitecoreItemSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
GetWorkQueueSettings | Gets the settings from the component.
HasSitecoreItemSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
HasWorkQueueSettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

Sitecore.DataExchange.Extensions Namespace


EndpointExtensions Methods

EndpointExtensions Methods

The EndpointExtensions type exposes the following members.

Methods
Name | Description
GetSitecoreItemSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
GetWorkQueueSettings | Gets the settings from the component.
HasSitecoreItemSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
HasWorkQueueSettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

EndpointExtensions Class
Sitecore.DataExchange.Extensions Namespace


EndpointExtensions.GetSitecoreItemSettings Method

EndpointExtensionsGetSitecoreItemSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static SitecoreItemSettings GetSitecoreItemSettings(
    this Endpoint endpoint
)

Parameters

endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
A Endpoint whose settings are retrieved.

Return Value

Type: SitecoreItemSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Endpoint. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointExtensions Class
Sitecore.DataExchange.Extensions Namespace


EndpointExtensions.GetTelemetryActivitySettings Method

EndpointExtensionsGetTelemetryActivitySettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static TelemetryActivitySettings GetTelemetryActivitySettings(
    this Endpoint endpoint
)

Parameters

endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
A Endpoint whose settings are retrieved.

Return Value

Type: TelemetryActivitySettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Endpoint. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointExtensions Class
Sitecore.DataExchange.Extensions Namespace


EndpointExtensions.GetWorkQueueSettings Method

EndpointExtensionsGetWorkQueueSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static WorkQueueSettings GetWorkQueueSettings(
    this Endpoint endpoint
)

Parameters

endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
A Endpoint whose settings are retrieved.

Return Value

Type: WorkQueueSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Endpoint. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointExtensions Class
Sitecore.DataExchange.Extensions Namespace


EndpointExtensions.HasSitecoreItemSettings Method

EndpointExtensionsHasSitecoreItemSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasSitecoreItemSettings(
    this Endpoint endpoint
)

Parameters

endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
A Endpoint which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Endpoint. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointExtensions Class
Sitecore.DataExchange.Extensions Namespace


EndpointExtensions.HasTelemetryActivitySettings Method

EndpointExtensionsHasTelemetryActivitySettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasTelemetryActivitySettings(
    this Endpoint endpoint
)

Parameters

endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
A Endpoint which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Endpoint. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointExtensions Class
Sitecore.DataExchange.Extensions Namespace


EndpointExtensions.HasWorkQueueSettings Method

EndpointExtensionsHasWorkQueueSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasWorkQueueSettings(
    this Endpoint endpoint
)

Parameters

endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
A Endpoint which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Endpoint. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointExtensions Class
Sitecore.DataExchange.Extensions Namespace


ItemModelExtensions Class

ItemModelExtensions Class
Extension methods for the ItemModel type.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ExtensionsItemModelExtensions

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class ItemModelExtensions

The ItemModelExtensions type exposes the following members.

Methods
Name | Description
GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type.
GetItemId | Gets the item ID from itemModel.
GetTemplateId | Gets the template ID from itemModel.
IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type.
Top
See Also

Reference

Sitecore.DataExchange.Extensions Namespace


ItemModelExtensions Methods

ItemModelExtensions Methods

The ItemModelExtensions type exposes the following members.

Methods
Name | Description
GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type.
GetItemId | Gets the item ID from itemModel.
GetTemplateId | Gets the template ID from itemModel.
IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type.
Top
See Also

Reference

ItemModelExtensions Class
Sitecore.DataExchange.Extensions Namespace


ItemModelExtensions.GetConverter(TTo) Method

ItemModelExtensionsGetConverterTTo Method
Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static IConverter<ItemModel, TTo> GetConverter<TTo>(
    this ItemModel itemModel,
    IItemModelRepository repository
)

Parameters

itemModel
Type: ItemModel
A ItemModel whose ID is retrieved.
repository
Type: Sitecore.DataExchange.RepositoriesIItemModelRepository
The component that is used to read ItemModel objects.

Type Parameters

TTo
The type to which itemModel should be converted into.

Return Value

Type: IConverter ItemModel, TTo
The converter for itemModel.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ItemModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ItemModelExtensions Class
Sitecore.DataExchange.Extensions Namespace


ItemModelExtensions.GetItemId Method

ItemModelExtensionsGetItemId Method
Gets the item ID from itemModel.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static Guid GetItemId(
    this ItemModel itemModel
)

Parameters

itemModel
Type: ItemModel
A ItemModel whose ID is retrieved.

Return Value

Type: Guid
The ID for itemModel.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ItemModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ItemModelExtensions Class
Sitecore.DataExchange.Extensions Namespace


ItemModelExtensions.GetTemplateId Method

ItemModelExtensionsGetTemplateId Method
Gets the template ID from itemModel.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static Guid GetTemplateId(
    this ItemModel itemModel
)

Parameters

itemModel
Type: ItemModel
A ItemModel whose template ID is retrieved.

Return Value

Type: Guid
The template ID for itemModel.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ItemModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ItemModelExtensions Class
Sitecore.DataExchange.Extensions Namespace


ItemModelExtensions.IsConvertible Method

ItemModelExtensionsIsConvertible Method
Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool IsConvertible(
    this ItemModel itemModel
)

Parameters

itemModel
Type: ItemModel
A ItemModel to check.

Return Value

Type: Boolean
The ID for itemModel.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ItemModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ItemModelExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions Class

PipelineBatchExtensions Class
Extension methods for the PipelineBatch type.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ExtensionsPipelineBatchExtensions

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class PipelineBatchExtensions

The PipelineBatchExtensions type exposes the following members.

Methods
Name | Description
GetPipelineBatchSummary | Gets the settings from the component.
GetProcessorSettings | Gets the settings from the component.
GetSitecoreItemSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
HasPipelineBatchSummary | Determines whether the settings have been assigned to the component.
HasProcessorSettings | Determines whether the settings have been assigned to the component.
HasSitecoreItemSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions Methods

PipelineBatchExtensions Methods

The PipelineBatchExtensions type exposes the following members.

Methods
Name | Description
GetPipelineBatchSummary | Gets the settings from the component.
GetProcessorSettings | Gets the settings from the component.
GetSitecoreItemSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
HasPipelineBatchSummary | Determines whether the settings have been assigned to the component.
HasProcessorSettings | Determines whether the settings have been assigned to the component.
HasSitecoreItemSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions.GetPipelineBatchSummary Method

PipelineBatchExtensionsGetPipelineBatchSummary Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static PipelineBatchSummary GetPipelineBatchSummary(
    this PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
A PipelineBatch whose settings are retrieved.

Return Value

Type: PipelineBatchSummary
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineBatch. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions.GetProcessorSettings Method

PipelineBatchExtensionsGetProcessorSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static PipelineStepSettings GetProcessorSettings(
    this PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
A PipelineBatch whose settings are retrieved.

Return Value

Type: PipelineStepSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineBatch. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions.GetSitecoreItemSettings Method

PipelineBatchExtensionsGetSitecoreItemSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static SitecoreItemSettings GetSitecoreItemSettings(
    this PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
A PipelineBatch whose settings are retrieved.

Return Value

Type: SitecoreItemSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineBatch. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions.GetTelemetryActivitySettings Method

PipelineBatchExtensionsGetTelemetryActivitySettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static TelemetryActivitySettings GetTelemetryActivitySettings(
    this PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
A PipelineBatch whose settings are retrieved.

Return Value

Type: TelemetryActivitySettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineBatch. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions.HasPipelineBatchSummary Method

PipelineBatchExtensionsHasPipelineBatchSummary Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasPipelineBatchSummary(
    this PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
A PipelineBatch which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineBatch. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions.HasProcessorSettings Method

PipelineBatchExtensionsHasProcessorSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasProcessorSettings(
    this PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
A PipelineBatch which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineBatch. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions.HasSitecoreItemSettings Method

PipelineBatchExtensionsHasSitecoreItemSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasSitecoreItemSettings(
    this PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
A PipelineBatch which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineBatch. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineBatchExtensions.HasTelemetryActivitySettings Method

PipelineBatchExtensionsHasTelemetryActivitySettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasTelemetryActivitySettings(
    this PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
A PipelineBatch which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineBatch. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineBatchExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions Class

PipelineContextExtensions Class
Extension methods for the PipelineContext type.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ExtensionsPipelineContextExtensions

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class PipelineContextExtensions

The PipelineContextExtensions type exposes the following members.

Methods
Name | Description
GetElevatedSecurityUserName | Gets the "elevated security user name" value from the pipeline batch set on the pipeline context. This value is set on a plugin on the pipeline batch. If this plugin is not found on the pipeline batch, the parent context for the pipeline context is checked.
GetIterableDataSettings | Gets the settings from the component.
GetParentPipelineContextSettings | Gets the settings from the component.
GetSynchronizationSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
HasIterableDataSettings | Determines whether the settings have been assigned to the component.
HasParentPipelineContextSettings | Determines whether the settings have been assigned to the component.
HasSynchronizationSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions Methods

PipelineContextExtensions Methods

The PipelineContextExtensions type exposes the following members.

Methods
Name | Description
GetElevatedSecurityUserName | Gets the "elevated security user name" value from the pipeline batch set on the pipeline context. This value is set on a plugin on the pipeline batch. If this plugin is not found on the pipeline batch, the parent context for the pipeline context is checked.
GetIterableDataSettings | Gets the settings from the component.
GetParentPipelineContextSettings | Gets the settings from the component.
GetSynchronizationSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
HasIterableDataSettings | Determines whether the settings have been assigned to the component.
HasParentPipelineContextSettings | Determines whether the settings have been assigned to the component.
HasSynchronizationSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.GetElevatedSecurityUserName Method

PipelineContextExtensionsGetElevatedSecurityUserName Method
Gets the "elevated security user name" value from the pipeline batch set on the pipeline context. This value is set on a plugin on the pipeline batch. If this plugin is not found on the pipeline batch, the parent context for the pipeline context is checked.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static string GetElevatedSecurityUserName(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext which may or may not have a user name specified.

Return Value

Type: String
The user name; if one is not found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.GetIterableDataSettings Method

PipelineContextExtensionsGetIterableDataSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static IterableDataSettings GetIterableDataSettings(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext whose settings are retrieved.

Return Value

Type: IterableDataSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.GetParentPipelineContextSettings Method

PipelineContextExtensionsGetParentPipelineContextSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static ParentPipelineContextSettings GetParentPipelineContextSettings(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext whose settings are retrieved.

Return Value

Type: ParentPipelineContextSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.GetSynchronizationSettings Method

PipelineContextExtensionsGetSynchronizationSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static SynchronizationSettings GetSynchronizationSettings(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext whose settings are retrieved.

Return Value

Type: SynchronizationSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.GetTelemetryActivitySettings Method

PipelineContextExtensionsGetTelemetryActivitySettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static TelemetryActivitySettings GetTelemetryActivitySettings(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext whose settings are retrieved.

Return Value

Type: TelemetryActivitySettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.HasIterableDataSettings Method

PipelineContextExtensionsHasIterableDataSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasIterableDataSettings(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.HasParentPipelineContextSettings Method

PipelineContextExtensionsHasParentPipelineContextSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasParentPipelineContextSettings(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.HasSynchronizationSettings Method

PipelineContextExtensionsHasSynchronizationSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasSynchronizationSettings(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineContextExtensions.HasTelemetryActivitySettings Method

PipelineContextExtensionsHasTelemetryActivitySettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasTelemetryActivitySettings(
    this PipelineContext pipelineContext
)

Parameters

pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
A PipelineContext which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineExtensions Class

PipelineExtensions Class
Extension methods for the PipelineStep type.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ExtensionsPipelineExtensions

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class PipelineExtensions

The PipelineExtensions type exposes the following members.

Methods
Name | Description
GetSitecoreItemSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
HasSitecoreItemSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

Sitecore.DataExchange.Extensions Namespace


PipelineExtensions Methods

PipelineExtensions Methods

The PipelineExtensions type exposes the following members.

Methods
Name | Description
GetSitecoreItemSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
HasSitecoreItemSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

PipelineExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineExtensions.GetSitecoreItemSettings Method

PipelineExtensionsGetSitecoreItemSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static SitecoreItemSettings GetSitecoreItemSettings(
    this Pipeline pipeline
)

Parameters

pipeline
Type: Sitecore.DataExchange.ModelsPipeline
A PipelineStep whose settings are retrieved.

Return Value

Type: SitecoreItemSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Pipeline. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineExtensions.GetTelemetryActivitySettings Method

PipelineExtensionsGetTelemetryActivitySettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static TelemetryActivitySettings GetTelemetryActivitySettings(
    this Pipeline pipeline
)

Parameters

pipeline
Type: Sitecore.DataExchange.ModelsPipeline
A PipelineStep whose settings are retrieved.

Return Value

Type: TelemetryActivitySettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Pipeline. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineExtensions.HasSitecoreItemSettings Method

PipelineExtensionsHasSitecoreItemSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasSitecoreItemSettings(
    this Pipeline pipeline
)

Parameters

pipeline
Type: Sitecore.DataExchange.ModelsPipeline
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Pipeline. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineExtensions.HasTelemetryActivitySettings Method

PipelineExtensionsHasTelemetryActivitySettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasTelemetryActivitySettings(
    this Pipeline pipeline
)

Parameters

pipeline
Type: Sitecore.DataExchange.ModelsPipeline
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Pipeline. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions Class

PipelineStepExtensions Class
Extension methods for the PipelineStep type.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ExtensionsPipelineStepExtensions

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class PipelineStepExtensions

The PipelineStepExtensions type exposes the following members.

Methods
Name | Description
GetEndpointSettings | Gets the settings from the component.
GetMappingSettings | Gets the settings from the component.
GetPipelinesSettings | Gets the settings from the component.
GetResolveIdentifierSettings | Gets the settings from the component.
GetResolveObjectSettings | Gets the settings from the component.
GetSitecoreItemSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
GetValueAccessSettings | Gets the settings from the component.
GetWorkQueueProcessorStepSettings | Gets the settings from the component.
HasEndpointSettings | Determines whether the settings have been assigned to the component.
HasMappingSettings | Determines whether the settings have been assigned to the component.
HasPipelinesSettings | Determines whether the settings have been assigned to the component.
HasResolveIdentifierSettings | Determines whether the settings have been assigned to the component.
HasResolveObjectSettings | Determines whether the settings have been assigned to the component.
HasSitecoreItemSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
HasValueAccessSettings | Determines whether the settings have been assigned to the component.
HasWorkQueueProcessorStepSettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions Methods

PipelineStepExtensions Methods

The PipelineStepExtensions type exposes the following members.

Methods
Name | Description
GetEndpointSettings | Gets the settings from the component.
GetMappingSettings | Gets the settings from the component.
GetPipelinesSettings | Gets the settings from the component.
GetResolveIdentifierSettings | Gets the settings from the component.
GetResolveObjectSettings | Gets the settings from the component.
GetSitecoreItemSettings | Gets the settings from the component.
GetTelemetryActivitySettings | Gets the settings from the component.
GetValueAccessSettings | Gets the settings from the component.
GetWorkQueueProcessorStepSettings | Gets the settings from the component.
HasEndpointSettings | Determines whether the settings have been assigned to the component.
HasMappingSettings | Determines whether the settings have been assigned to the component.
HasPipelinesSettings | Determines whether the settings have been assigned to the component.
HasResolveIdentifierSettings | Determines whether the settings have been assigned to the component.
HasResolveObjectSettings | Determines whether the settings have been assigned to the component.
HasSitecoreItemSettings | Determines whether the settings have been assigned to the component.
HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component.
HasValueAccessSettings | Determines whether the settings have been assigned to the component.
HasWorkQueueProcessorStepSettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetEndpointSettings Method

PipelineStepExtensionsGetEndpointSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static EndpointSettings GetEndpointSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: EndpointSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetMappingSettings Method

PipelineStepExtensionsGetMappingSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static MappingSettings GetMappingSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: MappingSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetPipelinesSettings Method

PipelineStepExtensionsGetPipelinesSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static PipelinesSettings GetPipelinesSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: PipelinesSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetResolveIdentifierSettings Method

PipelineStepExtensionsGetResolveIdentifierSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static ResolveIdentifierSettings GetResolveIdentifierSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: ResolveIdentifierSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetResolveObjectSettings Method

PipelineStepExtensionsGetResolveObjectSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static ResolveObjectSettings GetResolveObjectSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: ResolveObjectSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetSitecoreItemSettings Method

PipelineStepExtensionsGetSitecoreItemSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static SitecoreItemSettings GetSitecoreItemSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: SitecoreItemSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetTelemetryActivitySettings Method

PipelineStepExtensionsGetTelemetryActivitySettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static TelemetryActivitySettings GetTelemetryActivitySettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: TelemetryActivitySettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetValueAccessSettings Method

PipelineStepExtensionsGetValueAccessSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static ValueAccessSettings GetValueAccessSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: ValueAccessSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.GetWorkQueueProcessorStepSettings Method

PipelineStepExtensionsGetWorkQueueProcessorStepSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static WorkQueueProcessorStepSettings GetWorkQueueProcessorStepSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep whose settings are retrieved.

Return Value

Type: WorkQueueProcessorStepSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasEndpointSettings Method

PipelineStepExtensionsHasEndpointSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasEndpointSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasMappingSettings Method

PipelineStepExtensionsHasMappingSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasMappingSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasPipelinesSettings Method

PipelineStepExtensionsHasPipelinesSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasPipelinesSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasResolveIdentifierSettings Method

PipelineStepExtensionsHasResolveIdentifierSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasResolveIdentifierSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasResolveObjectSettings Method

PipelineStepExtensionsHasResolveObjectSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasResolveObjectSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasSitecoreItemSettings Method

PipelineStepExtensionsHasSitecoreItemSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasSitecoreItemSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasTelemetryActivitySettings Method

PipelineStepExtensionsHasTelemetryActivitySettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasTelemetryActivitySettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasValueAccessSettings Method

PipelineStepExtensionsHasValueAccessSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasValueAccessSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


PipelineStepExtensions.HasWorkQueueProcessorStepSettings Method

PipelineStepExtensionsHasWorkQueueProcessorStepSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasWorkQueueProcessorStepSettings(
    this PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
A PipelineStep which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PipelineStep. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PipelineStepExtensions Class
Sitecore.DataExchange.Extensions Namespace


WorkQueueContextExtensions Class

WorkQueueContextExtensions Class
Extension methods for the WorkQueueProcessorContext type.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ExtensionsWorkQueueContextExtensions

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class WorkQueueContextExtensions

The WorkQueueContextExtensions type exposes the following members.

Methods
Name | Description
GetParentPipelineContextSettings | Gets the settings from the component.
HasParentPipelineContextSettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

Sitecore.DataExchange.Extensions Namespace


WorkQueueContextExtensions Methods

WorkQueueContextExtensions Methods

The WorkQueueContextExtensions type exposes the following members.

Methods
Name | Description
GetParentPipelineContextSettings | Gets the settings from the component.
HasParentPipelineContextSettings | Determines whether the settings have been assigned to the component.
Top
See Also

Reference

WorkQueueContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


WorkQueueContextExtensions.GetParentPipelineContextSettings Method

WorkQueueContextExtensionsGetParentPipelineContextSettings Method
Gets the settings from the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static ParentPipelineContextSettings GetParentPipelineContextSettings(
    this WorkQueueProcessorContext pipeline
)

Parameters

pipeline
Type: Sitecore.DataExchange.ContextsWorkQueueProcessorContext
A WorkQueueProcessorContext whose settings are retrieved.

Return Value

Type: ParentPipelineContextSettings
The settings; if no settings are found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WorkQueueProcessorContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WorkQueueContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


WorkQueueContextExtensions.HasParentPipelineContextSettings Method

WorkQueueContextExtensionsHasParentPipelineContextSettings Method
Determines whether the settings have been assigned to the component.

Namespace: Sitecore.DataExchange.Extensions
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static bool HasParentPipelineContextSettings(
    this WorkQueueProcessorContext pipeline
)

Parameters

pipeline
Type: Sitecore.DataExchange.ContextsWorkQueueProcessorContext
A WorkQueueProcessorContext which may or may not have settings specified.

Return Value

Type: Boolean
if the component has settings specified; otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WorkQueueProcessorContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WorkQueueContextExtensions Class
Sitecore.DataExchange.Extensions Namespace


Sitecore.DataExchange.ItemModels.Endpoints Namespace

Sitecore.DataExchange.ItemModels.Endpoints Namespace

[Missing <summary> documentation for "N:Sitecore.DataExchange.ItemModels.Endpoints"]

Classes
 | Class | Description
Public class | WorkQueueEndpointItemModel | A Sitecore item that represents an endpoint that provides access to a IWorkQueue.


WorkQueueEndpointItemModel Class

WorkQueueEndpointItemModel Class
A Sitecore item that represents an endpoint that provides access to a IWorkQueue.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.ItemModels.EndpointsWorkQueueEndpointItemModel

Namespace: Sitecore.DataExchange.ItemModels.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class WorkQueueEndpointItemModel : ItemModel

The WorkQueueEndpointItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | WorkQueueEndpointItemModel | Initializes a new instance of the WorkQueueEndpointItemModel class
Top
Fields
Name | Description
QueueType | Field that represents the type that implements IWorkQueue.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.ItemModels.Endpoints Namespace


WorkQueueEndpointItemModel Constructor

WorkQueueEndpointItemModel Constructor
Initializes a new instance of the WorkQueueEndpointItemModel class

Namespace: Sitecore.DataExchange.ItemModels.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public WorkQueueEndpointItemModel()
See Also

Reference

WorkQueueEndpointItemModel Class
Sitecore.DataExchange.ItemModels.Endpoints Namespace


WorkQueueEndpointItemModel Methods

WorkQueueEndpointItemModel Methods

The WorkQueueEndpointItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

WorkQueueEndpointItemModel Class
Sitecore.DataExchange.ItemModels.Endpoints Namespace


WorkQueueEndpointItemModel Fields

WorkQueueEndpointItemModel Fields

The WorkQueueEndpointItemModel type exposes the following members.

Fields
Name | Description
QueueType | Field that represents the type that implements IWorkQueue.
Top
See Also

Reference

WorkQueueEndpointItemModel Class
Sitecore.DataExchange.ItemModels.Endpoints Namespace


WorkQueueEndpointItemModel.QueueType Field

WorkQueueEndpointItemModelQueueType Field
Field that represents the type that implements IWorkQueue.

Namespace: Sitecore.DataExchange.ItemModels.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string QueueType = "QueueType"

Field Value

Type: String
See Also

Reference

WorkQueueEndpointItemModel Class
Sitecore.DataExchange.ItemModels.Endpoints Namespace


Sitecore.DataExchange.Loggers Namespace

Sitecore.DataExchange.Loggers Namespace

This namespace contains loggers that are used by the framework.

Classes
 | Class | Description
Public class | PipelineBatchLogger | This logger writes to both the standard logger and to the pipeline batches summary plugin.
Enumerations
 | Enumeration | Description
Public enumeration | LogLevel | Represents the different log levels that are supported.


LogLevel Enumeration

LogLevel Enumeration
Represents the different log levels that are supported.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
[FlagsAttribute]
public enum LogLevel
Members
Member name | Value | Description
None | 0 | No messages are logged.
Debug | 1 | The greatest amount of detail is logged. This level of detail is used to debug problems.
Info | 2 | Informational messages are logged.
Warn | 4 | Potentially harmful situations are logged.
Error | 8 | Errors are logged.
Fatal | 16 | The least amount of detail is logged.
See Also

Reference

Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger Class

PipelineBatchLogger Class
This logger writes to both the standard logger and to the pipeline batches summary plugin.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.LoggersPipelineBatchLogger

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineBatchLogger : ILogger

The PipelineBatchLogger type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineBatchLogger | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | PipelineBatch | Gets the component whose activity is logged.
Top
Methods
 | Name | Description
Public method | Debug(String) | Writes a message to the log at the debug level.
Public method | Debug(String, Object) | Writes a message to the log at the debug level.
Public method | Error(String) | Writes a message to the log at the error level.
Public method | Error(String, Object) | Writes a message to the log at the error level.
Public method | Fatal(String) | Writes a message to the log at the fatal level.
Public method | Fatal(String, Object) | Writes a message to the log at the fatal level.
Public method | Info(String) | Writes a message to the log at the info level.
Public method | Info(String, Object) | Writes a message to the log at the info level.
Public method | Warn(String) | Writes a message to the log at the warn level.
Public method | Warn(String, Object) | Writes a message to the log at the warn level.
Protected method | WriteToSummary | Writes the specified message to the PipelineBatchSummary assigned to the PipelineBatch.
Top
See Also

Reference

Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger Constructor

PipelineBatchLogger Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatchLogger(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch

[Missing <param name="pipelineBatch"/> documentation for "M:Sitecore.DataExchange.Loggers.PipelineBatchLogger.#ctor(Sitecore.DataExchange.Models.PipelineBatch)"]

See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger Properties

PipelineBatchLogger Properties

The PipelineBatchLogger type exposes the following members.

Properties
 | Name | Description
Public property | PipelineBatch | Gets the component whose activity is logged.
Top
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.PipelineBatch Property

PipelineBatchLoggerPipelineBatch Property
Gets the component whose activity is logged.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatch PipelineBatch { get; }

Property Value

Type: PipelineBatch
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger Methods

PipelineBatchLogger Methods

The PipelineBatchLogger type exposes the following members.

Methods
 | Name | Description
Public method | Debug(String) | Writes a message to the log at the debug level.
Public method | Debug(String, Object) | Writes a message to the log at the debug level.
Public method | Error(String) | Writes a message to the log at the error level.
Public method | Error(String, Object) | Writes a message to the log at the error level.
Public method | Fatal(String) | Writes a message to the log at the fatal level.
Public method | Fatal(String, Object) | Writes a message to the log at the fatal level.
Public method | Info(String) | Writes a message to the log at the info level.
Public method | Info(String, Object) | Writes a message to the log at the info level.
Public method | Warn(String) | Writes a message to the log at the warn level.
Public method | Warn(String, Object) | Writes a message to the log at the warn level.
Protected method | WriteToSummary | Writes the specified message to the PipelineBatchSummary assigned to the PipelineBatch.
Top
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Debug Method

PipelineBatchLoggerDebug Method
Overload List
 | Name | Description
Public method | Debug(String) | Writes a message to the log at the debug level.
Public method | Debug(String, Object) | Writes a message to the log at the debug level.
Top
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Debug Method (String)

PipelineBatchLoggerDebug Method (String)
Writes a message to the log at the debug level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Debug(
    string message
)

Parameters

message
Type: SystemString
The message to write to the log.

Implements

ILogger.Debug(String)
See Also

Reference

PipelineBatchLogger Class
Debug Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Debug Method (String, Object[])

PipelineBatchLoggerDebug Method (String, Object)
Writes a message to the log at the debug level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Debug(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
A string that contains the message to write to the summary.
args
Type: SystemObject
An object array that contains zero or more objects to format.

Implements

ILogger.Debug(String, Object)
See Also

Reference

PipelineBatchLogger Class
Debug Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Error Method

PipelineBatchLoggerError Method
Overload List
 | Name | Description
Public method | Error(String) | Writes a message to the log at the error level.
Public method | Error(String, Object) | Writes a message to the log at the error level.
Top
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Error Method (String)

PipelineBatchLoggerError Method (String)
Writes a message to the log at the error level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Error(
    string message
)

Parameters

message
Type: SystemString
The message to write to the log.

Implements

ILogger.Error(String)
See Also

Reference

PipelineBatchLogger Class
Error Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Error Method (String, Object[])

PipelineBatchLoggerError Method (String, Object)
Writes a message to the log at the error level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Error(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
A string that contains the message to write to the summary.
args
Type: SystemObject
An object array that contains zero or more objects to format.

Implements

ILogger.Error(String, Object)
See Also

Reference

PipelineBatchLogger Class
Error Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Fatal Method

PipelineBatchLoggerFatal Method
Overload List
 | Name | Description
Public method | Fatal(String) | Writes a message to the log at the fatal level.
Public method | Fatal(String, Object) | Writes a message to the log at the fatal level.
Top
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Fatal Method (String)

PipelineBatchLoggerFatal Method (String)
Writes a message to the log at the fatal level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Fatal(
    string message
)

Parameters

message
Type: SystemString
The message to write to the log.

Implements

ILogger.Fatal(String)
See Also

Reference

PipelineBatchLogger Class
Fatal Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Fatal Method (String, Object[])

PipelineBatchLoggerFatal Method (String, Object)
Writes a message to the log at the fatal level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Fatal(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
A string that contains the message to write to the summary.
args
Type: SystemObject
An object array that contains zero or more objects to format.

Implements

ILogger.Fatal(String, Object)
See Also

Reference

PipelineBatchLogger Class
Fatal Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Info Method

PipelineBatchLoggerInfo Method
Overload List
 | Name | Description
Public method | Info(String) | Writes a message to the log at the info level.
Public method | Info(String, Object) | Writes a message to the log at the info level.
Top
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Info Method (String)

PipelineBatchLoggerInfo Method (String)
Writes a message to the log at the info level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Info(
    string message
)

Parameters

message
Type: SystemString
The message to write to the log.

Implements

ILogger.Info(String)
See Also

Reference

PipelineBatchLogger Class
Info Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Info Method (String, Object[])

PipelineBatchLoggerInfo Method (String, Object)
Writes a message to the log at the info level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Info(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
A string that contains the message to write to the summary.
args
Type: SystemObject
An object array that contains zero or more objects to format.

Implements

ILogger.Info(String, Object)
See Also

Reference

PipelineBatchLogger Class
Info Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Warn Method

PipelineBatchLoggerWarn Method
Overload List
 | Name | Description
Public method | Warn(String) | Writes a message to the log at the warn level.
Public method | Warn(String, Object) | Writes a message to the log at the warn level.
Top
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Warn Method (String)

PipelineBatchLoggerWarn Method (String)
Writes a message to the log at the warn level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Warn(
    string message
)

Parameters

message
Type: SystemString
The message to write to the log.

Implements

ILogger.Warn(String)
See Also

Reference

PipelineBatchLogger Class
Warn Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.Warn Method (String, Object[])

PipelineBatchLoggerWarn Method (String, Object)
Writes a message to the log at the warn level.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Warn(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
A string that contains the message to write to the summary.
args
Type: SystemObject
An object array that contains zero or more objects to format.

Implements

ILogger.Warn(String, Object)
See Also

Reference

PipelineBatchLogger Class
Warn Overload
Sitecore.DataExchange.Loggers Namespace


PipelineBatchLogger.WriteToSummary Method

PipelineBatchLoggerWriteToSummary Method
Writes the specified message to the PipelineBatchSummary assigned to the PipelineBatch.

Namespace: Sitecore.DataExchange.Loggers
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void WriteToSummary(
    LogLevel logLevel,
    string messageFormat,
    params Object[] args
)

Parameters

logLevel
Type: Sitecore.DataExchange.LoggersLogLevel
The log level for the message.
messageFormat
Type: SystemString
A string that contains the message to write to the summary.
args
Type: SystemObject
An object array that contains zero or more objects to format.
See Also

Reference

PipelineBatchLogger Class
Sitecore.DataExchange.Loggers Namespace


Sitecore.DataExchange.Models Namespace

Sitecore.DataExchange.Models Namespace

This namespace contains models that represent framework components.

Classes
 | Class | Description
Public class | Endpoint | Represents a system that data can be read from and/or written to.
Public class | Pipeline | Represents a collection of PipelineStep objects that can be run using a IPipelineProcessor.
Public class | PipelineBatch | Represents the ability to run Pipeline objects using a IPipelineBatchProcessor.
Public class | PipelineStep | Represents a step in a Pipeline that is run using a IPipelineStepProcessor.
Public class | Tenant | Represents a grouping of related settings that present a single tenant, organization, brand, etc.


Endpoint Class

Endpoint Class
Represents a system that data can be read from and/or written to.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ModelsEndpoint

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class Endpoint : IHasPlugins

The Endpoint type exposes the following members.

Constructors
 | Name | Description
Public method | Endpoint | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the endpoint.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.
Top
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetSitecoreItemSettings | Gets the settings from the component. (Defined by EndpointExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by EndpointExtensions.)
Public Extension Method | GetWorkQueueSettings | Gets the settings from the component. (Defined by EndpointExtensions.)
Public Extension Method | HasSitecoreItemSettings | Determines whether the settings have been assigned to the component. (Defined by EndpointExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by EndpointExtensions.)
Public Extension Method | HasWorkQueueSettings | Determines whether the settings have been assigned to the component. (Defined by EndpointExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models Namespace


Endpoint Constructor

Endpoint Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Endpoint()
See Also

Reference

Endpoint Class
Sitecore.DataExchange.Models Namespace


Endpoint Properties

Endpoint Properties

The Endpoint type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the endpoint.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.
Top
See Also

Reference

Endpoint Class
Sitecore.DataExchange.Models Namespace


Endpoint.Name Property

EndpointName Property
Gets or sets the name of the endpoint.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Endpoint Class
Sitecore.DataExchange.Models Namespace


Endpoint.Plugins Property

EndpointPlugins Property
Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin

Implements

IHasPluginsPlugins
See Also

Reference

Endpoint Class
Sitecore.DataExchange.Models Namespace


Endpoint Methods

Endpoint Methods

The Endpoint type exposes the following members.

Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetSitecoreItemSettings | Gets the settings from the component. (Defined by EndpointExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by EndpointExtensions.)
Public Extension Method | GetWorkQueueSettings | Gets the settings from the component. (Defined by EndpointExtensions.)
Public Extension Method | HasSitecoreItemSettings | Determines whether the settings have been assigned to the component. (Defined by EndpointExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by EndpointExtensions.)
Public Extension Method | HasWorkQueueSettings | Determines whether the settings have been assigned to the component. (Defined by EndpointExtensions.)
Top
See Also

Reference

Endpoint Class
Sitecore.DataExchange.Models Namespace


Endpoint.GetPlugin Method

EndpointGetPlugin Method
Overload List
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

Endpoint Class
Sitecore.DataExchange.Models Namespace


Endpoint.GetPlugin(T) Method

EndpointGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.

Implements

IHasPluginsGetPluginT
See Also

Reference

Endpoint Class
GetPlugin Overload
Sitecore.DataExchange.Models Namespace


Endpoint.GetPlugin Method (Type)

EndpointGetPlugin Method (Type)
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object GetPlugin(
    Type type
)

Parameters

type
Type: SystemType
The type of the plugin to get.

Return Value

Type: Object
If a plugin of the specified type is set, the plugin; otherwise .

Implements

IHasPluginsGetPlugin(Type)
See Also

Reference

Endpoint Class
GetPlugin Overload
Sitecore.DataExchange.Models Namespace


Pipeline Class

Pipeline Class
Represents a collection of PipelineStep objects that can be run using a IPipelineProcessor.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ModelsPipeline

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class Pipeline : IHasPlugins

The Pipeline type exposes the following members.

Constructors
 | Name | Description
Public method | Pipeline | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not the pipeline is enabled. If , PipelineProcessor will not process this pipeline.
Public property | Name | Gets or sets the name of the pipeline.
Public property | PipelineProcessor | Gets or sets the processor that is used to run the pipeline steps identified by PipelineSteps.
Public property | PipelineSteps | Gets the collection of pipeline steps that make up the pipeline.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineProcessor to know how to use any plugins that are assigned.
Top
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetSitecoreItemSettings | Gets the settings from the component. (Defined by PipelineExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by PipelineExtensions.)
Public Extension Method | HasSitecoreItemSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by PipelineExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models Namespace


Pipeline Constructor

Pipeline Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Pipeline()
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline Properties

Pipeline Properties

The Pipeline type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not the pipeline is enabled. If , PipelineProcessor will not process this pipeline.
Public property | Name | Gets or sets the name of the pipeline.
Public property | PipelineProcessor | Gets or sets the processor that is used to run the pipeline steps identified by PipelineSteps.
Public property | PipelineSteps | Gets the collection of pipeline steps that make up the pipeline.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineProcessor to know how to use any plugins that are assigned.
Top
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline.Enabled Property

PipelineEnabled Property

Gets or sets a value that indicates whether or not the pipeline is enabled.

If , PipelineProcessor will not process this pipeline.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Enabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline.Name Property

PipelineName Property
Gets or sets the name of the pipeline.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline.PipelineProcessor Property

PipelinePipelineProcessor Property
Gets or sets the processor that is used to run the pipeline steps identified by PipelineSteps.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IPipelineProcessor PipelineProcessor { get; set; }

Property Value

Type: IPipelineProcessor
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline.PipelineSteps Property

PipelinePipelineSteps Property
Gets the collection of pipeline steps that make up the pipeline.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<PipelineStep> PipelineSteps { get; }

Property Value

Type: ICollection PipelineStep
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline.Plugins Property

PipelinePlugins Property

Gets the collection of plugins assigned to this component.

These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineProcessor to know how to use any plugins that are assigned.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin

Implements

IHasPluginsPlugins
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline Methods

Pipeline Methods

The Pipeline type exposes the following members.

Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetSitecoreItemSettings | Gets the settings from the component. (Defined by PipelineExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by PipelineExtensions.)
Public Extension Method | HasSitecoreItemSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by PipelineExtensions.)
Top
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline.GetPlugin Method

PipelineGetPlugin Method
Overload List
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

Pipeline Class
Sitecore.DataExchange.Models Namespace


Pipeline.GetPlugin(T) Method

PipelineGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.

Implements

IHasPluginsGetPluginT
See Also

Reference

Pipeline Class
GetPlugin Overload
Sitecore.DataExchange.Models Namespace


Pipeline.GetPlugin Method (Type)

PipelineGetPlugin Method (Type)
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object GetPlugin(
    Type type
)

Parameters

type
Type: SystemType
The type of the plugin to get.

Return Value

Type: Object
If a plugin of the specified type is set, the plugin; otherwise .

Implements

IHasPluginsGetPlugin(Type)
See Also

Reference

Pipeline Class
GetPlugin Overload
Sitecore.DataExchange.Models Namespace


PipelineBatch Class

PipelineBatch Class
Represents the ability to run Pipeline objects using a IPipelineBatchProcessor.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ModelsPipelineBatch

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineBatch : IHasPlugins

The PipelineBatch type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineBatch | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not the pipeline batch is enabled.
Public property | ID | Gets or sets the identifier of the pipeline batch.
Public property | Name | Gets or sets the name of the pipeline batch.
Public property | PipelineBatchProcessor | Gets or sets the component that processes the pipeline batch.
Public property | Pipelines | Gets the collection of pipelines that can be run.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineBatchProcessor to know how to use any plugins that are assigned.
Public property | Tenant | Gets or sets the tenant under which the pipeline batch is defined.
Top
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPipelineBatchSummary | Gets the settings from the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | GetProcessorSettings | Gets the settings from the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | GetSitecoreItemSettings | Gets the settings from the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | HasPipelineBatchSummary | Determines whether the settings have been assigned to the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | HasProcessorSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | HasSitecoreItemSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by PipelineBatchExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models Namespace


PipelineBatch Constructor

PipelineBatch Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatch()
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch Properties

PipelineBatch Properties

The PipelineBatch type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not the pipeline batch is enabled.
Public property | ID | Gets or sets the identifier of the pipeline batch.
Public property | Name | Gets or sets the name of the pipeline batch.
Public property | PipelineBatchProcessor | Gets or sets the component that processes the pipeline batch.
Public property | Pipelines | Gets the collection of pipelines that can be run.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineBatchProcessor to know how to use any plugins that are assigned.
Public property | Tenant | Gets or sets the tenant under which the pipeline batch is defined.
Top
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.Enabled Property

PipelineBatchEnabled Property

Gets or sets a value that indicates whether or not the pipeline batch is enabled.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Enabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.ID Property

PipelineBatchID Property
Gets or sets the identifier of the pipeline batch.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Guid ID { get; set; }

Property Value

Type: Guid
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.Name Property

PipelineBatchName Property
Gets or sets the name of the pipeline batch.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.PipelineBatchProcessor Property

PipelineBatchPipelineBatchProcessor Property
Gets or sets the component that processes the pipeline batch.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IPipelineBatchProcessor PipelineBatchProcessor { get; set; }

Property Value

Type: IPipelineBatchProcessor
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.Pipelines Property

PipelineBatchPipelines Property
Gets the collection of pipelines that can be run.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<Pipeline> Pipelines { get; }

Property Value

Type: ICollection Pipeline
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.Plugins Property

PipelineBatchPlugins Property

Gets the collection of plugins assigned to this component.

These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineBatchProcessor to know how to use any plugins that are assigned.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin

Implements

IHasPluginsPlugins
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.Tenant Property

PipelineBatchTenant Property
Gets or sets the tenant under which the pipeline batch is defined.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Tenant Tenant { get; set; }

Property Value

Type: Tenant
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch Methods

PipelineBatch Methods

The PipelineBatch type exposes the following members.

Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPipelineBatchSummary | Gets the settings from the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | GetProcessorSettings | Gets the settings from the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | GetSitecoreItemSettings | Gets the settings from the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | HasPipelineBatchSummary | Determines whether the settings have been assigned to the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | HasProcessorSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | HasSitecoreItemSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineBatchExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by PipelineBatchExtensions.)
Top
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.GetPlugin Method

PipelineBatchGetPlugin Method
Overload List
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

PipelineBatch Class
Sitecore.DataExchange.Models Namespace


PipelineBatch.GetPlugin(T) Method

PipelineBatchGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.

Implements

IHasPluginsGetPluginT
See Also

Reference

PipelineBatch Class
GetPlugin Overload
Sitecore.DataExchange.Models Namespace


PipelineBatch.GetPlugin Method (Type)

PipelineBatchGetPlugin Method (Type)
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object GetPlugin(
    Type type
)

Parameters

type
Type: SystemType
The type of the plugin to get.

Return Value

Type: Object
If a plugin of the specified type is set, the plugin; otherwise .

Implements

IHasPluginsGetPlugin(Type)
See Also

Reference

PipelineBatch Class
GetPlugin Overload
Sitecore.DataExchange.Models Namespace


PipelineStep Class

PipelineStep Class
Represents a step in a Pipeline that is run using a IPipelineStepProcessor.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ModelsPipelineStep

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineStep : IHasPlugins

The PipelineStep type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineStep | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not the pipeline step is enabled. If , PipelineStepProcessor will skip this pipeline step.
Public property | Name | Gets or sets the name of the pipeline step.
Public property | PipelineStepProcessor | Gets or sets the component that processes the pipeline step.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineStepProcessor to know how to use any plugins that are assigned.
Top
Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEndpointSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetMappingSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetPipelinesSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetResolveIdentifierSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetResolveObjectSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetSitecoreItemSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetValueAccessSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetWorkQueueProcessorStepSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasEndpointSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasMappingSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasPipelinesSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasResolveIdentifierSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasResolveObjectSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasSitecoreItemSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasValueAccessSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasWorkQueueProcessorStepSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models Namespace


PipelineStep Constructor

PipelineStep Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineStep()
See Also

Reference

PipelineStep Class
Sitecore.DataExchange.Models Namespace


PipelineStep Properties

PipelineStep Properties

The PipelineStep type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not the pipeline step is enabled. If , PipelineStepProcessor will skip this pipeline step.
Public property | Name | Gets or sets the name of the pipeline step.
Public property | PipelineStepProcessor | Gets or sets the component that processes the pipeline step.
Public property | Plugins | Gets the collection of plugins assigned to this component. These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineStepProcessor to know how to use any plugins that are assigned.
Top
See Also

Reference

PipelineStep Class
Sitecore.DataExchange.Models Namespace


PipelineStep.Enabled Property

PipelineStepEnabled Property

Gets or sets a value that indicates whether or not the pipeline step is enabled.

If , PipelineStepProcessor will skip this pipeline step.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Enabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

PipelineStep Class
Sitecore.DataExchange.Models Namespace


PipelineStep.Name Property

PipelineStepName Property
Gets or sets the name of the pipeline step.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

PipelineStep Class
Sitecore.DataExchange.Models Namespace


PipelineStep.PipelineStepProcessor Property

PipelineStepPipelineStepProcessor Property
Gets or sets the component that processes the pipeline step.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IPipelineStepProcessor PipelineStepProcessor { get; set; }

Property Value

Type: IPipelineStepProcessor
See Also

Reference

PipelineStep Class
Sitecore.DataExchange.Models Namespace


PipelineStep.Plugins Property

PipelineStepPlugins Property

Gets the collection of plugins assigned to this component.

These plugins are used to extend the component without requiring inheritence. It is the responsibility of PipelineStepProcessor to know how to use any plugins that are assigned.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<IPlugin> Plugins { get; }

Property Value

Type: ICollection IPlugin

Implements

IHasPluginsPlugins
See Also

Reference

PipelineStep Class
Sitecore.DataExchange.Models Namespace


PipelineStep Methods

PipelineStep Methods

The PipelineStep type exposes the following members.

Methods
 | Name | Description
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEndpointSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetMappingSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetPipelinesSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetResolveIdentifierSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetResolveObjectSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetSitecoreItemSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetTelemetryActivitySettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetValueAccessSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | GetWorkQueueProcessorStepSettings | Gets the settings from the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasEndpointSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasMappingSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasPipelinesSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasResolveIdentifierSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasResolveObjectSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasSitecoreItemSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasTelemetryActivitySettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasValueAccessSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Public Extension Method | HasWorkQueueProcessorStepSettings | Determines whether the settings have been assigned to the component. (Defined by PipelineStepExtensions.)
Top
See Also

Reference

PipelineStep Class
Sitecore.DataExchange.Models Namespace


PipelineStep.GetPlugin Method

PipelineStepGetPlugin Method
Overload List
 | Name | Description
Public method | GetPluginT | Gets the first plugin whose type matches the generic parameter.
Public method | GetPlugin(Type) | Gets a specific plugin that has been assigned to the component.
Top
See Also

Reference

PipelineStep Class
Sitecore.DataExchange.Models Namespace


PipelineStep.GetPlugin(T) Method

PipelineStepGetPluginT Method
Gets the first plugin whose type matches the generic parameter.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T GetPlugin<T>()
where T : IPlugin

Type Parameters

T
The type of the plugin to get.

Return Value

Type: T
The first plugin whose type matches the generic parameter; if no match is found.

Implements

IHasPluginsGetPluginT
See Also

Reference

PipelineStep Class
GetPlugin Overload
Sitecore.DataExchange.Models Namespace


PipelineStep.GetPlugin Method (Type)

PipelineStepGetPlugin Method (Type)
Gets a specific plugin that has been assigned to the component.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object GetPlugin(
    Type type
)

Parameters

type
Type: SystemType
The type of the plugin to get.

Return Value

Type: Object
If a plugin of the specified type is set, the plugin; otherwise .

Implements

IHasPluginsGetPlugin(Type)
See Also

Reference

PipelineStep Class
GetPlugin Overload
Sitecore.DataExchange.Models Namespace


Tenant Class

Tenant Class
Represents a grouping of related settings that present a single tenant, organization, brand, etc.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.ModelsTenant

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class Tenant

The Tenant type exposes the following members.

Constructors
 | Name | Description
Public method | Tenant | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not the tenant is enabled.
Public property | ID | Gets or sets the identifier of the tenant.
Public property | Name | Gets or sets the name of the tenant.
Top
See Also

Reference

Sitecore.DataExchange.Models Namespace


Tenant Constructor

Tenant Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Tenant()
See Also

Reference

Tenant Class
Sitecore.DataExchange.Models Namespace


Tenant Properties

Tenant Properties

The Tenant type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not the tenant is enabled.
Public property | ID | Gets or sets the identifier of the tenant.
Public property | Name | Gets or sets the name of the tenant.
Top
See Also

Reference

Tenant Class
Sitecore.DataExchange.Models Namespace


Tenant.Enabled Property

TenantEnabled Property

Gets or sets a value that indicates whether or not the tenant is enabled.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Enabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

Tenant Class
Sitecore.DataExchange.Models Namespace


Tenant.ID Property

TenantID Property
Gets or sets the identifier of the tenant.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Guid ID { get; set; }

Property Value

Type: Guid
See Also

Reference

Tenant Class
Sitecore.DataExchange.Models Namespace


Tenant.Name Property

TenantName Property
Gets or sets the name of the tenant.

Namespace: Sitecore.DataExchange.Models
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Tenant Class
Sitecore.DataExchange.Models Namespace


Sitecore.DataExchange.Models.ItemModels.Common Namespace

Sitecore.DataExchange.Models.ItemModels.Common Namespace

This namespace contains item models that represent common framework components.

Classes
 | Class | Description
Public class | ConvertibleItemModel | A Sitecore item that represents a component that implements IConverterTFrom, TTo.
Public class | EnableableItemModel | A Sitecore item that represents a component that can be enabled and disabled using a checkbox.
Public class | MeasureableItemModel | A Sitecore item that represents a TelemetryActivitySettings.
Public class | OffsetableItemModel | A Sitecore item that represents a component that has a date that can be offset.
Public class | ProcessableItemModel | A Sitecore item that represents a component whose logic is controlled by a processor.
Public class | ResolveIdentifierItemModel | A Sitecore item that represents a ResolveIdentifierSettings.


ConvertibleItemModel Class

ConvertibleItemModel Class
A Sitecore item that represents a component that implements IConverterTFrom, TTo.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.CommonConvertibleItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ConvertibleItemModel : ItemModel

The ConvertibleItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ConvertibleItemModel | Initializes a new instance of the ConvertibleItemModel class
Top
Fields
Name | Description
ConverterType | Field that identifies the type that implements IConverterTFrom, TTo.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Common Namespace


ConvertibleItemModel Constructor

ConvertibleItemModel Constructor
Initializes a new instance of the ConvertibleItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ConvertibleItemModel()
See Also

Reference

ConvertibleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ConvertibleItemModel Methods

ConvertibleItemModel Methods

The ConvertibleItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ConvertibleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ConvertibleItemModel Fields

ConvertibleItemModel Fields

The ConvertibleItemModel type exposes the following members.

Fields
Name | Description
ConverterType | Field that identifies the type that implements IConverterTFrom, TTo.
Top
See Also

Reference

ConvertibleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ConvertibleItemModel.ConverterType Field

ConvertibleItemModelConverterType Field
Field that identifies the type that implements IConverterTFrom, TTo.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ConverterType = "ConverterType"

Field Value

Type: String
See Also

Reference

ConvertibleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


EnableableItemModel Class

EnableableItemModel Class
A Sitecore item that represents a component that can be enabled and disabled using a checkbox.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.CommonEnableableItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class EnableableItemModel : ItemModel

The EnableableItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | EnableableItemModel | Initializes a new instance of the EnableableItemModel class
Top
Fields
Name | Description
Enabled | Checkbox field that identifies whether or not the component is enabled.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Common Namespace


EnableableItemModel Constructor

EnableableItemModel Constructor
Initializes a new instance of the EnableableItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected EnableableItemModel()
See Also

Reference

EnableableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


EnableableItemModel Methods

EnableableItemModel Methods

The EnableableItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

EnableableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


EnableableItemModel Fields

EnableableItemModel Fields

The EnableableItemModel type exposes the following members.

Fields
Name | Description
Enabled | Checkbox field that identifies whether or not the component is enabled.
Top
See Also

Reference

EnableableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


EnableableItemModel.Enabled Field

EnableableItemModelEnabled Field
Checkbox field that identifies whether or not the component is enabled.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Enabled = "Enabled"

Field Value

Type: String
See Also

Reference

EnableableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


MeasureableItemModel Class

MeasureableItemModel Class
A Sitecore item that represents a TelemetryActivitySettings.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.CommonMeasureableItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class MeasureableItemModel : ItemModel

The MeasureableItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | MeasureableItemModel | Initializes a new instance of the MeasureableItemModel class
Top
Fields
Name | Description
TelemetryEnabled | Checkbox field that represents Enabled.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Common Namespace


MeasureableItemModel Constructor

MeasureableItemModel Constructor
Initializes a new instance of the MeasureableItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected MeasureableItemModel()
See Also

Reference

MeasureableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


MeasureableItemModel Methods

MeasureableItemModel Methods

The MeasureableItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

MeasureableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


MeasureableItemModel Fields

MeasureableItemModel Fields

The MeasureableItemModel type exposes the following members.

Fields
Name | Description
TelemetryEnabled | Checkbox field that represents Enabled.
Top
See Also

Reference

MeasureableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


MeasureableItemModel.TelemetryEnabled Field

MeasureableItemModelTelemetryEnabled Field
Checkbox field that represents Enabled.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string TelemetryEnabled = "TelemetryEnabled"

Field Value

Type: String
See Also

Reference

MeasureableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


OffsetableItemModel Class

OffsetableItemModel Class

A Sitecore item that represents a component that has a date that can be offset.

Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.CommonOffsetableItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class OffsetableItemModel : ItemModel

The OffsetableItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | OffsetableItemModel | Initializes a new instance of the OffsetableItemModel class
Top
Fields
Name | Description
Offset | Field that identifies the offset value.
Operator | Field that represents how the offset value is applied to the value being offset.
UnitOfTime | Field that represents the unit of time for the offset value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Common Namespace


OffsetableItemModel Constructor

OffsetableItemModel Constructor
Initializes a new instance of the OffsetableItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected OffsetableItemModel()
See Also

Reference

OffsetableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


OffsetableItemModel Methods

OffsetableItemModel Methods

The OffsetableItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

OffsetableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


OffsetableItemModel Fields

OffsetableItemModel Fields

The OffsetableItemModel type exposes the following members.

Fields
Name | Description
Offset | Field that identifies the offset value.
Operator | Field that represents how the offset value is applied to the value being offset.
UnitOfTime | Field that represents the unit of time for the offset value.
Top
See Also

Reference

OffsetableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


OffsetableItemModel.Offset Field

OffsetableItemModelOffset Field
Field that identifies the offset value.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Offset = "Offset"

Field Value

Type: String
See Also

Reference

OffsetableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


OffsetableItemModel.Operator Field

OffsetableItemModelOperator Field
Field that represents how the offset value is applied to the value being offset.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Operator = "Operator"

Field Value

Type: String
See Also

Reference

OffsetableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


OffsetableItemModel.UnitOfTime Field

OffsetableItemModelUnitOfTime Field
Field that represents the unit of time for the offset value.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string UnitOfTime = "UnitOfTime"

Field Value

Type: String
See Also

Reference

OffsetableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ProcessableItemModel Class

ProcessableItemModel Class
A Sitecore item that represents a component whose logic is controlled by a processor.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.CommonProcessableItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ProcessableItemModel : ItemModel

The ProcessableItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ProcessableItemModel | Initializes a new instance of the ProcessableItemModel class
Top
Fields
Name | Description
ProcessorType | Field that identifies the type that implements the processor.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Common Namespace


ProcessableItemModel Constructor

ProcessableItemModel Constructor
Initializes a new instance of the ProcessableItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ProcessableItemModel()
See Also

Reference

ProcessableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ProcessableItemModel Methods

ProcessableItemModel Methods

The ProcessableItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ProcessableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ProcessableItemModel Fields

ProcessableItemModel Fields

The ProcessableItemModel type exposes the following members.

Fields
Name | Description
ProcessorType | Field that identifies the type that implements the processor.
Top
See Also

Reference

ProcessableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ProcessableItemModel.ProcessorType Field

ProcessableItemModelProcessorType Field
Field that identifies the type that implements the processor.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ProcessorType = "ProcessorType"

Field Value

Type: String
See Also

Reference

ProcessableItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ResolveIdentifierItemModel Class

ResolveIdentifierItemModel Class
A Sitecore item that represents a ResolveIdentifierSettings.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.CommonResolveIdentifierItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ResolveIdentifierItemModel : ItemModel

The ResolveIdentifierItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ResolveIdentifierItemModel | Initializes a new instance of the ResolveIdentifierItemModel class
Top
Fields
Name | Description
IdentifierObjectLocation | Reference field that represents IdentifierObjectLocation.
IdentifierValueAccessor | Reference field that represents IdentifierValueAccessor.
ValueReaderToConvertIdentifierValueForComparison | Reference field that represents ValueReaderToConvertIdentifierValueForComparison.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Common Namespace


ResolveIdentifierItemModel Constructor

ResolveIdentifierItemModel Constructor
Initializes a new instance of the ResolveIdentifierItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ResolveIdentifierItemModel()
See Also

Reference

ResolveIdentifierItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ResolveIdentifierItemModel Methods

ResolveIdentifierItemModel Methods

The ResolveIdentifierItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ResolveIdentifierItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ResolveIdentifierItemModel Fields

ResolveIdentifierItemModel Fields

The ResolveIdentifierItemModel type exposes the following members.

Fields
Name | Description
IdentifierObjectLocation | Reference field that represents IdentifierObjectLocation.
IdentifierValueAccessor | Reference field that represents IdentifierValueAccessor.
ValueReaderToConvertIdentifierValueForComparison | Reference field that represents ValueReaderToConvertIdentifierValueForComparison.
Top
See Also

Reference

ResolveIdentifierItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ResolveIdentifierItemModel.IdentifierObjectLocation Field

ResolveIdentifierItemModelIdentifierObjectLocation Field
Reference field that represents IdentifierObjectLocation.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string IdentifierObjectLocation = "IdentifierObjectLocation"

Field Value

Type: String
See Also

Reference

ResolveIdentifierItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ResolveIdentifierItemModel.IdentifierValueAccessor Field

ResolveIdentifierItemModelIdentifierValueAccessor Field
Reference field that represents IdentifierValueAccessor.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string IdentifierValueAccessor = "IdentifierValueAccessor"

Field Value

Type: String
See Also

Reference

ResolveIdentifierItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


ResolveIdentifierItemModel.ValueReaderToConvertIdentifierValueForComparison Field

ResolveIdentifierItemModelValueReaderToConvertIdentifierValueForComparison Field
Reference field that represents ValueReaderToConvertIdentifierValueForComparison.

Namespace: Sitecore.DataExchange.Models.ItemModels.Common
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ValueReaderToConvertIdentifierValueForComparison = "ValueReaderToConvertIdentifierValueForComparison"

Field Value

Type: String
See Also

Reference

ResolveIdentifierItemModel Class
Sitecore.DataExchange.Models.ItemModels.Common Namespace


Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace

This namespace contains item models that represent framework components related to data access.

Classes
 | Class | Description
Public class | AppendableItemModel | A Sitecore item that represents a component that supports IValueAppender.
Public class | ConstantValueReaderItemModel | A Sitecore item that represents a ConstantValueReader.
Public class | EnumValueReaderItemModel | A Sitecore item that represents a EnumValueReader.
Public class | FallbackValueReaderItemModel | A Sitecore item that represents a FallbackValueReader.
Public class | IsoDateValueReaderItemModel | A Sitecore item that represents a IsoDateValueReader.
Public class | MethodValueReaderItemModel | A Sitecore item that represents a MethodValueReader.
Public class | MethodValueReaderParameterItemModel | A Sitecore item that represents a parameter for a MethodValueReader.
Public class | NowValueReaderItemModel | A Sitecore item that represents a NowValueReader.
Public class | PropertyValueAccessorItemModel | A Sitecore item that represents a IValueAccessor that exposes a PropertyValueReader and a PropertyValueWriter.
Public class | PropertyValueReaderItemModel | A Sitecore item that represents a PropertyValueReader.
Public class | PropertyValueWriterItemModel | A Sitecore item that represents a PropertyValueWriter.
Public class | TargetReaderValueWriterItemModel | A Sitecore item that represents a TargetReaderValueWriter.
Public class | ValueAccessorItemModel | A Sitecore item that represents a IValueAccessor.
Public class | ValueAccessorSetItemModel | A Sitecore item that represents a IValueAccessorSet.
Public class | ValueAccessorValueReaderItemModel | A Sitecore item that allows a IValueAccessor to be assigned.


AppendableItemModel Class

AppendableItemModel Class
A Sitecore item that represents a component that supports IValueAppender.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessAppendableItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class AppendableItemModel : ItemModel

The AppendableItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | AppendableItemModel | Initializes a new instance of the AppendableItemModel class
Top
Fields
Name | Description
DoNotUseValueAppender | Field that indicates whether or not the the value appender should not be used.
ValueAppenderType | Field that identifies the type that implements IValueAppender.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


AppendableItemModel Constructor

AppendableItemModel Constructor
Initializes a new instance of the AppendableItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected AppendableItemModel()
See Also

Reference

AppendableItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


AppendableItemModel Methods

AppendableItemModel Methods

The AppendableItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

AppendableItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


AppendableItemModel Fields

AppendableItemModel Fields

The AppendableItemModel type exposes the following members.

Fields
Name | Description
DoNotUseValueAppender | Field that indicates whether or not the the value appender should not be used.
ValueAppenderType | Field that identifies the type that implements IValueAppender.
Top
See Also

Reference

AppendableItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


AppendableItemModel.DoNotUseValueAppender Field

AppendableItemModelDoNotUseValueAppender Field
Field that indicates whether or not the the value appender should not be used.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string DoNotUseValueAppender = "DoNotUseValueAppender"

Field Value

Type: String
See Also

Reference

AppendableItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


AppendableItemModel.ValueAppenderType Field

AppendableItemModelValueAppenderType Field
Field that identifies the type that implements IValueAppender.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ValueAppenderType = "ValueAppenderType"

Field Value

Type: String
See Also

Reference

AppendableItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ConstantValueReaderItemModel Class

ConstantValueReaderItemModel Class
A Sitecore item that represents a ConstantValueReader.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessConstantValueReaderItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ConstantValueReaderItemModel : ItemModel

The ConstantValueReaderItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ConstantValueReaderItemModel | Initializes a new instance of the ConstantValueReaderItemModel class
Top
Fields
Name | Description
Value | Field that represents Value.
ValueType | Field that specifies the type of the value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ConstantValueReaderItemModel Constructor

ConstantValueReaderItemModel Constructor
Initializes a new instance of the ConstantValueReaderItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ConstantValueReaderItemModel()
See Also

Reference

ConstantValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ConstantValueReaderItemModel Methods

ConstantValueReaderItemModel Methods

The ConstantValueReaderItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ConstantValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ConstantValueReaderItemModel Fields

ConstantValueReaderItemModel Fields

The ConstantValueReaderItemModel type exposes the following members.

Fields
Name | Description
Value | Field that represents Value.
ValueType | Field that specifies the type of the value.
Top
See Also

Reference

ConstantValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ConstantValueReaderItemModel.Value Field

ConstantValueReaderItemModelValue Field
Field that represents Value.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Value = "Value"

Field Value

Type: String
See Also

Reference

ConstantValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ConstantValueReaderItemModel.ValueType Field

ConstantValueReaderItemModelValueType Field
Field that specifies the type of the value.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ValueType = "ValueType"

Field Value

Type: String
See Also

Reference

ConstantValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


EnumValueReaderItemModel Class

EnumValueReaderItemModel Class
A Sitecore item that represents a EnumValueReader.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessEnumValueReaderItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class EnumValueReaderItemModel : ItemModel

The EnumValueReaderItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | EnumValueReaderItemModel | Initializes a new instance of the EnumValueReaderItemModel class
Top
Fields
Name | Description
EnumType | Field that represents EnumType.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


EnumValueReaderItemModel Constructor

EnumValueReaderItemModel Constructor
Initializes a new instance of the EnumValueReaderItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected EnumValueReaderItemModel()
See Also

Reference

EnumValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


EnumValueReaderItemModel Methods

EnumValueReaderItemModel Methods

The EnumValueReaderItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

EnumValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


EnumValueReaderItemModel Fields

EnumValueReaderItemModel Fields

The EnumValueReaderItemModel type exposes the following members.

Fields
Name | Description
EnumType | Field that represents EnumType.
Top
See Also

Reference

EnumValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


EnumValueReaderItemModel.EnumType Field

EnumValueReaderItemModelEnumType Field
Field that represents EnumType.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string EnumType = "EnumType"

Field Value

Type: String
See Also

Reference

EnumValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


FallbackValueReaderItemModel Class

FallbackValueReaderItemModel Class
A Sitecore item that represents a FallbackValueReader.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessFallbackValueReaderItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class FallbackValueReaderItemModel : ItemModel

The FallbackValueReaderItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | FallbackValueReaderItemModel | Initializes a new instance of the FallbackValueReaderItemModel class
Top
Fields
Name | Description
Readers | Field that represents Readers.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


FallbackValueReaderItemModel Constructor

FallbackValueReaderItemModel Constructor
Initializes a new instance of the FallbackValueReaderItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected FallbackValueReaderItemModel()
See Also

Reference

FallbackValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


FallbackValueReaderItemModel Methods

FallbackValueReaderItemModel Methods

The FallbackValueReaderItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

FallbackValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


FallbackValueReaderItemModel Fields

FallbackValueReaderItemModel Fields

The FallbackValueReaderItemModel type exposes the following members.

Fields
Name | Description
Readers | Field that represents Readers.
Top
See Also

Reference

FallbackValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


FallbackValueReaderItemModel.Readers Field

FallbackValueReaderItemModelReaders Field
Field that represents Readers.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Readers = "Readers"

Field Value

Type: String
See Also

Reference

FallbackValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


IsoDateValueReaderItemModel Class

IsoDateValueReaderItemModel Class
A Sitecore item that represents a IsoDateValueReader.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessIsoDateValueReaderItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IsoDateValueReaderItemModel : ItemModel

The IsoDateValueReaderItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | IsoDateValueReaderItemModel | Initializes a new instance of the IsoDateValueReaderItemModel class
Top
Fields
Name | Description
ConvertToUtc | Field that represents ConvertToUtc.
IncludeTicks | Field that represents IncludeTicks.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


IsoDateValueReaderItemModel Constructor

IsoDateValueReaderItemModel Constructor
Initializes a new instance of the IsoDateValueReaderItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IsoDateValueReaderItemModel()
See Also

Reference

IsoDateValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


IsoDateValueReaderItemModel Methods

IsoDateValueReaderItemModel Methods

The IsoDateValueReaderItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

IsoDateValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


IsoDateValueReaderItemModel Fields

IsoDateValueReaderItemModel Fields

The IsoDateValueReaderItemModel type exposes the following members.

Fields
Name | Description
ConvertToUtc | Field that represents ConvertToUtc.
IncludeTicks | Field that represents IncludeTicks.
Top
See Also

Reference

IsoDateValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


IsoDateValueReaderItemModel.ConvertToUtc Field

IsoDateValueReaderItemModelConvertToUtc Field
Field that represents ConvertToUtc.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ConvertToUtc = "ConvertToUtc"

Field Value

Type: String
See Also

Reference

IsoDateValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


IsoDateValueReaderItemModel.IncludeTicks Field

IsoDateValueReaderItemModelIncludeTicks Field
Field that represents IncludeTicks.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string IncludeTicks = "IncludeTicks"

Field Value

Type: String
See Also

Reference

IsoDateValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderItemModel Class

MethodValueReaderItemModel Class
A Sitecore item that represents a MethodValueReader.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessMethodValueReaderItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class MethodValueReaderItemModel : ItemModel

The MethodValueReaderItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | MethodValueReaderItemModel | Initializes a new instance of the MethodValueReaderItemModel class
Top
Fields
Name | Description
ExtensionMethodType | Field that represents ExtensionMethodType.
IsExtensionMethod | Field that represents IsExtensionMethod.
MethodName | Field that represents MethodName.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderItemModel Constructor

MethodValueReaderItemModel Constructor
Initializes a new instance of the MethodValueReaderItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected MethodValueReaderItemModel()
See Also

Reference

MethodValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderItemModel Methods

MethodValueReaderItemModel Methods

The MethodValueReaderItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

MethodValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderItemModel Fields

MethodValueReaderItemModel Fields

The MethodValueReaderItemModel type exposes the following members.

Fields
Name | Description
ExtensionMethodType | Field that represents ExtensionMethodType.
IsExtensionMethod | Field that represents IsExtensionMethod.
MethodName | Field that represents MethodName.
Top
See Also

Reference

MethodValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderItemModel.ExtensionMethodType Field

MethodValueReaderItemModelExtensionMethodType Field
Field that represents ExtensionMethodType.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ExtensionMethodType = "ExtensionMethodType"

Field Value

Type: String
See Also

Reference

MethodValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderItemModel.IsExtensionMethod Field

MethodValueReaderItemModelIsExtensionMethod Field
Field that represents IsExtensionMethod.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string IsExtensionMethod = "IsExtensionMethod"

Field Value

Type: String
See Also

Reference

MethodValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderItemModel.MethodName Field

MethodValueReaderItemModelMethodName Field
Field that represents MethodName.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string MethodName = "MethodName"

Field Value

Type: String
See Also

Reference

MethodValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderParameterItemModel Class

MethodValueReaderParameterItemModel Class
A Sitecore item that represents a parameter for a MethodValueReader.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessMethodValueReaderParameterItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class MethodValueReaderParameterItemModel : ItemModel

The MethodValueReaderParameterItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | MethodValueReaderParameterItemModel | Initializes a new instance of the MethodValueReaderParameterItemModel class
Top
Fields
Name | Description
Type | Field that represents the object's type.
Value | Field that represents object's value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderParameterItemModel Constructor

MethodValueReaderParameterItemModel Constructor
Initializes a new instance of the MethodValueReaderParameterItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected MethodValueReaderParameterItemModel()
See Also

Reference

MethodValueReaderParameterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderParameterItemModel Methods

MethodValueReaderParameterItemModel Methods

The MethodValueReaderParameterItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

MethodValueReaderParameterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderParameterItemModel Fields

MethodValueReaderParameterItemModel Fields

The MethodValueReaderParameterItemModel type exposes the following members.

Fields
Name | Description
Type | Field that represents the object's type.
Value | Field that represents object's value.
Top
See Also

Reference

MethodValueReaderParameterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderParameterItemModel.Type Field

MethodValueReaderParameterItemModelType Field
Field that represents the object's type.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Type = "Type"

Field Value

Type: String
See Also

Reference

MethodValueReaderParameterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


MethodValueReaderParameterItemModel.Value Field

MethodValueReaderParameterItemModelValue Field
Field that represents object's value.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Value = "Value"

Field Value

Type: String
See Also

Reference

MethodValueReaderParameterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


NowValueReaderItemModel Class

NowValueReaderItemModel Class
A Sitecore item that represents a NowValueReader.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessNowValueReaderItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class NowValueReaderItemModel : ItemModel

The NowValueReaderItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | NowValueReaderItemModel | Initializes a new instance of the NowValueReaderItemModel class
Top
Fields
Name | Description
UtcDate | Field that represents UtcDate.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


NowValueReaderItemModel Constructor

NowValueReaderItemModel Constructor
Initializes a new instance of the NowValueReaderItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected NowValueReaderItemModel()
See Also

Reference

NowValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


NowValueReaderItemModel Methods

NowValueReaderItemModel Methods

The NowValueReaderItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

NowValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


NowValueReaderItemModel Fields

NowValueReaderItemModel Fields

The NowValueReaderItemModel type exposes the following members.

Fields
Name | Description
UtcDate | Field that represents UtcDate.
Top
See Also

Reference

NowValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


NowValueReaderItemModel.UtcDate Field

NowValueReaderItemModelUtcDate Field
Field that represents UtcDate.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string UtcDate = "UtcDate"

Field Value

Type: String
See Also

Reference

NowValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueAccessorItemModel Class

PropertyValueAccessorItemModel Class
A Sitecore item that represents a IValueAccessor that exposes a PropertyValueReader and a PropertyValueWriter.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessPropertyValueAccessorItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PropertyValueAccessorItemModel : ItemModel

The PropertyValueAccessorItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyValueAccessorItemModel | Initializes a new instance of the PropertyValueAccessorItemModel class
Top
Fields
Name | Description
PropertyName | Field that represents PropertyName and a PropertyName.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueAccessorItemModel Constructor

PropertyValueAccessorItemModel Constructor
Initializes a new instance of the PropertyValueAccessorItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PropertyValueAccessorItemModel()
See Also

Reference

PropertyValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueAccessorItemModel Methods

PropertyValueAccessorItemModel Methods

The PropertyValueAccessorItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

PropertyValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueAccessorItemModel Fields

PropertyValueAccessorItemModel Fields

The PropertyValueAccessorItemModel type exposes the following members.

Fields
Name | Description
PropertyName | Field that represents PropertyName and a PropertyName.
Top
See Also

Reference

PropertyValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueAccessorItemModel.PropertyName Field

PropertyValueAccessorItemModelPropertyName Field
Field that represents PropertyName and a PropertyName.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string PropertyName = "PropertyName"

Field Value

Type: String
See Also

Reference

PropertyValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueReaderItemModel Class

PropertyValueReaderItemModel Class
A Sitecore item that represents a PropertyValueReader.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessPropertyValueReaderItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class PropertyValueReaderItemModel : ItemModel

The PropertyValueReaderItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | PropertyValueReaderItemModel | Initializes a new instance of the PropertyValueReaderItemModel class
Top
Fields
Name | Description
PropertyName | Field that represents PropertyName.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueReaderItemModel Constructor

PropertyValueReaderItemModel Constructor
Initializes a new instance of the PropertyValueReaderItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected PropertyValueReaderItemModel()
See Also

Reference

PropertyValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueReaderItemModel Methods

PropertyValueReaderItemModel Methods

The PropertyValueReaderItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

PropertyValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueReaderItemModel Fields

PropertyValueReaderItemModel Fields

The PropertyValueReaderItemModel type exposes the following members.

Fields
Name | Description
PropertyName | Field that represents PropertyName.
Top
See Also

Reference

PropertyValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueReaderItemModel.PropertyName Field

PropertyValueReaderItemModelPropertyName Field
Field that represents PropertyName.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string PropertyName = "PropertyName"

Field Value

Type: String
See Also

Reference

PropertyValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueWriterItemModel Class

PropertyValueWriterItemModel Class
A Sitecore item that represents a PropertyValueWriter.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessPropertyValueWriterItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class PropertyValueWriterItemModel : ItemModel

The PropertyValueWriterItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | PropertyValueWriterItemModel | Initializes a new instance of the PropertyValueWriterItemModel class
Top
Fields
Name | Description
PropertyName | Field that represents PropertyName.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueWriterItemModel Constructor

PropertyValueWriterItemModel Constructor
Initializes a new instance of the PropertyValueWriterItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected PropertyValueWriterItemModel()
See Also

Reference

PropertyValueWriterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueWriterItemModel Methods

PropertyValueWriterItemModel Methods

The PropertyValueWriterItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

PropertyValueWriterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueWriterItemModel Fields

PropertyValueWriterItemModel Fields

The PropertyValueWriterItemModel type exposes the following members.

Fields
Name | Description
PropertyName | Field that represents PropertyName.
Top
See Also

Reference

PropertyValueWriterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


PropertyValueWriterItemModel.PropertyName Field

PropertyValueWriterItemModelPropertyName Field
Field that represents PropertyName.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string PropertyName = "PropertyName"

Field Value

Type: String
See Also

Reference

PropertyValueWriterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


TargetReaderValueWriterItemModel Class

TargetReaderValueWriterItemModel Class
A Sitecore item that represents a TargetReaderValueWriter.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessTargetReaderValueWriterItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class TargetReaderValueWriterItemModel : ItemModel

The TargetReaderValueWriterItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | TargetReaderValueWriterItemModel | Initializes a new instance of the TargetReaderValueWriterItemModel class
Top
Fields
Name | Description
ValueAccessor | Field that represents ValueAccessor.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


TargetReaderValueWriterItemModel Constructor

TargetReaderValueWriterItemModel Constructor
Initializes a new instance of the TargetReaderValueWriterItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected TargetReaderValueWriterItemModel()
See Also

Reference

TargetReaderValueWriterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


TargetReaderValueWriterItemModel Methods

TargetReaderValueWriterItemModel Methods

The TargetReaderValueWriterItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

TargetReaderValueWriterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


TargetReaderValueWriterItemModel Fields

TargetReaderValueWriterItemModel Fields

The TargetReaderValueWriterItemModel type exposes the following members.

Fields
Name | Description
ValueAccessor | Field that represents ValueAccessor.
Top
See Also

Reference

TargetReaderValueWriterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


TargetReaderValueWriterItemModel.ValueAccessor Field

TargetReaderValueWriterItemModelValueAccessor Field
Field that represents ValueAccessor.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ValueAccessor = "ValueAccessor"

Field Value

Type: String
See Also

Reference

TargetReaderValueWriterItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorItemModel Class

ValueAccessorItemModel Class
A Sitecore item that represents a IValueAccessor.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessValueAccessorItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ValueAccessorItemModel : ItemModel

The ValueAccessorItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ValueAccessorItemModel | Initializes a new instance of the ValueAccessorItemModel class
Top
Fields
Name | Description
ValueReader | Reference field that represents ValueReader.
ValueWriter | Reference field that represents ValueWriter.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorItemModel Constructor

ValueAccessorItemModel Constructor
Initializes a new instance of the ValueAccessorItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ValueAccessorItemModel()
See Also

Reference

ValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorItemModel Methods

ValueAccessorItemModel Methods

The ValueAccessorItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorItemModel Fields

ValueAccessorItemModel Fields

The ValueAccessorItemModel type exposes the following members.

Fields
Name | Description
ValueReader | Reference field that represents ValueReader.
ValueWriter | Reference field that represents ValueWriter.
Top
See Also

Reference

ValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorItemModel.ValueReader Field

ValueAccessorItemModelValueReader Field
Reference field that represents ValueReader.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ValueReader = "ValueReader"

Field Value

Type: String
See Also

Reference

ValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorItemModel.ValueWriter Field

ValueAccessorItemModelValueWriter Field
Reference field that represents ValueWriter.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ValueWriter = "ValueWriter"

Field Value

Type: String
See Also

Reference

ValueAccessorItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorSetItemModel Class

ValueAccessorSetItemModel Class
A Sitecore item that represents a IValueAccessorSet.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessValueAccessorSetItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ValueAccessorSetItemModel : ItemModel

The ValueAccessorSetItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ValueAccessorSetItemModel | Initializes a new instance of the ValueAccessorSetItemModel class
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorSetItemModel Constructor

ValueAccessorSetItemModel Constructor
Initializes a new instance of the ValueAccessorSetItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ValueAccessorSetItemModel()
See Also

Reference

ValueAccessorSetItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorSetItemModel Methods

ValueAccessorSetItemModel Methods

The ValueAccessorSetItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ValueAccessorSetItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorValueReaderItemModel Class

ValueAccessorValueReaderItemModel Class
A Sitecore item that allows a IValueAccessor to be assigned.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.DataAccessValueAccessorValueReaderItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ValueAccessorValueReaderItemModel : ItemModel

The ValueAccessorValueReaderItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ValueAccessorValueReaderItemModel | Initializes a new instance of the ValueAccessorValueReaderItemModel class
Top
Fields
Name | Description
ValueAccessor | Field that represents the IValueAccessor object whose IValueReader is read.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorValueReaderItemModel Constructor

ValueAccessorValueReaderItemModel Constructor
Initializes a new instance of the ValueAccessorValueReaderItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ValueAccessorValueReaderItemModel()
See Also

Reference

ValueAccessorValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorValueReaderItemModel Methods

ValueAccessorValueReaderItemModel Methods

The ValueAccessorValueReaderItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ValueAccessorValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorValueReaderItemModel Fields

ValueAccessorValueReaderItemModel Fields

The ValueAccessorValueReaderItemModel type exposes the following members.

Fields
Name | Description
ValueAccessor | Field that represents the IValueAccessor object whose IValueReader is read.
Top
See Also

Reference

ValueAccessorValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


ValueAccessorValueReaderItemModel.ValueAccessor Field

ValueAccessorValueReaderItemModelValueAccessor Field
Field that represents the IValueAccessor object whose IValueReader is read.

Namespace: Sitecore.DataExchange.Models.ItemModels.DataAccess
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ValueAccessor = "ValueAccessor"

Field Value

Type: String
See Also

Reference

ValueAccessorValueReaderItemModel Class
Sitecore.DataExchange.Models.ItemModels.DataAccess Namespace


Sitecore.DataExchange.Models.ItemModels.Endpoints Namespace

Sitecore.DataExchange.Models.ItemModels.Endpoints Namespace

This namespace contains item models that represent framework components related to endpoints.

Classes
 | Class | Description
Public class | EndpointItemModel | A Sitecore item that represents a Endpoint.


EndpointItemModel Class

EndpointItemModel Class
A Sitecore item that represents a Endpoint.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.EndpointsEndpointItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class EndpointItemModel : ItemModel

The EndpointItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | EndpointItemModel | Initializes a new instance of the EndpointItemModel class
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Endpoints Namespace


EndpointItemModel Constructor

EndpointItemModel Constructor
Initializes a new instance of the EndpointItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Endpoints
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected EndpointItemModel()
See Also

Reference

EndpointItemModel Class
Sitecore.DataExchange.Models.ItemModels.Endpoints Namespace


EndpointItemModel Methods

EndpointItemModel Methods

The EndpointItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

EndpointItemModel Class
Sitecore.DataExchange.Models.ItemModels.Endpoints Namespace


Sitecore.DataExchange.Models.ItemModels.Mapping Namespace

Sitecore.DataExchange.Models.ItemModels.Mapping Namespace

This namespace contains item models that represent framework components related to mapping.

Classes
 | Class | Description
Public class | CollectionCountMappingRuleItemModel | A Sitecore item that represents a CollectionCountMappingRule.
Public class | MappingItemModel | A Sitecore item that represents a IMapping.
Public class | MappingSetItemModel | A Sitecore item that represents a IMappingSet.


CollectionCountMappingRuleItemModel Class

CollectionCountMappingRuleItemModel Class
A Sitecore item that represents a CollectionCountMappingRule.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.MappingCollectionCountMappingRuleItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class CollectionCountMappingRuleItemModel : ItemModel

The CollectionCountMappingRuleItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionCountMappingRuleItemModel | Initializes a new instance of the CollectionCountMappingRuleItemModel class
Top
Fields
Name | Description
MaxCount | Field that represents MaxCount.
MinCount | Field that represents MinCount.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


CollectionCountMappingRuleItemModel Constructor

CollectionCountMappingRuleItemModel Constructor
Initializes a new instance of the CollectionCountMappingRuleItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public CollectionCountMappingRuleItemModel()
See Also

Reference

CollectionCountMappingRuleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


CollectionCountMappingRuleItemModel Methods

CollectionCountMappingRuleItemModel Methods

The CollectionCountMappingRuleItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

CollectionCountMappingRuleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


CollectionCountMappingRuleItemModel Fields

CollectionCountMappingRuleItemModel Fields

The CollectionCountMappingRuleItemModel type exposes the following members.

Fields
Name | Description
MaxCount | Field that represents MaxCount.
MinCount | Field that represents MinCount.
Top
See Also

Reference

CollectionCountMappingRuleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


CollectionCountMappingRuleItemModel.MaxCount Field

CollectionCountMappingRuleItemModelMaxCount Field
Field that represents MaxCount.

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string MaxCount = "MaxCount"

Field Value

Type: String
See Also

Reference

CollectionCountMappingRuleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


CollectionCountMappingRuleItemModel.MinCount Field

CollectionCountMappingRuleItemModelMinCount Field
Field that represents MinCount.

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string MinCount = "MinCount"

Field Value

Type: String
See Also

Reference

CollectionCountMappingRuleItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel Class

MappingItemModel Class
A Sitecore item that represents a IMapping.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.MappingMappingItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class MappingItemModel : ItemModel

The MappingItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | MappingItemModel | Initializes a new instance of the MappingItemModel class
Top
Fields
Name | Description
ApplyMappingRules | Reference field that represents ApplyMappingRules.
IgnoreNullValues | Reference field that represents IgnoreNullValues.
SourceAccessor | Reference field that represents SourceAccessor.
SourceValueTransformer | Reference field that represents SourceValueTransformer.
TargetAccessor | Reference field that represents TargetAccessor.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel Constructor

MappingItemModel Constructor
Initializes a new instance of the MappingItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected MappingItemModel()
See Also

Reference

MappingItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel Methods

MappingItemModel Methods

The MappingItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

MappingItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel Fields

MappingItemModel Fields

The MappingItemModel type exposes the following members.

Fields
Name | Description
ApplyMappingRules | Reference field that represents ApplyMappingRules.
IgnoreNullValues | Reference field that represents IgnoreNullValues.
SourceAccessor | Reference field that represents SourceAccessor.
SourceValueTransformer | Reference field that represents SourceValueTransformer.
TargetAccessor | Reference field that represents TargetAccessor.
Top
See Also

Reference

MappingItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel.ApplyMappingRules Field

MappingItemModelApplyMappingRules Field
Reference field that represents ApplyMappingRules.

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ApplyMappingRules = "ApplyMappingRules"

Field Value

Type: String
See Also

Reference

MappingItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel.IgnoreNullValues Field

MappingItemModelIgnoreNullValues Field
Reference field that represents IgnoreNullValues.

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string IgnoreNullValues = "IgnoreNullValues"

Field Value

Type: String
See Also

Reference

MappingItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel.SourceAccessor Field

MappingItemModelSourceAccessor Field
Reference field that represents SourceAccessor.

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string SourceAccessor = "SourceAccessor"

Field Value

Type: String
See Also

Reference

MappingItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel.SourceValueTransformer Field

MappingItemModelSourceValueTransformer Field
Reference field that represents SourceValueTransformer.

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string SourceValueTransformer = "SourceValueTransformer"

Field Value

Type: String
See Also

Reference

MappingItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingItemModel.TargetAccessor Field

MappingItemModelTargetAccessor Field
Reference field that represents TargetAccessor.

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string TargetAccessor = "TargetAccessor"

Field Value

Type: String
See Also

Reference

MappingItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingSetItemModel Class

MappingSetItemModel Class
A Sitecore item that represents a IMappingSet.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.MappingMappingSetItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class MappingSetItemModel : ItemModel

The MappingSetItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | MappingSetItemModel | Initializes a new instance of the MappingSetItemModel class
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingSetItemModel Constructor

MappingSetItemModel Constructor
Initializes a new instance of the MappingSetItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Mapping
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected MappingSetItemModel()
See Also

Reference

MappingSetItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


MappingSetItemModel Methods

MappingSetItemModel Methods

The MappingSetItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

MappingSetItemModel Class
Sitecore.DataExchange.Models.ItemModels.Mapping Namespace


Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace

Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace

This namespace contains item models that represent framework components related to pipelines.

Classes
 | Class | Description
Public class | PipelineBatchItemModel | A Sitecore item that represents a PipelineBatch.
Public class | PipelineItemModel | A Sitecore item that represents a PipelineStep.


PipelineBatchItemModel Class

PipelineBatchItemModel Class
A Sitecore item that represents a PipelineBatch.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.PipelinesPipelineBatchItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class PipelineBatchItemModel : ItemModel

The PipelineBatchItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | PipelineBatchItemModel | Initializes a new instance of the PipelineBatchItemModel class
Top
Fields
Name | Description
CanRunOutOfProcess | Checkbox field that determines whether or not a pipeline batch can be run outside of the Sitecore server. This value is used to filter pipeline batches when they are retrieved by the IPipelineBatchRepository.
LastRunCompleted | Indicates whether or not the last run completed.
LastRunFinished | Date/time field that represents LastRunFinished.
LogLevels | Reference field that represents LogLevels.
MaxSize | Reference field that represents MaxSize .
Messages | Reference field that represents Messages.
Pipelines | Reference field that represents Pipelines.
RequestedAt | Date/time field that represents RequestedAt.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel Constructor

PipelineBatchItemModel Constructor
Initializes a new instance of the PipelineBatchItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected PipelineBatchItemModel()
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel Methods

PipelineBatchItemModel Methods

The PipelineBatchItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel Fields

PipelineBatchItemModel Fields

The PipelineBatchItemModel type exposes the following members.

Fields
Name | Description
CanRunOutOfProcess | Checkbox field that determines whether or not a pipeline batch can be run outside of the Sitecore server. This value is used to filter pipeline batches when they are retrieved by the IPipelineBatchRepository.
LastRunCompleted | Indicates whether or not the last run completed.
LastRunFinished | Date/time field that represents LastRunFinished.
LogLevels | Reference field that represents LogLevels.
MaxSize | Reference field that represents MaxSize .
Messages | Reference field that represents Messages.
Pipelines | Reference field that represents Pipelines.
RequestedAt | Date/time field that represents RequestedAt.
Top
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel.CanRunOutOfProcess Field

PipelineBatchItemModelCanRunOutOfProcess Field
Checkbox field that determines whether or not a pipeline batch can be run outside of the Sitecore server. This value is used to filter pipeline batches when they are retrieved by the IPipelineBatchRepository.

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string CanRunOutOfProcess = "CanRunOutOfProcess"

Field Value

Type: String
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel.LastRunCompleted Field

PipelineBatchItemModelLastRunCompleted Field
Indicates whether or not the last run completed.

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string LastRunCompleted = "LastRunCompleted"

Field Value

Type: String
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel.LastRunFinished Field

PipelineBatchItemModelLastRunFinished Field
Date/time field that represents LastRunFinished.

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string LastRunFinished = "LastRunFinished"

Field Value

Type: String
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel.LogLevels Field

PipelineBatchItemModelLogLevels Field
Reference field that represents LogLevels.

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string LogLevels = "LogLevels"

Field Value

Type: String
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel.MaxSize Field

PipelineBatchItemModelMaxSize Field
Reference field that represents MaxSize .

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string MaxSize = "MaxSize"

Field Value

Type: String
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel.Messages Field

PipelineBatchItemModelMessages Field
Reference field that represents Messages.

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Messages = "Messages"

Field Value

Type: String
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel.Pipelines Field

PipelineBatchItemModelPipelines Field
Reference field that represents Pipelines.

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Pipelines = "Pipelines"

Field Value

Type: String
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineBatchItemModel.RequestedAt Field

PipelineBatchItemModelRequestedAt Field
Date/time field that represents RequestedAt.

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string RequestedAt = "RequestedAt"

Field Value

Type: String
See Also

Reference

PipelineBatchItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineItemModel Class

PipelineItemModel Class
A Sitecore item that represents a PipelineStep.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.PipelinesPipelineItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class PipelineItemModel : ItemModel

The PipelineItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | PipelineItemModel | Initializes a new instance of the PipelineItemModel class
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineItemModel Constructor

PipelineItemModel Constructor
Initializes a new instance of the PipelineItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected PipelineItemModel()
See Also

Reference

PipelineItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


PipelineItemModel Methods

PipelineItemModel Methods

The PipelineItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

PipelineItemModel Class
Sitecore.DataExchange.Models.ItemModels.Pipelines Namespace


Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace

Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace

This namespace contains item models that represent framework components related to pipeline processor definitions.

Classes
 | Class | Description
Public class | ApplyMappingStepItemModel | A Sitecore item that represents a MappingSettings.
Public class | IterateDataAndRunPipelinesStepItemModel | A Sitecore item that represents a PipelineStep used to iterate the object assigned to Source and run the PipelineStep assigned to Pipelines.
Public class | ProcessQueueStepItemModel | A Sitecore item that represents a WorkQueueProcessorStepSettings.
Public class | ResolveObjectFromEndpointStepItemModel | A Sitecore item that represents a PipelineStep used to resolve an object from an endpoint.


ApplyMappingStepItemModel Class

ApplyMappingStepItemModel Class
A Sitecore item that represents a MappingSettings.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.PipelineStepsApplyMappingStepItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ApplyMappingStepItemModel : ItemModel

The ApplyMappingStepItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ApplyMappingStepItemModel | Initializes a new instance of the ApplyMappingStepItemModel class
Top
Fields
Name | Description
MappingSet | Reference field that represents MappingSet.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ApplyMappingStepItemModel Constructor

ApplyMappingStepItemModel Constructor
Initializes a new instance of the ApplyMappingStepItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ApplyMappingStepItemModel()
See Also

Reference

ApplyMappingStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ApplyMappingStepItemModel Methods

ApplyMappingStepItemModel Methods

The ApplyMappingStepItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ApplyMappingStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ApplyMappingStepItemModel Fields

ApplyMappingStepItemModel Fields

The ApplyMappingStepItemModel type exposes the following members.

Fields
Name | Description
MappingSet | Reference field that represents MappingSet.
Top
See Also

Reference

ApplyMappingStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ApplyMappingStepItemModel.MappingSet Field

ApplyMappingStepItemModelMappingSet Field
Reference field that represents MappingSet.

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string MappingSet = "MappingSet"

Field Value

Type: String
See Also

Reference

ApplyMappingStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


IterateDataAndRunPipelinesStepItemModel Class

IterateDataAndRunPipelinesStepItemModel Class
A Sitecore item that represents a PipelineStep used to iterate the object assigned to Source and run the PipelineStep assigned to Pipelines.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.PipelineStepsIterateDataAndRunPipelinesStepItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class IterateDataAndRunPipelinesStepItemModel : ItemModel

The IterateDataAndRunPipelinesStepItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | IterateDataAndRunPipelinesStepItemModel | Initializes a new instance of the IterateDataAndRunPipelinesStepItemModel class
Top
Fields
Name | Description
Pipelines | Reference field that represents Pipelines.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


IterateDataAndRunPipelinesStepItemModel Constructor

IterateDataAndRunPipelinesStepItemModel Constructor
Initializes a new instance of the IterateDataAndRunPipelinesStepItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IterateDataAndRunPipelinesStepItemModel()
See Also

Reference

IterateDataAndRunPipelinesStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


IterateDataAndRunPipelinesStepItemModel Methods

IterateDataAndRunPipelinesStepItemModel Methods

The IterateDataAndRunPipelinesStepItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

IterateDataAndRunPipelinesStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


IterateDataAndRunPipelinesStepItemModel Fields

IterateDataAndRunPipelinesStepItemModel Fields

The IterateDataAndRunPipelinesStepItemModel type exposes the following members.

Fields
Name | Description
Pipelines | Reference field that represents Pipelines.
Top
See Also

Reference

IterateDataAndRunPipelinesStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


IterateDataAndRunPipelinesStepItemModel.Pipelines Field

IterateDataAndRunPipelinesStepItemModelPipelines Field
Reference field that represents Pipelines.

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string Pipelines = "Pipelines"

Field Value

Type: String
See Also

Reference

IterateDataAndRunPipelinesStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ProcessQueueStepItemModel Class

ProcessQueueStepItemModel Class
A Sitecore item that represents a WorkQueueProcessorStepSettings.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.PipelineStepsProcessQueueStepItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ProcessQueueStepItemModel : ItemModel

The ProcessQueueStepItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessQueueStepItemModel | Initializes a new instance of the ProcessQueueStepItemModel class
Top
Fields
Name | Description
PostProcessPipelineBatches | Reference field that represents PostProcessPipelineBatches.
QueueProcessor | Field that represents the type that implements IWorkQueueProcessor.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ProcessQueueStepItemModel Constructor

ProcessQueueStepItemModel Constructor
Initializes a new instance of the ProcessQueueStepItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ProcessQueueStepItemModel()
See Also

Reference

ProcessQueueStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ProcessQueueStepItemModel Methods

ProcessQueueStepItemModel Methods

The ProcessQueueStepItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ProcessQueueStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ProcessQueueStepItemModel Fields

ProcessQueueStepItemModel Fields

The ProcessQueueStepItemModel type exposes the following members.

Fields
Name | Description
PostProcessPipelineBatches | Reference field that represents PostProcessPipelineBatches.
QueueProcessor | Field that represents the type that implements IWorkQueueProcessor.
Top
See Also

Reference

ProcessQueueStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ProcessQueueStepItemModel.PostProcessPipelineBatches Field

ProcessQueueStepItemModelPostProcessPipelineBatches Field
Reference field that represents PostProcessPipelineBatches.

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string PostProcessPipelineBatches = "PostProcessPipelineBatches"

Field Value

Type: String
See Also

Reference

ProcessQueueStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ProcessQueueStepItemModel.QueueProcessor Field

ProcessQueueStepItemModelQueueProcessor Field
Field that represents the type that implements IWorkQueueProcessor.

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string QueueProcessor = "QueueProcessor"

Field Value

Type: String
See Also

Reference

ProcessQueueStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ResolveObjectFromEndpointStepItemModel Class

ResolveObjectFromEndpointStepItemModel Class
A Sitecore item that represents a PipelineStep used to resolve an object from an endpoint.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
FieldDictionary
ItemModel
Sitecore.DataExchange.Models.ItemModels.PipelineStepsResolveObjectFromEndpointStepItemModel

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class ResolveObjectFromEndpointStepItemModel : ItemModel

The ResolveObjectFromEndpointStepItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ResolveObjectFromEndpointStepItemModel | Initializes a new instance of the ResolveObjectFromEndpointStepItemModel class
Top
Fields
Name | Description
DoNotCreateIfObjectNotResolved | Checkbox field that represents DoNotCreateIfObjectNotResolved.
EndpointFrom | Reference field that represents EndpointFrom.
FinishPipelineIfObjectNotResolved | Reference field that represents FinishPipelineIfObjectNotResolved
ResolvedObjectLocation | Reference field that represents ResolvedObjectLocation.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ResolveObjectFromEndpointStepItemModel Constructor

ResolveObjectFromEndpointStepItemModel Constructor
Initializes a new instance of the ResolveObjectFromEndpointStepItemModel class

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected ResolveObjectFromEndpointStepItemModel()
See Also

Reference

ResolveObjectFromEndpointStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ResolveObjectFromEndpointStepItemModel Methods

ResolveObjectFromEndpointStepItemModel Methods

The ResolveObjectFromEndpointStepItemModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | GetConverterTTo | Gets the IConverterTFrom, TTo that can convert itemModel from ItemModel to the specified type. (Defined by ItemModelExtensions.)
Public Extension Method | GetItemId | Gets the item ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | GetTemplateId | Gets the template ID from itemModel. (Defined by ItemModelExtensions.)
Public Extension Method | IsConvertible | Indicates whether itemModel has a field that stores information about the IConverterTFrom, TTo that would be used to convert itemModel from ItemModel to another type. (Defined by ItemModelExtensions.)
Top
See Also

Reference

ResolveObjectFromEndpointStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ResolveObjectFromEndpointStepItemModel Fields

ResolveObjectFromEndpointStepItemModel Fields

The ResolveObjectFromEndpointStepItemModel type exposes the following members.

Fields
Name | Description
DoNotCreateIfObjectNotResolved | Checkbox field that represents DoNotCreateIfObjectNotResolved.
EndpointFrom | Reference field that represents EndpointFrom.
FinishPipelineIfObjectNotResolved | Reference field that represents FinishPipelineIfObjectNotResolved
ResolvedObjectLocation | Reference field that represents ResolvedObjectLocation.
Top
See Also

Reference

ResolveObjectFromEndpointStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ResolveObjectFromEndpointStepItemModel.DoNotCreateIfObjectNotResolved Field

ResolveObjectFromEndpointStepItemModelDoNotCreateIfObjectNotResolved Field
Checkbox field that represents DoNotCreateIfObjectNotResolved.

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string DoNotCreateIfObjectNotResolved = "DoNotCreateIfObjectNotResolved"

Field Value

Type: String
See Also

Reference

ResolveObjectFromEndpointStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ResolveObjectFromEndpointStepItemModel.EndpointFrom Field

ResolveObjectFromEndpointStepItemModelEndpointFrom Field
Reference field that represents EndpointFrom.

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string EndpointFrom = "EndpointFrom"

Field Value

Type: String
See Also

Reference

ResolveObjectFromEndpointStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ResolveObjectFromEndpointStepItemModel.FinishPipelineIfObjectNotResolved Field

ResolveObjectFromEndpointStepItemModelFinishPipelineIfObjectNotResolved Field
Reference field that represents FinishPipelineIfObjectNotResolved

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string FinishPipelineIfObjectNotResolved = "FinishPipelineIfObjectNotResolved"

Field Value

Type: String
See Also

Reference

ResolveObjectFromEndpointStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


ResolveObjectFromEndpointStepItemModel.ResolvedObjectLocation Field

ResolveObjectFromEndpointStepItemModelResolvedObjectLocation Field
Reference field that represents ResolvedObjectLocation.

Namespace: Sitecore.DataExchange.Models.ItemModels.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const string ResolvedObjectLocation = "ResolvedObjectLocation"

Field Value

Type: String
See Also

Reference

ResolveObjectFromEndpointStepItemModel Class
Sitecore.DataExchange.Models.ItemModels.PipelineSteps Namespace


Sitecore.DataExchange.Plugins Namespace

Sitecore.DataExchange.Plugins Namespace

This namespace contains implementations of IPlugin.

Classes
 | Class | Description
Public class | DateOffsetSettings | Settings that allow a date offset to be specified.
Public class | DateRangeSettings | Settings that allow a date range to be specified.
Public class | DateRangeSettingsHelper | Helper class for calculating a date range and creating a DateRangeSettings object that corresponds to the range. This type is designed to simplify the process of creating date ranges such as "from at least 1 week ago" and "up to the next month".
Public class | EndpointSettings | Settings that allow a component to identify Endpoint objects that the component can use to read data from and write data to systems.
Public class | IterableDataSettings | Settings that allow a component to have iterable data assigned.
Public class | MappingSettings | Settings that allow a component to have a IMappingSet assigned.
Public class | ParentPipelineContextSettings | Settings that allow a component to have a parent PipelineContext.
Public class | PipelineBatchSummary | Settings that describe how and when a pipeline batch last ran.
Public class | PipelinesSettings | Settings that allow a component to have PipelineStep objects assigned. An example where pipelines are used is when a component (usually a pipeline processor) reads data from an external system. The component must do something with the data it reads. Rather than hard-coding the logic into the component, a pipeline can be configured to control how the data is handled.
Public class | PipelineStepSettings | Settings that makes information available to pipeline steps.
Public class | ResolveIdentifierSettings | Settings that allow a component to describe how to locate and access an identifier. This plugin is typically used in cases where a pipeline step need to read a specific value from the pipeline context. For example, if the pipeline step is used to write data it may be necessary to determine whether or not the data already exists. This plugin would be used to specify which components to use in order to make this determination.
Public class | ResolveObjectSettings | Settings that are used by a component that resolves an object. These settings tell the component how to locate the object the component will resolve, and what the component should do with the object after the component has resolved it. An example where this plugin is used is when a component has a value that identifies an object on an external system and the component must use that identifier to find the object.
Public class | SitecoreItemSettings | Settings that make Sitecore item information available to framework components.
Public class | SynchronizationSettings | Settings that allow a component to maintain state during a synchronization process.
Public class | TelemetryActivitySettings | Settings that allow a component to control how telemetry activity is handled.
Public class | ValueAccessSettings | Settings that allow a component to identify a IValueAccessor object that the component can use to read and write values.
Public class | WorkQueueProcessorStepSettings | Settings that allow a component to have a IWorkQueueProcessor assigned.
Public class | WorkQueueSettings | Settings that allow a component to have a IWorkQueue assigned.
Enumerations
 | Enumeration | Description
Public enumeration | DateOffsetOperator | Represents the operator used to determine the date offset.
Public enumeration | UnitOfTime | Represents units of time that can be used to configure date offsets.


DateOffsetOperator Enumeration

DateOffsetOperator Enumeration
Represents the operator used to determine the date offset.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public enum DateOffsetOperator
Members
Member name | Value | Description
Unspecified | 0 | Unspecified.
BetweenNowAndSelectedDate | 1 | Between now and the selected date.
OnOrAfterSelectedDate | 2 | On or after the selected date.
BetweenSelectedDateAndNow | 3 | Between the selected date and now.
OnOrBeforeSelectedDate | 4 | On or before the selected date.
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


DateOffsetSettings Class

DateOffsetSettings Class
Settings that allow a date offset to be specified.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsDateOffsetSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DateOffsetSettings : IPlugin

The DateOffsetSettings type exposes the following members.

Constructors
 | Name | Description
Public method | DateOffsetSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Offset | Sets or sets the value that indicates how many units the date is offset.
Public property | Operator | Gets or sets the operator used to define the date offset.
Public property | UnitOfTime | Gets or sets the unit of time that the date is offset.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


DateOffsetSettings Constructor

DateOffsetSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateOffsetSettings()
See Also

Reference

DateOffsetSettings Class
Sitecore.DataExchange.Plugins Namespace


DateOffsetSettings Properties

DateOffsetSettings Properties

The DateOffsetSettings type exposes the following members.

Properties
 | Name | Description
Public property | Offset | Sets or sets the value that indicates how many units the date is offset.
Public property | Operator | Gets or sets the operator used to define the date offset.
Public property | UnitOfTime | Gets or sets the unit of time that the date is offset.
Top
See Also

Reference

DateOffsetSettings Class
Sitecore.DataExchange.Plugins Namespace


DateOffsetSettings.Offset Property

DateOffsetSettingsOffset Property
Sets or sets the value that indicates how many units the date is offset.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int Offset { get; set; }

Property Value

Type: Int32
See Also

Reference

DateOffsetSettings Class
Sitecore.DataExchange.Plugins Namespace


DateOffsetSettings.Operator Property

DateOffsetSettingsOperator Property
Gets or sets the operator used to define the date offset.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateOffsetOperator Operator { get; set; }

Property Value

Type: DateOffsetOperator
See Also

Reference

DateOffsetSettings Class
Sitecore.DataExchange.Plugins Namespace


DateOffsetSettings.UnitOfTime Property

DateOffsetSettingsUnitOfTime Property
Gets or sets the unit of time that the date is offset.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public UnitOfTime UnitOfTime { get; set; }

Property Value

Type: UnitOfTime
See Also

Reference

DateOffsetSettings Class
Sitecore.DataExchange.Plugins Namespace


DateRangeSettings Class

DateRangeSettings Class
Settings that allow a date range to be specified.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsDateRangeSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DateRangeSettings : IPlugin

The DateRangeSettings type exposes the following members.

Constructors
 | Name | Description
Public method | DateRangeSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | LowerBound | The lower bound of the range of dates this plugin represents.
Public property | UpperBound | The upper bound of the range of dates this plugin represents.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


DateRangeSettings Constructor

DateRangeSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateRangeSettings()
See Also

Reference

DateRangeSettings Class
Sitecore.DataExchange.Plugins Namespace


DateRangeSettings Properties

DateRangeSettings Properties

The DateRangeSettings type exposes the following members.

Properties
 | Name | Description
Public property | LowerBound | The lower bound of the range of dates this plugin represents.
Public property | UpperBound | The upper bound of the range of dates this plugin represents.
Top
See Also

Reference

DateRangeSettings Class
Sitecore.DataExchange.Plugins Namespace


DateRangeSettings.LowerBound Property

DateRangeSettingsLowerBound Property
The lower bound of the range of dates this plugin represents.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateTime LowerBound { get; set; }

Property Value

Type: DateTime
See Also

Reference

DateRangeSettings Class
Sitecore.DataExchange.Plugins Namespace


DateRangeSettings.UpperBound Property

DateRangeSettingsUpperBound Property
The upper bound of the range of dates this plugin represents.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateTime UpperBound { get; set; }

Property Value

Type: DateTime
See Also

Reference

DateRangeSettings Class
Sitecore.DataExchange.Plugins Namespace


DateRangeSettingsHelper Class

DateRangeSettingsHelper Class

Helper class for calculating a date range and creating a DateRangeSettings object that corresponds to the range.

This type is designed to simplify the process of creating date ranges such as "from at least 1 week ago" and "up to the next month".

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsDateRangeSettingsHelper

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class DateRangeSettingsHelper

The DateRangeSettingsHelper type exposes the following members.

Constructors
 | Name | Description
Public method | DateRangeSettingsHelper | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Public method | Create(DateTime, DateOffsetOperator) | Creates a plugin that is populated to reflect the date range specified by the parameters.
Public method | Create(DateTime, DateOffsetOperator, Int32, UnitOfTime) | Creates a plugin that is populated to reflect the date range specified by the parameters.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


DateRangeSettingsHelper Constructor

DateRangeSettingsHelper Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateRangeSettingsHelper()
See Also

Reference

DateRangeSettingsHelper Class
Sitecore.DataExchange.Plugins Namespace


DateRangeSettingsHelper Methods

DateRangeSettingsHelper Methods
Methods
 | Name | Description
Public method | Create(DateTime, DateOffsetOperator) | Creates a plugin that is populated to reflect the date range specified by the parameters.
Public method | Create(DateTime, DateOffsetOperator, Int32, UnitOfTime) | Creates a plugin that is populated to reflect the date range specified by the parameters.
Top
See Also

Reference

DateRangeSettingsHelper Class
Sitecore.DataExchange.Plugins Namespace


DateRangeSettingsHelper.Create Method

DateRangeSettingsHelperCreate Method
Overload List
 | Name | Description
Public method | Create(DateTime, DateOffsetOperator) | Creates a plugin that is populated to reflect the date range specified by the parameters.
Public method | Create(DateTime, DateOffsetOperator, Int32, UnitOfTime) | Creates a plugin that is populated to reflect the date range specified by the parameters.
Top
See Also

Reference

DateRangeSettingsHelper Class
Sitecore.DataExchange.Plugins Namespace


DateRangeSettingsHelper.Create Method (DateTime, DateOffsetOperator)

DateRangeSettingsHelperCreate Method (DateTime, DateOffsetOperator)
Creates a plugin that is populated to reflect the date range specified by the parameters.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateRangeSettings Create(
    DateTime dateTime,
    DateOffsetOperator offsetOperator
)

Parameters

dateTime
Type: SystemDateTime
The date/time object that serves as the starting point for determining the date range.
offsetOperator
Type: Sitecore.DataExchange.PluginsDateOffsetOperator
Specifies how the date range is calculated.

Return Value

Type: DateRangeSettings
A plugin with that corresponds to the calculated date range.
See Also

Reference

DateRangeSettingsHelper Class
Create Overload
Sitecore.DataExchange.Plugins Namespace


DateRangeSettingsHelper.Create Method (DateTime, DateOffsetOperator, Int32, UnitOfTime)

DateRangeSettingsHelperCreate Method (DateTime, DateOffsetOperator, Int32, UnitOfTime)
Creates a plugin that is populated to reflect the date range specified by the parameters.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateRangeSettings Create(
    DateTime dateTime,
    DateOffsetOperator offsetOperator,
    int offsetValue,
    UnitOfTime offsetUnitOfTime
)

Parameters

dateTime
Type: SystemDateTime
The date/time object that serves as the starting point for determining the date range.
offsetOperator
Type: Sitecore.DataExchange.PluginsDateOffsetOperator
Specifies how the date range is calculated.
offsetValue
Type: SystemInt32
Specifies the numeric offset that is applied to dateTime. Use a negative number to use past dates.
offsetUnitOfTime
Type: Sitecore.DataExchange.PluginsUnitOfTime
Specifies the unit of time for offsetValue.

Return Value

Type: DateRangeSettings
A plugin with that corresponds to the calculated date range.
See Also

Reference

DateRangeSettingsHelper Class
Create Overload
Sitecore.DataExchange.Plugins Namespace


EndpointSettings Class

EndpointSettings Class
Settings that allow a component to identify Endpoint objects that the component can use to read data from and write data to systems.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsEndpointSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class EndpointSettings : IPlugin

The EndpointSettings type exposes the following members.

Constructors
 | Name | Description
Public method | EndpointSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | EndpointFrom | Gets or sets the endpoint from which the component can read data.
Public property | EndpointTo | Gets or sets the endpoint to which the component can write data.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


EndpointSettings Constructor

EndpointSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public EndpointSettings()
See Also

Reference

EndpointSettings Class
Sitecore.DataExchange.Plugins Namespace


EndpointSettings Properties

EndpointSettings Properties

The EndpointSettings type exposes the following members.

Properties
 | Name | Description
Public property | EndpointFrom | Gets or sets the endpoint from which the component can read data.
Public property | EndpointTo | Gets or sets the endpoint to which the component can write data.
Top
See Also

Reference

EndpointSettings Class
Sitecore.DataExchange.Plugins Namespace


EndpointSettings.EndpointFrom Property

EndpointSettingsEndpointFrom Property
Gets or sets the endpoint from which the component can read data.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Endpoint EndpointFrom { get; set; }

Property Value

Type: Endpoint
See Also

Reference

EndpointSettings Class
Sitecore.DataExchange.Plugins Namespace


EndpointSettings.EndpointTo Property

EndpointSettingsEndpointTo Property
Gets or sets the endpoint to which the component can write data.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Endpoint EndpointTo { get; set; }

Property Value

Type: Endpoint
See Also

Reference

EndpointSettings Class
Sitecore.DataExchange.Plugins Namespace


IterableDataSettings Class

IterableDataSettings Class
Settings that allow a component to have iterable data assigned.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsIterableDataSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IterableDataSettings : IPlugin

The IterableDataSettings type exposes the following members.

Constructors
 | Name | Description
Public method | IterableDataSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Data | Gets the data that can be iterated.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


IterableDataSettings Constructor

IterableDataSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IterableDataSettings(
    IEnumerable data
)

Parameters

data
Type: System.CollectionsIEnumerable

[Missing <param name="data"/> documentation for "M:Sitecore.DataExchange.Plugins.IterableDataSettings.#ctor(System.Collections.IEnumerable)"]

See Also

Reference

IterableDataSettings Class
Sitecore.DataExchange.Plugins Namespace


IterableDataSettings Properties

IterableDataSettings Properties

The IterableDataSettings type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets the data that can be iterated.
Top
See Also

Reference

IterableDataSettings Class
Sitecore.DataExchange.Plugins Namespace


IterableDataSettings.Data Property

IterableDataSettingsData Property
Gets the data that can be iterated.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable Data { get; }

Property Value

Type: IEnumerable
See Also

Reference

IterableDataSettings Class
Sitecore.DataExchange.Plugins Namespace


MappingSettings Class

MappingSettings Class
Settings that allow a component to have a IMappingSet assigned.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsMappingSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class MappingSettings : IPlugin

The MappingSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MappingSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | MappingSet | Gets or sets the mapping set.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


MappingSettings Constructor

MappingSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MappingSettings()
See Also

Reference

MappingSettings Class
Sitecore.DataExchange.Plugins Namespace


MappingSettings Properties

MappingSettings Properties

The MappingSettings type exposes the following members.

Properties
 | Name | Description
Public property | MappingSet | Gets or sets the mapping set.
Top
See Also

Reference

MappingSettings Class
Sitecore.DataExchange.Plugins Namespace


MappingSettings.MappingSet Property

MappingSettingsMappingSet Property
Gets or sets the mapping set.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IMappingSet MappingSet { get; set; }

Property Value

Type: IMappingSet
See Also

Reference

MappingSettings Class
Sitecore.DataExchange.Plugins Namespace


ParentPipelineContextSettings Class

ParentPipelineContextSettings Class
Settings that allow a component to have a parent PipelineContext.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsParentPipelineContextSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ParentPipelineContextSettings : IPlugin

The ParentPipelineContextSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ParentPipelineContextSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ParentPipelineContext | Gets or sets the context pipeline context.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


ParentPipelineContextSettings Constructor

ParentPipelineContextSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ParentPipelineContextSettings()
See Also

Reference

ParentPipelineContextSettings Class
Sitecore.DataExchange.Plugins Namespace


ParentPipelineContextSettings Properties

ParentPipelineContextSettings Properties

The ParentPipelineContextSettings type exposes the following members.

Properties
 | Name | Description
Public property | ParentPipelineContext | Gets or sets the context pipeline context.
Top
See Also

Reference

ParentPipelineContextSettings Class
Sitecore.DataExchange.Plugins Namespace


ParentPipelineContextSettings.ParentPipelineContext Property

ParentPipelineContextSettingsParentPipelineContext Property
Gets or sets the context pipeline context.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineContext ParentPipelineContext { get; set; }

Property Value

Type: PipelineContext
See Also

Reference

ParentPipelineContextSettings Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary Class

PipelineBatchSummary Class
Settings that describe how and when a pipeline batch last ran.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsPipelineBatchSummary

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineBatchSummary : IPlugin,
    IRuntimeSummary

The PipelineBatchSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineBatchSummary | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | LastRunFinished | Gets or sets a value that indicates the last time the component finished running. The default value is MinValue.
Public property | LogLevels | Gets the value that determines which log messages are written to the messages collection. This value must be set in order for any messages to be written. There is no default value.
Public property | MaxSize | Gets or sets the maximum number of messages that will be recorded in the message collection. The default value is set to DefaultMaxSize. Use a negative number to support an unlimited number of messages.
Public property | Messages | Gets a collection of messages that provide information on what happened when the pipline task was run.
Public property | RequestedAt | Gets or sets a value that indicates when a request to process the component was received.
Top
Fields
Name | Description
DefaultMaxSize | The default value used for the MaxSize property.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary Constructor

PipelineBatchSummary Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatchSummary()
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary Properties

PipelineBatchSummary Properties

The PipelineBatchSummary type exposes the following members.

Properties
 | Name | Description
Public property | LastRunFinished | Gets or sets a value that indicates the last time the component finished running. The default value is MinValue.
Public property | LogLevels | Gets the value that determines which log messages are written to the messages collection. This value must be set in order for any messages to be written. There is no default value.
Public property | MaxSize | Gets or sets the maximum number of messages that will be recorded in the message collection. The default value is set to DefaultMaxSize. Use a negative number to support an unlimited number of messages.
Public property | Messages | Gets a collection of messages that provide information on what happened when the pipline task was run.
Public property | RequestedAt | Gets or sets a value that indicates when a request to process the component was received.
Top
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary.LastRunFinished Property

PipelineBatchSummaryLastRunFinished Property

Gets or sets a value that indicates the last time the component finished running.

The default value is MinValue.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateTime LastRunFinished { get; set; }

Property Value

Type: DateTime
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary.LogLevels Property

PipelineBatchSummaryLogLevels Property

Gets the value that determines which log messages are written to the messages collection.

This value must be set in order for any messages to be written. There is no default value.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<LogLevel> LogLevels { get; }

Property Value

Type: ICollection LogLevel
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary.MaxSize Property

PipelineBatchSummaryMaxSize Property

Gets or sets the maximum number of messages that will be recorded in the message collection.

The default value is set to DefaultMaxSize. Use a negative number to support an unlimited number of messages.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int MaxSize { get; set; }

Property Value

Type: Int32
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary.Messages Property

PipelineBatchSummaryMessages Property
Gets a collection of messages that provide information on what happened when the pipline task was run.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public MessageCollection Messages { get; }

Property Value

Type: MessageCollection

Implements

IRuntimeSummaryMessages
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary.RequestedAt Property

PipelineBatchSummaryRequestedAt Property
Gets or sets a value that indicates when a request to process the component was received.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public DateTime RequestedAt { get; set; }

Property Value

Type: DateTime
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary Fields

PipelineBatchSummary Fields

The PipelineBatchSummary type exposes the following members.

Fields
Name | Description
DefaultMaxSize | The default value used for the MaxSize property.
Top
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelineBatchSummary.DefaultMaxSize Field

PipelineBatchSummaryDefaultMaxSize Field
The default value used for the MaxSize property.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public const int DefaultMaxSize = 1000

Field Value

Type: Int32
See Also

Reference

PipelineBatchSummary Class
Sitecore.DataExchange.Plugins Namespace


PipelinesSettings Class

PipelinesSettings Class

Settings that allow a component to have PipelineStep objects assigned.

An example where pipelines are used is when a component (usually a pipeline processor) reads data from an external system. The component must do something with the data it reads. Rather than hard-coding the logic into the component, a pipeline can be configured to control how the data is handled.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsPipelinesSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelinesSettings : IPlugin

The PipelinesSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PipelinesSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Pipelines | Gets the pipelines.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


PipelinesSettings Constructor

PipelinesSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelinesSettings()
See Also

Reference

PipelinesSettings Class
Sitecore.DataExchange.Plugins Namespace


PipelinesSettings Properties

PipelinesSettings Properties

The PipelinesSettings type exposes the following members.

Properties
 | Name | Description
Public property | Pipelines | Gets the pipelines.
Top
See Also

Reference

PipelinesSettings Class
Sitecore.DataExchange.Plugins Namespace


PipelinesSettings.Pipelines Property

PipelinesSettingsPipelines Property
Gets the pipelines.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<Pipeline> Pipelines { get; }

Property Value

Type: ICollection Pipeline
See Also

Reference

PipelinesSettings Class
Sitecore.DataExchange.Plugins Namespace


PipelineStepSettings Class

PipelineStepSettings Class
Settings that makes information available to pipeline steps.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsPipelineStepSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineStepSettings : IPlugin

The PipelineStepSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineStepSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ElevatedSecurityUserName | Gets or sets the name of the user on whom's behalf code may run. Certain components may include logic that must run using a specific account. This value is available to those components.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


PipelineStepSettings Constructor

PipelineStepSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineStepSettings()
See Also

Reference

PipelineStepSettings Class
Sitecore.DataExchange.Plugins Namespace


PipelineStepSettings Properties

PipelineStepSettings Properties

The PipelineStepSettings type exposes the following members.

Properties
 | Name | Description
Public property | ElevatedSecurityUserName | Gets or sets the name of the user on whom's behalf code may run. Certain components may include logic that must run using a specific account. This value is available to those components.
Top
See Also

Reference

PipelineStepSettings Class
Sitecore.DataExchange.Plugins Namespace


PipelineStepSettings.ElevatedSecurityUserName Property

PipelineStepSettingsElevatedSecurityUserName Property

Gets or sets the name of the user on whom's behalf code may run.

Certain components may include logic that must run using a specific account. This value is available to those components.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string ElevatedSecurityUserName { get; set; }

Property Value

Type: String
See Also

Reference

PipelineStepSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveIdentifierSettings Class

ResolveIdentifierSettings Class

Settings that allow a component to describe how to locate and access an identifier.

This plugin is typically used in cases where a pipeline step need to read a specific value from the pipeline context. For example, if the pipeline step is used to write data it may be necessary to determine whether or not the data already exists. This plugin would be used to specify which components to use in order to make this determination.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsResolveIdentifierSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ResolveIdentifierSettings : IPlugin

The ResolveIdentifierSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveIdentifierSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | IdentifierObjectLocation | Gets or sets the location of the object whose identifier is available. It is up to the component that uses the plugin to understand how to use this value.
Public property | IdentifierValueAccessor | Gets or sets the object that provides access to a component that can be used to read the identifier value from the identifier object and to a component that cab be used to write the resolved object to specific location.
Public property | ValueReaderToConvertIdentifierValueForComparison | Gets or sets the object used to convert the value read by the value reader set on IdentifierValueAccessor. An example of how this property is used is when a string value is read but a guid value is needed.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


ResolveIdentifierSettings Constructor

ResolveIdentifierSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ResolveIdentifierSettings()
See Also

Reference

ResolveIdentifierSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveIdentifierSettings Properties

ResolveIdentifierSettings Properties

The ResolveIdentifierSettings type exposes the following members.

Properties
 | Name | Description
Public property | IdentifierObjectLocation | Gets or sets the location of the object whose identifier is available. It is up to the component that uses the plugin to understand how to use this value.
Public property | IdentifierValueAccessor | Gets or sets the object that provides access to a component that can be used to read the identifier value from the identifier object and to a component that cab be used to write the resolved object to specific location.
Public property | ValueReaderToConvertIdentifierValueForComparison | Gets or sets the object used to convert the value read by the value reader set on IdentifierValueAccessor. An example of how this property is used is when a string value is read but a guid value is needed.
Top
See Also

Reference

ResolveIdentifierSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveIdentifierSettings.IdentifierObjectLocation Property

ResolveIdentifierSettingsIdentifierObjectLocation Property
Gets or sets the location of the object whose identifier is available. It is up to the component that uses the plugin to understand how to use this value.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string IdentifierObjectLocation { get; set; }

Property Value

Type: String
See Also

Reference

ResolveIdentifierSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveIdentifierSettings.IdentifierValueAccessor Property

ResolveIdentifierSettingsIdentifierValueAccessor Property
Gets or sets the object that provides access to a component that can be used to read the identifier value from the identifier object and to a component that cab be used to write the resolved object to specific location.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueAccessor IdentifierValueAccessor { get; set; }

Property Value

Type: IValueAccessor
See Also

Reference

ResolveIdentifierSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveIdentifierSettings.ValueReaderToConvertIdentifierValueForComparison Property

ResolveIdentifierSettingsValueReaderToConvertIdentifierValueForComparison Property

Gets or sets the object used to convert the value read by the value reader set on IdentifierValueAccessor.

An example of how this property is used is when a string value is read but a guid value is needed.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueReader ValueReaderToConvertIdentifierValueForComparison { get; set; }

Property Value

Type: IValueReader
See Also

Reference

ResolveIdentifierSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveObjectSettings Class

ResolveObjectSettings Class

Settings that are used by a component that resolves an object. These settings tell the component how to locate the object the component will resolve, and what the component should do with the object after the component has resolved it.

An example where this plugin is used is when a component has a value that identifies an object on an external system and the component must use that identifier to find the object.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsResolveObjectSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ResolveObjectSettings : IPlugin

The ResolveObjectSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveObjectSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | DoNotCreateIfObjectNotResolved | Gets or sets a value that tells the component whether or not the component should create a new object if the object the component attempts to resolve cannot be located. This setting allows you to support scenarios where new data can be created in a target system, as well as where existing data can be updated but no new data should be created.
Public property | FinishPipelineIfObjectNotResolved | Gets or sets a value that tells the component whether or not the pipeline should be finished when the object is not resolved. This value is used in cases when it is not an error when the object is not resolved, but processing cannot continue without the object.
Public property | ResolvedObjectLocation | Gets or sets the location where the component should set the object after the component has resolved the object. It is up to the component that uses the plugin to understand how to use this value.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


ResolveObjectSettings Constructor

ResolveObjectSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ResolveObjectSettings()
See Also

Reference

ResolveObjectSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveObjectSettings Properties

ResolveObjectSettings Properties

The ResolveObjectSettings type exposes the following members.

Properties
 | Name | Description
Public property | DoNotCreateIfObjectNotResolved | Gets or sets a value that tells the component whether or not the component should create a new object if the object the component attempts to resolve cannot be located. This setting allows you to support scenarios where new data can be created in a target system, as well as where existing data can be updated but no new data should be created.
Public property | FinishPipelineIfObjectNotResolved | Gets or sets a value that tells the component whether or not the pipeline should be finished when the object is not resolved. This value is used in cases when it is not an error when the object is not resolved, but processing cannot continue without the object.
Public property | ResolvedObjectLocation | Gets or sets the location where the component should set the object after the component has resolved the object. It is up to the component that uses the plugin to understand how to use this value.
Top
See Also

Reference

ResolveObjectSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveObjectSettings.DoNotCreateIfObjectNotResolved Property

ResolveObjectSettingsDoNotCreateIfObjectNotResolved Property

Gets or sets a value that tells the component whether or not the component should create a new object if the object the component attempts to resolve cannot be located.

This setting allows you to support scenarios where new data can be created in a target system, as well as where existing data can be updated but no new data should be created.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool DoNotCreateIfObjectNotResolved { get; set; }

Property Value

Type: Boolean
See Also

Reference

ResolveObjectSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveObjectSettings.FinishPipelineIfObjectNotResolved Property

ResolveObjectSettingsFinishPipelineIfObjectNotResolved Property

Gets or sets a value that tells the component whether or not the pipeline should be finished when the object is not resolved.

This value is used in cases when it is not an error when the object is not resolved, but processing cannot continue without the object.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool FinishPipelineIfObjectNotResolved { get; set; }

Property Value

Type: Boolean
See Also

Reference

ResolveObjectSettings Class
Sitecore.DataExchange.Plugins Namespace


ResolveObjectSettings.ResolvedObjectLocation Property

ResolveObjectSettingsResolvedObjectLocation Property
Gets or sets the location where the component should set the object after the component has resolved the object. It is up to the component that uses the plugin to understand how to use this value.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string ResolvedObjectLocation { get; set; }

Property Value

Type: String
See Also

Reference

ResolveObjectSettings Class
Sitecore.DataExchange.Plugins Namespace


SitecoreItemSettings Class

SitecoreItemSettings Class
Settings that make Sitecore item information available to framework components.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsSitecoreItemSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class SitecoreItemSettings : IPlugin

The SitecoreItemSettings type exposes the following members.

Constructors
 | Name | Description
Public method | SitecoreItemSettings | Initializes a new instance of the SitecoreItemSettings class
Top
Properties
 | Name | Description
Public property | ItemId | Gets or sets the ID for the Sitecore item that represents the framework component.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


SitecoreItemSettings Constructor

SitecoreItemSettings Constructor
Initializes a new instance of the SitecoreItemSettings class

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public SitecoreItemSettings()
See Also

Reference

SitecoreItemSettings Class
Sitecore.DataExchange.Plugins Namespace


SitecoreItemSettings Properties

SitecoreItemSettings Properties

The SitecoreItemSettings type exposes the following members.

Properties
 | Name | Description
Public property | ItemId | Gets or sets the ID for the Sitecore item that represents the framework component.
Top
See Also

Reference

SitecoreItemSettings Class
Sitecore.DataExchange.Plugins Namespace


SitecoreItemSettings.ItemId Property

SitecoreItemSettingsItemId Property
Gets or sets the ID for the Sitecore item that represents the framework component.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Guid ItemId { get; set; }

Property Value

Type: Guid
See Also

Reference

SitecoreItemSettings Class
Sitecore.DataExchange.Plugins Namespace


SynchronizationSettings Class

SynchronizationSettings Class
Settings that allow a component to maintain state during a synchronization process.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsSynchronizationSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class SynchronizationSettings : IPlugin

The SynchronizationSettings type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizationSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Source | Gets or sets the object from which values are read during a synchronization process.
Public property | Target | Gets or sets the object to which values are written during a synchronization process.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


SynchronizationSettings Constructor

SynchronizationSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public SynchronizationSettings()
See Also

Reference

SynchronizationSettings Class
Sitecore.DataExchange.Plugins Namespace


SynchronizationSettings Properties

SynchronizationSettings Properties

The SynchronizationSettings type exposes the following members.

Properties
 | Name | Description
Public property | Source | Gets or sets the object from which values are read during a synchronization process.
Public property | Target | Gets or sets the object to which values are written during a synchronization process.
Top
See Also

Reference

SynchronizationSettings Class
Sitecore.DataExchange.Plugins Namespace


SynchronizationSettings.Source Property

SynchronizationSettingsSource Property
Gets or sets the object from which values are read during a synchronization process.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object Source { get; set; }

Property Value

Type: Object
See Also

Reference

SynchronizationSettings Class
Sitecore.DataExchange.Plugins Namespace


SynchronizationSettings.Target Property

SynchronizationSettingsTarget Property
Gets or sets the object to which values are written during a synchronization process.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object Target { get; set; }

Property Value

Type: Object
See Also

Reference

SynchronizationSettings Class
Sitecore.DataExchange.Plugins Namespace


TelemetryActivitySettings Class

TelemetryActivitySettings Class
Settings that allow a component to control how telemetry activity is handled.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsTelemetryActivitySettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class TelemetryActivitySettings : IPlugin

The TelemetryActivitySettings type exposes the following members.

Constructors
 | Name | Description
Public method | TelemetryActivitySettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not telemetry activity is captured for the component.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


TelemetryActivitySettings Constructor

TelemetryActivitySettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public TelemetryActivitySettings()
See Also

Reference

TelemetryActivitySettings Class
Sitecore.DataExchange.Plugins Namespace


TelemetryActivitySettings Properties

TelemetryActivitySettings Properties

The TelemetryActivitySettings type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value that indicates whether or not telemetry activity is captured for the component.
Top
See Also

Reference

TelemetryActivitySettings Class
Sitecore.DataExchange.Plugins Namespace


TelemetryActivitySettings.Enabled Property

TelemetryActivitySettingsEnabled Property
Gets or sets a value that indicates whether or not telemetry activity is captured for the component.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Enabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

TelemetryActivitySettings Class
Sitecore.DataExchange.Plugins Namespace


UnitOfTime Enumeration

UnitOfTime Enumeration
Represents units of time that can be used to configure date offsets.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public enum UnitOfTime
Members
Member name | Value | Description
Unspecified | 0 | Unspecified.
Seconds | 1 | Seconds.
Minutes | 2 | Minutes.
Hours | 3 | Hours.
Days | 4 | Days.
Weeks | 5 | Weeks.
Months | 6 | Months.
Years | 7 | Years.
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


ValueAccessSettings Class

ValueAccessSettings Class
Settings that allow a component to identify a IValueAccessor object that the component can use to read and write values.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsValueAccessSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ValueAccessSettings : IPlugin

The ValueAccessSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAccessSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ValueAccessor | Gets or sets the components used to read and write values.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


ValueAccessSettings Constructor

ValueAccessSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ValueAccessSettings()
See Also

Reference

ValueAccessSettings Class
Sitecore.DataExchange.Plugins Namespace


ValueAccessSettings Properties

ValueAccessSettings Properties

The ValueAccessSettings type exposes the following members.

Properties
 | Name | Description
Public property | ValueAccessor | Gets or sets the components used to read and write values.
Top
See Also

Reference

ValueAccessSettings Class
Sitecore.DataExchange.Plugins Namespace


ValueAccessSettings.ValueAccessor Property

ValueAccessSettingsValueAccessor Property
Gets or sets the components used to read and write values.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IValueAccessor ValueAccessor { get; set; }

Property Value

Type: IValueAccessor
See Also

Reference

ValueAccessSettings Class
Sitecore.DataExchange.Plugins Namespace


WorkQueueProcessorStepSettings Class

WorkQueueProcessorStepSettings Class
Settings that allow a component to have a IWorkQueueProcessor assigned.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsWorkQueueProcessorStepSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class WorkQueueProcessorStepSettings : IPlugin

The WorkQueueProcessorStepSettings type exposes the following members.

Constructors
 | Name | Description
Public method | WorkQueueProcessorStepSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | QueueProcessor | Gets or sets the component used to handle entries in a IWorkQueue.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


WorkQueueProcessorStepSettings Constructor

WorkQueueProcessorStepSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public WorkQueueProcessorStepSettings()
See Also

Reference

WorkQueueProcessorStepSettings Class
Sitecore.DataExchange.Plugins Namespace


WorkQueueProcessorStepSettings Properties

WorkQueueProcessorStepSettings Properties

The WorkQueueProcessorStepSettings type exposes the following members.

Properties
 | Name | Description
Public property | QueueProcessor | Gets or sets the component used to handle entries in a IWorkQueue.
Top
See Also

Reference

WorkQueueProcessorStepSettings Class
Sitecore.DataExchange.Plugins Namespace


WorkQueueProcessorStepSettings.QueueProcessor Property

WorkQueueProcessorStepSettingsQueueProcessor Property
Gets or sets the component used to handle entries in a IWorkQueue.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IWorkQueueProcessor QueueProcessor { get; set; }

Property Value

Type: IWorkQueueProcessor
See Also

Reference

WorkQueueProcessorStepSettings Class
Sitecore.DataExchange.Plugins Namespace


WorkQueueSettings Class

WorkQueueSettings Class
Settings that allow a component to have a IWorkQueue assigned.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.PluginsWorkQueueSettings

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class WorkQueueSettings : IPlugin

The WorkQueueSettings type exposes the following members.

Constructors
 | Name | Description
Public method | WorkQueueSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | WorkQueue | Gets or sets the work queue that the component will use.
Top
See Also

Reference

Sitecore.DataExchange.Plugins Namespace


WorkQueueSettings Constructor

WorkQueueSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public WorkQueueSettings()
See Also

Reference

WorkQueueSettings Class
Sitecore.DataExchange.Plugins Namespace


WorkQueueSettings Properties

WorkQueueSettings Properties

The WorkQueueSettings type exposes the following members.

Properties
 | Name | Description
Public property | WorkQueue | Gets or sets the work queue that the component will use.
Top
See Also

Reference

WorkQueueSettings Class
Sitecore.DataExchange.Plugins Namespace


WorkQueueSettings.WorkQueue Property

WorkQueueSettingsWorkQueue Property
Gets or sets the work queue that the component will use.

Namespace: Sitecore.DataExchange.Plugins
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IWorkQueue WorkQueue { get; set; }

Property Value

Type: IWorkQueue
See Also

Reference

WorkQueueSettings Class
Sitecore.DataExchange.Plugins Namespace


Sitecore.DataExchange.Processors Namespace

Sitecore.DataExchange.Processors Namespace

This namespace contains processors used by framework components. Processors are used to implement business logic.

Classes
 | Class | Description
Public class | PipelineBatchProcessorEventArgs | Provides data to the events on a IPipelineBatchProcessor.
Interfaces
 | Interface | Description
Public interface | IDataExchangeProcessorTModel, TContext | Provides the ability to process a specific type of model.
Public interface | IPipelineBatchProcessor | Provides the ability to process a PipelineBatch.
Public interface | IPipelineProcessor | Provides the ability to process a Pipeline.
Public interface | IPipelineStepProcessor | Provides the ability to run a PipelineStep.
Public interface | IWorkQueueProcessor | Provides the ability to process the objects in a IWorkQueue.


IDataExchangeProcessor(TModel, TContext) Interface

IDataExchangeProcessorTModel, TContext Interface
Provides the ability to process a specific type of model.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IDataExchangeProcessor<TModel, TContext>
where TContext : IDataExchangeContext

Type Parameters

TModel
The type of the model the processor supports.
TContext
The type of the context the processor supports.

The IDataExchangeProcessorTModel, TContext type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model.
Public method | Process | Processes the specified model.
Top
See Also

Reference

Sitecore.DataExchange.Processors Namespace


IDataExchangeProcessor(TModel, TContext) Methods

IDataExchangeProcessorTModel, TContext Methods

The IDataExchangeProcessorTModel, TContext generic type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model.
Public method | Process | Processes the specified model.
Top
See Also

Reference

IDataExchangeProcessorTModel, TContext Interface
Sitecore.DataExchange.Processors Namespace


IDataExchangeProcessor(TModel, TContext).CanProcess Method

IDataExchangeProcessorTModel, TContextCanProcess Method

Gets a value that indicates whether or not the processor is able to handle the model.

The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool CanProcess(
    TModel model,
    TContext context
)

Parameters

model
Type: TModel
The object that contains the settings that control how the processor works.
context
Type: TContext
The context in which the processor will run.

Return Value

Type: Boolean
if the processor can handle the model; otherwise.
See Also

Reference

IDataExchangeProcessorTModel, TContext Interface
Sitecore.DataExchange.Processors Namespace


IDataExchangeProcessor(TModel, TContext).Process Method

IDataExchangeProcessorTModel, TContextProcess Method
Processes the specified model.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
void Process(
    TModel model,
    TContext context
)

Parameters

model
Type: TModel
The object that contains the settings that control how the processor works.
context
Type: TContext
The context in which the processor will run.
See Also

Reference

IDataExchangeProcessorTModel, TContext Interface
Sitecore.DataExchange.Processors Namespace


IPipelineBatchProcessor Interface

IPipelineBatchProcessor Interface
Provides the ability to process a PipelineBatch.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IPipelineBatchProcessor : IDataExchangeProcessor<PipelineBatch, PipelineBatchContext>

The IPipelineBatchProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Public method | Process | Processes the specified model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Top
Events
 | Name | Description
Public event | Aborted | Occurs when the pipeline batch processor is aborted due to a critical error.
Public event | Finished | Occurs when the pipeline batch processor is finished. If Aborted occurs, this event will not occur.
Public event | Started | Occurs when the pipeline batch processor is started.
Top
See Also

Reference

Sitecore.DataExchange.Processors Namespace


IPipelineBatchProcessor Methods

IPipelineBatchProcessor Methods

The IPipelineBatchProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Public method | Process | Processes the specified model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Top
See Also

Reference

IPipelineBatchProcessor Interface
Sitecore.DataExchange.Processors Namespace


IPipelineBatchProcessor Events

IPipelineBatchProcessor Events

The IPipelineBatchProcessor type exposes the following members.

Events
 | Name | Description
Public event | Aborted | Occurs when the pipeline batch processor is aborted due to a critical error.
Public event | Finished | Occurs when the pipeline batch processor is finished. If Aborted occurs, this event will not occur.
Public event | Started | Occurs when the pipeline batch processor is started.
Top
See Also

Reference

IPipelineBatchProcessor Interface
Sitecore.DataExchange.Processors Namespace


IPipelineBatchProcessor.Aborted Event

IPipelineBatchProcessorAborted Event
Occurs when the pipeline batch processor is aborted due to a critical error.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
event EventHandler<PipelineBatchProcessorEventArgs> Aborted

Value

Type: SystemEventHandler PipelineBatchProcessorEventArgs
See Also

Reference

IPipelineBatchProcessor Interface
Sitecore.DataExchange.Processors Namespace


IPipelineBatchProcessor.Finished Event

IPipelineBatchProcessorFinished Event
Occurs when the pipeline batch processor is finished. If Aborted occurs, this event will not occur.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
event EventHandler<PipelineBatchProcessorEventArgs> Finished

Value

Type: SystemEventHandler PipelineBatchProcessorEventArgs
See Also

Reference

IPipelineBatchProcessor Interface
Sitecore.DataExchange.Processors Namespace


IPipelineBatchProcessor.Started Event

IPipelineBatchProcessorStarted Event
Occurs when the pipeline batch processor is started.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
event EventHandler<PipelineBatchProcessorEventArgs> Started

Value

Type: SystemEventHandler PipelineBatchProcessorEventArgs
See Also

Reference

IPipelineBatchProcessor Interface
Sitecore.DataExchange.Processors Namespace


IPipelineProcessor Interface

IPipelineProcessor Interface
Provides the ability to process a Pipeline.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IPipelineProcessor : IDataExchangeProcessor<Pipeline, PipelineContext>

The IPipelineProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Public method | Process | Processes the specified model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Top
See Also

Reference

Sitecore.DataExchange.Processors Namespace


IPipelineProcessor Methods

IPipelineProcessor Methods

The IPipelineProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Public method | Process | Processes the specified model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Top
See Also

Reference

IPipelineProcessor Interface
Sitecore.DataExchange.Processors Namespace


IPipelineStepProcessor Interface

IPipelineStepProcessor Interface
Provides the ability to run a PipelineStep.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IPipelineStepProcessor : IDataExchangeProcessor<PipelineStep, PipelineContext>

The IPipelineStepProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Public method | Process | Processes the specified model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Top
See Also

Reference

Sitecore.DataExchange.Processors Namespace


IPipelineStepProcessor Methods

IPipelineStepProcessor Methods

The IPipelineStepProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Public method | Process | Processes the specified model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Top
See Also

Reference

IPipelineStepProcessor Interface
Sitecore.DataExchange.Processors Namespace


IWorkQueueProcessor Interface

IWorkQueueProcessor Interface
Provides the ability to process the objects in a IWorkQueue.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IWorkQueueProcessor : IDataExchangeProcessor<IWorkQueue, WorkQueueProcessorContext>

The IWorkQueueProcessor type exposes the following members.

Properties
 | Name | Description
Public property | PostProcessPipelineBatches | Gets a collection of PipelineBatch objects that are run after the entries in the work queue are processed. How, exactly, this collection of pipeline batches is used is determined by the work queue processor.
Top
Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Public method | Process | Processes the specified model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Top
See Also

Reference

Sitecore.DataExchange.Processors Namespace


IWorkQueueProcessor Properties

IWorkQueueProcessor Properties

The IWorkQueueProcessor type exposes the following members.

Properties
 | Name | Description
Public property | PostProcessPipelineBatches | Gets a collection of PipelineBatch objects that are run after the entries in the work queue are processed. How, exactly, this collection of pipeline batches is used is determined by the work queue processor.
Top
See Also

Reference

IWorkQueueProcessor Interface
Sitecore.DataExchange.Processors Namespace


IWorkQueueProcessor.PostProcessPipelineBatches Property

IWorkQueueProcessorPostProcessPipelineBatches Property
Gets a collection of PipelineBatch objects that are run after the entries in the work queue are processed. How, exactly, this collection of pipeline batches is used is determined by the work queue processor.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ICollection<PipelineBatch> PostProcessPipelineBatches { get; }

Property Value

Type: ICollection PipelineBatch
See Also

Reference

IWorkQueueProcessor Interface
Sitecore.DataExchange.Processors Namespace


IWorkQueueProcessor Methods

IWorkQueueProcessor Methods

The IWorkQueueProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. The primary logic that is implemented in this method is checking to see if the plugins that the processor depends on are set on the model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Public method | Process | Processes the specified model. (Inherited from IDataExchangeProcessorTModel, TContext.)
Top
See Also

Reference

IWorkQueueProcessor Interface
Sitecore.DataExchange.Processors Namespace


PipelineBatchProcessorEventArgs Class

PipelineBatchProcessorEventArgs Class
Provides data to the events on a IPipelineBatchProcessor.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sitecore.DataExchange.ProcessorsPipelineBatchProcessorEventArgs

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineBatchProcessorEventArgs : EventArgs

The PipelineBatchProcessorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineBatchProcessorEventArgs | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | PipelineBatch | Gets the pipeline batch being run.
Top
See Also

Reference

Sitecore.DataExchange.Processors Namespace


PipelineBatchProcessorEventArgs Constructor

PipelineBatchProcessorEventArgs Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatchProcessorEventArgs(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The pipeline batch that is being run.
See Also

Reference

PipelineBatchProcessorEventArgs Class
Sitecore.DataExchange.Processors Namespace


PipelineBatchProcessorEventArgs Properties

PipelineBatchProcessorEventArgs Properties

The PipelineBatchProcessorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PipelineBatch | Gets the pipeline batch being run.
Top
See Also

Reference

PipelineBatchProcessorEventArgs Class
Sitecore.DataExchange.Processors Namespace


PipelineBatchProcessorEventArgs.PipelineBatch Property

PipelineBatchProcessorEventArgsPipelineBatch Property
Gets the pipeline batch being run.

Namespace: Sitecore.DataExchange.Processors
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatch PipelineBatch { get; }

Property Value

Type: PipelineBatch
See Also

Reference

PipelineBatchProcessorEventArgs Class
Sitecore.DataExchange.Processors Namespace


Sitecore.DataExchange.Processors.PipelineBatches Namespace

Sitecore.DataExchange.Processors.PipelineBatches Namespace

This namespace contains implementations of IPipelineBatchProcessor.

Classes
 | Class | Description
Public class | BasePipelineBatchProcessor | Base class for pipeline batch processors that support the plugin PipelineBatchSummary.
Public class | ItemBasedPipelineBatchProcessor | A IPipelineBatchProcessor that uses a Sitecore item to store information that captures processor activity.


BasePipelineBatchProcessor Class

BasePipelineBatchProcessor Class
Base class for pipeline batch processors that support the plugin PipelineBatchSummary.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineBatchesBasePipelineBatchProcessor
Sitecore.DataExchange.Processors.PipelineBatchesItemBasedPipelineBatchProcessor

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BasePipelineBatchProcessor : IPipelineBatchProcessor,
    IDataExchangeProcessor<PipelineBatch, PipelineBatchContext>

The BasePipelineBatchProcessor type exposes the following members.

Constructors
 | Name | Description
Protected method | BasePipelineBatchProcessor | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. This method uses the values from the plugin PipelineBatchSummary to determine the return value.
Protected method | OnAborted | Raises the Aborted event.
Protected method | OnFinished | Raises the Finished event.
Protected method | OnStarted | Raises the Started event.
Public method | Process | Processes the specified model.
Top
Events
 | Name | Description
Public event | Aborted | Occurs when the pipeline batch processor is aborted due to a critical error.
Public event | Finished | Occurs when the pipeline batch processor is finished. If Aborted occurs, this event will not occur.
Public event | Started | Occurs when the pipeline batch processor is started.
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor Constructor

BasePipelineBatchProcessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BasePipelineBatchProcessor()
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor Methods

BasePipelineBatchProcessor Methods

The BasePipelineBatchProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. This method uses the values from the plugin PipelineBatchSummary to determine the return value.
Protected method | OnAborted | Raises the Aborted event.
Protected method | OnFinished | Raises the Finished event.
Protected method | OnStarted | Raises the Started event.
Public method | Process | Processes the specified model.
Top
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor.CanProcess Method

BasePipelineBatchProcessorCanProcess Method

Gets a value that indicates whether or not the processor is able to handle the model.

This method uses the values from the plugin PipelineBatchSummary to determine the return value.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool CanProcess(
    PipelineBatch pipelineBatch,
    PipelineBatchContext pipelineBatchContext
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The object that contains the settings that control how the processor works.
pipelineBatchContext
Type: Sitecore.DataExchange.ContextsPipelineBatchContext
The context in which the processor will run.

Return Value

Type: Boolean
if the processor can handle the model; otherwise.

Implements

IDataExchangeProcessorTModel, TContextCanProcess(TModel, TContext)
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor.OnAborted Method

BasePipelineBatchProcessorOnAborted Method
Raises the Aborted event.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void OnAborted(
    PipelineBatchProcessorEventArgs e
)

Parameters

e
Type: Sitecore.DataExchange.ProcessorsPipelineBatchProcessorEventArgs
The event data.
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor.OnFinished Method

BasePipelineBatchProcessorOnFinished Method
Raises the Finished event.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void OnFinished(
    PipelineBatchProcessorEventArgs e
)

Parameters

e
Type: Sitecore.DataExchange.ProcessorsPipelineBatchProcessorEventArgs
The event data.
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor.OnStarted Method

BasePipelineBatchProcessorOnStarted Method
Raises the Started event.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void OnStarted(
    PipelineBatchProcessorEventArgs e
)

Parameters

e
Type: Sitecore.DataExchange.ProcessorsPipelineBatchProcessorEventArgs
The event data.
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor.Process Method

BasePipelineBatchProcessorProcess Method

Processes the specified model.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Process(
    PipelineBatch pipelineBatch,
    PipelineBatchContext pipelineBatchContext
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The object that contains the settings that control how the processor works.
pipelineBatchContext
Type: Sitecore.DataExchange.ContextsPipelineBatchContext
The context in which the processor will run.

Implements

IDataExchangeProcessorTModel, TContextProcess(TModel, TContext)
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor Events

BasePipelineBatchProcessor Events

The BasePipelineBatchProcessor type exposes the following members.

Events
 | Name | Description
Public event | Aborted | Occurs when the pipeline batch processor is aborted due to a critical error.
Public event | Finished | Occurs when the pipeline batch processor is finished. If Aborted occurs, this event will not occur.
Public event | Started | Occurs when the pipeline batch processor is started.
Top
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor.Aborted Event

BasePipelineBatchProcessorAborted Event
Occurs when the pipeline batch processor is aborted due to a critical error.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public event EventHandler<PipelineBatchProcessorEventArgs> Aborted

Value

Type: SystemEventHandler PipelineBatchProcessorEventArgs

Implements

IPipelineBatchProcessorAborted
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor.Finished Event

BasePipelineBatchProcessorFinished Event
Occurs when the pipeline batch processor is finished. If Aborted occurs, this event will not occur.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public event EventHandler<PipelineBatchProcessorEventArgs> Finished

Value

Type: SystemEventHandler PipelineBatchProcessorEventArgs

Implements

IPipelineBatchProcessorFinished
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


BasePipelineBatchProcessor.Started Event

BasePipelineBatchProcessorStarted Event
Occurs when the pipeline batch processor is started.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public event EventHandler<PipelineBatchProcessorEventArgs> Started

Value

Type: SystemEventHandler PipelineBatchProcessorEventArgs

Implements

IPipelineBatchProcessorStarted
See Also

Reference

BasePipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


ItemBasedPipelineBatchProcessor Class

ItemBasedPipelineBatchProcessor Class
A IPipelineBatchProcessor that uses a Sitecore item to store information that captures processor activity.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineBatchesBasePipelineBatchProcessor
Sitecore.DataExchange.Processors.PipelineBatchesItemBasedPipelineBatchProcessor

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ItemBasedPipelineBatchProcessor : BasePipelineBatchProcessor

The ItemBasedPipelineBatchProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | ItemBasedPipelineBatchProcessor | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. This method uses the values from the plugin PipelineBatchSummary to determine the return value. (Inherited from BasePipelineBatchProcessor.)
Protected method | OnAborted | Raises the Aborted event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor finished running. (Overrides BasePipelineBatchProcessorOnAborted(PipelineBatchProcessorEventArgs).)
Protected method | OnFinished | Raises the Finished event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor finished running. (Overrides BasePipelineBatchProcessorOnFinished(PipelineBatchProcessorEventArgs).)
Protected method | OnStarted | Raises the Started event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor was started. (Overrides BasePipelineBatchProcessorOnStarted(PipelineBatchProcessorEventArgs).)
Public method | Process | Processes the specified model. (Inherited from BasePipelineBatchProcessor.)
Top
Events
 | Name | Description
Public event | Aborted | Occurs when the pipeline batch processor is aborted due to a critical error. (Inherited from BasePipelineBatchProcessor.)
Public event | Finished | Occurs when the pipeline batch processor is finished. If Aborted occurs, this event will not occur. (Inherited from BasePipelineBatchProcessor.)
Public event | Started | Occurs when the pipeline batch processor is started. (Inherited from BasePipelineBatchProcessor.)
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineBatches Namespace


ItemBasedPipelineBatchProcessor Constructor

ItemBasedPipelineBatchProcessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ItemBasedPipelineBatchProcessor()
See Also

Reference

ItemBasedPipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


ItemBasedPipelineBatchProcessor Methods

ItemBasedPipelineBatchProcessor Methods

The ItemBasedPipelineBatchProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the model. This method uses the values from the plugin PipelineBatchSummary to determine the return value. (Inherited from BasePipelineBatchProcessor.)
Protected method | OnAborted | Raises the Aborted event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor finished running. (Overrides BasePipelineBatchProcessorOnAborted(PipelineBatchProcessorEventArgs).)
Protected method | OnFinished | Raises the Finished event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor finished running. (Overrides BasePipelineBatchProcessorOnFinished(PipelineBatchProcessorEventArgs).)
Protected method | OnStarted | Raises the Started event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor was started. (Overrides BasePipelineBatchProcessorOnStarted(PipelineBatchProcessorEventArgs).)
Public method | Process | Processes the specified model. (Inherited from BasePipelineBatchProcessor.)
Top
See Also

Reference

ItemBasedPipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


ItemBasedPipelineBatchProcessor.OnAborted Method

ItemBasedPipelineBatchProcessorOnAborted Method
Raises the Aborted event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor finished running.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void OnAborted(
    PipelineBatchProcessorEventArgs e
)

Parameters

e
Type: Sitecore.DataExchange.ProcessorsPipelineBatchProcessorEventArgs
The event data.
See Also

Reference

ItemBasedPipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


ItemBasedPipelineBatchProcessor.OnFinished Method

ItemBasedPipelineBatchProcessorOnFinished Method
Raises the Finished event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor finished running.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void OnFinished(
    PipelineBatchProcessorEventArgs e
)

Parameters

e
Type: Sitecore.DataExchange.ProcessorsPipelineBatchProcessorEventArgs
The event data.
See Also

Reference

ItemBasedPipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


ItemBasedPipelineBatchProcessor.OnStarted Method

ItemBasedPipelineBatchProcessorOnStarted Method
Raises the Started event and updates a field on the Sitecore item that represents the pipeline batch with the date/time when the processor was started.

Namespace: Sitecore.DataExchange.Processors.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void OnStarted(
    PipelineBatchProcessorEventArgs e
)

Parameters

e
Type: Sitecore.DataExchange.ProcessorsPipelineBatchProcessorEventArgs
The event data.
See Also

Reference

ItemBasedPipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


ItemBasedPipelineBatchProcessor Events

ItemBasedPipelineBatchProcessor Events

The ItemBasedPipelineBatchProcessor type exposes the following members.

Events
 | Name | Description
Public event | Aborted | Occurs when the pipeline batch processor is aborted due to a critical error. (Inherited from BasePipelineBatchProcessor.)
Public event | Finished | Occurs when the pipeline batch processor is finished. If Aborted occurs, this event will not occur. (Inherited from BasePipelineBatchProcessor.)
Public event | Started | Occurs when the pipeline batch processor is started. (Inherited from BasePipelineBatchProcessor.)
Top
See Also

Reference

ItemBasedPipelineBatchProcessor Class
Sitecore.DataExchange.Processors.PipelineBatches Namespace


Sitecore.DataExchange.Processors.Pipelines Namespace

Sitecore.DataExchange.Processors.Pipelines Namespace

This namespace contains implementations of IPipelineProcessor.

Classes
 | Class | Description
Public class | PipelineProcessor | Provides the ability to process a Pipeline.


PipelineProcessor Class

PipelineProcessor Class
Provides the ability to process a Pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelinesPipelineProcessor

Namespace: Sitecore.DataExchange.Processors.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineProcessor : IPipelineProcessor,
    IDataExchangeProcessor<Pipeline, PipelineContext>

The PipelineProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineProcessor | Initializes a new instance of the PipelineProcessor class
Top
Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the Pipeline. The default implementation checks to see whether or not the pipeline is enabled.
Protected method | OnCriticalError | This method is called when a critical error is reported in the pipeline context. By default this method sets the critical error flag on the PipelineBatchContext.
Public method | Process | Processes the specified Pipeline.
Protected method | ProcessPipelineStep | Processes the specified PipelineStep.
Top
See Also

Reference

Sitecore.DataExchange.Processors.Pipelines Namespace


PipelineProcessor Constructor

PipelineProcessor Constructor
Initializes a new instance of the PipelineProcessor class

Namespace: Sitecore.DataExchange.Processors.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineProcessor()
See Also

Reference

PipelineProcessor Class
Sitecore.DataExchange.Processors.Pipelines Namespace


PipelineProcessor Methods

PipelineProcessor Methods

The PipelineProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the Pipeline. The default implementation checks to see whether or not the pipeline is enabled.
Protected method | OnCriticalError | This method is called when a critical error is reported in the pipeline context. By default this method sets the critical error flag on the PipelineBatchContext.
Public method | Process | Processes the specified Pipeline.
Protected method | ProcessPipelineStep | Processes the specified PipelineStep.
Top
See Also

Reference

PipelineProcessor Class
Sitecore.DataExchange.Processors.Pipelines Namespace


PipelineProcessor.CanProcess Method

PipelineProcessorCanProcess Method

Gets a value that indicates whether or not the processor is able to handle the Pipeline.

The default implementation checks to see whether or not the pipeline is enabled.

Namespace: Sitecore.DataExchange.Processors.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool CanProcess(
    Pipeline pipeline,
    PipelineContext pipelineContext
)

Parameters

pipeline
Type: Sitecore.DataExchange.ModelsPipeline
The pipeline that will be processed.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: Boolean
if the processor can handle the pipeline; otherwise.

Implements

IDataExchangeProcessorTModel, TContextCanProcess(TModel, TContext)
See Also

Reference

PipelineProcessor Class
Sitecore.DataExchange.Processors.Pipelines Namespace


PipelineProcessor.OnCriticalError Method

PipelineProcessorOnCriticalError Method

This method is called when a critical error is reported in the pipeline context.

By default this method sets the critical error flag on the PipelineBatchContext.

Namespace: Sitecore.DataExchange.Processors.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void OnCriticalError(
    PipelineStep errorStep,
    IEnumerable<PipelineStep> completedSteps,
    Pipeline pipeline,
    PipelineContext pipelineContext
)

Parameters

errorStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The pipeline step that experienced the error.
completedSteps
Type: System.Collections.GenericIEnumerable PipelineStep
Collection of pipeline steps that were completed successfully before the critical error occurred.
pipeline
Type: Sitecore.DataExchange.ModelsPipeline
The pipeline that was being processed when the critical error occurred.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The pipeline context that was used when the critical error occurred.
See Also

Reference

PipelineProcessor Class
Sitecore.DataExchange.Processors.Pipelines Namespace


PipelineProcessor.Process Method

PipelineProcessorProcess Method
Processes the specified Pipeline.

Namespace: Sitecore.DataExchange.Processors.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual void Process(
    Pipeline pipeline,
    PipelineContext pipelineContext
)

Parameters

pipeline
Type: Sitecore.DataExchange.ModelsPipeline
The pipeline to process.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Implements

IDataExchangeProcessorTModel, TContextProcess(TModel, TContext)
See Also

Reference

PipelineProcessor Class
Sitecore.DataExchange.Processors.Pipelines Namespace


PipelineProcessor.ProcessPipelineStep Method

PipelineProcessorProcessPipelineStep Method
Processes the specified PipelineStep.

Namespace: Sitecore.DataExchange.Processors.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual bool ProcessPipelineStep(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The pipeline step to process.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sitecore.DataExchange.Processors.Pipelines.PipelineProcessor.ProcessPipelineStep(Sitecore.DataExchange.Models.PipelineStep,Sitecore.DataExchange.Contexts.PipelineContext)"]

See Also

Reference

PipelineProcessor Class
Sitecore.DataExchange.Processors.Pipelines Namespace


Sitecore.DataExchange.Processors.PipelineSteps Namespace

Sitecore.DataExchange.Processors.PipelineSteps Namespace

This namespace contains implementations of IPipelineStepProcessor.

Classes
 | Class | Description
Public class | ApplyMappingStepProcessor | Pipeline step processor that run a IMappingSet using the source and target objects specified on a MappingContext.
Public class | BasePipelineStepProcessor | Base type for pipeline step processors. This type implements basic validation logic and convenience methods.
Public class | BasePipelineStepWithEndpointsProcessor | Base type for pipeline step processors that use endpoints. This type implements basic validation logic and convenience methods.
Public class | BaseReadDataStepProcessor | Base type for pipeline step processors that read data. This type implements basic validation logic and convenience methods.
Public class | BaseResolveObjectFromEndpointStepProcessorT | Base type for pipeline step processors that resolve objects from Endpoint. This type implements basic validation logic and convenience methods.
Public class | BaseResolveObjectFromQueueStepProcessorT | Base type for pipeline step processors that resolve objects from a IWorkQueue. This type implements basic validation logic and convenience methods.
Public class | IterateAndRunPipelinesStepProcessor | Iterates a collection of objects and, for each object, passes the object to a set of other pipelines.
Public class | ProcessQueueStepProcessor | Processes the entries in a IWorkQueue.


ApplyMappingStepProcessor Class

ApplyMappingStepProcessor Class
Pipeline step processor that run a IMappingSet using the source and target objects specified on a MappingContext.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsApplyMappingStepProcessor

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ApplyMappingStepProcessor : BasePipelineStepProcessor

The ApplyMappingStepProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | ApplyMappingStepProcessor | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Public method | Process | Applies the IMappingSet to the source and target objects set on the pipeline context. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineSteps Namespace


ApplyMappingStepProcessor Constructor

ApplyMappingStepProcessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ApplyMappingStepProcessor()
See Also

Reference

ApplyMappingStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


ApplyMappingStepProcessor Methods

ApplyMappingStepProcessor Methods

The ApplyMappingStepProcessor type exposes the following members.

Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Public method | Process | Applies the IMappingSet to the source and target objects set on the pipeline context. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Top
See Also

Reference

ApplyMappingStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


ApplyMappingStepProcessor.Process Method

ApplyMappingStepProcessorProcess Method
Applies the IMappingSet to the source and target objects set on the pipeline context.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override void Process(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context with the source and target objects specified.

Implements

IDataExchangeProcessorTModel, TContextProcess(TModel, TContext)
See Also

Reference

ApplyMappingStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepProcessor Class

BasePipelineStepProcessor Class
Base type for pipeline step processors. This type implements basic validation logic and convenience methods.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsApplyMappingStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepWithEndpointsProcessor
Sitecore.DataExchange.Processors.PipelineStepsIterateAndRunPipelinesStepProcessor

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BasePipelineStepProcessor : IPipelineStepProcessor,
    IDataExchangeProcessor<PipelineStep, PipelineContext>

The BasePipelineStepProcessor type exposes the following members.

Constructors
 | Name | Description
Protected method | BasePipelineStepProcessor | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor.
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled.
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object.
Public method | Process | Processes the specified PipelineStep.
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepProcessor Constructor

BasePipelineStepProcessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BasePipelineStepProcessor()
See Also

Reference

BasePipelineStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepProcessor Methods

BasePipelineStepProcessor Methods

The BasePipelineStepProcessor type exposes the following members.

Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor.
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled.
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object.
Public method | Process | Processes the specified PipelineStep.
Top
See Also

Reference

BasePipelineStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepProcessor.AreRequiredPluginsSet Method

BasePipelineStepProcessorAreRequiredPluginsSet Method

Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext.

The default implementation uses attributes that are set on the BasePipelineStepProcessor.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual bool AreRequiredPluginsSet(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The pipeline step whose plugins are checked.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The pipeline context whose plugins are checked.

Return Value

Type: Boolean
if the required plugins are set; otherwise.
See Also

Reference

BasePipelineStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepProcessor.CanProcess Method

BasePipelineStepProcessorCanProcess Method

Gets a value that indicates whether or not the processor is able to handle the pipeline step.

The primary logic that is implemented in this method is checking to see if the pipeline step is enabled.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool CanProcess(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: Boolean
if the processor can handle the pipeline step; otherwise.

Implements

IDataExchangeProcessorTModel, TContextCanProcess(TModel, TContext)
Exceptions
Exception | Condition
ArgumentNullException | pipelineStep is null.
ArgumentNullException | pipelineContext is null.
See Also

Reference

BasePipelineStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepProcessor.GetMissingRequiredPlugin(T) Method

BasePipelineStepProcessorGetMissingRequiredPluginT Method
Gets a collection of the plugins that are required but missing from the specified object.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IEnumerable<Type> GetMissingRequiredPlugin<T>(
    IHasPlugins obj
)
where T : BaseRequiredPluginsAttribute

Parameters

obj
Type: Sitecore.DataExchangeIHasPlugins
The object that must have the plugins assigned.

Type Parameters

T
Attribute type that identifies the required plugins.

Return Value

Type: IEnumerable Type
A collection of the plugin types that are missing.
See Also

Reference

BasePipelineStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepProcessor.Process Method

BasePipelineStepProcessorProcess Method
Processes the specified PipelineStep.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract void Process(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Implements

IDataExchangeProcessorTModel, TContextProcess(TModel, TContext)
See Also

Reference

BasePipelineStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepWithEndpointsProcessor Class

BasePipelineStepWithEndpointsProcessor Class
Base type for pipeline step processors that use endpoints. This type implements basic validation logic and convenience methods.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepWithEndpointsProcessor
Sitecore.DataExchange.Processors.PipelineStepsBaseReadDataStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsBaseResolveObjectFromEndpointStepProcessorT
Sitecore.DataExchange.Processors.PipelineStepsProcessQueueStepProcessor

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BasePipelineStepWithEndpointsProcessor : BasePipelineStepProcessor

The BasePipelineStepWithEndpointsProcessor type exposes the following members.

Constructors
 | Name | Description
Protected method | BasePipelineStepWithEndpointsProcessor | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint.
Public method | Process | Processes the specified PipelineStep. (Inherited from BasePipelineStepProcessor.)
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepWithEndpointsProcessor Constructor

BasePipelineStepWithEndpointsProcessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BasePipelineStepWithEndpointsProcessor()
See Also

Reference

BasePipelineStepWithEndpointsProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepWithEndpointsProcessor Methods

BasePipelineStepWithEndpointsProcessor Methods

The BasePipelineStepWithEndpointsProcessor type exposes the following members.

Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint.
Public method | Process | Processes the specified PipelineStep. (Inherited from BasePipelineStepProcessor.)
Top
See Also

Reference

BasePipelineStepWithEndpointsProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BasePipelineStepWithEndpointsProcessor.IsEndpointValid Method

BasePipelineStepWithEndpointsProcessorIsEndpointValid Method
Gets a value that indicates whether or not the processor can read data from the specified endpoint.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual bool IsEndpointValid(
    Endpoint endpoint,
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
The endpoint to check.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: Boolean
if the endpoint is value; otherwise.
See Also

Reference

BasePipelineStepWithEndpointsProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseReadDataStepProcessor Class

BaseReadDataStepProcessor Class
Base type for pipeline step processors that read data. This type implements basic validation logic and convenience methods.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepWithEndpointsProcessor
Sitecore.DataExchange.Processors.PipelineStepsBaseReadDataStepProcessor

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BaseReadDataStepProcessor : BasePipelineStepWithEndpointsProcessor

The BaseReadDataStepProcessor type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseReadDataStepProcessor | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint. (Inherited from BasePipelineStepWithEndpointsProcessor.)
Public method | Process | Reads data from the Endpoint assigned to the pipeline step. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Protected method | ReadData | Reads data from the specified endpoint. It is up to the implementation of this method to determine what to do with the data that is read.
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseReadDataStepProcessor Constructor

BaseReadDataStepProcessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BaseReadDataStepProcessor()
See Also

Reference

BaseReadDataStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseReadDataStepProcessor Methods

BaseReadDataStepProcessor Methods

The BaseReadDataStepProcessor type exposes the following members.

Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint. (Inherited from BasePipelineStepWithEndpointsProcessor.)
Public method | Process | Reads data from the Endpoint assigned to the pipeline step. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Protected method | ReadData | Reads data from the specified endpoint. It is up to the implementation of this method to determine what to do with the data that is read.
Top
See Also

Reference

BaseReadDataStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseReadDataStepProcessor.Process Method

BaseReadDataStepProcessorProcess Method
Reads data from the Endpoint assigned to the pipeline step.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override void Process(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Implements

IDataExchangeProcessorTModel, TContextProcess(TModel, TContext)
See Also

Reference

BaseReadDataStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseReadDataStepProcessor.ReadData Method

BaseReadDataStepProcessorReadData Method
Reads data from the specified endpoint. It is up to the implementation of this method to determine what to do with the data that is read.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected abstract void ReadData(
    Endpoint endpoint,
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
The endpoint to check.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.
See Also

Reference

BaseReadDataStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepProcessor(T) Class

BaseResolveObjectFromEndpointStepProcessorT Class
Base type for pipeline step processors that resolve objects from Endpoint. This type implements basic validation logic and convenience methods.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepWithEndpointsProcessor
Sitecore.DataExchange.Processors.PipelineStepsBaseResolveObjectFromEndpointStepProcessorT
Sitecore.DataExchange.Processors.PipelineStepsBaseResolveObjectFromQueueStepProcessorT

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BaseResolveObjectFromEndpointStepProcessor<T> : BasePipelineStepWithEndpointsProcessor

Type Parameters

T
The type of object that is resolved.

The BaseResolveObjectFromEndpointStepProcessorT type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseResolveObjectFromEndpointStepProcessorT | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetIdentifierObject | Gets the object whose identifier is used to read an object from the endpoint.
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint. (Inherited from BasePipelineStepWithEndpointsProcessor.)
Public method | Process | Resolves an object from the Endpoint set on the pipeline step. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Protected method | ResolveObject | Resolves an object from the specified endpoint that matches the specified identifier value.
Protected method | StoreResolvedObject | Stores the resolved object in the location determined by the pipeline step and/or the pipeline context.
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepProcessor(T) Constructor

BaseResolveObjectFromEndpointStepProcessorT Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BaseResolveObjectFromEndpointStepProcessor()
See Also

Reference

BaseResolveObjectFromEndpointStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepProcessor(T) Methods

BaseResolveObjectFromEndpointStepProcessorT Methods

The BaseResolveObjectFromEndpointStepProcessorT generic type exposes the following members.

Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetIdentifierObject | Gets the object whose identifier is used to read an object from the endpoint.
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint. (Inherited from BasePipelineStepWithEndpointsProcessor.)
Public method | Process | Resolves an object from the Endpoint set on the pipeline step. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Protected method | ResolveObject | Resolves an object from the specified endpoint that matches the specified identifier value.
Protected method | StoreResolvedObject | Stores the resolved object in the location determined by the pipeline step and/or the pipeline context.
Top
See Also

Reference

BaseResolveObjectFromEndpointStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepProcessor(T).GetIdentifierObject Method

BaseResolveObjectFromEndpointStepProcessorTGetIdentifierObject Method
Gets the object whose identifier is used to read an object from the endpoint.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected Object GetIdentifierObject(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: Object
The object whose identifier will be used; if no object could be determined.
See Also

Reference

BaseResolveObjectFromEndpointStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepProcessor(T).Process Method

BaseResolveObjectFromEndpointStepProcessorTProcess Method
Resolves an object from the Endpoint set on the pipeline step.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override void Process(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Implements

IDataExchangeProcessorTModel, TContextProcess(TModel, TContext)
See Also

Reference

BaseResolveObjectFromEndpointStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepProcessor(T).ResolveObject Method

BaseResolveObjectFromEndpointStepProcessorTResolveObject Method
Resolves an object from the specified endpoint that matches the specified identifier value.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected abstract T ResolveObject(
    string identifierValue,
    Endpoint endpoint,
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

identifierValue
Type: SystemString
The value used to read an object from the endpoint.
endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
The endpoint from which the object is read.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: T
The object that is read from the endpoint.
See Also

Reference

BaseResolveObjectFromEndpointStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromEndpointStepProcessor(T).StoreResolvedObject Method

BaseResolveObjectFromEndpointStepProcessorTStoreResolvedObject Method
Stores the resolved object in the location determined by the pipeline step and/or the pipeline context.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual bool StoreResolvedObject(
    T resolvedObject,
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

resolvedObject
Type: T
The object to store.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: Boolean
if the resolved object was stored; otherwise.
See Also

Reference

BaseResolveObjectFromEndpointStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromQueueStepProcessor(T) Class

BaseResolveObjectFromQueueStepProcessorT Class
Base type for pipeline step processors that resolve objects from a IWorkQueue. This type implements basic validation logic and convenience methods.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepWithEndpointsProcessor
Sitecore.DataExchange.Processors.PipelineStepsBaseResolveObjectFromEndpointStepProcessor T
Sitecore.DataExchange.Processors.PipelineStepsBaseResolveObjectFromQueueStepProcessorT

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BaseResolveObjectFromQueueStepProcessor<T> : BaseResolveObjectFromEndpointStepProcessor<T>

Type Parameters

T
The type of object that is resolved.

The BaseResolveObjectFromQueueStepProcessorT type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseResolveObjectFromQueueStepProcessorT | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | ConvertIdentifierObjectToQueueObject | Reads the identifier object from the pipeline step and/or pipeline context and converts that object into an object that is compatible with the support IWorkQueue.
Protected method | GetIdentifierObject | Gets the object whose identifier is used to read an object from the endpoint. (Inherited from BaseResolveObjectFromEndpointStepProcessorT.)
Protected method | GetKeyForQueueObject | Gets the key that is used to access the specified entry from the work queue.
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint. (Inherited from BasePipelineStepWithEndpointsProcessor.)
Public method | Process | Resolves an object from the Endpoint set on the pipeline step. (Inherited from BaseResolveObjectFromEndpointStepProcessorT.)
Protected method | ResolveObject | Resolves an object from a IWorkQueue access from the specified endpoint that matches the specified identifier value. (Overrides BaseResolveObjectFromEndpointStepProcessorTResolveObject(String, Endpoint, PipelineStep, PipelineContext).)
Protected method | StoreResolvedObject | Stores the resolved object in the location determined by the pipeline step and/or the pipeline context. (Inherited from BaseResolveObjectFromEndpointStepProcessorT.)
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromQueueStepProcessor(T) Constructor

BaseResolveObjectFromQueueStepProcessorT Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BaseResolveObjectFromQueueStepProcessor()
See Also

Reference

BaseResolveObjectFromQueueStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromQueueStepProcessor(T) Methods

BaseResolveObjectFromQueueStepProcessorT Methods

The BaseResolveObjectFromQueueStepProcessorT generic type exposes the following members.

Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | ConvertIdentifierObjectToQueueObject | Reads the identifier object from the pipeline step and/or pipeline context and converts that object into an object that is compatible with the support IWorkQueue.
Protected method | GetIdentifierObject | Gets the object whose identifier is used to read an object from the endpoint. (Inherited from BaseResolveObjectFromEndpointStepProcessorT.)
Protected method | GetKeyForQueueObject | Gets the key that is used to access the specified entry from the work queue.
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint. (Inherited from BasePipelineStepWithEndpointsProcessor.)
Public method | Process | Resolves an object from the Endpoint set on the pipeline step. (Inherited from BaseResolveObjectFromEndpointStepProcessorT.)
Protected method | ResolveObject | Resolves an object from a IWorkQueue access from the specified endpoint that matches the specified identifier value. (Overrides BaseResolveObjectFromEndpointStepProcessorTResolveObject(String, Endpoint, PipelineStep, PipelineContext).)
Protected method | StoreResolvedObject | Stores the resolved object in the location determined by the pipeline step and/or the pipeline context. (Inherited from BaseResolveObjectFromEndpointStepProcessorT.)
Top
See Also

Reference

BaseResolveObjectFromQueueStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromQueueStepProcessor(T).ConvertIdentifierObjectToQueueObject Method

BaseResolveObjectFromQueueStepProcessorTConvertIdentifierObjectToQueueObject Method
Reads the identifier object from the pipeline step and/or pipeline context and converts that object into an object that is compatible with the support IWorkQueue.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected abstract T ConvertIdentifierObjectToQueueObject(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: T
An object that is compatible with the supported IWorkQueue.
See Also

Reference

BaseResolveObjectFromQueueStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromQueueStepProcessor(T).GetKeyForQueueObject Method

BaseResolveObjectFromQueueStepProcessorTGetKeyForQueueObject Method
Gets the key that is used to access the specified entry from the work queue.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected abstract Object GetKeyForQueueObject(
    T entry
)

Parameters

entry
Type: T
The entry in the work queue.

Return Value

Type: Object
The key used to access the specified entry from the work queue.
See Also

Reference

BaseResolveObjectFromQueueStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


BaseResolveObjectFromQueueStepProcessor(T).ResolveObject Method

BaseResolveObjectFromQueueStepProcessorTResolveObject Method
Resolves an object from a IWorkQueue access from the specified endpoint that matches the specified identifier value.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override T ResolveObject(
    string identifierValue,
    Endpoint endpoint,
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

identifierValue
Type: SystemString
The value used to read an object from the endpoint.
endpoint
Type: Sitecore.DataExchange.ModelsEndpoint
The endpoint from which the object is read.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Return Value

Type: T
The object that is read from the work queue.
See Also

Reference

BaseResolveObjectFromQueueStepProcessorT Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


IterateAndRunPipelinesStepProcessor Class

IterateAndRunPipelinesStepProcessor Class
Iterates a collection of objects and, for each object, passes the object to a set of other pipelines.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsIterateAndRunPipelinesStepProcessor

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class IterateAndRunPipelinesStepProcessor : BasePipelineStepProcessor

The IterateAndRunPipelinesStepProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | IterateAndRunPipelinesStepProcessor | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | OnCriticalError | This method is called when a critical error is reported in the pipeline context. By default this method does nothing. Classes that inherit from this type can override this method.
Public method | Process | Iterates a collection of objects set on the pipeline context and passes each object to a set of pipelines. For each object, a new PipelineContext is created, a new SynchronizationSettings plugin is added to the new pipeline context, the object is added as the source object to the new pipeline context. Then the collection of pipelines set on a plugin on the pipeline step is iterated. Each pipeline is run using the new pipeline context. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Protected method | ProcessPipelines | Runs each of the specified sub-pipelines using the specified pipeline context.
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineSteps Namespace


IterateAndRunPipelinesStepProcessor Constructor

IterateAndRunPipelinesStepProcessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IterateAndRunPipelinesStepProcessor()
See Also

Reference

IterateAndRunPipelinesStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


IterateAndRunPipelinesStepProcessor Methods

IterateAndRunPipelinesStepProcessor Methods

The IterateAndRunPipelinesStepProcessor type exposes the following members.

Methods
 | Name | Description
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | OnCriticalError | This method is called when a critical error is reported in the pipeline context. By default this method does nothing. Classes that inherit from this type can override this method.
Public method | Process | Iterates a collection of objects set on the pipeline context and passes each object to a set of pipelines. For each object, a new PipelineContext is created, a new SynchronizationSettings plugin is added to the new pipeline context, the object is added as the source object to the new pipeline context. Then the collection of pipelines set on a plugin on the pipeline step is iterated. Each pipeline is run using the new pipeline context. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Protected method | ProcessPipelines | Runs each of the specified sub-pipelines using the specified pipeline context.
Top
See Also

Reference

IterateAndRunPipelinesStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


IterateAndRunPipelinesStepProcessor.OnCriticalError Method

IterateAndRunPipelinesStepProcessorOnCriticalError Method

This method is called when a critical error is reported in the pipeline context.

By default this method does nothing. Classes that inherit from this type can override this method.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void OnCriticalError(
    Pipeline errorPipeline,
    IEnumerable<Pipeline> completedPipelines,
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

errorPipeline
Type: Sitecore.DataExchange.ModelsPipeline
The pipeline that experienced the error.
completedPipelines
Type: System.Collections.GenericIEnumerable Pipeline
Collection of pipelines that were completed successfully before the critical error occurred.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The pipeline step that was being processed when the critical error occurred.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The pipeline context that was used when the critical error occurred.
See Also

Reference

IterateAndRunPipelinesStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


IterateAndRunPipelinesStepProcessor.Process Method

IterateAndRunPipelinesStepProcessorProcess Method

Iterates a collection of objects set on the pipeline context and passes each object to a set of pipelines.

For each object, a new PipelineContext is created, a new SynchronizationSettings plugin is added to the new pipeline context, the object is added as the source object to the new pipeline context.

Then the collection of pipelines set on a plugin on the pipeline step is iterated. Each pipeline is run using the new pipeline context.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override void Process(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Implements

IDataExchangeProcessorTModel, TContextProcess(TModel, TContext)
See Also

Reference

IterateAndRunPipelinesStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


IterateAndRunPipelinesStepProcessor.ProcessPipelines Method

IterateAndRunPipelinesStepProcessorProcessPipelines Method
Runs each of the specified sub-pipelines using the specified pipeline context.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void ProcessPipelines(
    PipelineStep pipelineStep,
    ICollection<Pipeline> subPipelines,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
subPipelines
Type: System.Collections.GenericICollection Pipeline
The sub-pipelines that this method runs.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context that is used when the sub-pipelines are run.
See Also

Reference

IterateAndRunPipelinesStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


ProcessQueueStepProcessor Class

ProcessQueueStepProcessor Class
Processes the entries in a IWorkQueue.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepProcessor
Sitecore.DataExchange.Processors.PipelineStepsBasePipelineStepWithEndpointsProcessor
Sitecore.DataExchange.Processors.PipelineStepsProcessQueueStepProcessor

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ProcessQueueStepProcessor : BasePipelineStepWithEndpointsProcessor

The ProcessQueueStepProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessQueueStepProcessor | Initializes a new instance of the class.
Top
Methods
 | Name | Description
Protected method | AddPluginsToProcessorContext | Adds plugins to the specified WorkQueueProcessorContext. These plugins are available to the IWorkQueueProcessor that is used by Process(PipelineStep, PipelineContext).
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint. (Inherited from BasePipelineStepWithEndpointsProcessor.)
Public method | Process | Runs the specified IWorkQueueProcessor against the specified IWorkQueue. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Top
See Also

Reference

Sitecore.DataExchange.Processors.PipelineSteps Namespace


ProcessQueueStepProcessor Constructor

ProcessQueueStepProcessor Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ProcessQueueStepProcessor()
See Also

Reference

ProcessQueueStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


ProcessQueueStepProcessor Methods

ProcessQueueStepProcessor Methods

The ProcessQueueStepProcessor type exposes the following members.

Methods
 | Name | Description
Protected method | AddPluginsToProcessorContext | Adds plugins to the specified WorkQueueProcessorContext. These plugins are available to the IWorkQueueProcessor that is used by Process(PipelineStep, PipelineContext).
Protected method | AreRequiredPluginsSet | Gets a value that indicates whether or not the require plugins are set on the specified PipelineStep and PipelineContext. The default implementation uses attributes that are set on the BasePipelineStepProcessor. (Inherited from BasePipelineStepProcessor.)
Public method | CanProcess | Gets a value that indicates whether or not the processor is able to handle the pipeline step. The primary logic that is implemented in this method is checking to see if the pipeline step is enabled. (Inherited from BasePipelineStepProcessor.)
Protected method | GetMissingRequiredPluginT | Gets a collection of the plugins that are required but missing from the specified object. (Inherited from BasePipelineStepProcessor.)
Protected method | IsEndpointValid | Gets a value that indicates whether or not the processor can read data from the specified endpoint. (Inherited from BasePipelineStepWithEndpointsProcessor.)
Public method | Process | Runs the specified IWorkQueueProcessor against the specified IWorkQueue. (Overrides BasePipelineStepProcessorProcess(PipelineStep, PipelineContext).)
Top
See Also

Reference

ProcessQueueStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


ProcessQueueStepProcessor.AddPluginsToProcessorContext Method

ProcessQueueStepProcessorAddPluginsToProcessorContext Method
Adds plugins to the specified WorkQueueProcessorContext. These plugins are available to the IWorkQueueProcessor that is used by Process(PipelineStep, PipelineContext).

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void AddPluginsToProcessorContext(
    WorkQueueProcessorContext processorContext,
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

processorContext
Type: Sitecore.DataExchange.ContextsWorkQueueProcessorContext
The context to which the plugins will be added.
pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.
See Also

Reference

ProcessQueueStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


ProcessQueueStepProcessor.Process Method

ProcessQueueStepProcessorProcess Method
Runs the specified IWorkQueueProcessor against the specified IWorkQueue.

Namespace: Sitecore.DataExchange.Processors.PipelineSteps
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override void Process(
    PipelineStep pipelineStep,
    PipelineContext pipelineContext
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The object that contains the settings that control how the processor works.
pipelineContext
Type: Sitecore.DataExchange.ContextsPipelineContext
The context in which the processor will run.

Implements

IDataExchangeProcessorTModel, TContextProcess(TModel, TContext)
See Also

Reference

ProcessQueueStepProcessor Class
Sitecore.DataExchange.Processors.PipelineSteps Namespace


Sitecore.DataExchange.Queues Namespace

Sitecore.DataExchange.Queues Namespace

[Missing <summary> documentation for "N:Sitecore.DataExchange.Queues"]

Classes
 | Class | Description
Public class | InMemoryWorkQueue | A queue that stores entries in memory.
Public class | WorkQueueManager | Provides access to IWorkQueue objects.
Interfaces
 | Interface | Description
Public interface | IWorkQueue | Represents a queue that stores objects using a key.


InMemoryWorkQueue Class

InMemoryWorkQueue Class
A queue that stores entries in memory.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.QueuesInMemoryWorkQueue

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class InMemoryWorkQueue : IWorkQueue

The InMemoryWorkQueue type exposes the following members.

Constructors
 | Name | Description
Public method | InMemoryWorkQueue | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Lock | The object used to lock the queue in order to prevent concurrency problems.
Protected property | Queues | Gets the data structures used to store queue entries.
Top
Methods
 | Name | Description
Public method | AddT | Adds an item to the queue using the specified key.
Public method | ContainsT | Determines whether or not an object has already been added to the queue using the specified key.
Public method | GetT | Gets the object from the queue using the specified key.
Public method | GetEntriesT | Gets all entries of a specific type from the queue.
Public method | GetKeysT | Gets all keys for entries of a specific type from the queue.
Public method | RemoveT | Removes an object from the queue.
Top
See Also

Reference

Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue Constructor

InMemoryWorkQueue Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public InMemoryWorkQueue()
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue Properties

InMemoryWorkQueue Properties

The InMemoryWorkQueue type exposes the following members.

Properties
 | Name | Description
Public property | Lock | The object used to lock the queue in order to prevent concurrency problems.
Protected property | Queues | Gets the data structures used to store queue entries.
Top
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue.Lock Property

InMemoryWorkQueueLock Property
The object used to lock the queue in order to prevent concurrency problems.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Object Lock { get; }

Property Value

Type: Object

Implements

IWorkQueueLock
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue.Queues Property

InMemoryWorkQueueQueues Property
Gets the data structures used to store queue entries.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected IDictionary<Type, Object> Queues { get; }

Property Value

Type: IDictionary Type, Object
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue Methods

InMemoryWorkQueue Methods

The InMemoryWorkQueue type exposes the following members.

Methods
 | Name | Description
Public method | AddT | Adds an item to the queue using the specified key.
Public method | ContainsT | Determines whether or not an object has already been added to the queue using the specified key.
Public method | GetT | Gets the object from the queue using the specified key.
Public method | GetEntriesT | Gets all entries of a specific type from the queue.
Public method | GetKeysT | Gets all keys for entries of a specific type from the queue.
Public method | RemoveT | Removes an object from the queue.
Top
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue.Add(T) Method

InMemoryWorkQueueAddT Method
Adds an item to the queue using the specified key.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Add<T>(
    Object key,
    T item
)

Parameters

key
Type: SystemObject
The key used to retrieve the item from the queue.
item
Type: T
The object to add to the queue.

Type Parameters

T
The type of the object being added to the queue.

Return Value

Type: Boolean
if the object was added to the queue; otherwise.

Implements

IWorkQueueAddT(Object, T)
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue.Contains(T) Method

InMemoryWorkQueueContainsT Method
Determines whether or not an object has already been added to the queue using the specified key.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Contains<T>(
    Object key
)

Parameters

key
Type: SystemObject
The key used to retrieve the item from the queue.

Type Parameters

T
The type of the object being added to the queue.

Return Value

Type: Boolean
if an object is in the queue; otherwise.

Implements

IWorkQueueContainsT(Object)
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue.Get(T) Method

InMemoryWorkQueueGetT Method
Gets the object from the queue using the specified key.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public T Get<T>(
    Object key
)

Parameters

key
Type: SystemObject
The key used to retrieve the item from the queue.

Type Parameters

T
The type of the object being added to the queue.

Return Value

Type: T
The object read from the queue using the key; if no object is in the queue for the specified key, the default value for the specified type is returned.

Implements

IWorkQueueGetT(Object)
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue.GetEntries(T) Method

InMemoryWorkQueueGetEntriesT Method
Gets all entries of a specific type from the queue.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<T> GetEntries<T>()

Type Parameters

T
The type of entries to retrieve from the queue.

Return Value

Type: IEnumerable T
Collection of entries.

Implements

IWorkQueueGetEntriesT
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue.GetKeys(T) Method

InMemoryWorkQueueGetKeysT Method
Gets all keys for entries of a specific type from the queue.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<Object> GetKeys<T>()

Type Parameters

T
The type of entries to retrieve from the queue.

Return Value

Type: IEnumerable Object
Collection of keys.

Implements

IWorkQueueGetKeysT
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


InMemoryWorkQueue.Remove(T) Method

InMemoryWorkQueueRemoveT Method
Removes an object from the queue.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Remove<T>(
    Object key
)

Parameters

key
Type: SystemObject
The key used to retrieve the item from the queue.

Type Parameters

T
The type of the object to remove from the queue.

Return Value

Type: Boolean
if an object was removed from the queue; otherwise.

Implements

IWorkQueueRemoveT(Object)
See Also

Reference

InMemoryWorkQueue Class
Sitecore.DataExchange.Queues Namespace


IWorkQueue Interface

IWorkQueue Interface
Represents a queue that stores objects using a key.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IWorkQueue

The IWorkQueue type exposes the following members.

Properties
 | Name | Description
Public property | Lock | The object used to lock the queue in order to prevent concurrency problems.
Top
Methods
 | Name | Description
Public method | AddT | Adds an item to the queue using the specified key.
Public method | ContainsT | Determines whether or not an object has already been added to the queue using the specified key.
Public method | GetT | Gets the object from the queue using the specified key.
Public method | GetEntriesT | Gets all entries of a specific type from the queue.
Public method | GetKeysT | Gets all keys for entries of a specific type from the queue.
Public method | RemoveT | Removes an object from the queue.
Top
See Also

Reference

Sitecore.DataExchange.Queues Namespace


IWorkQueue Properties

IWorkQueue Properties

The IWorkQueue type exposes the following members.

Properties
 | Name | Description
Public property | Lock | The object used to lock the queue in order to prevent concurrency problems.
Top
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


IWorkQueue.Lock Property

IWorkQueueLock Property
The object used to lock the queue in order to prevent concurrency problems.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
Object Lock { get; }

Property Value

Type: Object
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


IWorkQueue Methods

IWorkQueue Methods

The IWorkQueue type exposes the following members.

Methods
 | Name | Description
Public method | AddT | Adds an item to the queue using the specified key.
Public method | ContainsT | Determines whether or not an object has already been added to the queue using the specified key.
Public method | GetT | Gets the object from the queue using the specified key.
Public method | GetEntriesT | Gets all entries of a specific type from the queue.
Public method | GetKeysT | Gets all keys for entries of a specific type from the queue.
Public method | RemoveT | Removes an object from the queue.
Top
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


IWorkQueue.Add(T) Method

IWorkQueueAddT Method
Adds an item to the queue using the specified key.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool Add<T>(
    Object key,
    T item
)

Parameters

key
Type: SystemObject
The key used to retrieve the item from the queue.
item
Type: T
The object to add to the queue.

Type Parameters

T
The type of the object being added to the queue.

Return Value

Type: Boolean
if the object was added to the queue; otherwise.
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


IWorkQueue.Contains(T) Method

IWorkQueueContainsT Method
Determines whether or not an object has already been added to the queue using the specified key.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool Contains<T>(
    Object key
)

Parameters

key
Type: SystemObject
The key used to retrieve the item from the queue.

Type Parameters

T
The type of the object being added to the queue.

Return Value

Type: Boolean
if an object is in the queue; otherwise.
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


IWorkQueue.Get(T) Method

IWorkQueueGetT Method
Gets the object from the queue using the specified key.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
T Get<T>(
    Object key
)

Parameters

key
Type: SystemObject
The key used to retrieve the item from the queue.

Type Parameters

T
The type of the object being added to the queue.

Return Value

Type: T
The object read from the queue using the key; if no object is in the queue for the specified key, the default value for the specified type is returned.
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


IWorkQueue.GetEntries(T) Method

IWorkQueueGetEntriesT Method
Gets all entries of a specific type from the queue.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IEnumerable<T> GetEntries<T>()

Type Parameters

T
The type of entries to retrieve from the queue.

Return Value

Type: IEnumerable T
Collection of entries.
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


IWorkQueue.GetKeys(T) Method

IWorkQueueGetKeysT Method
Gets all keys for entries of a specific type from the queue.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IEnumerable<Object> GetKeys<T>()

Type Parameters

T
The type of entries to retrieve from the queue.

Return Value

Type: IEnumerable Object
Collection of keys.
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


IWorkQueue.Remove(T) Method

IWorkQueueRemoveT Method
Removes an object from the queue.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool Remove<T>(
    Object key
)

Parameters

key
Type: SystemObject
The key used to retrieve the item from the queue.

Type Parameters

T
The type of the object to remove from the queue.

Return Value

Type: Boolean
if an object was removed from the queue; otherwise.
See Also

Reference

IWorkQueue Interface
Sitecore.DataExchange.Queues Namespace


WorkQueueManager Class

WorkQueueManager Class
Provides access to IWorkQueue objects.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.QueuesWorkQueueManager

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static class WorkQueueManager

The WorkQueueManager type exposes the following members.

Methods
Name | Description
AddWorkQueue | Adds a new queue.
GetWorkQueue | Gets a specific queue.
Top
See Also

Reference

Sitecore.DataExchange.Queues Namespace


WorkQueueManager Methods

WorkQueueManager Methods

The WorkQueueManager type exposes the following members.

Methods
Name | Description
AddWorkQueue | Adds a new queue.
GetWorkQueue | Gets a specific queue.
Top
See Also

Reference

WorkQueueManager Class
Sitecore.DataExchange.Queues Namespace


WorkQueueManager.AddWorkQueue Method

WorkQueueManagerAddWorkQueue Method
Adds a new queue.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static void AddWorkQueue(
    Guid queueId,
    IWorkQueue queue
)

Parameters

queueId
Type: SystemGuid
Identifier for the queue to add.
queue
Type: Sitecore.DataExchange.QueuesIWorkQueue
Queue to add.
See Also

Reference

WorkQueueManager Class
Sitecore.DataExchange.Queues Namespace


WorkQueueManager.GetWorkQueue Method

WorkQueueManagerGetWorkQueue Method
Gets a specific queue.

Namespace: Sitecore.DataExchange.Queues
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public static IWorkQueue GetWorkQueue(
    Guid queueId
)

Parameters

queueId
Type: SystemGuid
Identifier for the queue to retrieve.

Return Value

Type: IWorkQueue
The queue; if no queue exists with the specified identifier.
See Also

Reference

WorkQueueManager Class
Sitecore.DataExchange.Queues Namespace


Sitecore.DataExchange.Remote.Http Namespace

Sitecore.DataExchange.Remote.Http Namespace

This namespace contains types that define the components used to make HTTP calls to a Sitecore server in order to use the Sitecore Client Services API.

Classes
 | Class | Description
Public class | ConnectionSettings | Represents the information needed to make a connection to a Sitecore server using the Sitecore Client Services API.
Public class | SitecoreWebApiClient | Provides the ability to make calls using the Sitecore Services Client API. This class is basically a wrapper around the HttpClient class.


ConnectionSettings Class

ConnectionSettings Class
Represents the information needed to make a connection to a Sitecore server using the Sitecore Client Services API.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Remote.HttpConnectionSettings

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ConnectionSettings

The ConnectionSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Host | Host name of the Sitecore server to connect to.
Public property | LoginTimeout | The number of minutes that a login is valid. The default value is 20 minutes.
Public property | Password | Password for the user to authenticate with.
Public property | UserName | Name of the user to authenticate with.
Top
See Also

Reference

Sitecore.DataExchange.Remote.Http Namespace


ConnectionSettings Constructor

ConnectionSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ConnectionSettings()
See Also

Reference

ConnectionSettings Class
Sitecore.DataExchange.Remote.Http Namespace


ConnectionSettings Properties

ConnectionSettings Properties

The ConnectionSettings type exposes the following members.

Properties
 | Name | Description
Public property | Host | Host name of the Sitecore server to connect to.
Public property | LoginTimeout | The number of minutes that a login is valid. The default value is 20 minutes.
Public property | Password | Password for the user to authenticate with.
Public property | UserName | Name of the user to authenticate with.
Top
See Also

Reference

ConnectionSettings Class
Sitecore.DataExchange.Remote.Http Namespace


ConnectionSettings.Host Property

ConnectionSettingsHost Property
Host name of the Sitecore server to connect to.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Host { get; set; }

Property Value

Type: String
See Also

Reference

ConnectionSettings Class
Sitecore.DataExchange.Remote.Http Namespace


ConnectionSettings.LoginTimeout Property

ConnectionSettingsLoginTimeout Property
The number of minutes that a login is valid. The default value is 20 minutes.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int LoginTimeout { get; set; }

Property Value

Type: Int32
Remarks

In order to use the Sitecore Client Services API a Sitecore user must be authenticated. After authentication happens, however, a cookie is available that lasts for a certain amount of time. This means that authentication does not necessarily need to happen before each API call.

The component that uses this object can use this value to determine whether or not to authenticate the user before making an API call.

See Also

Reference

ConnectionSettings Class
Sitecore.DataExchange.Remote.Http Namespace


ConnectionSettings.Password Property

ConnectionSettingsPassword Property
Password for the user to authenticate with.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Password { get; set; }

Property Value

Type: String
See Also

Reference

ConnectionSettings Class
Sitecore.DataExchange.Remote.Http Namespace


ConnectionSettings.UserName Property

ConnectionSettingsUserName Property
Name of the user to authenticate with.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string UserName { get; set; }

Property Value

Type: String
See Also

Reference

ConnectionSettings Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient Class

SitecoreWebApiClient Class
Provides the ability to make calls using the Sitecore Services Client API. This class is basically a wrapper around the HttpClient class.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Remote.HttpSitecoreWebApiClient

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class SitecoreWebApiClient : IDisposable

The SitecoreWebApiClient type exposes the following members.

Constructors
 | Name | Description
Public method | SitecoreWebApiClient | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | HttpClient | Gets the component used to make HTTP calls to the Sitecore server.
Protected property | LastLogin | Gets or sets the time the last login was completed. This value is compared with the LoginTimeout was from the ConnectionSettings used to create this object in order to determine whether or not to perform a login before executing specific calls to the Sitecore server.
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources and disposes of managed resources.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the repository and optionally disposes of the managed resources.
 | DoDelete | Uses the HttpClient to send a GET command to the Sitecore server.
 | DoGet | Uses the HttpClient to send a GET command to the Sitecore server.
 | DoPatch | Uses the HttpClient to send a PATCH command to the Sitecore server.
 | DoPost | Uses the HttpClient to send a POST command to the Sitecore server.
Top
See Also

Reference

Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient Constructor

SitecoreWebApiClient Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public SitecoreWebApiClient(
    ConnectionSettings settings
)

Parameters

settings
Type: Sitecore.DataExchange.Remote.HttpConnectionSettings
The settings used to make a connection to a Sitecore server.
Exceptions
Exception | Condition
ArgumentNullException | settings is null.
ArgumentException | Host specified on settings is null, empty or invalid.
ArgumentException | UserName specified on settings is null, empty or invalid.
ArgumentException | Password specified on settings is null, empty or invalid.
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient Properties

SitecoreWebApiClient Properties

The SitecoreWebApiClient type exposes the following members.

Properties
 | Name | Description
Protected property | HttpClient | Gets the component used to make HTTP calls to the Sitecore server.
Protected property | LastLogin | Gets or sets the time the last login was completed. This value is compared with the LoginTimeout was from the ConnectionSettings used to create this object in order to determine whether or not to perform a login before executing specific calls to the Sitecore server.
Top
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.HttpClient Property

SitecoreWebApiClientHttpClient Property
Gets the component used to make HTTP calls to the Sitecore server.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected HttpClient HttpClient { get; }

Property Value

Type: HttpClient
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.LastLogin Property

SitecoreWebApiClientLastLogin Property

Gets or sets the time the last login was completed.

This value is compared with the LoginTimeout was from the ConnectionSettings used to create this object in order to determine whether or not to perform a login before executing specific calls to the Sitecore server.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected DateTime LastLogin { get; set; }

Property Value

Type: DateTime
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient Methods

SitecoreWebApiClient Methods

The SitecoreWebApiClient type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources and disposes of managed resources.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the repository and optionally disposes of the managed resources.
 | DoDelete | Uses the HttpClient to send a GET command to the Sitecore server.
 | DoGet | Uses the HttpClient to send a GET command to the Sitecore server.
 | DoPatch | Uses the HttpClient to send a PATCH command to the Sitecore server.
 | DoPost | Uses the HttpClient to send a POST command to the Sitecore server.
Top
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.Dispose Method

SitecoreWebApiClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases unmanaged resources and disposes of managed resources.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the repository and optionally disposes of the managed resources.
Top
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.Dispose Method

SitecoreWebApiClientDispose Method
Releases unmanaged resources and disposes of managed resources.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

SitecoreWebApiClient Class
Dispose Overload
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.Dispose Method (Boolean)

SitecoreWebApiClientDispose Method (Boolean)
Releases the unmanaged resources used by the repository and optionally disposes of the managed resources.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
to release managed and unmanaged resources; to release only unmanaged resources.
See Also

Reference

SitecoreWebApiClient Class
Dispose Overload
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.DoDelete Method

SitecoreWebApiClientDoDelete Method
Uses the HttpClient to send a GET command to the Sitecore server.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public HttpResponseMessage DoDelete(
    string uri,
    IDictionary<string, string> parameters
)

Parameters

uri
Type: SystemString
The uri for the request.
parameters
Type: System.Collections.GenericIDictionary String, String
The parameters that are encoded and appended to uri prior to the HTTP request being sent. This parameter may be .

Return Value

Type: HttpResponseMessage
The HTTP response.
Examples

The following example demonstrates how to use this method to get an item from Sitecore using the Sitecore Client Services API.

C#
Copy
var settings = new ConnectionSettings
{
    Host = "localhost",
    UserName = "sitecore\\admin",
    Password = "b"
};
using (var client = new SitecoreWebApiClient(settings))
{
    var uri = "sitecore/api/ssc/item/{A9D31791-ED49-4C4D-805F-A134978C2215}";
    var parameters = new Dictionary<string, string>();
    parameters["database"] = "master";
    var response = client.DoDelete(uri, parameters);
    if (response.StatusCode == System.Net.HttpStatusCode.NoContent)
    {
        //success
    }
}
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.DoGet Method

SitecoreWebApiClientDoGet Method
Uses the HttpClient to send a GET command to the Sitecore server.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public HttpResponseMessage DoGet(
    string uri,
    IDictionary<string, string> parameters
)

Parameters

uri
Type: SystemString
The uri for the request.
parameters
Type: System.Collections.GenericIDictionary String, String
The parameters that are encoded and appended to uri prior to the HTTP request being sent. This parameter may be .

Return Value

Type: HttpResponseMessage
The HTTP response.
Examples

The following example demonstrates how to use this method to get an item from Sitecore using the Sitecore Client Services API.

C#
Copy
var settings = new ConnectionSettings
{
    Host = "localhost",
    UserName = "sitecore\\admin",
    Password = "b"
};
using (var client = new SitecoreWebApiClient(settings))
{
    var uri = "sitecore/api/ssc/item/{110D559F-DEA5-42EA-9C1C-8A5DF7E70EF9}";
    var parameters = new Dictionary<string, string>();
    parameters["database"] = "master";
    var response = client.DoGet(uri, parameters);
    var json = response.Content.ReadAsStringAsync().Result;
    var itemModel = Newtonsoft.Json.JsonConvert.DeserializeObject<Sitecore.Services.Core.Model.ItemModel>(json);
}
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.DoPatch Method

SitecoreWebApiClientDoPatch Method
Uses the HttpClient to send a PATCH command to the Sitecore server.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public HttpResponseMessage DoPatch(
    string uri,
    IDictionary<string, string> parameters,
    ItemModel itemModel
)

Parameters

uri
Type: SystemString
The uri for the request.
parameters
Type: System.Collections.GenericIDictionary String, String
The parameters that are encoded and appended to uri prior to the HTTP request being sent. This parameter may be .
itemModel
Type: ItemModel
The object that is serialized to JSON format and included in the HTTP request.

Return Value

Type: HttpResponseMessage
The HTTP response.
Examples

The following example demonstrates how to use this method to update an existing item in Sitecore using the Sitecore Client Services API.

C#
Copy
var settings = new ConnectionSettings
{
    Host = "localhost",
    UserName = "sitecore\\admin",
    Password = "b"
};
using (var client = new SitecoreWebApiClient(settings))
{
    var itemModel = new Sitecore.Services.Core.Model.ItemModel();
    itemModel[Sitecore.Services.Core.Model.ItemModel.ItemName] = "Updated Item Name";
    //
    var uri = "sitecore/api/ssc/item/{A9D31791-ED49-4C4D-805F-A134978C2215}";
    var parameters = new Dictionary<string, string>();
    parameters["database"] = "master";
    var response = client.DoPatch(uri, parameters, itemModel);
    if (response.StatusCode == System.Net.HttpStatusCode.NoContent)
    {
        //success
    }
}
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


SitecoreWebApiClient.DoPost Method

SitecoreWebApiClientDoPost Method
Uses the HttpClient to send a POST command to the Sitecore server.

Namespace: Sitecore.DataExchange.Remote.Http
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public HttpResponseMessage DoPost(
    string uri,
    IDictionary<string, string> parameters,
    ItemModel itemModel
)

Parameters

uri
Type: SystemString
The uri for the request.
parameters
Type: System.Collections.GenericIDictionary String, String
The parameters that are encoded and appended to uri prior to the HTTP request being sent. This parameter may be .
itemModel
Type: ItemModel
The object that is serialized to JSON format and included in the HTTP request.

Return Value

Type: HttpResponseMessage
The HTTP response.
Examples

The following example demonstrates how to use this method to create an item in Sitecore using the Sitecore Client Services API.

C#
Copy
var settings = new ConnectionSettings
{
    Host = "localhost",
    UserName = "sitecore\\admin",
    Password = "b"
};
using (var client = new SitecoreWebApiClient(settings))
{
    var itemModel = new Sitecore.Services.Core.Model.ItemModel();
    itemModel[Sitecore.Services.Core.Model.ItemModel.ItemName] = "New Item";
    itemModel[Sitecore.Services.Core.Model.ItemModel.TemplateID] = "{76036F5E-CBCE-46D1-AF0A-4143F9B557AA}";
    //
    var parentPath = System.Web.HttpUtility.UrlEncode("sitecore/content/Home");
    var uri = "sitecore/api/ssc/item/" + parentPath;
    var parameters = new Dictionary<string, string>();
    parameters["database"] = "master";
    var response = client.DoPost(uri, parameters, itemModel);
    if (response.StatusCode == System.Net.HttpStatusCode.Created)
    {
        //success
    }
}
See Also

Reference

SitecoreWebApiClient Class
Sitecore.DataExchange.Remote.Http Namespace


Sitecore.DataExchange.Remote.Repositories Namespace

Sitecore.DataExchange.Remote.Repositories Namespace

This namespace contains repositories used by framework components to read and write data.

Classes
Class | Description
WebApiItemModelRepository | This IItemModelRepository is used when the data exchange process runs outside of the Sitecore server. It uses the Sitecore Services Client to resolve item models.


WebApiItemModelRepository Class

WebApiItemModelRepository Class

This IItemModelRepository is used when the data exchange process runs outside of the Sitecore server. It uses the Sitecore Services Client to resolve item models.

Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Remote.RepositoriesWebApiItemModelRepository

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class WebApiItemModelRepository : IItemModelRepository,
    IDisposable

The WebApiItemModelRepository type exposes the following members.

Constructors
 | Name | Description
Public method | WebApiItemModelRepository | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Protected property | Client | Gets the component used to interact with the Sitecore Services Client.
Public property | DatabaseName | Gets or sets the name of the Sitecore database whose items are accessed.
Top
Methods
 | Name | Description
Public method | Create | Creates a new item.
Public method | Dispose | Releases unmanaged resources and disposes of managed resources.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the repository and optionally disposes of the managed resources.
Public method | Get(Guid) | Gets an item using a specific ID from the database specified by DatabaseName.
Public method | Get(String) | Gets an item using a specific content path.
Public method | GetChildren | Gets the child items for a specific parent item from the database specified by DatabaseName.
Public method | Search | Searches for items.
Public method | Update | Updates the specified item.
Top
Examples

If you are using this implementation is it likely you will need to assign it to the Data Exchange context so the repository is available to other framework components.

The following code demonstrates how to do this.

C#
Copy
var settings = new ConnectionSettings
{
    Host = "localhost",
    UserName = "sitecore\\admin",
    Password = "b"
};
var repo = new WebApiItemModelRepository("master", settings);
Sitecore.DataExchange.Context.ItemModelRepository = repo;
See Also

Reference

Sitecore.DataExchange.Remote.Repositories Namespace
ContextItemModelRepository


WebApiItemModelRepository Constructor

WebApiItemModelRepository Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public WebApiItemModelRepository(
    string databaseName,
    ConnectionSettings settings
)

Parameters

databaseName
Type: SystemString
Name of the Sitecore database whose items are accessed.
settings
Type: Sitecore.DataExchange.Remote.HttpConnectionSettings
Settings used to specify which Sitecore server to connect to.
Exceptions
Exception | Condition
ArgumentNullException | databaseName is null.
ArgumentException | databaseName is empty or whitespace.
ArgumentNullException | settings is null.
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository Properties

WebApiItemModelRepository Properties

The WebApiItemModelRepository type exposes the following members.

Properties
 | Name | Description
Protected property | Client | Gets the component used to interact with the Sitecore Services Client.
Public property | DatabaseName | Gets or sets the name of the Sitecore database whose items are accessed.
Top
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Client Property

WebApiItemModelRepositoryClient Property
Gets the component used to interact with the Sitecore Services Client.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected SitecoreWebApiClient Client { get; }

Property Value

Type: SitecoreWebApiClient
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.DatabaseName Property

WebApiItemModelRepositoryDatabaseName Property
Gets or sets the name of the Sitecore database whose items are accessed.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string DatabaseName { get; }

Property Value

Type: String

Implements

IItemModelRepositoryDatabaseName
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository Methods

WebApiItemModelRepository Methods

The WebApiItemModelRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates a new item.
Public method | Dispose | Releases unmanaged resources and disposes of managed resources.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the repository and optionally disposes of the managed resources.
Public method | Get(Guid) | Gets an item using a specific ID from the database specified by DatabaseName.
Public method | Get(String) | Gets an item using a specific content path.
Public method | GetChildren | Gets the child items for a specific parent item from the database specified by DatabaseName.
Public method | Search | Searches for items.
Public method | Update | Updates the specified item.
Top
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Create Method

WebApiItemModelRepositoryCreate Method
Creates a new item.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Guid Create(
    string itemName,
    Guid templateId,
    Guid parentId
)

Parameters

itemName
Type: SystemString
The name for the item that is created.
templateId
Type: SystemGuid
The id of the template used to create the item.
parentId
Type: SystemGuid
The id of the parent item for the item that is created.

Return Value

Type: Guid
The id of the item that was created; Empty if no item was created.

Implements

IItemModelRepositoryCreate(String, Guid, Guid)
Exceptions
Exception | Condition
ArgumentNullException | itemName is null.
ArgumentException | itemName is empty or whitespace.
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Dispose Method

WebApiItemModelRepositoryDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases unmanaged resources and disposes of managed resources.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the repository and optionally disposes of the managed resources.
Top
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Dispose Method

WebApiItemModelRepositoryDispose Method
Releases unmanaged resources and disposes of managed resources.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

WebApiItemModelRepository Class
Dispose Overload
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Dispose Method (Boolean)

WebApiItemModelRepositoryDispose Method (Boolean)
Releases the unmanaged resources used by the repository and optionally disposes of the managed resources.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
to release managed and unmanaged resources; to release only unmanaged resources.
See Also

Reference

WebApiItemModelRepository Class
Dispose Overload
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Get Method

WebApiItemModelRepositoryGet Method
Overload List
 | Name | Description
Public method | Get(Guid) | Gets an item using a specific ID from the database specified by DatabaseName.
Public method | Get(String) | Gets an item using a specific content path.
Top
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Get Method (Guid)

WebApiItemModelRepositoryGet Method (Guid)
Gets an item using a specific ID from the database specified by DatabaseName.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ItemModel Get(
    Guid id
)

Parameters

id
Type: SystemGuid
ID of the item to retrieve.

Return Value

Type: ItemModel
The item, or if no item was retrieved.

Implements

IItemModelRepositoryGet(Guid)
See Also

Reference

WebApiItemModelRepository Class
Get Overload
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Get Method (String)

WebApiItemModelRepositoryGet Method (String)
Gets an item using a specific content path.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ItemModel Get(
    string path
)

Parameters

path
Type: SystemString
Path of the item to retrieve.

Return Value

Type: ItemModel
The item, or if no item was retrieved.

Implements

IItemModelRepositoryGet(String)
See Also

Reference

WebApiItemModelRepository Class
Get Overload
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.GetChildren Method

WebApiItemModelRepositoryGetChildren Method
Gets the child items for a specific parent item from the database specified by DatabaseName.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<ItemModel> GetChildren(
    Guid id
)

Parameters

id
Type: SystemGuid
ID of the parent item.

Return Value

Type: IEnumerable ItemModel
A collection of ItemModel objects.

Implements

IItemModelRepositoryGetChildren(Guid)
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Search Method

WebApiItemModelRepositorySearch Method
Searches for items.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<ItemModel> Search(
    ItemSearchSettings settings
)

Parameters

settings
Type: Sitecore.DataExchange.RepositoriesItemSearchSettings
The object that contains settings that control the search.

Return Value

Type: IEnumerable ItemModel
A collection of ItemModel objects.

Implements

IItemModelRepositorySearch(ItemSearchSettings)
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


WebApiItemModelRepository.Update Method

WebApiItemModelRepositoryUpdate Method
Updates the specified item.

Namespace: Sitecore.DataExchange.Remote.Repositories
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Update(
    Guid id,
    ItemModel itemModel
)

Parameters

id
Type: SystemGuid
ID of the item to update.
itemModel
Type: ItemModel
The item model that represents the Sitecore item that should be updated.

Return Value

Type: Boolean
if the item was updated in Sitecore; otherwise.

Implements

IItemModelRepositoryUpdate(Guid, ItemModel)
Exceptions
Exception | Condition
ArgumentNullException | itemModel is null.
See Also

Reference

WebApiItemModelRepository Class
Sitecore.DataExchange.Remote.Repositories Namespace


Sitecore.DataExchange.Remote.Runners Namespace

Sitecore.DataExchange.Remote.Runners Namespace

This namespace contains repositories used by framework components to run other framework components.

Classes
 | Class | Description
Public class | RemotePipelineBatchRunner | Implements the ability to run pipeline batches from outside of a Sitecore server.


RemotePipelineBatchRunner Class

RemotePipelineBatchRunner Class
Implements the ability to run pipeline batches from outside of a Sitecore server.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.RunnersBasePipelineBatchRunner Guid
Sitecore.DataExchange.Remote.RunnersRemotePipelineBatchRunner

Namespace: Sitecore.DataExchange.Remote.Runners
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class RemotePipelineBatchRunner : BasePipelineBatchRunner<Guid>

The RemotePipelineBatchRunner type exposes the following members.

Constructors
 | Name | Description
Public method | RemotePipelineBatchRunner | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | CurrentProcesses | Gets a collection of the processes that are currently running. (Inherited from BasePipelineBatchRunnerTProcess.)
Top
Methods
 | Name | Description
Protected method | GetLoggerForPipelineBatchContext | Gets the logger that is set on the pipeline batch context. (Inherited from BasePipelineBatchRunnerTProcess.)
Public method | IsRunning | Determines whether or not a pipeline batch is currently running. (Inherited from BasePipelineBatchRunnerTProcess.)
Protected method | OnFinished | Raises the Finished event. (Inherited from BasePipelineBatchRunnerTProcess.)
Protected method | OnStarted | Raises the Started event. (Inherited from BasePipelineBatchRunnerTProcess.)
Public method | Run | Runs the specified pipeline batch. When the pipeline batch is finished running, the process that represented the pipeline batch being run is removed from CurrentProcesses. However, it is the responsibility of the component that uses the pipeline batch runner to put the process in the collection in the first place. (Inherited from BasePipelineBatchRunnerTProcess.)
Top
Events
 | Name | Description
Public event | Finished | Occurs when the pipeline batch runner is finished. (Inherited from BasePipelineBatchRunnerTProcess.)
Public event | Started | Occurs when the pipeline batch runner is started. (Inherited from BasePipelineBatchRunnerTProcess.)
Top
See Also

Reference

Sitecore.DataExchange.Remote.Runners Namespace


RemotePipelineBatchRunner Constructor

RemotePipelineBatchRunner Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Remote.Runners
Assembly: Sitecore.DataExchange.Remote (in Sitecore.DataExchange.Remote.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public RemotePipelineBatchRunner()
See Also

Reference

RemotePipelineBatchRunner Class
Sitecore.DataExchange.Remote.Runners Namespace


RemotePipelineBatchRunner Properties

RemotePipelineBatchRunner Properties

The RemotePipelineBatchRunner type exposes the following members.

Properties
 | Name | Description
Public property | CurrentProcesses | Gets a collection of the processes that are currently running. (Inherited from BasePipelineBatchRunnerTProcess.)
Top
See Also

Reference

RemotePipelineBatchRunner Class
Sitecore.DataExchange.Remote.Runners Namespace


RemotePipelineBatchRunner Methods

RemotePipelineBatchRunner Methods

The RemotePipelineBatchRunner type exposes the following members.

Methods
 | Name | Description
Protected method | GetLoggerForPipelineBatchContext | Gets the logger that is set on the pipeline batch context. (Inherited from BasePipelineBatchRunnerTProcess.)
Public method | IsRunning | Determines whether or not a pipeline batch is currently running. (Inherited from BasePipelineBatchRunnerTProcess.)
Protected method | OnFinished | Raises the Finished event. (Inherited from BasePipelineBatchRunnerTProcess.)
Protected method | OnStarted | Raises the Started event. (Inherited from BasePipelineBatchRunnerTProcess.)
Public method | Run | Runs the specified pipeline batch. When the pipeline batch is finished running, the process that represented the pipeline batch being run is removed from CurrentProcesses. However, it is the responsibility of the component that uses the pipeline batch runner to put the process in the collection in the first place. (Inherited from BasePipelineBatchRunnerTProcess.)
Top
See Also

Reference

RemotePipelineBatchRunner Class
Sitecore.DataExchange.Remote.Runners Namespace


RemotePipelineBatchRunner Events

RemotePipelineBatchRunner Events

The RemotePipelineBatchRunner type exposes the following members.

Events
 | Name | Description
Public event | Finished | Occurs when the pipeline batch runner is finished. (Inherited from BasePipelineBatchRunnerTProcess.)
Public event | Started | Occurs when the pipeline batch runner is started. (Inherited from BasePipelineBatchRunnerTProcess.)
Top
See Also

Reference

RemotePipelineBatchRunner Class
Sitecore.DataExchange.Remote.Runners Namespace


Sitecore.DataExchange.Repositories Namespace

Sitecore.DataExchange.Repositories Namespace

This namespace contains repositories used by framework components to read and write data.

Classes
 | Class | Description
Public class | ItemSearchSettings | Represents settings used to control Search(ItemSearchSettings).
Public class | SearchFilter | Represents a filter that can be applied to a search conducted using Search(ItemSearchSettings).
Interfaces
 | Interface | Description
Public interface | IItemModelRepository | Represents a repository that provides access to Sitecore items. Examples of implementations include accessing Sitecore items using the Sitecore content API or the Sitecore web API.
Public interface | IPipelineBatchRepository | Represents a repository that provides access to pipeline batches. Examples of implementations include storing pipeline batch configuration information in Sitecore items or in a config file.


IItemModelRepository Interface

IItemModelRepository Interface

Represents a repository that provides access to Sitecore items. Examples of implementations include accessing Sitecore items using the Sitecore content API or the Sitecore web API.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IItemModelRepository

The IItemModelRepository type exposes the following members.

Properties
 | Name | Description
Public property | DatabaseName | Gets the name of the Sitecore database that this repository provides access to.
Top
Methods
 | Name | Description
Public method | Create | Creates a new item.
Public method | Get(Guid) | Gets an item using a specific ID.
Public method | Get(String) | Gets an item using a specific content path.
Public method | GetChildren | Gets the child items for a specific parent item.
Public method | Search | Searches for items.
Public method | Update | Updates the specified item.
Top
Remarks

When a framework component needs to interact with Sitecore, the component uses the context to access an IItemModelRepository. The item model repository object must be set on the context prior to a component using the repository.

When components run within the Sitecore process, this is handled by the initialize pipeline. When components run outside of Sitecore, however, the application using the components must set the repository.

The value is set on ItemModelRepository.

See Also

Reference

Sitecore.DataExchange.Repositories Namespace


IItemModelRepository Properties

IItemModelRepository Properties

The IItemModelRepository type exposes the following members.

Properties
 | Name | Description
Public property | DatabaseName | Gets the name of the Sitecore database that this repository provides access to.
Top
See Also

Reference

IItemModelRepository Interface
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository.DatabaseName Property

IItemModelRepositoryDatabaseName Property
Gets the name of the Sitecore database that this repository provides access to.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
string DatabaseName { get; }

Property Value

Type: String
See Also

Reference

IItemModelRepository Interface
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository Methods

IItemModelRepository Methods

The IItemModelRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates a new item.
Public method | Get(Guid) | Gets an item using a specific ID.
Public method | Get(String) | Gets an item using a specific content path.
Public method | GetChildren | Gets the child items for a specific parent item.
Public method | Search | Searches for items.
Public method | Update | Updates the specified item.
Top
See Also

Reference

IItemModelRepository Interface
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository.Create Method

IItemModelRepositoryCreate Method
Creates a new item.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
Guid Create(
    string itemName,
    Guid templateId,
    Guid parentId
)

Parameters

itemName
Type: SystemString
The name for the item that is created.
templateId
Type: SystemGuid
The id of the template used to create the item.
parentId
Type: SystemGuid
The id of the parent item for the item that is created.

Return Value

Type: Guid
The id of the item that was created; Empty if no item was created.
See Also

Reference

IItemModelRepository Interface
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository.Get Method

IItemModelRepositoryGet Method
Overload List
 | Name | Description
Public method | Get(Guid) | Gets an item using a specific ID.
Public method | Get(String) | Gets an item using a specific content path.
Top
See Also

Reference

IItemModelRepository Interface
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository.Get Method (Guid)

IItemModelRepositoryGet Method (Guid)
Gets an item using a specific ID.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ItemModel Get(
    Guid id
)

Parameters

id
Type: SystemGuid
ID of the item to retrieve.

Return Value

Type: ItemModel
The item, or if no item was retrieved.
See Also

Reference

IItemModelRepository Interface
Get Overload
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository.Get Method (String)

IItemModelRepositoryGet Method (String)
Gets an item using a specific content path.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
ItemModel Get(
    string path
)

Parameters

path
Type: SystemString
Path of the item to retrieve.

Return Value

Type: ItemModel
The item, or if no item was retrieved.
See Also

Reference

IItemModelRepository Interface
Get Overload
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository.GetChildren Method

IItemModelRepositoryGetChildren Method
Gets the child items for a specific parent item.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IEnumerable<ItemModel> GetChildren(
    Guid id
)

Parameters

id
Type: SystemGuid
ID of the parent item.

Return Value

Type: IEnumerable ItemModel
A collection of ItemModel objects.
See Also

Reference

IItemModelRepository Interface
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository.Search Method

IItemModelRepositorySearch Method
Searches for items.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IEnumerable<ItemModel> Search(
    ItemSearchSettings settings
)

Parameters

settings
Type: Sitecore.DataExchange.RepositoriesItemSearchSettings
The object that contains settings that control the search.

Return Value

Type: IEnumerable ItemModel
A collection of ItemModel objects.
See Also

Reference

IItemModelRepository Interface
Sitecore.DataExchange.Repositories Namespace


IItemModelRepository.Update Method

IItemModelRepositoryUpdate Method
Updates the specified item.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool Update(
    Guid id,
    ItemModel itemModel
)

Parameters

id
Type: SystemGuid
ID of the item to update.
itemModel
Type: ItemModel
The item model that represents the Sitecore item that should be updated.

Return Value

Type: Boolean
if the item was updated in Sitecore; otherwise.
See Also

Reference

IItemModelRepository Interface
Sitecore.DataExchange.Repositories Namespace


IPipelineBatchRepository Interface

IPipelineBatchRepository Interface

Represents a repository that provides access to pipeline batches. Examples of implementations include storing pipeline batch configuration information in Sitecore items or in a config file.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IPipelineBatchRepository

The IPipelineBatchRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetPipelineBatches | Gets a collection of PipelineBatch objects that are available for the specified tenant.
Public method | GetTentants | Gets a collection of Tenant objects that are available to the repository.
Top
See Also

Reference

Sitecore.DataExchange.Repositories Namespace


IPipelineBatchRepository Methods

IPipelineBatchRepository Methods

The IPipelineBatchRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetPipelineBatches | Gets a collection of PipelineBatch objects that are available for the specified tenant.
Public method | GetTentants | Gets a collection of Tenant objects that are available to the repository.
Top
See Also

Reference

IPipelineBatchRepository Interface
Sitecore.DataExchange.Repositories Namespace


IPipelineBatchRepository.GetPipelineBatches Method

IPipelineBatchRepositoryGetPipelineBatches Method
Gets a collection of PipelineBatch objects that are available for the specified tenant.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IEnumerable<PipelineBatch> GetPipelineBatches(
    Guid tenantId,
    bool remoteOnly = false
)

Parameters

tenantId
Type: SystemGuid
The tenant whose pipeline batches are retrieved,
remoteOnly (Optional)
Type: SystemBoolean
Indicates whether or not only pipeline batches that can be called remotely are included.

Return Value

Type: IEnumerable PipelineBatch
A collection of PipelineBatch objects.
See Also

Reference

IPipelineBatchRepository Interface
Sitecore.DataExchange.Repositories Namespace


IPipelineBatchRepository.GetTentants Method

IPipelineBatchRepositoryGetTentants Method
Gets a collection of Tenant objects that are available to the repository.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IEnumerable<Tenant> GetTentants()

Return Value

Type: IEnumerable Tenant
A collection of Tenant objects.
See Also

Reference

IPipelineBatchRepository Interface
Sitecore.DataExchange.Repositories Namespace


ItemSearchSettings Class

ItemSearchSettings Class
Represents settings used to control Search(ItemSearchSettings).
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.RepositoriesItemSearchSettings

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class ItemSearchSettings

The ItemSearchSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ItemSearchSettings | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | Language | Gets or sets the language used in the search.
Public property | Page | Gets or sets the page number in the result set of pages that are returned.
Public property | PageSize | Gets or sets the maximum number of results that will be returned.
Public property | SearchFilters | Gets the collection of the field names and values that are used to build the query.
Public property | Term | Gets or sets the search term.
Top
See Also

Reference

Sitecore.DataExchange.Repositories Namespace


ItemSearchSettings Constructor

ItemSearchSettings Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ItemSearchSettings()
See Also

Reference

ItemSearchSettings Class
Sitecore.DataExchange.Repositories Namespace


ItemSearchSettings Properties

ItemSearchSettings Properties

The ItemSearchSettings type exposes the following members.

Properties
 | Name | Description
Public property | Language | Gets or sets the language used in the search.
Public property | Page | Gets or sets the page number in the result set of pages that are returned.
Public property | PageSize | Gets or sets the maximum number of results that will be returned.
Public property | SearchFilters | Gets the collection of the field names and values that are used to build the query.
Public property | Term | Gets or sets the search term.
Top
See Also

Reference

ItemSearchSettings Class
Sitecore.DataExchange.Repositories Namespace


ItemSearchSettings.Language Property

ItemSearchSettingsLanguage Property
Gets or sets the language used in the search.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Language { get; set; }

Property Value

Type: String
See Also

Reference

ItemSearchSettings Class
Sitecore.DataExchange.Repositories Namespace


ItemSearchSettings.Page Property

ItemSearchSettingsPage Property
Gets or sets the page number in the result set of pages that are returned.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int Page { get; set; }

Property Value

Type: Int32
See Also

Reference

ItemSearchSettings Class
Sitecore.DataExchange.Repositories Namespace


ItemSearchSettings.PageSize Property

ItemSearchSettingsPageSize Property
Gets or sets the maximum number of results that will be returned.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public int PageSize { get; set; }

Property Value

Type: Int32
See Also

Reference

ItemSearchSettings Class
Sitecore.DataExchange.Repositories Namespace


ItemSearchSettings.SearchFilters Property

ItemSearchSettingsSearchFilters Property
Gets the collection of the field names and values that are used to build the query.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ICollection<SearchFilter> SearchFilters { get; }

Property Value

Type: ICollection SearchFilter
See Also

Reference

ItemSearchSettings Class
Sitecore.DataExchange.Repositories Namespace


ItemSearchSettings.Term Property

ItemSearchSettingsTerm Property
Gets or sets the search term.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Term { get; set; }

Property Value

Type: String
See Also

Reference

ItemSearchSettings Class
Sitecore.DataExchange.Repositories Namespace


SearchFilter Class

SearchFilter Class
Represents a filter that can be applied to a search conducted using Search(ItemSearchSettings).
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.RepositoriesSearchFilter

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class SearchFilter

The SearchFilter type exposes the following members.

Constructors
 | Name | Description
Public method | SearchFilter | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the name of the field.
Public property | Value | Gets or sets the value of the search facet.
Top
Methods
 | Name | Description
Public method | GetHashCode | Returns the hash code for this string. (Overrides ObjectGetHashCode.)
Public method | ToString | Combines the values of FieldName and Value into the format required by the search method. (Overrides ObjectToString.)
Top
See Also

Reference

Sitecore.DataExchange.Repositories Namespace


SearchFilter Constructor

SearchFilter Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public SearchFilter()
See Also

Reference

SearchFilter Class
Sitecore.DataExchange.Repositories Namespace


SearchFilter Properties

SearchFilter Properties

The SearchFilter type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the name of the field.
Public property | Value | Gets or sets the value of the search facet.
Top
See Also

Reference

SearchFilter Class
Sitecore.DataExchange.Repositories Namespace


SearchFilter.FieldName Property

SearchFilterFieldName Property
Gets or sets the name of the field.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string FieldName { get; set; }

Property Value

Type: String
See Also

Reference

SearchFilter Class
Sitecore.DataExchange.Repositories Namespace


SearchFilter.Value Property

SearchFilterValue Property
Gets or sets the value of the search facet.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Value { get; set; }

Property Value

Type: String
See Also

Reference

SearchFilter Class
Sitecore.DataExchange.Repositories Namespace


SearchFilter Methods

SearchFilter Methods

The SearchFilter type exposes the following members.

Methods
 | Name | Description
Public method | GetHashCode | Returns the hash code for this string. (Overrides ObjectGetHashCode.)
Public method | ToString | Combines the values of FieldName and Value into the format required by the search method. (Overrides ObjectToString.)
Top
See Also

Reference

SearchFilter Class
Sitecore.DataExchange.Repositories Namespace


SearchFilter.GetHashCode Method

SearchFilterGetHashCode Method
Returns the hash code for this string.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

SearchFilter Class
Sitecore.DataExchange.Repositories Namespace


SearchFilter.ToString Method

SearchFilterToString Method
Combines the values of FieldName and Value into the format required by the search method.

Namespace: Sitecore.DataExchange.Repositories
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
The formatted search facet value; Empty if FieldName and Value are both empty.
See Also

Reference

SearchFilter Class
Sitecore.DataExchange.Repositories Namespace


Sitecore.DataExchange.Repositories.PipelineBatches Namespace

Sitecore.DataExchange.Repositories.PipelineBatches Namespace

This namespace contains implementations of IPipelineBatchRepository.

Classes
 | Class | Description
Public class | SitecorePipelineBatchRepository | Provides access to pipeline batch information that is stored as Sitecore items.


SitecorePipelineBatchRepository Class

SitecorePipelineBatchRepository Class
Provides access to pipeline batch information that is stored as Sitecore items.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.Repositories.PipelineBatchesSitecorePipelineBatchRepository

Namespace: Sitecore.DataExchange.Repositories.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class SitecorePipelineBatchRepository : IPipelineBatchRepository

The SitecorePipelineBatchRepository type exposes the following members.

Constructors
 | Name | Description
Public method | SitecorePipelineBatchRepository | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | ItemModelRepository | Gets or sets the component used to access the Sitecore items used to store pipeline batch information. If the setter has not been called explicitly, the value from ItemModelRepository from Context is used.
Public property | TenantsRoot | Gets or sets the ID for the Sitecore item under which tenant definition items are stored. The default value is the ID for the Sitecore item located at /sitecore/system/Data Exchange.
Top
Methods
 | Name | Description
Public method | GetPipelineBatches | Gets a collection of PipelineBatch objects that are available for the specified tenant.
Public method | GetTentants | Gets a collection of Tenant objects that are available to the repository.
Top
See Also

Reference

Sitecore.DataExchange.Repositories.PipelineBatches Namespace


SitecorePipelineBatchRepository Constructor

SitecorePipelineBatchRepository Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Repositories.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public SitecorePipelineBatchRepository()
See Also

Reference

SitecorePipelineBatchRepository Class
Sitecore.DataExchange.Repositories.PipelineBatches Namespace


SitecorePipelineBatchRepository Properties

SitecorePipelineBatchRepository Properties

The SitecorePipelineBatchRepository type exposes the following members.

Properties
 | Name | Description
Public property | ItemModelRepository | Gets or sets the component used to access the Sitecore items used to store pipeline batch information. If the setter has not been called explicitly, the value from ItemModelRepository from Context is used.
Public property | TenantsRoot | Gets or sets the ID for the Sitecore item under which tenant definition items are stored. The default value is the ID for the Sitecore item located at /sitecore/system/Data Exchange.
Top
See Also

Reference

SitecorePipelineBatchRepository Class
Sitecore.DataExchange.Repositories.PipelineBatches Namespace


SitecorePipelineBatchRepository.ItemModelRepository Property

SitecorePipelineBatchRepositoryItemModelRepository Property

Gets or sets the component used to access the Sitecore items used to store pipeline batch information.

If the setter has not been called explicitly, the value from ItemModelRepository from Context is used.

Namespace: Sitecore.DataExchange.Repositories.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IItemModelRepository ItemModelRepository { get; set; }

Property Value

Type: IItemModelRepository
See Also

Reference

SitecorePipelineBatchRepository Class
Sitecore.DataExchange.Repositories.PipelineBatches Namespace


SitecorePipelineBatchRepository.TenantsRoot Property

SitecorePipelineBatchRepositoryTenantsRoot Property

Gets or sets the ID for the Sitecore item under which tenant definition items are stored.

The default value is the ID for the Sitecore item located at /sitecore/system/Data Exchange.

Namespace: Sitecore.DataExchange.Repositories.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Guid TenantsRoot { get; set; }

Property Value

Type: Guid
See Also

Reference

SitecorePipelineBatchRepository Class
Sitecore.DataExchange.Repositories.PipelineBatches Namespace


SitecorePipelineBatchRepository Methods

SitecorePipelineBatchRepository Methods

The SitecorePipelineBatchRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetPipelineBatches | Gets a collection of PipelineBatch objects that are available for the specified tenant.
Public method | GetTentants | Gets a collection of Tenant objects that are available to the repository.
Top
See Also

Reference

SitecorePipelineBatchRepository Class
Sitecore.DataExchange.Repositories.PipelineBatches Namespace


SitecorePipelineBatchRepository.GetPipelineBatches Method

SitecorePipelineBatchRepositoryGetPipelineBatches Method
Gets a collection of PipelineBatch objects that are available for the specified tenant.

Namespace: Sitecore.DataExchange.Repositories.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<PipelineBatch> GetPipelineBatches(
    Guid tenantId,
    bool remoteOnly = false
)

Parameters

tenantId
Type: SystemGuid
The tenant whose pipeline batches are retrieved.
remoteOnly (Optional)
Type: SystemBoolean
Indicates whether or not only pipeline batches that can be called remotely are included.

Return Value

Type: IEnumerable PipelineBatch
A collection of PipelineBatch objects.

Implements

IPipelineBatchRepositoryGetPipelineBatches(Guid, Boolean)
Exceptions
Exception | Condition
InvalidOperationException | The pipeline batches root cannot be retrieved by ItemModelRepository.
See Also

Reference

SitecorePipelineBatchRepository Class
Sitecore.DataExchange.Repositories.PipelineBatches Namespace


SitecorePipelineBatchRepository.GetTentants Method

SitecorePipelineBatchRepositoryGetTentants Method
Gets a collection of Tenant objects that are available to the repository.

Namespace: Sitecore.DataExchange.Repositories.PipelineBatches
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IEnumerable<Tenant> GetTentants()

Return Value

Type: IEnumerable Tenant
A collection of Tenant objects.

Implements

IPipelineBatchRepositoryGetTentants
See Also

Reference

SitecorePipelineBatchRepository Class
Sitecore.DataExchange.Repositories.PipelineBatches Namespace


Sitecore.DataExchange.Runners Namespace

Sitecore.DataExchange.Runners Namespace

This namespace contains components that are used to run pipeline batches.

Classes
 | Class | Description
Public class | BasePipelineBatchRunnerTProcess | Implements the ability to run pipeline batches.
Public class | PipelineBatchRunnerEventArgs | Provides data to the events on a IPipelineBatchRunnerTProcess.
Interfaces
 | Interface | Description
Public interface | IPipelineBatchRunnerTProcess | Represents a component that can run a pipeline batch.


BasePipelineBatchRunner(TProcess) Class

BasePipelineBatchRunnerTProcess Class
Implements the ability to run pipeline batches.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.RunnersBasePipelineBatchRunnerTProcess
Sitecore.DataExchange.Remote.RunnersRemotePipelineBatchRunner

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BasePipelineBatchRunner<TProcess> : IPipelineBatchRunner<TProcess>

Type Parameters

TProcess
The type of object that represents a pipeline batch being run.

The BasePipelineBatchRunnerTProcess type exposes the following members.

Constructors
 | Name | Description
Protected method | BasePipelineBatchRunnerTProcess | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | CurrentProcesses | Gets a collection of the processes that are currently running.
Top
Methods
 | Name | Description
Protected method | GetLoggerForPipelineBatchContext | Gets the logger that is set on the pipeline batch context.
Public method | IsRunning | Determines whether or not a pipeline batch is currently running.
Protected method | OnFinished | Raises the Finished event.
Protected method | OnStarted | Raises the Started event.
Public method | Run | Runs the specified pipeline batch. When the pipeline batch is finished running, the process that represented the pipeline batch being run is removed from CurrentProcesses. However, it is the responsibility of the component that uses the pipeline batch runner to put the process in the collection in the first place.
Top
Events
 | Name | Description
Public event | Finished | Occurs when the pipeline batch runner is finished.
Public event | Started | Occurs when the pipeline batch runner is started.
Top
See Also

Reference

Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess) Constructor

BasePipelineBatchRunnerTProcess Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BasePipelineBatchRunner()
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess) Properties

BasePipelineBatchRunnerTProcess Properties

The BasePipelineBatchRunnerTProcess generic type exposes the following members.

Properties
 | Name | Description
Public property | CurrentProcesses | Gets a collection of the processes that are currently running.
Top
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess).CurrentProcesses Property

BasePipelineBatchRunnerTProcessCurrentProcesses Property

Gets a collection of the processes that are currently running.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IDictionary<Guid, TProcess> CurrentProcesses { get; }

Property Value

Type: IDictionary Guid, TProcess

Implements

IPipelineBatchRunnerTProcessCurrentProcesses
Remarks

This property is used in cases where an object is available that represents a pipeline batch. For example, when a pipeline batch is run as a Sitecore job, the job object represents a pipeline batch running.

This property can be ignored in cases where pipeline batches are run as simple method calls. When a method is run, there is no object available that represents the progress of the method execution. In this case there is nothing to keep track of because the pipeline batch is finished when the method is finished running.

See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess) Methods

BasePipelineBatchRunnerTProcess Methods

The BasePipelineBatchRunnerTProcess generic type exposes the following members.

Methods
 | Name | Description
Protected method | GetLoggerForPipelineBatchContext | Gets the logger that is set on the pipeline batch context.
Public method | IsRunning | Determines whether or not a pipeline batch is currently running.
Protected method | OnFinished | Raises the Finished event.
Protected method | OnStarted | Raises the Started event.
Public method | Run | Runs the specified pipeline batch. When the pipeline batch is finished running, the process that represented the pipeline batch being run is removed from CurrentProcesses. However, it is the responsibility of the component that uses the pipeline batch runner to put the process in the collection in the first place.
Top
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess).GetLoggerForPipelineBatchContext Method

BasePipelineBatchRunnerTProcessGetLoggerForPipelineBatchContext Method
Gets the logger that is set on the pipeline batch context.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected virtual ILogger GetLoggerForPipelineBatchContext(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The pipeline batch that will be run.

Return Value

Type: ILogger
The logger that is set on the pipeline batch.
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess).IsRunning Method

BasePipelineBatchRunnerTProcessIsRunning Method
Determines whether or not a pipeline batch is currently running.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual bool IsRunning(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The pipeline batch that may or may not be running.

Return Value

Type: Boolean
if the pipeline batch is currently running; otherwise.

Implements

IPipelineBatchRunnerTProcessIsRunning(PipelineBatch)
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess).OnFinished Method

BasePipelineBatchRunnerTProcessOnFinished Method
Raises the Finished event.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected void OnFinished(
    PipelineBatchRunnerEventArgs e
)

Parameters

e
Type: Sitecore.DataExchange.RunnersPipelineBatchRunnerEventArgs
The event data.
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess).OnStarted Method

BasePipelineBatchRunnerTProcessOnStarted Method
Raises the Started event.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected void OnStarted(
    PipelineBatchRunnerEventArgs e
)

Parameters

e
Type: Sitecore.DataExchange.RunnersPipelineBatchRunnerEventArgs
The event data.
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess).Run Method

BasePipelineBatchRunnerTProcessRun Method

Runs the specified pipeline batch.

When the pipeline batch is finished running, the process that represented the pipeline batch being run is removed from CurrentProcesses.

However, it is the responsibility of the component that uses the pipeline batch runner to put the process in the collection in the first place.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Run(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The pipeline batch to run.

Return Value

Type: Boolean
if the pipeline batch was run; otherwise.

Implements

IPipelineBatchRunnerTProcessRun(PipelineBatch)
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess) Events

BasePipelineBatchRunnerTProcess Events

The BasePipelineBatchRunnerTProcess generic type exposes the following members.

Events
 | Name | Description
Public event | Finished | Occurs when the pipeline batch runner is finished.
Public event | Started | Occurs when the pipeline batch runner is started.
Top
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess).Finished Event

BasePipelineBatchRunnerTProcessFinished Event
Occurs when the pipeline batch runner is finished.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public event EventHandler<PipelineBatchRunnerEventArgs> Finished

Value

Type: SystemEventHandler PipelineBatchRunnerEventArgs

Implements

IPipelineBatchRunnerTProcessFinished
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


BasePipelineBatchRunner(TProcess).Started Event

BasePipelineBatchRunnerTProcessStarted Event
Occurs when the pipeline batch runner is started.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public event EventHandler<PipelineBatchRunnerEventArgs> Started

Value

Type: SystemEventHandler PipelineBatchRunnerEventArgs

Implements

IPipelineBatchRunnerTProcessStarted
See Also

Reference

BasePipelineBatchRunnerTProcess Class
Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess) Interface

IPipelineBatchRunnerTProcess Interface
Represents a component that can run a pipeline batch.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public interface IPipelineBatchRunner<TProcess>

Type Parameters

TProcess
The type of object that represents a pipeline batch being run.

The IPipelineBatchRunnerTProcess type exposes the following members.

Properties
 | Name | Description
Public property | CurrentProcesses | Gets a collection of the processes that are currently running.
Top
Methods
 | Name | Description
Public method | IsRunning | Determines whether or not a pipeline batch is currently running.
Public method | Run | Runs the specified pipeline batch.
Top
Events
 | Name | Description
Public event | Finished | Occurs when the pipeline batch runner is finished.
Public event | Started | Occurs when the pipeline batch runner is started.
Top
See Also

Reference

Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess) Properties

IPipelineBatchRunnerTProcess Properties

The IPipelineBatchRunnerTProcess generic type exposes the following members.

Properties
 | Name | Description
Public property | CurrentProcesses | Gets a collection of the processes that are currently running.
Top
See Also

Reference

IPipelineBatchRunnerTProcess Interface
Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess).CurrentProcesses Property

IPipelineBatchRunnerTProcessCurrentProcesses Property
Gets a collection of the processes that are currently running.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
IDictionary<Guid, TProcess> CurrentProcesses { get; }

Property Value

Type: IDictionary Guid, TProcess
See Also

Reference

IPipelineBatchRunnerTProcess Interface
Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess) Methods

IPipelineBatchRunnerTProcess Methods

The IPipelineBatchRunnerTProcess generic type exposes the following members.

Methods
 | Name | Description
Public method | IsRunning | Determines whether or not a pipeline batch is currently running.
Public method | Run | Runs the specified pipeline batch.
Top
See Also

Reference

IPipelineBatchRunnerTProcess Interface
Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess).IsRunning Method

IPipelineBatchRunnerTProcessIsRunning Method
Determines whether or not a pipeline batch is currently running.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool IsRunning(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The pipeline batch that may or may not be running.

Return Value

Type: Boolean
if the pipeline batch is currently running; otherwise.
See Also

Reference

IPipelineBatchRunnerTProcess Interface
Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess).Run Method

IPipelineBatchRunnerTProcessRun Method
Runs the specified pipeline batch.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
bool Run(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The pipeline batch to run.

Return Value

Type: Boolean
if the pipeline batch was run; otherwise.
See Also

Reference

IPipelineBatchRunnerTProcess Interface
Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess) Events

IPipelineBatchRunnerTProcess Events

The IPipelineBatchRunnerTProcess generic type exposes the following members.

Events
 | Name | Description
Public event | Finished | Occurs when the pipeline batch runner is finished.
Public event | Started | Occurs when the pipeline batch runner is started.
Top
See Also

Reference

IPipelineBatchRunnerTProcess Interface
Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess).Finished Event

IPipelineBatchRunnerTProcessFinished Event
Occurs when the pipeline batch runner is finished.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
event EventHandler<PipelineBatchRunnerEventArgs> Finished

Value

Type: SystemEventHandler PipelineBatchRunnerEventArgs
See Also

Reference

IPipelineBatchRunnerTProcess Interface
Sitecore.DataExchange.Runners Namespace


IPipelineBatchRunner(TProcess).Started Event

IPipelineBatchRunnerTProcessStarted Event
Occurs when the pipeline batch runner is started.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
event EventHandler<PipelineBatchRunnerEventArgs> Started

Value

Type: SystemEventHandler PipelineBatchRunnerEventArgs
See Also

Reference

IPipelineBatchRunnerTProcess Interface
Sitecore.DataExchange.Runners Namespace


PipelineBatchRunnerEventArgs Class

PipelineBatchRunnerEventArgs Class
Provides data to the events on a IPipelineBatchRunnerTProcess.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sitecore.DataExchange.RunnersPipelineBatchRunnerEventArgs

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineBatchRunnerEventArgs : EventArgs

The PipelineBatchRunnerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineBatchRunnerEventArgs | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | PipelineBatch | Gets the pipeline batch being used by the runner.
Top
See Also

Reference

Sitecore.DataExchange.Runners Namespace


PipelineBatchRunnerEventArgs Constructor

PipelineBatchRunnerEventArgs Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatchRunnerEventArgs(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The pipeline batch that is being or was run.
See Also

Reference

PipelineBatchRunnerEventArgs Class
Sitecore.DataExchange.Runners Namespace


PipelineBatchRunnerEventArgs Properties

PipelineBatchRunnerEventArgs Properties

The PipelineBatchRunnerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PipelineBatch | Gets the pipeline batch being used by the runner.
Top
See Also

Reference

PipelineBatchRunnerEventArgs Class
Sitecore.DataExchange.Runners Namespace


PipelineBatchRunnerEventArgs.PipelineBatch Property

PipelineBatchRunnerEventArgsPipelineBatch Property
Gets the pipeline batch being used by the runner.

Namespace: Sitecore.DataExchange.Runners
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatch PipelineBatch { get; }

Property Value

Type: PipelineBatch
See Also

Reference

PipelineBatchRunnerEventArgs Class
Sitecore.DataExchange.Runners Namespace


Sitecore.DataExchange.Telemetry Namespace

Sitecore.DataExchange.Telemetry Namespace

This namespace contains framework components related to telemetry.

Classes
 | Class | Description
Public class | BaseTelemetry | Base class for components that are monitored.
Public class | TelemetryProperty | Represents a value that is tracked during monitoring.
Delegates
 | Delegate | Description
Public delegate | ChangedEventHandler | Represents the method that will handle state changes on components that are monitored.


BaseTelemetry Class

BaseTelemetry Class
Base class for components that are monitored.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.TelemetryBaseTelemetry
Sitecore.DataExchange.Telemetry.PipelinesBasePipelineActivity

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BaseTelemetry : IDisposable

The BaseTelemetry type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseTelemetry | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is .
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled.
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.)
Public property | Logger | Gets the component used for logging. By default, this is Logger.
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete.
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object.
Top
Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored.
Public method | Dispose | Ensures that any monitoring is stopped.
Protected method | Finalize | Deconstructor the object. (Overrides ObjectFinalize.)
Protected method | OnActivityComplete | Method that raises the ActivityComplete event.
Protected method | OnActivityStart | Method that raises the ActivityStart event.
Public method | Start | Method that causes the monitoring to start. This method also raises the ActivityStart event.
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event.
Top
Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed.
Public event | ActivityStart | Occurs when an activity being monitored is started.
Top
See Also

Reference

Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry Constructor

BaseTelemetry Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected BaseTelemetry()
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry Properties

BaseTelemetry Properties

The BaseTelemetry type exposes the following members.

Properties
 | Name | Description
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is .
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled.
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.)
Public property | Logger | Gets the component used for logging. By default, this is Logger.
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete.
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object.
Top
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.DisableLogger Property

BaseTelemetryDisableLogger Property

Gets a value that determines whether or not the logger is used.

Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is .

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool DisableLogger { get; set; }

Property Value

Type: Boolean
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.Enabled Property

BaseTelemetryEnabled Property
Gets or sets a value that indicates whether or not the monitor is enabled.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool Enabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.IsRunning Property

BaseTelemetryIsRunning Property
Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.)

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public bool IsRunning { get; protected set; }

Property Value

Type: Boolean
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.Logger Property

BaseTelemetryLogger Property
Gets the component used for logging. By default, this is Logger.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public ILogger Logger { get; set; }

Property Value

Type: ILogger
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.StopWatch Property

BaseTelemetryStopWatch Property
Gets the stopwatch that tracks how long an activity being monitored takes to complete.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Stopwatch StopWatch { get; }

Property Value

Type: Stopwatch
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.TelemetryId Property

BaseTelemetryTelemetryId Property
Gets a value that uniquely identifies the monitoring performed by the object.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Guid TelemetryId { get; }

Property Value

Type: Guid
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry Methods

BaseTelemetry Methods

The BaseTelemetry type exposes the following members.

Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored.
Public method | Dispose | Ensures that any monitoring is stopped.
Protected method | Finalize | Deconstructor the object. (Overrides ObjectFinalize.)
Protected method | OnActivityComplete | Method that raises the ActivityComplete event.
Protected method | OnActivityStart | Method that raises the ActivityStart event.
Public method | Start | Method that causes the monitoring to start. This method also raises the ActivityStart event.
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event.
Top
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.AddTelemetryProperty Method

BaseTelemetryAddTelemetryProperty Method
Adds a property that can be monitored.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void AddTelemetryProperty(
    string propertyName,
    string propertyValue
)

Parameters

propertyName
Type: SystemString

[Missing <param name="propertyName"/> documentation for "M:Sitecore.DataExchange.Telemetry.BaseTelemetry.AddTelemetryProperty(System.String,System.String)"]

propertyValue
Type: SystemString

[Missing <param name="propertyValue"/> documentation for "M:Sitecore.DataExchange.Telemetry.BaseTelemetry.AddTelemetryProperty(System.String,System.String)"]

See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.Dispose Method

BaseTelemetryDispose Method
Ensures that any monitoring is stopped.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.Finalize Method

BaseTelemetryFinalize Method
Deconstructor the object.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.OnActivityComplete Method

BaseTelemetryOnActivityComplete Method
Method that raises the ActivityComplete event.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected void OnActivityComplete(
    EventArgs e
)

Parameters

e
Type: SystemEventArgs
The data that is passed to the event.
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.OnActivityStart Method

BaseTelemetryOnActivityStart Method
Method that raises the ActivityStart event.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected void OnActivityStart(
    EventArgs e
)

Parameters

e
Type: SystemEventArgs
The data that is passed to the event.
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.Start Method

BaseTelemetryStart Method
Method that causes the monitoring to start. This method also raises the ActivityStart event.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual BaseTelemetry Start(
    string context
)

Parameters

context
Type: SystemString
A human-readable value that identifies an activity.

Return Value

Type: BaseTelemetry
An object that represents the monitoring of a component.
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.Stop Method

BaseTelemetryStop Method
Method that causes the monitoring to stop. This method also raises the ActivityComplete event.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public virtual void Stop()
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry Events

BaseTelemetry Events

The BaseTelemetry type exposes the following members.

Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed.
Public event | ActivityStart | Occurs when an activity being monitored is started.
Top
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.ActivityComplete Event

BaseTelemetryActivityComplete Event
Occurs when an activity being monitored is completed.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public event ChangedEventHandler ActivityComplete

Value

Type: Sitecore.DataExchange.TelemetryChangedEventHandler
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


BaseTelemetry.ActivityStart Event

BaseTelemetryActivityStart Event
Occurs when an activity being monitored is started.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public event ChangedEventHandler ActivityStart

Value

Type: Sitecore.DataExchange.TelemetryChangedEventHandler
See Also

Reference

BaseTelemetry Class
Sitecore.DataExchange.Telemetry Namespace


ChangedEventHandler Delegate

ChangedEventHandler Delegate
Represents the method that will handle state changes on components that are monitored.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public delegate void ChangedEventHandler(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Sitecore.DataExchange.Telemetry Namespace


TelemetryProperty Class

TelemetryProperty Class
Represents a value that is tracked during monitoring.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.TelemetryTelemetryProperty

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class TelemetryProperty

The TelemetryProperty type exposes the following members.

Constructors
 | Name | Description
Public method | TelemetryProperty | Initializes a new instance of the TelemetryProperty class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the property.
Public property | Value | Gets or sets the value of the property.
Top
See Also

Reference

Sitecore.DataExchange.Telemetry Namespace


TelemetryProperty Constructor

TelemetryProperty Constructor
Initializes a new instance of the TelemetryProperty class

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public TelemetryProperty()
See Also

Reference

TelemetryProperty Class
Sitecore.DataExchange.Telemetry Namespace


TelemetryProperty Properties

TelemetryProperty Properties

The TelemetryProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the property.
Public property | Value | Gets or sets the value of the property.
Top
See Also

Reference

TelemetryProperty Class
Sitecore.DataExchange.Telemetry Namespace


TelemetryProperty.Name Property

TelemetryPropertyName Property
Gets or sets the name of the property.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

TelemetryProperty Class
Sitecore.DataExchange.Telemetry Namespace


TelemetryProperty.Value Property

TelemetryPropertyValue Property
Gets or sets the value of the property.

Namespace: Sitecore.DataExchange.Telemetry
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public string Value { get; set; }

Property Value

Type: String
See Also

Reference

TelemetryProperty Class
Sitecore.DataExchange.Telemetry Namespace


Sitecore.DataExchange.Telemetry.Pipelines Namespace

Sitecore.DataExchange.Telemetry.Pipelines Namespace

This namespace contains framework components related to telemetry related to pipelines.

Classes
 | Class | Description
Public class | BasePipelineActivity | Base class for pipeline activity that can be monitored.
Public class | PipelineActivity | Represents a pipeline activity that can be monitored.
Public class | PipelineBatchActivity | Represents a pipeline batch activity that can be monitored.
Public class | PipelineStepActivity | Represents a pipeline processor definition activity that can be monitored.


BasePipelineActivity Class

BasePipelineActivity Class
Base class for pipeline activity that can be monitored.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.TelemetryBaseTelemetry
Sitecore.DataExchange.Telemetry.PipelinesBasePipelineActivity
Sitecore.DataExchange.Telemetry.PipelinesPipelineActivity
Sitecore.DataExchange.Telemetry.PipelinesPipelineBatchActivity
Sitecore.DataExchange.Telemetry.PipelinesPipelineStepActivity

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public abstract class BasePipelineActivity : BaseTelemetry

The BasePipelineActivity type exposes the following members.

Constructors
 | Name | Description
Public method | BasePipelineActivity | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | DataExchangeContext | Gets the IDataExchangeContext used during the activity being monitored.
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is . (Inherited from BaseTelemetry.)
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled. (Inherited from BaseTelemetry.)
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.) (Inherited from BaseTelemetry.)
Public property | Logger | Gets the component used for logging. By default, this is Logger. (Inherited from BaseTelemetry.)
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete. (Inherited from BaseTelemetry.)
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object. (Inherited from BaseTelemetry.)
Top
Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored. (Inherited from BaseTelemetry.)
Public method | Dispose | Ensures that any monitoring is stopped. (Inherited from BaseTelemetry.)
Protected method | Finalize | Deconstructor the object. (Inherited from BaseTelemetry.)
Protected method | GetContext | Gets a human-readable value that helps to identify the activity being monitored.
Protected method | OnActivityComplete | Method that raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Protected method | OnActivityStart | Method that raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start.
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Top
Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed. (Inherited from BaseTelemetry.)
Public event | ActivityStart | Occurs when an activity being monitored is started. (Inherited from BaseTelemetry.)
Top
See Also

Reference

Sitecore.DataExchange.Telemetry.Pipelines Namespace


BasePipelineActivity Constructor

BasePipelineActivity Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public BasePipelineActivity()
See Also

Reference

BasePipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


BasePipelineActivity Properties

BasePipelineActivity Properties

The BasePipelineActivity type exposes the following members.

Properties
 | Name | Description
Public property | DataExchangeContext | Gets the IDataExchangeContext used during the activity being monitored.
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is . (Inherited from BaseTelemetry.)
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled. (Inherited from BaseTelemetry.)
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.) (Inherited from BaseTelemetry.)
Public property | Logger | Gets the component used for logging. By default, this is Logger. (Inherited from BaseTelemetry.)
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete. (Inherited from BaseTelemetry.)
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object. (Inherited from BaseTelemetry.)
Top
See Also

Reference

BasePipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


BasePipelineActivity.DataExchangeContext Property

BasePipelineActivityDataExchangeContext Property
Gets the IDataExchangeContext used during the activity being monitored.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public IDataExchangeContext DataExchangeContext { get; }

Property Value

Type: IDataExchangeContext
See Also

Reference

BasePipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


BasePipelineActivity Methods

BasePipelineActivity Methods

The BasePipelineActivity type exposes the following members.

Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored. (Inherited from BaseTelemetry.)
Public method | Dispose | Ensures that any monitoring is stopped. (Inherited from BaseTelemetry.)
Protected method | Finalize | Deconstructor the object. (Inherited from BaseTelemetry.)
Protected method | GetContext | Gets a human-readable value that helps to identify the activity being monitored.
Protected method | OnActivityComplete | Method that raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Protected method | OnActivityStart | Method that raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start.
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Top
See Also

Reference

BasePipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


BasePipelineActivity.GetContext Method

BasePipelineActivityGetContext Method
Gets a human-readable value that helps to identify the activity being monitored.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected abstract string GetContext()

Return Value

Type: String
The value.
See Also

Reference

BasePipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


BasePipelineActivity.Start Method

BasePipelineActivityStart Method
Overload List
 | Name | Description
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start.
Top
See Also

Reference

BasePipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


BasePipelineActivity.Start Method (IDataExchangeContext)

BasePipelineActivityStart Method (IDataExchangeContext)
Method that causes the monitoring to start.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public BaseTelemetry Start(
    IDataExchangeContext context
)

Parameters

context
Type: Sitecore.DataExchange.ContextsIDataExchangeContext
The DataExchangeContext used during the activity being monitored.

Return Value

Type: BaseTelemetry
An object that represents the monitoring of a component.
See Also

Reference

BasePipelineActivity Class
Start Overload
Sitecore.DataExchange.Telemetry.Pipelines Namespace


BasePipelineActivity Events

BasePipelineActivity Events

The BasePipelineActivity type exposes the following members.

Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed. (Inherited from BaseTelemetry.)
Public event | ActivityStart | Occurs when an activity being monitored is started. (Inherited from BaseTelemetry.)
Top
See Also

Reference

BasePipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineActivity Class

PipelineActivity Class
Represents a pipeline activity that can be monitored.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.TelemetryBaseTelemetry
Sitecore.DataExchange.Telemetry.PipelinesBasePipelineActivity
Sitecore.DataExchange.Telemetry.PipelinesPipelineActivity

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineActivity : BasePipelineActivity

The PipelineActivity type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineActivity | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | DataExchangeContext | Gets the IDataExchangeContext used during the activity being monitored. (Inherited from BasePipelineActivity.)
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is . (Inherited from BaseTelemetry.)
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled. (Inherited from BaseTelemetry.)
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.) (Inherited from BaseTelemetry.)
Public property | Logger | Gets the component used for logging. By default, this is Logger. (Inherited from BaseTelemetry.)
Public property | Pipeline | Gets the pipeline whose activity is monitored.
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete. (Inherited from BaseTelemetry.)
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object. (Inherited from BaseTelemetry.)
Top
Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored. (Inherited from BaseTelemetry.)
Public method | Dispose | Ensures that any monitoring is stopped. (Inherited from BaseTelemetry.)
Protected method | Finalize | Deconstructor the object. (Inherited from BaseTelemetry.)
Protected method | GetContext | Gets a human-readable value that helps to identify the activity being monitored. (Overrides BasePipelineActivityGetContext.)
Protected method | OnActivityComplete | Method that raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Protected method | OnActivityStart | Method that raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start. (Inherited from BasePipelineActivity.)
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Top
Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed. (Inherited from BaseTelemetry.)
Public event | ActivityStart | Occurs when an activity being monitored is started. (Inherited from BaseTelemetry.)
Top
See Also

Reference

Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineActivity Constructor

PipelineActivity Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineActivity(
    Pipeline pipeline
)

Parameters

pipeline
Type: Sitecore.DataExchange.ModelsPipeline
The pipeline whose activity is monitored.
See Also

Reference

PipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineActivity Properties

PipelineActivity Properties

The PipelineActivity type exposes the following members.

Properties
 | Name | Description
Public property | DataExchangeContext | Gets the IDataExchangeContext used during the activity being monitored. (Inherited from BasePipelineActivity.)
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is . (Inherited from BaseTelemetry.)
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled. (Inherited from BaseTelemetry.)
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.) (Inherited from BaseTelemetry.)
Public property | Logger | Gets the component used for logging. By default, this is Logger. (Inherited from BaseTelemetry.)
Public property | Pipeline | Gets the pipeline whose activity is monitored.
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete. (Inherited from BaseTelemetry.)
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineActivity.Pipeline Property

PipelineActivityPipeline Property
Gets the pipeline whose activity is monitored.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public Pipeline Pipeline { get; }

Property Value

Type: Pipeline
See Also

Reference

PipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineActivity Methods

PipelineActivity Methods

The PipelineActivity type exposes the following members.

Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored. (Inherited from BaseTelemetry.)
Public method | Dispose | Ensures that any monitoring is stopped. (Inherited from BaseTelemetry.)
Protected method | Finalize | Deconstructor the object. (Inherited from BaseTelemetry.)
Protected method | GetContext | Gets a human-readable value that helps to identify the activity being monitored. (Overrides BasePipelineActivityGetContext.)
Protected method | OnActivityComplete | Method that raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Protected method | OnActivityStart | Method that raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start. (Inherited from BasePipelineActivity.)
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineActivity.GetContext Method

PipelineActivityGetContext Method
Gets a human-readable value that helps to identify the activity being monitored.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override string GetContext()

Return Value

Type: String
The pipeline name.
See Also

Reference

PipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineActivity Events

PipelineActivity Events

The PipelineActivity type exposes the following members.

Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed. (Inherited from BaseTelemetry.)
Public event | ActivityStart | Occurs when an activity being monitored is started. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineBatchActivity Class

PipelineBatchActivity Class
Represents a pipeline batch activity that can be monitored.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.TelemetryBaseTelemetry
Sitecore.DataExchange.Telemetry.PipelinesBasePipelineActivity
Sitecore.DataExchange.Telemetry.PipelinesPipelineBatchActivity

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineBatchActivity : BasePipelineActivity

The PipelineBatchActivity type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineBatchActivity | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | DataExchangeContext | Gets the IDataExchangeContext used during the activity being monitored. (Inherited from BasePipelineActivity.)
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is . (Inherited from BaseTelemetry.)
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled. (Inherited from BaseTelemetry.)
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.) (Inherited from BaseTelemetry.)
Public property | Logger | Gets the component used for logging. By default, this is Logger. (Inherited from BaseTelemetry.)
Public property | PipelineBatch | Gets the pipeline batch whose activity is monitored.
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete. (Inherited from BaseTelemetry.)
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object. (Inherited from BaseTelemetry.)
Top
Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored. (Inherited from BaseTelemetry.)
Public method | Dispose | Ensures that any monitoring is stopped. (Inherited from BaseTelemetry.)
Protected method | Finalize | Deconstructor the object. (Inherited from BaseTelemetry.)
Protected method | GetContext | Gets a human-readable value that helps to identify the activity being monitored. (Overrides BasePipelineActivityGetContext.)
Protected method | OnActivityComplete | Method that raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Protected method | OnActivityStart | Method that raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start. (Inherited from BasePipelineActivity.)
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Top
Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed. (Inherited from BaseTelemetry.)
Public event | ActivityStart | Occurs when an activity being monitored is started. (Inherited from BaseTelemetry.)
Top
See Also

Reference

Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineBatchActivity Constructor

PipelineBatchActivity Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatchActivity(
    PipelineBatch pipelineBatch
)

Parameters

pipelineBatch
Type: Sitecore.DataExchange.ModelsPipelineBatch
The pipeline batch whose activity is monitored.
See Also

Reference

PipelineBatchActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineBatchActivity Properties

PipelineBatchActivity Properties

The PipelineBatchActivity type exposes the following members.

Properties
 | Name | Description
Public property | DataExchangeContext | Gets the IDataExchangeContext used during the activity being monitored. (Inherited from BasePipelineActivity.)
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is . (Inherited from BaseTelemetry.)
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled. (Inherited from BaseTelemetry.)
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.) (Inherited from BaseTelemetry.)
Public property | Logger | Gets the component used for logging. By default, this is Logger. (Inherited from BaseTelemetry.)
Public property | PipelineBatch | Gets the pipeline batch whose activity is monitored.
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete. (Inherited from BaseTelemetry.)
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineBatchActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineBatchActivity.PipelineBatch Property

PipelineBatchActivityPipelineBatch Property
Gets the pipeline batch whose activity is monitored.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineBatch PipelineBatch { get; }

Property Value

Type: PipelineBatch
See Also

Reference

PipelineBatchActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineBatchActivity Methods

PipelineBatchActivity Methods

The PipelineBatchActivity type exposes the following members.

Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored. (Inherited from BaseTelemetry.)
Public method | Dispose | Ensures that any monitoring is stopped. (Inherited from BaseTelemetry.)
Protected method | Finalize | Deconstructor the object. (Inherited from BaseTelemetry.)
Protected method | GetContext | Gets a human-readable value that helps to identify the activity being monitored. (Overrides BasePipelineActivityGetContext.)
Protected method | OnActivityComplete | Method that raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Protected method | OnActivityStart | Method that raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start. (Inherited from BasePipelineActivity.)
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineBatchActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineBatchActivity.GetContext Method

PipelineBatchActivityGetContext Method
Gets a human-readable value that helps to identify the activity being monitored.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override string GetContext()

Return Value

Type: String
The pipeline batch name.
See Also

Reference

PipelineBatchActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineBatchActivity Events

PipelineBatchActivity Events

The PipelineBatchActivity type exposes the following members.

Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed. (Inherited from BaseTelemetry.)
Public event | ActivityStart | Occurs when an activity being monitored is started. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineBatchActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineStepActivity Class

PipelineStepActivity Class
Represents a pipeline processor definition activity that can be monitored.
Inheritance Hierarchy
SystemObject
Sitecore.DataExchange.TelemetryBaseTelemetry
Sitecore.DataExchange.Telemetry.PipelinesBasePipelineActivity
Sitecore.DataExchange.Telemetry.PipelinesPipelineStepActivity

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public class PipelineStepActivity : BasePipelineActivity

The PipelineStepActivity type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineStepActivity | Initializes a new instance of the class.
Top
Properties
 | Name | Description
Public property | DataExchangeContext | Gets the IDataExchangeContext used during the activity being monitored. (Inherited from BasePipelineActivity.)
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is . (Inherited from BaseTelemetry.)
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled. (Inherited from BaseTelemetry.)
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.) (Inherited from BaseTelemetry.)
Public property | Logger | Gets the component used for logging. By default, this is Logger. (Inherited from BaseTelemetry.)
Public property | PipelineStep | Gets the pipeline step whose activity is monitored.
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete. (Inherited from BaseTelemetry.)
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object. (Inherited from BaseTelemetry.)
Top
Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored. (Inherited from BaseTelemetry.)
Public method | Dispose | Ensures that any monitoring is stopped. (Inherited from BaseTelemetry.)
Protected method | Finalize | Deconstructor the object. (Inherited from BaseTelemetry.)
Protected method | GetContext | Gets a human-readable value that helps to identify the activity being monitored. (Overrides BasePipelineActivityGetContext.)
Protected method | OnActivityComplete | Method that raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Protected method | OnActivityStart | Method that raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start. (Inherited from BasePipelineActivity.)
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Top
Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed. (Inherited from BaseTelemetry.)
Public event | ActivityStart | Occurs when an activity being monitored is started. (Inherited from BaseTelemetry.)
Top
See Also

Reference

Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineStepActivity Constructor

PipelineStepActivity Constructor
Initializes a new instance of the class.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineStepActivity(
    PipelineStep pipelineStep
)

Parameters

pipelineStep
Type: Sitecore.DataExchange.ModelsPipelineStep
The pipeline step whose activity is monitored.
See Also

Reference

PipelineStepActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineStepActivity Properties

PipelineStepActivity Properties

The PipelineStepActivity type exposes the following members.

Properties
 | Name | Description
Public property | DataExchangeContext | Gets the IDataExchangeContext used during the activity being monitored. (Inherited from BasePipelineActivity.)
Public property | DisableLogger | Gets a value that determines whether or not the logger is used. Types that inherit from BaseTelemetry do not need to check this value. The property Logger will return a NullLogger if DisableLogger is . (Inherited from BaseTelemetry.)
Public property | Enabled | Gets or sets a value that indicates whether or not the monitor is enabled. (Inherited from BaseTelemetry.)
Public property | IsRunning | Gets or sets a value that indicates whether or not the telemetry is running (meaning is has been started and has not yet stopped.) (Inherited from BaseTelemetry.)
Public property | Logger | Gets the component used for logging. By default, this is Logger. (Inherited from BaseTelemetry.)
Public property | PipelineStep | Gets the pipeline step whose activity is monitored.
Public property | StopWatch | Gets the stopwatch that tracks how long an activity being monitored takes to complete. (Inherited from BaseTelemetry.)
Public property | TelemetryId | Gets a value that uniquely identifies the monitoring performed by the object. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineStepActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineStepActivity.PipelineStep Property

PipelineStepActivityPipelineStep Property
Gets the pipeline step whose activity is monitored.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
public PipelineStep PipelineStep { get; }

Property Value

Type: PipelineStep
See Also

Reference

PipelineStepActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineStepActivity Methods

PipelineStepActivity Methods

The PipelineStepActivity type exposes the following members.

Methods
 | Name | Description
Public method | AddTelemetryProperty | Adds a property that can be monitored. (Inherited from BaseTelemetry.)
Public method | Dispose | Ensures that any monitoring is stopped. (Inherited from BaseTelemetry.)
Protected method | Finalize | Deconstructor the object. (Inherited from BaseTelemetry.)
Protected method | GetContext | Gets a human-readable value that helps to identify the activity being monitored. (Overrides BasePipelineActivityGetContext.)
Protected method | OnActivityComplete | Method that raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Protected method | OnActivityStart | Method that raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(String) | Method that causes the monitoring to start. This method also raises the ActivityStart event. (Inherited from BaseTelemetry.)
Public method | Start(IDataExchangeContext) | Method that causes the monitoring to start. (Inherited from BasePipelineActivity.)
Public method | Stop | Method that causes the monitoring to stop. This method also raises the ActivityComplete event. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineStepActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineStepActivity.GetContext Method

PipelineStepActivityGetContext Method
Gets a human-readable value that helps to identify the activity being monitored.

Namespace: Sitecore.DataExchange.Telemetry.Pipelines
Assembly: Sitecore.DataExchange (in Sitecore.DataExchange.dll) Version: 1.0.0-r0
Syntax
C#
Copy
protected override string GetContext()

Return Value

Type: String
the pipeline step name.
See Also

Reference

PipelineStepActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace


PipelineStepActivity Events

PipelineStepActivity Events

The PipelineStepActivity type exposes the following members.

Events
 | Name | Description
Public event | ActivityComplete | Occurs when an activity being monitored is completed. (Inherited from BaseTelemetry.)
Public event | ActivityStart | Occurs when an activity being monitored is started. (Inherited from BaseTelemetry.)
Top
See Also

Reference

PipelineStepActivity Class
Sitecore.DataExchange.Telemetry.Pipelines Namespace